[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[virt-tools-list] [PATCH] support: decrease required libvirt version for stream console



According to the changelog of libvirt http://libvirt.org/news.html,
the required version for stream console should be 0.8.6.

Please check the link: http://libvirt.org/news.html, libvirt started
to support virDomainOpenConsole() since "0.8.6: Nov 30 2010". And there
were also many changes related to stream console.

In practical terms, I have tested the change with libvirtd-0.8.8 in
Ubuntu 12.04.2 (x64) and another ARM port libvird-0.8.8. I think changing
to 0.8.6 should be fine because according to the changelog there are
no big changes in libvirt-0.8.7 and libvirt-0.8.8.

Signed-off-by: Ying-Shiuan Pan <yspan itri org tw>
---
 virtinst/support.py | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/virtinst/support.py b/virtinst/support.py
index 3980829..3f5e9b4 100644
--- a/virtinst/support.py
+++ b/virtinst/support.py
@@ -341,7 +341,7 @@ SUPPORT_DOMAIN_MIGRATE_DOWNTIME = _make(
         # downtime value
         args=(30, 12345678))
 SUPPORT_DOMAIN_JOB_INFO = _make(function="virDomain.jobInfo", args=())
-SUPPORT_DOMAIN_CONSOLE_STREAM = _make(version=9003)
+SUPPORT_DOMAIN_CONSOLE_STREAM = _make(version=8006)
 SUPPORT_DOMAIN_SET_METADATA = _make(version=9010)
 SUPPORT_DOMAIN_CPU_HOST_MODEL = _make(version=9010)
 SUPPORT_DOMAIN_LIST_SNAPSHOTS = _make(function="virDomain.listAllSnapshots",
-- 
1.8.1.2


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]