[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[virt-tools-list] progress on virt-viewer for windows



Hi Christophe,
If someone provides newer windows binaries -- which aren't missing
dlls, like the ones at http://teuf.fedorapeople.org/virt-viewer-msi/
-- I will test then.
I gave you links to RPMs containing the missing dlls (rpm2cpio foo.dll
  | cpio -id will unpack them on linux) in
https://www.redhat.com/archives/virt-tools-list/2013-September/msg00037.html,
did you try adding these dlls in the place the installer put the other ones
to see if this helps?
The first missing DLL was libvirt-lxc-0.dll. After I put it on the virt-viewer install dir, I got the error:

C:\Program Files\VirtViewer\bin>virsh -c qemu+tcp://kvmhost/system
error: failed to connect to the hypervisor
error: authentication failed: unsupported authentication type 1

Nice, there wan't other missing DLLs. :-)

It looks like the windows port can't do SASL auth over TCP. So I changed libvirtd.conf to allow unauthenticated connections over TCP.

It worked!!!!!

Quickly changed libvirtd.conf to allow only TLS connections, not to let my host insecure. Then tried again:

C:\Program Files\VirtViewer\bin>virsh -c qemu+tls://kvmhost/system

It worked!!!

Thanks a lot for your help, and I'm eager to try the next release you are about to build.


PS: Would it be hard to add SASL support to the windows port? It's much easier to setup than TLS.


[]s, Fernando Lozano


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]