[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [virt-tools-list] virt-install fails to install debian wheezy domU on debian wheezy dom0



On Fri, 27 Sep 2013, Cole Robinson wrote:

On 09/27/2013 05:01 AM, Tomas Agartz wrote:

I have several XEN domU:s running om my server that I have installed in the past. I have recently upgraded the dom0 (and most of the domU) to Debian Wheezy. Tried installing a new (wheezy) guest today, but it seems to fail to mount the initrd if I understand the error correctly. This is how I install:

virt-install --name=${DOMU} --ram=128 --disk path=/dev/vg1/${DOMU} --network bridge:vlan200 --nographics --paravirt --location ${URL}

with URL=http://130.239.18.163/debian/dists/wheezy/main/installer-i386 it fails but if I change the URL to point to squeeze instead, the installation starts.

virt-install in Debian Wheezy (on my dom0) is version 0.600.1. My dom0 is a x86_64 machine.

No idea if this is a Debian problem, a problem with virt-install, or if I am doing sometihng wrong myself, so I am asking on this list first.

Please provide the output of this command with --debug.

DOMU=test
URL=http://130.239.18.163/debian/dists/wheezy/main/installer-i386
virt-install --debug --name=${DOMU} --ram=128 --disk path=/dev/vg1/${DOMU} --network bridge:vlan200 --nographics --paravirt --location ${URL} > virt-install.txt 2>&1

Output posted at: http://tlund.pp.se/virt-install/virt-install.txt

Also, how is it failing? virt-install error or error inside the VM install?

[    1.451502] No filesystem could mount root, tried:
[    1.451509] Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)
[    1.451522] Pid: 1, comm: swapper/0 Not tainted 3.2.0-4-686-pae #1 Debian 3.2.46-1
[    1.451530] Call Trace:
[    1.451543]  [<c12becb0>] ? panic+0x4d/0x141
[    1.451551]  [<c1419aa4>] ? mount_block_root+0x1e2/0x203
[    1.451561]  [<c1002930>] ? hypercall_page+0x930/0x1000
[    1.451567]  [<c1419afe>] ? mount_root+0x39/0x4d
[    1.451576]  [<c1419c20>] ? prepare_namespace+0x10e/0x13e
[    1.451583]  [<c1419829>] ? kernel_init+0x12c/0x131
[    1.451592]  [<c14196fd>] ? start_kernel+0x32a/0x32a
[    1.451598]  [<c12c84fe>] ? kernel_thread_helper+0x6/0x10

//tlund


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]