[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Problems with undefined reference errors



On 12 Jun 2003, Bill Baker wrote:

>> You clearly state that you've upgraded to Red Hat [Linux] 9 here.
>> There are no significant differences between XFree86 4.3.0-2 and 
>> 4.3.0-3 except a few minor driver bug fixes and other trivial 
>> stuff.  I also have a Red Hat Linux 8.0 machine here with XFree86 
>> 4.3.0 installed on it:
>
>Allow me to quote you what I also said later on in the same message:
>
>> I have a custom build of XFree86 (4.3.0-3) installed that I built
>> from the source RPM under Red Hat 8.0
>
>While upgrading to RH9, the XFree86 packages were not upgraded, since it
>saw 4.3.0-3 as being newer than 4.3.0-2.

Of course.  4.3.0-3 *IS* newer than 4.3.0-2.


>> >I could try installing the 4.3.0-2 binaries from the RH9 CD to
>> >see if that works.  I just wondered if there was anything else I
>> >could do, short of doing that.
>> 
>> Red Hat Linux 9 binaries generally will not install on Red Hat 
>> Linux 8.0 without recompilation, and even then, some require spec 
>> file editing prior to rebuilding, and many of them have other 
>> dependancies on packages from Red Hat Linux 9 also.
>
>That's fine.  I am running RH9.

Make up your mind.


>> You've said you were using RHL 9 in your original mail, and the C 
>> compiler you said you used, is the one from RHL 9 as well.  Now 
>> you say you're using RHL 8.0, which only confuses things.  Have 
>> you also manually rebuild the gcc rpms from RHL 9 and installed 
>> them on RHL 8.0?
>
>No, what I meant was that the XFree86 packages had been built and
>installed on my system while I was running RH8.  I have since upgraded
>to RH9.

Ok, so you're using an unofficial and unsupported custom build of 
XFree86.  We've established that now.


>> I'm not sure what exactly you're running, but I'm sure that the
>> problem isn't something caused by Red Hat Linux provided
>> packages.  ;o)
>
>I never said it was.  I did wonder if that might be the case, though,
>since glibc 2.3 and wine don't play very well together, unless you build
>wine from CVS.  I always try to leave all possibilities open.

Use LD_ASSUME_KERNEL=2.2.5 for wine until the wine project fixes
wine.


>> Again, my suggestion is to back up your data, install Red Hat 
>> Linux 9, don't modify anything or install homebrew packages, and 
>> try to compile the program.  It will work, trust me.  ;o)  And I 
>> mean you no disrespect.  I'm just trying to show you that it does 
>> really work.
>
>I figured there could be something wrong with my setup.  I went ahead
>and installed XFree86 4.3.0-2, and tried compiling my program again.  It
>now works, and next I'll try compile other packages as well.

Sounds like a confirmation of broken unofficial custom built 
packages causing system problems, as suspected.  I tried to point 
that out as a cause, but you've only taken offense.  Nonetheless, 
I'm glad I was able to help you solve the problem, and hope it 
works well for you.


-- 
Mike A. Harris





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]