[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: RedHat 9 & Radeon 9000



On Fri, 12 Sep 2003, Nathanael Noblet wrote:

>> You can't just swap video cards and use the configuration from a
>> Matrox card on a Radeon for example.
>>
>> If you switch video hardware, you will have to reconfigure X
>> before you use it.  Run:
>>
>> redhat-config-xfree86 --reconfig
>>
>> Then things should work.
>
>*Should* being the operative word. Unfortunately in my case it isn't 
>working. That is why I removed it and put a matrox in. It detected the 
>change and ran the configuration program. I put the radeon in a machine 
>that had had the matrox, and is running Beta (Severn). It detected the 
>card and set it up and it worked.

It works for me, which means that it should also work for you.  
You just need to determine what the problem really is.


>The kicker to all this is that the RH 9 machine that the radeon card 
>came from was working originally. It had been since I first installed. 
>SO, I'm wondering what changed that it won't work. I didn't see any 
>XFree updates recently.

There haven't been any.

>The card is obviously not faulty since I can get it working
>elsewhere. Would there be some kind of file that I can remove or
>something???

No.  It worked before, so it will work now.  Either you've 
changed something or something is misconfigured.  Are you using a 
Red Hat supplied kernel?


>I thought that perhaps part of my problem stems from the fact
>that I have a KVM switch in there and it had trouble detecting
>the monitor settings (though it worked fine on install months
>ago).

KVM switches indeed can cause problems, and as such they are 
unsupported by Red Hat.  It is possible to have a KVM switch that 
works perfectly fine with everything and has no problems, however 
it's also possible to have one that does not work properly or 
interferes with the keyboard, mouse or video, so they're 
unsupported.  Any time you're troubleshooting X configuration 
problems and using a KVM, it is strongly advised to connect the 
hardware directly to the computer without the KVM and solve the X 
problems, simply to remove the KVM out of the way as a variable.


>So I hooked a monitor up directly and it still didn't work. I've
>tried the MonitorLayout suggestions and I don't see any ignore
>messages but I also don't get anything either.

Running "redhat-config-xfree86 --reconfig", and the "--reconfig" 
part is crucial, results in the existing config file being 
eliminated and a brand new one generated.  The new config file 
will be the same config file that would be generated if you were 
to do a brand new fresh OS installation, as the config tool 
generating the file is the same.  The only difference would be 
what other software and versions are installed on your system.

If you're not using a Red Hat binary kernel, all bets are off.


>I've gone and retrieved the XFree86 packages from rawhide. They
>require a newer GLIBC...

The XFree86 binary packages in rawhide will not work on Red Hat 
Linux 9.  The libGL and DRI have been patched with optimizations 
which speed up OpenGL application startup time, as well as thread 
local storage optimizations.  The binary build has many runtime 
dependancies on the environment it was compiled in (rawhide) and 
should not be used unless you're running the Severn beta or 
later.

Since the problem you're having is not the result of an XFree86 
change however, the XFree86-4.3.0-2 should work with what you 
have now, since it did before, and nothing has changed with 
respect to X.  If you were to upgrade to a new X, you're 
replacing something not broken with something not broken, and 
whatever is broken is unlikely to have been changed, so you're 
more likely to not solve the problem.

>which well I don't think would be smart to upgrade on a
>production system...

Correct.

>who knows what will break.

I know many things that will break.


>SO I got the SRPMS, which also require a newer GLIBC package...

No, the current XFree86 src.rpm by default is configured to 
compile for Red Hat Linux development, which ends up in rawhide.  
The package has no hard dependancy on glibc or gcc however and it 
can be configured to compile and work on Red Hat Linux 8.0 and 
later.  I do all of my development and coding on Red Hat Linux 
8.0 using the src.rpm from rawhide.  You can't however just 
recompile it without modification on Red Hat Linux 8.0 or 9, you 
have to edit the spec file and change the defaults appropriately.  

If you try to compile the src.rpm without changing the defaults, 
you'll find that it will require many things from rawhide, a lot 
of which is experimental, or at least is likely to cause large 
problems if just simply dropped into a RHL 9 system.

>SO I got the original XFree SRPMS to rebuild, I have rebuilt
>them, and I'm getting "file conflicts from..." not sure why...
>Its the same packages I would assume. All I did was rpmbuild
>--rebuild XFree86-4.3.0-2.src.rpm

The error message you cite is incomplete, so I can't comment on 
wether that is something caused by something you've done wrong, 
or wether it is a bug in the package that I should fix.  If you 
provide the complete error message, I will likely be able to 
determine that however.  But you definitely shouldn't be using 
rawhide glibc or other major core OS components on a RHL 9 system 
unless you expect breakage and are willing to accept that and 
deal with it.


>So I'm still stuck. I've left the radeon card in this machine
>since I can do most everything from the command line. Though I'd
>like to get it working again.
>
>Any more ideas? Places to look? I've done a rpm -V XFree86 and
>nothing comes up...

You haven't given enough details to begin to hazard a guess as to 
what's wrong on your system.  Instead of guessing what's wrong 
and making random guesses as to how to fix it, then getting 
frustrated when they don't work, and possibly making your entire 
system unstable or unuseable, why not explain the problem, then 
wait until someone who is able to help you has time to respond 
and ask for more details, etc?

Radeon 9000 works on stock Red Hat Linux 9 in singlehead
configuration.  If you use a dualhead configuration (with any
Radeon or FireGL) there is a known bug in the default radeon
driver where the second monitor goes to sleep when the mouse
pointer crosses between screens.  The workaround is to disable
hwcursor.  This has been fixed for quite a while now in rawhide,
and will be fixed in the next RHL 9 XFree86 update also.  If 
you're not using dualhead, then this problem wont affect you.

Run: "redhat-config-xfree86 --reconfig" then startx, if it fails,
then post your config file and X server log, and
/var/log/messages file on the web or ftp somewhere that I can
look at them.  Also, "rpm -V $(rpm -qa |grep XFree86) > rpm.log".  

Be sure to check your hyperlinks in a web browser first before
posting the URLs (I say this because 90% of the time someone
doesn't check their links and they are broken).

I'll look at your config and log file, and see if I can 
determine what it is that is wrong.


-- 
Mike A. Harris




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]