<!DOCTYPE html>
<html lang="en" dir="ltr" prefix="content: http://purl.org/rss/1.0/modules/content/  dc: http://purl.org/dc/terms/  foaf: http://xmlns.com/foaf/0.1/  og: http://ogp.me/ns#  rdfs: http://www.w3.org/2000/01/rdf-schema#  schema: http://schema.org/  sioc: http://rdfs.org/sioc/ns#  sioct: http://rdfs.org/sioc/types#  skos: http://www.w3.org/2004/02/skos/core#  xsd: http://www.w3.org/2001/XMLSchema# ">
<head>
<script id="dpal" src="https://www.redhat.com/ma/dpal.js"></script>
<meta charset="utf-8" />
<meta name="title" content="Celebrate the holidays at your Bash prompt | Enable Sysadmin" />
<link rel="canonical" href="https://www.redhat.com/sysadmin/holiday-bash-prompt" />
<meta property="og:site_name" content="Enable Sysadmin" />
<meta name="twitter:card" content="photo" />
<meta name="dcterms.title" content="Celebrate the holidays at your Bash prompt" />
<meta name="twitter:title" content="Celebrate the holidays at your Bash prompt" />
<meta name="dcterms.creator" content="Jason Baker" />
<meta name="description" content="Your Linux terminal probably supports Unicode, so why not take advantage of that and add a seasonal touch to your prompt?" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.redhat.com/sysadmin/holiday-bash-prompt" />
<meta name="twitter:site:id" content="14627400" />
<meta property="og:title" content="Celebrate the holidays at your Bash prompt" />
<meta name="twitter:creator" content="@jehb" />
<meta name="dcterms.publisher" content="Red Hat, Inc." />
<meta name="twitter:url" content="https://www.redhat.com/sysadmin/holiday-bash-prompt" />
<meta name="twitter:image" content="https://www.redhat.com/sysadmin/sites/default/files/styles/full/public/2019-12/linux-toy-bash-prompt.png?itok=CGCqusyl" />
<meta name="twitter:image:width" content="600" />
<meta name="twitter:image:height" content="1000" />
<meta name="twitter:image:alt" content="Red Hat, Inc." />
<meta property="og:image" content="https://www.redhat.com/sysadmin/sites/default/files/styles/full/public/2019-12/linux-toy-bash-prompt.png?itok=CGCqusyl" />
<meta property="og:image:secure_url" content="https://www.redhat.com/sysadmin/sites/default/files/styles/full/public/2019-12/linux-toy-bash-prompt.png?itok=CGCqusyl" />
<meta name="dcterms.language" content="en" />
<meta property="og:image:type" content="image/jpeg" />
<meta property="og:video:width" content="600" />
<meta property="og:image:width" content="1000" />
<meta property="og:image:height" content="675" />
<meta property="og:image:alt" content="https://www.redhat.com/sysadmin/sites/default/files/styles/full/public/2019-12/linux-toy-bash-prompt.png?itok=CGCqusyl" />
<meta property="og:updated_time" content="2019-12-25T10:00:00+0000" />
<meta property="og:street_address" content="100 East Davie Street" />
<meta property="og:locality" content="Raleigh" />
<meta property="og:region" content="NC" />
<meta property="og:postal_code" content="27601" />
<meta property="og:country_name" content="United States" />
<meta property="og:phone_number" content="+1 919 754 4950" />
<meta property="og:fax_number" content="+1 919 800 3804" />
<meta property="og:locale" content="en_US" />
<meta property="article:author" content="https://www.redhat.com/sysadmin/users/jason-baker" />
<meta property="article:publisher" content="https://www.facebook.com/redhatinc" />
<meta property="article:section" content="Enable Sysadmin" />
<meta property="article:tag" content="Sysadmin culture" />
<meta property="article:modified_time" content="2019-12-25T10:00:00+0000" />
<meta name="Generator" content="Drupal 8 (https://www.drupal.org)" />
<meta name="MobileOptimized" content="width" />
<meta name="HandheldFriendly" content="true" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<script type="application/ld+json">{
    "@context": "https://schema.org",
    "@graph": [
        {
            "@type": "TechArticle",
            "headline": "Celebrate the holidays at your Bash prompt",
            "name": "Celebrate the holidays at your Bash prompt",
            "about": "Sysadmin culture",
            "description": "Your Linux terminal probably supports Unicode, so why not take advantage of that and add a seasonal touch to your prompt?",
            "image": {
                "@type": "ImageObject",
                "url": "https://www.redhat.com/sysadmin/sites/default/files/styles/full/public/2019-12/linux-toy-bash-prompt.png?itok=CGCqusyl",
                "width": "1000",
                "height": "600"
            },
            "dateModified": "2019-12-25T10:00:00+0000",
            "author": {
                "@type": "Person",
                "@id": "https://www.redhat.com/sysadmin/users/jason-baker",
                "name": "Jason Baker",
                "url": "https://www.redhat.com/sysadmin/users/jason-baker",
                "sameAs": "https://twitter.com/jehb"
            },
            "publisher": {
                "@type": "Organization",
                "@id": "https://www.redhat.com/"
            },
            "mainEntityOfPage": "https://www.redhat.com/sysadmin/holiday-bash-prompt"
        },
        {
            "@type": "WebPage",
            "@id": "https://www.redhat.com/sysadmin/holiday-bash-prompt",
            "publisher": {
                "@type": "Organization",
                "@id": "https://www.redhat.com/"
            }
        },
        {
            "@type": "Person",
            "name": "Jason Baker",
            "sameAs": "https://twitter.com/jehb",
            "image": {
                "@type": "ImageObject",
                "url": "https://www.redhat.com/sysadmin/sites/default/files/styles/user_picture_square/public/pictures/2019-05/jason-baker.jpg?itok=WAyYqSp0",
                "width": "240",
                "height": "240"
            }
        },
        {
            "@type": "Corporation",
            "@id": "https://www.redhat.com/",
            "name": "Red Hat, Inc.",
            "url": "https://www.redhat.com/",
            "sameAs": [
                "https://en.wikipedia.org/wiki/Red_Hat",
                "http://www.linkedin.com/company/red-hat",
                "http://www.youtube.com/user/RedHatVideos",
                "https://www.facebook.com/redhatinc",
                "https://twitter.com/RedHat"
            ],
            "telephone": "+1 919 754 4950",
            "contactPoint": {
                "@type": "ContactPoint",
                "telephone": "+1-888-RED-HAT1",
                "availableLanguage": "English",
                "contactType": "sales",
                "faxnumber": "+1 919 800 3804"
            },
            "logo": {
                "@type": "ImageObject",
                "url": "https://www.redhat.com/sysadmin/themes/custom/sysadmin/assets/images/red-hat-logo.png",
                "width": "254",
                "height": "60"
            },
            "address": {
                "@type": "PostalAddress",
                "streetAddress": "100 East Davie Street",
                "addressLocality": "Raleigh",
                "addressRegion": "NC",
                "postalCode": "27601",
                "addressCountry": "United States"
            }
        },
        {
            "@type": "WebSite",
            "@id": "https://www.redhat.com/sysadmin/",
            "name": "Enable Sysadmin",
            "url": "https://www.redhat.com/sysadmin/",
            "publisher": {
                "@type": "Organization",
                "@id": "https://www.redhat.com/"
            }
        }
    ]
}</script>
<link rel="shortcut icon" href="/sysadmin/themes/custom/sysadmin/favicon.ico" type="image/vnd.microsoft.icon" />
<link rel="revision" href="https://www.redhat.com/sysadmin/holiday-bash-prompt" />
<link rel="apple-touch-icon" sizes="180x180" href="/sysadmin/themes/custom/sysadmin/assets/favicon/apple-touch-icon.png">
<link rel="icon" type="image/png" sizes="32x32" href="/sysadmin/themes/custom/sysadmin/assets/favicon/favicon-32x32.png">
<link rel="icon" type="image/png" sizes="16x16" href="/sysadmin/themes/custom/sysadmin/assets/favicon/favicon-16x16.png">
<link rel="manifest" href="/sysadmin/themes/custom/sysadmin/assets/favicon/site.webmanifest">
<link rel="mask-icon" href="/sysadmin/themes/custom/sysadmin/assets/favicon/safari-pinned-tab.svg" color="#ee0000">
<meta name="msapplication-TileColor" content="#1a1a1a">
<meta name="theme-color" content="#ffffff">
<title>Celebrate the holidays at your Bash prompt | Enable Sysadmin</title>
<link rel="stylesheet" media="all" href="/sysadmin/sites/default/files/css/css_y3Xr5G8fIRYFF5ceJ8PSWt5P0C14zqhCAJrGX41FquU.css?q2rtaf" />
<link rel="stylesheet" media="all" href="/sysadmin/sites/default/files/css/css_TjGBCG78x5_q0XdCYHB7NlVjmDlAtmTGO28oOnKzjrk.css?q2rtaf" />


<!--[if lte IE 8]>
<script src="/sysadmin/sites/default/files/js/js_VtafjXmRvoUgAzqzYTA3Wrjkx9wcWhjP0G4ZnnqRamA.js"></script>
<![endif]-->


</head>
<body>
<a href="#main-content" class="visually-hidden focusable">
Skip to main content
</a>

  <div class="dialog-off-canvas-main-canvas" data-off-canvas-main-canvas>
    

<div class="redhat-cookie-banner">
<section id="redhat-cookie-privacy-banner" class="redhat-cookie-banner-wrapper" style="display: block;">
  <div class="container my-3 pr-5">
    <p>We use cookies on our websites to deliver our online services. Details about how we use cookies and how you may disable them are set out in our <a href="http://www.redhat.com/en/about/privacy-policy#cookies">Privacy Statement</a>. By using this website you agree to our use of cookies.
    <span class="cookie-more">
    <a id="redhat-cookie-privacy-banner-close" href="javascript:void(0);" class="cookie-close">&times;</a>
    </span>
    </p>
  </div>
</section>
</div>

<div class="page">

  <div class="navbar navbar-expand-lg justify-content-between navbar-dark bg-dark">
    <div class="container">
                
  <div class="block block--sysadmin-navbar-branding">

  
    

    
  <a href="https://www.redhat.com/" class="navbar-brand ">
            <img src="/sysadmin/themes/custom/sysadmin/logo.svg" width="135" height="31" class="d-inline-block align-top" alt="Red Hat logo" />

        
  </a>


  </div>


      
      <div>
        <button class="navbar-toggler" type="button" data-toggle="collapse"  data-parent="#collapse-parent" data-target="#search-collapse" aria-controls="search-collapse" aria-expanded="false" aria-label="Toggle search">
          <svg class="icon-collapsed" width="30" height="30" viewBox="0 0 30 30" xmlns="http://www.w3.org/2000/svg"><line x1="18.95" y1="19.15" x2="25.25" y2="25.75"/><circle cx="13.25" cy="12.75" r="8.5"/></svg>
          <svg class="icon-expanded" width="30" height="30" viewBox="0 0 30 30" xmlns="http://www.w3.org/2000/svg"><line x1="7.25" y1="7.25" x2="22.75" y2="22.75"/><line x1="7.25" y1="22.75" x2="22.75" y2="7.25"/></svg>
          <span style="vertical-align: middle;">Search</span>
        </button>
        <button class="navbar-toggler" type="button" data-toggle="collapse" data-parent="#collapse-parent" data-target="#mobilenav-collapse" aria-controls="mobilenav-collapse" aria-expanded="false" aria-label="Toggle navigation">
          <svg class="icon-collapsed" width="30" height="30" viewBox="0 0 30 30" xmlns="http://www.w3.org/2000/svg"><path d="M4 7h22M4 15h22M4 23h22"/></svg>
          <svg class="icon-expanded" width="30" height="30" viewBox="0 0 30 30" xmlns="http://www.w3.org/2000/svg"><line x1="7.25" y1="7.25" x2="22.75" y2="22.75"/><line x1="7.25" y1="22.75" x2="22.75" y2="7.25"/></svg>
        </button>
      </div>
    </div>
  </div>

  <div id="collapse-parent">
    <div id="search-collapse" class="search-collapse collapse" data-parent="#collapse-parent">
      <div class="py-4 px-3">
        <form class="form-inline m-2" action="/sysadmin/search/node" accept-charset="UTF-8" method="get">
          <div class="input-group flex-fill">
            <input class="form-control" type="search" name="keys" id="search" value="" placeholder="Search this site…" aria-label="Search this site…">
            <div class="input-group-append">
              <button class="btn btn-secondary font-weight-bold" type="submit">Search</button>
            </div>
          </div>
        </form>
      </div>
    </div>

    <div id="mobilenav-collapse" class="mobilenav-collapse d-lg-none collapse" data-parent="#collapse-parent">
                
  <div class="block block--sysadmin-navbar-sitename sitename">

  
    

    
  <a href="/sysadmin/" class="navbar-brand sitename">
        Enable Sysadmin
  </a>

  <span class="d-none d-lg-inline ml-1 mr-3 h5 navbar-sitename-divider">&nbsp;</span>

  </div>

  <div class="block block--sysadmin-main-menu">

  
    

      
  


  <ul class="nav navbar-nav">
                                  <li class="nav-item  dropdown">
                      <a href="/sysadmin/" class="nav-link dropdown-toggle" data-toggle="dropdown" data-drupal-link-system-path="&lt;front&gt;">Articles</a>
                          <div class="dropdown-menu">
          <a href="/sysadmin/topics/automation" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/146">Automation</a>
          <a href="/sysadmin/topics/career" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/51">Career</a>
          <a href="/sysadmin/topics/sysadmin-culture" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/41">Culture</a>
          <a href="/sysadmin/topics/linux" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/21">Linux</a>
          <a href="/sysadmin/topics/programming" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/71"> Programming</a>
          <a href="/sysadmin/topics/security" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/96">Security</a>
  </div>
                              </li>
                              <li class="nav-item  dropdown">
                      <a href="/sysadmin/about" class="nav-link dropdown-toggle" data-toggle="dropdown" data-drupal-link-system-path="node/71">About</a>
                          <div class="dropdown-menu">
          <a href="/sysadmin/about" class="dropdown-item" data-drupal-link-system-path="node/71">Topics</a>
          <a href="/sysadmin/email" class="dropdown-item" data-drupal-link-system-path="node/376">Email newsletter</a>
          <a href="/sysadmin/join-community" class="dropdown-item" data-drupal-link-system-path="node/641">Join the community</a>
          <a href="/sysadmin/community-guidelines" class="dropdown-item" data-drupal-link-system-path="node/156">Community guidelines</a>
  </div>
                              </li>
                              <li class="nav-item  ">
                      <a href="/sysadmin/welcome" class="nav-link">Welcome</a>
                  </li>
            </ul>


  
  </div>


      
              
          </div>
  </div>

  


<nav class="navbar navbar-expand-lg justify-content-between navbar-light  d-none d-lg-block text-dark bg-light border-bottom-light-gray">
      <div class="container">
  
      
  
  <button class="navbar-toggler" type="button" data-toggle="collapse" data-target=".navbar-collapse" aria-controls="navbar-collapse" aria-expanded="false" aria-label="Toggle navigation">
    <span class="navbar-toggler-icon"></span>
  </button>

  <div class="collapse navbar-collapse">
                  <div class="mr-auto d-flex navbar-desktop">
            
  <div class="block block--sysadmin-navbar-sitename sitename">

  
    

    
  <a href="/sysadmin/" class="navbar-brand sitename">
        Enable Sysadmin
  </a>

  <span class="d-none d-lg-inline ml-1 mr-3 h5 navbar-sitename-divider">&nbsp;</span>

  </div>

  <div class="block block--sysadmin-main-menu">

  
    

      
  


  <ul class="nav navbar-nav">
                                  <li class="nav-item  dropdown">
                      <a href="/sysadmin/" class="nav-link dropdown-toggle" data-toggle="dropdown" data-drupal-link-system-path="&lt;front&gt;">Articles</a>
                          <div class="dropdown-menu">
          <a href="/sysadmin/topics/automation" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/146">Automation</a>
          <a href="/sysadmin/topics/career" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/51">Career</a>
          <a href="/sysadmin/topics/sysadmin-culture" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/41">Culture</a>
          <a href="/sysadmin/topics/linux" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/21">Linux</a>
          <a href="/sysadmin/topics/programming" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/71"> Programming</a>
          <a href="/sysadmin/topics/security" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/96">Security</a>
  </div>
                              </li>
                              <li class="nav-item  dropdown">
                      <a href="/sysadmin/about" class="nav-link dropdown-toggle" data-toggle="dropdown" data-drupal-link-system-path="node/71">About</a>
                          <div class="dropdown-menu">
          <a href="/sysadmin/about" class="dropdown-item" data-drupal-link-system-path="node/71">Topics</a>
          <a href="/sysadmin/email" class="dropdown-item" data-drupal-link-system-path="node/376">Email newsletter</a>
          <a href="/sysadmin/join-community" class="dropdown-item" data-drupal-link-system-path="node/641">Join the community</a>
          <a href="/sysadmin/community-guidelines" class="dropdown-item" data-drupal-link-system-path="node/156">Community guidelines</a>
  </div>
                              </li>
                              <li class="nav-item  ">
                      <a href="/sysadmin/welcome" class="nav-link">Welcome</a>
                  </li>
            </ul>


  
  </div>


        </div>
          
                  
      
      <div class="dropdown show text-align-right">
  <a href="/sysadmin/subscribe" class="navbar-util navbar-util--rss" aria-label="Subscribe to our feed or newsletter blast">
    <svg width="22" height="23" viewBox="0 0 22 23" xmlns="http://www.w3.org/2000/svg"><title>Subscribe to our RSS feed or Email blast</title><path d="M0 4.23c9.79 0 17.75 8 17.75 17.84h4.23A22.05 22.05 0 0 0 0 0v4.23z M0 7.67v4.23c2.74 0 5.33 1.07 7.27 3.03a10.26 10.26 0 0 1 3 7.3h4.24c0-8.02-6.5-14.56-14.51-14.56M2.93 16.87a2.94 2.94 0 0 0 0 5.85 2.93 2.93 0 1 0 0-5.85" fill-rule="evenodd"/></svg>

    <span class="sr-only">Subscribe to our RSS feed or Email blast.</span>
  </a>

    <a id="dropdownSearchLink" href="/sysadmin/search/node" class="navbar-util navbar-util--search" role="button" aria-label="Search this site…" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false">
    <svg width="30" height="30" viewBox="0 0 30 30" xmlns="http://www.w3.org/2000/svg" style="fill:none;stroke-width:3;stroke:#000;stroke-linecap:round;"><line x1="18.95" y1="19.15" x2="25.25" y2="25.75"/><circle cx="13.25" cy="12.75" r="8.5"/></svg>

  </a>
  <div class="dropdown-menu dropdown-menu-right p-1 pt-2" aria-labelledby="dropdownSearchLink">
    <form class="form-inline m-2" action="/sysadmin/search/node" accept-charset="UTF-8" method="get">
      <div class="input-group flex-fill">
        <input class="form-control" type="search" name="keys" id="search" value="" placeholder="Search this site…" aria-label="Search this site…">
        <div class="input-group-append">
          <button class="btn btn-secondary font-weight-bold" type="submit">GO</button>
        </div>
      </div>
    </form>
  </div>
  </div>
      </div>

      </div>
  </nav>

  <main class="pb-5">
                  <header class="page__header">
          <div class="container">
              <div data-drupal-messages-fallback class="hidden"></div>


          </div>
        </header>
          
    <a name="main-content" tabindex="-1"></a>

                  <div class="page__content">
                  
  <div class="block block--sysadmin-content">

  
    

      <article data-history-node-id="1331" role="article" about="/sysadmin/holiday-bash-prompt" typeof="schema:Article" class="full full--article node node--promoted">
  
    <span property="schema:name" content="Celebrate the holidays at your Bash prompt" class="hidden"></span>
  <span property="schema:interactionCount" content="UserComments:0" class="hidden"></span>


      <div  class="section my-5 narrow">
  <div class="container">
    <div >
      
  <div data-layout-content-preview-placeholder-label="&quot;Title&quot; field" class="block">

  
    

      <span property="schema:name"><h1 class="font-weight-bold">Celebrate the holidays at your Bash prompt</h1>
</span>

  
  </div>

  <div data-layout-content-preview-placeholder-label="&quot;Subhead&quot; field" class="block">

  
    

      
            <div class="article__field-subhead">Your Linux terminal probably supports Unicode, so why not take advantage of that and add a seasonal touch to your prompt?</div>
      
  
  </div>

    </div>
  </div>
</div>
<div  class="section pb-5 narrow">
  <div class="container">
    <div >
      
  <div data-layout-content-preview-placeholder-label="&quot;Article Byline&quot; block" class="block">

  
    

      <p class="article-byline">
  <span class="article-date">
          Posted December 25, 2019
      </span>
    <span aria-hidden="true">|</span>
  <span class="article-authors">
    <strong class="sr-only">by</strong>
          <a href="/sysadmin/users/jason-baker" class="article-author article-author--primary">Jason Baker<span class="author-affiliate"> (Red Hat)</span></a>      </span>
  </p>

  
  </div>

  <div data-layout-content-preview-placeholder-label="&quot;Media&quot; field" class="block">

  
    

      
            <div class="article__field-media"><figure>
  
  
  <div class="image__field-media-image">
    <div class="field__label font-weight-bold visually-hidden">
      Image    </div>
                  <div class="field__item">  
<img src="/sysadmin/sites/default/files/styles/full/public/2019-12/linux-toy-bash-prompt.png?itok=CGCqusyl" width="1000" height="600" typeof="foaf:Image" loading="lazy" class="img-thumbnail" src="/sysadmin/sites/default/files/styles/full/public/2019-12/linux-toy-bash-prompt.png?itok=CGCqusyl" alt="Winter Bash Prompt" />


</div>
              </div>

  <figcaption>
    
  </figcaption>
</figure>
</div>
      
  
  </div>

  <div data-layout-content-preview-placeholder-label="&quot;Body&quot; field" class="block">

  
    

      
            <div property="schema:text" class="article__body"><p>Are you on call today, or hiding in the back room to avoid being your family sysadmin over the holidays? Why not celebrate the holidays by adding some winter cheer to your Bash prompt?</p>

<p>Your Bash prompt currently might be a simple dollar sign (<strong>$</strong>), or more likely, it's something a little longer. If you're not sure what makes up your Bash prompt right now, you can find it in an environment variable called $PS1. To see it, type:</p>

<pre>
<code class="language-shell">echo $PS1</code></pre>

<p>For me, this returns:</p>

<pre>
<code class="language-plaintext">[\u@\h \W]\$</code></pre>

<div data-embed-button="resource_list" data-entity-embed-display="view_mode:resource_list.link" data-entity-type="resource_list" data-entity-uuid="60b26066-acd0-4332-afa7-d98c9a079f02" data-langcode="en" class="align-right embedded-entity embedded-entity--resources embedded-entity--resources--link"><aside class="eck-entity mt-2 py-3 pr-3 border-top border-danger"><h2 class="h4">
      More Linux resources
  </h2>

<ul class="pl-3 mb-0"><li class="my-2"><a href="https://developers.redhat.com/cheat-sheets/linux-commands-cheat-sheet/?intcmp=701f20000012ngPAAQ">Download Now: Linux Commands Cheat Sheet</a></li>
      <li class="my-2"><a href="https://developers.redhat.com/cheat-sheets/advanced-linux-commands/?intcmp=701f20000012ngPAAQ">Advanced Linux Commands Cheat Sheet for Developers</a></li>
      <li class="my-2"><a href="https://www.redhat.com/en/technologies/linux-platforms/enterprise-linux/try-it?intcmp=701f20000012ngPAAQ">Download Red Hat Enterprise Linux Server 8 Trial</a></li>
      <li class="my-2"><a href="https://www.redhat.com/rhtapps/assessment/session/?intcmp=701f20000012ngPAAQ">Linux System Administration Skills Assessment</a></li>
  </ul></aside></div>
<p>The <strong>\u</strong>, <strong>\h</strong>, and <strong>\W</strong> are special characters for username, hostname, and working directory. There are others you can use as well; for help building out your Bash prompt, you can use <a href="http://ezprompt.net/" target="_blank">EzPrompt</a>, an online generator of PS1 configurations that includes lots of options including date and time, Git status, and more.</p>

<p>You may have other variables that make up your Bash prompt set as well; <strong>$PS2 </strong>for me contains the closing brace of my command prompt. See <a href="https://access.redhat.com/solutions/505983" target="_blank">this article</a> for more information.</p>

<p>To change your prompt, simply set the environment variable in your terminal like this:</p>

<pre>
<code class="language-shell">$ PS1='\u is cold: '
jehb is cold:</code></pre>

<p>To set it permanently, add the same code to your <strong>/etc/</strong><strong>bashrc</strong><strong> </strong>using your favorite text editor.</p>

<p>So what does this have to do with winterization? Well, chances are on a modern machine, your terminal support Unicode, so you're not limited to the standard ASCII character set. You can use any emoji that's a part of the Unicode specification, including a snowflake ❄, a snowman ☃, or a pair of skis 🎿. You've got plenty of wintery options to choose from.</p>

<pre>
<code class="language-plaintext">🎄 Christmas Tree
🧥 Coat
🦌 Deer
🧤 Gloves
🤶 Mrs. Claus
🎅 Santa Claus
🧣 Scarf
🎿 Skis
🏂 Snowboarder
❄ Snowflake
☃ Snowman
⛄ Snowman Without Snow
🎁 Wrapped Gift</code></pre>

<p>Pick your favorite, and enjoy some winter cheer. Fun fact: modern filesystems also support Unicode characters in their filenames, meaning you can technically name your next program <strong>"❄❄❄❄❄.py"</strong>. That said, please don't. </p>

<p><em><strong>This article was <a href="https://opensource.com/article/18/12/linux-toy-bash-prompt">originally</a> published on Opensource.com in 2018.</strong></em></p>
</div>
      
  
  </div>

  <div data-layout-content-preview-placeholder-label="&quot;Listicle&quot; views block" class="block">

  
    

      <div class="views-element-container"><div class="listicle-view js-view-dom-id-55c77e6150529d10aea533b930079ff556b6030e26ef62dd985a2c881589ff04">
  
  
  

  
  
  

      <div class="listicle-row"><div class="views-field views-field-field-listicle"><div class="field-content"></div></div></div>

    

  
  

  
  
</div>
</div>

  
  </div>

  <div data-layout-content-preview-placeholder-label="&quot;Topics&quot; field" class="block">

  
    

      <div class="topics">
  <strong>Topics:</strong>&nbsp;&nbsp;
      <a href="/sysadmin/topics/sysadmin-culture" class="btn btn-primary btn-sm font-weight-bold">Sysadmin culture</a>&nbsp;&nbsp;
  </div>
  
  </div>

    </div>
  </div>
</div>
<div >
  <div >
    
  <div data-layout-content-preview-placeholder-label="&quot;Entity view (Content)&quot; block" class="block">

  
    

      
<section data-history-node-id="1331" role="article" about="/sysadmin/holiday-bash-prompt" typeof="schema:Article" class="section my-5 py-5 bg-light-gray authors-bio authors-bio--article">
  <div class="container">
          <div class="row">
        <div class="col-md-2 text-center">
                      
<img data-affiliation="Red Hat" src="/sysadmin/sites/default/files/styles/user_picture_square/public/pictures/2019-05/jason-baker.jpg?itok=WAyYqSp0" width="240" height="240" typeof="foaf:Image" loading="lazy" class="rounded-circle img-thumbnail" src="/sysadmin/sites/default/files/styles/user_picture_square/public/pictures/2019-05/jason-baker.jpg?itok=WAyYqSp0" alt="Author’s photo" />


          
        </div>
        <div class="col-md-10 col-lg-8">
          <h2 class="font-weight-light text-center text-md-left">
                          Jason Baker
                      </h2>
          <div>
                          <p>
                Red Hat Certified System Administrator. Linux desktop enthusiast. Map/geospatial nerd. Raspberry Pi tinkerer. Data analysis and visualization geek. Occasional pythonista.
                                  <a href="/sysadmin/users/jason-baker" class="author-more-link">More about me</a>
                              </p>
                      </div>
        </div>
      </div>
      </div>
</section>



  
  </div>

  <div data-layout-content-preview-placeholder-label="&quot;Contributors&quot; block" class="block">

  
    

      

  
  </div>

  </div>
</div>
<div  class="section">
  <div class="container">
    <div >
      
  <div data-layout-content-preview-placeholder-label="&quot;Related Content&quot; views block" class="block">

  
    

      <div class="views-element-container"><div class="js-view-dom-id-0b2aaed91a81df160edaaaaf5898d466de7f76e0dca87ed92fbc227fa743bc48">
  
  
  

  
  
  

    <h2>Related Content</h2>
                        <div class="card-deck my-4">
                        <article data-history-node-id="1376" role="article" about="/sysadmin/perception-reality" typeof="schema:Article" class="card card--article node node--promoted">
      <div class="card-img-top">
            <div class="article__field-media"><article>
  
      
  <div class="image__field-media-image">
    <div class="field__label font-weight-bold visually-hidden">
      Image    </div>
                  <div class="field__item">    <picture>
                <!--[if IE 9]><video style="display: none;"><![endif]-->
              <source srcset="/sysadmin/sites/default/files/styles/card/public/2019-12/person-holding-microsoft-xbox-one-controller-1666759%20Cropped.webp?itok=o0UX9JGC 1x" type="image/webp"/>
              <source srcset="/sysadmin/sites/default/files/styles/card/public/2019-12/person-holding-microsoft-xbox-one-controller-1666759%20Cropped.jpg?itok=o0UX9JGC 1x" type="image/jpeg"/>
            <!--[if IE 9]></video><![endif]-->
            
<img srcset="/sysadmin/sites/default/files/styles/card/public/2019-12/person-holding-microsoft-xbox-one-controller-1666759%20Cropped.jpg?itok=o0UX9JGC 1x" src="/sysadmin/sites/default/files/styles/card/public/2019-12/person-holding-microsoft-xbox-one-controller-1666759%20Cropped.jpg?itok=o0UX9JGC" typeof="foaf:Image" loading="lazy" class="img-thumbnail" src="/sysadmin/sites/default/files/styles/card/public/2019-12/person-holding-microsoft-xbox-one-controller-1666759%20Cropped.jpg?itok=o0UX9JGC" alt="What my family thinks a sysadmin does" />

  </picture>

</div>
              </div>

  </article>
</div>
      </div>
      <div class="card-body">
    <div class="h4 card-title"><a href="/sysadmin/perception-reality"><span property="schema:name">Perception and reality: What my family thinks a sysadmin does</span>
</a></div>
    <div class="card-text">
            <div property="schema:text" class="article__body">A family's thoughts on what a sysadmin does at work.</div>
      </div>
  </div>
  <div class="card-footer">
    <div class="article-date">
      <span class="label">Posted:</span>
      December 24, 2019
    </div>
    <div class="article-authors">
              <span class="label">Author:</span>
                    <a href="/sysadmin/users/bthompson" class="article-author article-author--primary">Brady Thompson<span class="author-affiliate"> (Red Hat Accelerator)</span></a>          </div>
  </div>
</article>


                            <article data-history-node-id="1356" role="article" about="/sysadmin/sysadmin-truths" typeof="schema:Article" class="card card--article node node--promoted">
      <div class="card-img-top">
            <div class="article__field-media"><article>
  
      
  <div class="image__field-media-image">
    <div class="field__label font-weight-bold visually-hidden">
      Image    </div>
                  <div class="field__item">    <picture>
                <!--[if IE 9]><video style="display: none;"><![endif]-->
              <source srcset="/sysadmin/sites/default/files/styles/card/public/2019-12/superhero-kid.webp?itok=sZ-QEwG2 1x" type="image/webp"/>
              <source srcset="/sysadmin/sites/default/files/styles/card/public/2019-12/superhero-kid.jpeg?itok=sZ-QEwG2 1x" type="image/jpeg"/>
            <!--[if IE 9]></video><![endif]-->
            
<img srcset="/sysadmin/sites/default/files/styles/card/public/2019-12/superhero-kid.jpeg?itok=sZ-QEwG2 1x" src="/sysadmin/sites/default/files/styles/card/public/2019-12/superhero-kid.jpeg?itok=sZ-QEwG2" typeof="foaf:Image" loading="lazy" class="img-thumbnail" src="/sysadmin/sites/default/files/styles/card/public/2019-12/superhero-kid.jpeg?itok=sZ-QEwG2" alt="Superhero kid" />

  </picture>

</div>
              </div>

  </article>
</div>
      </div>
      <div class="card-body">
    <div class="h4 card-title"><a href="/sysadmin/sysadmin-truths"><span property="schema:name">Sysadmin truths: What my family thinks I do all day</span>
</a></div>
    <div class="card-text">
            <div property="schema:text" class="article__body">Some jobs are just hard to explain. Nathan Lager makes an attempt to explain his.</div>
      </div>
  </div>
  <div class="card-footer">
    <div class="article-date">
      <span class="label">Posted:</span>
      December 23, 2019
    </div>
    <div class="article-authors">
              <span class="label">Author:</span>
                    <a href="/sysadmin/users/nathan-lager" class="article-author article-author--primary">Nathan Lager<span class="author-affiliate"> (Red Hat)</span></a>          </div>
  </div>
</article>


                            <article data-history-node-id="1351" role="article" about="/sysadmin/family-holiday-sysadmin" typeof="schema:Article" class="card card--article node node--promoted">
      <div class="card-img-top">
            <div class="article__field-media"><article>
  
      
  <div class="image__field-media-image">
    <div class="field__label font-weight-bold visually-hidden">
      Image    </div>
                  <div class="field__item">    <picture>
                <!--[if IE 9]><video style="display: none;"><![endif]-->
              <source srcset="/sysadmin/sites/default/files/styles/card/public/2019-12/group-of-people-watching-on-laptop-1595385.webp?itok=bsyJtrUT 1x" type="image/webp"/>
              <source srcset="/sysadmin/sites/default/files/styles/card/public/2019-12/group-of-people-watching-on-laptop-1595385.jpg?itok=bsyJtrUT 1x" type="image/jpeg"/>
            <!--[if IE 9]></video><![endif]-->
            
<img srcset="/sysadmin/sites/default/files/styles/card/public/2019-12/group-of-people-watching-on-laptop-1595385.jpg?itok=bsyJtrUT 1x" src="/sysadmin/sites/default/files/styles/card/public/2019-12/group-of-people-watching-on-laptop-1595385.jpg?itok=bsyJtrUT" typeof="foaf:Image" loading="lazy" class="img-thumbnail" src="/sysadmin/sites/default/files/styles/card/public/2019-12/group-of-people-watching-on-laptop-1595385.jpg?itok=bsyJtrUT" alt="people watching one person work. " />

  </picture>

</div>
              </div>

  </article>
</div>
      </div>
      <div class="card-body">
    <div class="h4 card-title"><a href="/sysadmin/family-holiday-sysadmin"><span property="schema:name">5 tips for being the family holiday sysadmin</span>
</a></div>
    <div class="card-text">
            <div property="schema:text" class="article__body">Here are 5 tips for preparing yourself for the inundation of technical requests that seem to accompany the holiday season.</div>
      </div>
  </div>
  <div class="card-footer">
    <div class="article-date">
      <span class="label">Posted:</span>
      December 20, 2019
    </div>
    <div class="article-authors">
              <span class="label">Author:</span>
                    <a href="/sysadmin/users/acritelli" class="article-author article-author--primary">Anthony Critelli</a>          </div>
  </div>
</article>


                              </div>
            
    

  
  

  
  
</div>
</div>

  
  </div>

    </div>
  </div>
</div>
<div  class="section my-5 pb-5 narrow">
  <div class="container">
    <div >
      
    </div>
  </div>
</div>
<div  class="section my-5 pb-5 ">
  <div class="container">
    <div >
      

  <div data-layout-content-preview-placeholder-label="&quot;CTA Subscribe (Red on Black)&quot; block" class="block block--cta cta cta--red-on-black cta-- my-5 p-3 text-center">

  
    

    <div class="d-md-flex justify-content-around align-items-center flex-wrap">
    <div class="cta__content my-2">
      
            <div class="cta__field-content p-2"><p class="h4 mb-4 mt-3 font-weight-bold">OUR BEST CONTENT, DELIVERED TO YOUR INBOX</p>

<p><iframe title="Subscribe to our newsletter" aria-label="Embedded form to subscribe to our email newsletter" frameborder="0" height="50" scrolling="no" src="/sysadmin/eloqua-embedded-subscribe.html?offer_id=701f20000012gE7AAI" style="max-width:670px;margin:0 auto;" width="100%"></iframe></p>
</div>
      
    </div>
      </div>
  
  </div>

    </div>
  </div>
</div>

  </article>

  
  </div>


              </div>
        </main>

            <footer>
              <div class="page__colophon bg-dark-gray py-4 bg-dark-gray">
          <div class="container">
              
  <div class="block block--basic block--sysadmin-colophon-disclaimer">

  
    

      
            <div class="basic__body"><p>The opinions expressed on this website are those of each author, not of the author's employer or of Red Hat.</p>

<p>Red Hat and the Red Hat logo are trademarks of Red Hat, Inc., registered in the United States and other countries.</p>
</div>
      
  
  </div>


          </div>
        </div>
                    <div class="page__footer bg-dark py-3">
        <div class="container">
          <div class="d-sm-flex justify-content-between align-items-center">
              

  
    

    
  <a href="https://www.redhat.com/" class="navbar-brand mr-0 mr-lg-auto mb-3 mb-sm-0">
            <img src="/sysadmin/themes/custom/sysadmin/logo.svg" width="135" height="31" class="d-inline-block align-top" alt="Red Hat logo" />

        
  </a>



  <div class="block block--basic block--copyright my-0 mx-sm-3 mb-1 mb-sm-0">

  
    

      
            <div class="basic__body"><p>Copyright ©2019 Red Hat, Inc.</p>
</div>
      
  
  </div>

  <div class="block block--sysadmin-footer my-0 mb-1 mb-sm-0">

  
    

      
  


  <ul class="nav d-flex d-sm-block d-md-flex justify-content-center align-items-center">
                                  <li class="nav-item  ">
                      <a href="https://www.redhat.com/en/about/privacy-policy" class="nav-link">Privacy Policy</a>
                  </li>
                              <li class="nav-item  ">
                      <a href="https://www.redhat.com/en/about/terms-use" class="nav-link">Terms of Use</a>
                  </li>
                              <li class="nav-item  ">
                      <a href="https://www.redhat.com/en/about/all-policies-guidelines" class="nav-link">All policies and guidelines</a>
                  </li>
            </ul>


  
  </div>

  <div class="block block--sharelinks">

  
    

      <div class="a2a_kit a2a_kit_size_32 a2a_floating_style a2a_vertical_style" data-a2a-url="https://www.redhat.com/sysadmin/holiday-bash-prompt">
  <a class="a2a_button_twitter a2a_counter"></a>
  <a class="a2a_button_facebook a2a_counter"></a>
  <a class="a2a_button_linkedin a2a_counter"></a>
  <a class="a2a_button_reddit a2a_counter"></a>
  <a class="a2a_button_email a2a_counter"></a>
</div>
<div class="a2a_kit a2a_kit_size_32 a2a_floating_style a2a_default_style">
  <a class="a2a_button_twitter a2a_counter"></a>
  <a class="a2a_button_facebook a2a_counter"></a>
  <a class="a2a_button_linkedin a2a_counter"></a>
  <a class="a2a_button_reddit a2a_counter"></a>
  <a class="a2a_button_email a2a_counter"></a>
</div>

<script>
  var a2a_config = a2a_config || {};
  a2a_config.templates = a2a_config.templates || {};
  a2a_config.templates.twitter = {
    text: "Celebrate the holidays at your Bash prompt https://red.ht/2SqHxiU via #EnableSysadmin by @jehb",
  };
  a2a_config.templates.facebook = {
    hashtag: "#EnableSysadmin",
  };
</script>
  
  </div>


  <div class="block block--cta block--ctasubscribesidebar cta cta--blue-on-white cta-- my-5 p-3 text-center">

  
    

    <div class="d-md-flex justify-content-around align-items-center flex-wrap">
    <div class="cta__content my-2">
      
            <div class="cta__field-content p-2"><div class="subscribe-sidebar">
<div class="target-band-never-show-button">x</div>

<h4>Subscribe now</h4>

<p class="eloqua-email-capture-text">Get the highlights in your inbox every week.</p>

<p><iframe aria-label="Embedded form to subscribe to our email newsletter" frameborder="0" height="50" scrolling="no" src="/sysadmin/eloqua-embedded-email-capture-block.html?offer_id=701f20000012gE7AAI" style="max-width:670px;margin:0 auto;" title="Subscribe to our newsletter" width="100%"></iframe></p>
</div>
</div>
      
    </div>
      </div>
  
  </div>


          </div>
        </div>
            </footer>
      </div>

  </div>


<script type="application/json" data-drupal-selector="drupal-settings-json">{"path":{"baseUrl":"\/sysadmin\/","scriptPath":null,"pathPrefix":"","currentPath":"node\/1331","currentPathIsAdmin":false,"isFront":false,"currentLanguage":"en"},"pluralDelimiter":"\u0003","ckeditorheight":{"offset":1,"line_height":1.5,"unit":"em"},"user":{"uid":0,"permissionsHash":"653231f2fd62822d854a459f8c9bd92cdd388cedec8e99ad361c1430eee2d8b2"}}</script>
<script src="/sysadmin/sites/default/files/js/js_9eb-EnvnGXlvzduK6BukFzfAEqF9VdfUbhP4wF58USQ.js"></script>

  <script type="text/javascript">
    if (("undefined" !== typeof _satellite) && ("function" === typeof _satellite.pageBottom)) {
      _satellite.pageBottom();
    }
  </script>
</body>
</html>
