<!DOCTYPE html>
<html lang="en" dir="ltr" prefix="content: http://purl.org/rss/1.0/modules/content/  dc: http://purl.org/dc/terms/  foaf: http://xmlns.com/foaf/0.1/  og: http://ogp.me/ns#  rdfs: http://www.w3.org/2000/01/rdf-schema#  schema: http://schema.org/  sioc: http://rdfs.org/sioc/ns#  sioct: http://rdfs.org/sioc/types#  skos: http://www.w3.org/2004/02/skos/core#  xsd: http://www.w3.org/2001/XMLSchema# ">
<head>
<script id="dpal" src="https://www.redhat.com/ma/dpal.js"></script>
<meta charset="utf-8" />
<meta name="title" content="4 lessons for sysadmins from The Unicorn Project | Enable Sysadmin" />
<link rel="canonical" href="https://www.redhat.com/sysadmin/unicorn-project" />
<meta property="og:site_name" content="Enable Sysadmin" />
<meta name="twitter:card" content="photo" />
<meta name="dcterms.title" content="4 lessons for sysadmins from The Unicorn Project" />
<meta name="twitter:title" content="4 lessons for sysadmins from The Unicorn Project" />
<meta name="dcterms.creator" content="jhibbets" />
<meta name="description" content="Lessons for sysadmins and DevOps from the novel &quot;The Unicorn Project.&quot;" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.redhat.com/sysadmin/unicorn-project" />
<meta name="twitter:site:id" content="14627400" />
<meta property="og:title" content="4 lessons for sysadmins from The Unicorn Project" />
<meta name="twitter:creator" content="@jhibbets" />
<meta name="dcterms.publisher" content="Red Hat, Inc." />
<meta name="twitter:url" content="https://www.redhat.com/sysadmin/unicorn-project" />
<meta name="twitter:image" content="https://www.redhat.com/sysadmin/sites/default/files/styles/full/public/2019-12/unicorn-project.jpg?itok=gldRBWIF" />
<meta name="twitter:image:width" content="600" />
<meta name="twitter:image:height" content="1000" />
<meta name="twitter:image:alt" content="Red Hat, Inc." />
<meta property="og:image" content="https://www.redhat.com/sysadmin/sites/default/files/styles/full/public/2019-12/unicorn-project.jpg?itok=gldRBWIF" />
<meta property="og:image:secure_url" content="https://www.redhat.com/sysadmin/sites/default/files/styles/full/public/2019-12/unicorn-project.jpg?itok=gldRBWIF" />
<meta name="dcterms.language" content="en" />
<meta property="og:image:type" content="image/jpeg" />
<meta property="og:video:width" content="600" />
<meta property="og:image:width" content="1000" />
<meta property="og:image:height" content="675" />
<meta property="og:image:alt" content="https://www.redhat.com/sysadmin/sites/default/files/styles/full/public/2019-12/unicorn-project.jpg?itok=gldRBWIF" />
<meta property="og:updated_time" content="2020-01-07T08:00:00+0000" />
<meta property="og:street_address" content="100 East Davie Street" />
<meta property="og:locality" content="Raleigh" />
<meta property="og:region" content="NC" />
<meta property="og:postal_code" content="27601" />
<meta property="og:country_name" content="United States" />
<meta property="og:phone_number" content="+1 919 754 4950" />
<meta property="og:fax_number" content="+1 919 800 3804" />
<meta property="og:locale" content="en_US" />
<meta property="article:author" content="https://www.redhat.com/sysadmin/users/jhibbets" />
<meta property="article:publisher" content="https://www.facebook.com/redhatinc" />
<meta property="article:section" content="Enable Sysadmin" />
<meta property="article:tag" content="DevOps" />
<meta property="article:tag" content="Automation" />
<meta property="article:modified_time" content="2020-01-07T08:00:00+0000" />
<meta name="Generator" content="Drupal 8 (https://www.drupal.org)" />
<meta name="MobileOptimized" content="width" />
<meta name="HandheldFriendly" content="true" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<script type="application/ld+json">{
    "@context": "https://schema.org",
    "@graph": [
        {
            "@type": "TechArticle",
            "headline": "4 lessons for sysadmins from The Unicorn Project",
            "name": "4 lessons for sysadmins from The Unicorn Project",
            "about": [
                "DevOps",
                "Automation"
            ],
            "description": "Lessons for sysadmins and DevOps from the novel \u0022The Unicorn Project.\u0022",
            "image": {
                "@type": "ImageObject",
                "url": "https://www.redhat.com/sysadmin/sites/default/files/styles/full/public/2019-12/unicorn-project.jpg?itok=gldRBWIF",
                "width": "1000",
                "height": "600"
            },
            "dateModified": "2020-01-07T08:00:00+0000",
            "author": {
                "@type": "Person",
                "@id": "https://www.redhat.com/sysadmin/users/jhibbets",
                "name": "jhibbets",
                "url": "https://www.redhat.com/sysadmin/users/jhibbets",
                "sameAs": "https://twitter.com/jhibbets"
            },
            "publisher": {
                "@type": "Organization",
                "@id": "https://www.redhat.com/"
            },
            "mainEntityOfPage": "https://www.redhat.com/sysadmin/unicorn-project"
        },
        {
            "@type": "WebPage",
            "@id": "https://www.redhat.com/sysadmin/unicorn-project",
            "publisher": {
                "@type": "Organization",
                "@id": "https://www.redhat.com/"
            }
        },
        {
            "@type": "Person",
            "name": "Jason Hibbets",
            "sameAs": "https://twitter.com/jhibbets",
            "image": {
                "@type": "ImageObject",
                "url": "https://www.redhat.com/sysadmin/sites/default/files/styles/user_picture_square/public/pictures/2019-05/jhibbets_headshot_sm.jpg?itok=ekjsEjuc",
                "width": "240",
                "height": "240"
            }
        },
        {
            "@type": "Corporation",
            "@id": "https://www.redhat.com/",
            "name": "Red Hat, Inc.",
            "url": "https://www.redhat.com/",
            "sameAs": [
                "https://en.wikipedia.org/wiki/Red_Hat",
                "http://www.linkedin.com/company/red-hat",
                "http://www.youtube.com/user/RedHatVideos",
                "https://www.facebook.com/redhatinc",
                "https://twitter.com/RedHat"
            ],
            "telephone": "+1 919 754 4950",
            "contactPoint": {
                "@type": "ContactPoint",
                "telephone": "+1-888-RED-HAT1",
                "availableLanguage": "English",
                "contactType": "sales",
                "faxnumber": "+1 919 800 3804"
            },
            "logo": {
                "@type": "ImageObject",
                "url": "https://www.redhat.com/sysadmin/themes/custom/sysadmin/assets/images/red-hat-logo.png",
                "width": "254",
                "height": "60"
            },
            "address": {
                "@type": "PostalAddress",
                "streetAddress": "100 East Davie Street",
                "addressLocality": "Raleigh",
                "addressRegion": "NC",
                "postalCode": "27601",
                "addressCountry": "United States"
            }
        },
        {
            "@type": "WebSite",
            "@id": "https://www.redhat.com/sysadmin/",
            "name": "Enable Sysadmin",
            "url": "https://www.redhat.com/sysadmin/",
            "publisher": {
                "@type": "Organization",
                "@id": "https://www.redhat.com/"
            }
        }
    ]
}</script>
<link rel="shortcut icon" href="/sysadmin/themes/custom/sysadmin/favicon.ico" type="image/vnd.microsoft.icon" />
<link rel="revision" href="https://www.redhat.com/sysadmin/unicorn-project" />
<link rel="apple-touch-icon" sizes="180x180" href="/sysadmin/themes/custom/sysadmin/assets/favicon/apple-touch-icon.png">
<link rel="icon" type="image/png" sizes="32x32" href="/sysadmin/themes/custom/sysadmin/assets/favicon/favicon-32x32.png">
<link rel="icon" type="image/png" sizes="16x16" href="/sysadmin/themes/custom/sysadmin/assets/favicon/favicon-16x16.png">
<link rel="manifest" href="/sysadmin/themes/custom/sysadmin/assets/favicon/site.webmanifest">
<link rel="mask-icon" href="/sysadmin/themes/custom/sysadmin/assets/favicon/safari-pinned-tab.svg" color="#ee0000">
<meta name="msapplication-TileColor" content="#1a1a1a">
<meta name="theme-color" content="#ffffff">
<title>4 lessons for sysadmins from The Unicorn Project | Enable Sysadmin</title>
<link rel="stylesheet" media="all" href="/sysadmin/sites/default/files/css/css_y3Xr5G8fIRYFF5ceJ8PSWt5P0C14zqhCAJrGX41FquU.css?q3rox3" />
<link rel="stylesheet" media="all" href="/sysadmin/sites/default/files/css/css_TjGBCG78x5_q0XdCYHB7NlVjmDlAtmTGO28oOnKzjrk.css?q3rox3" />


<!--[if lte IE 8]>
<script src="/sysadmin/sites/default/files/js/js_VtafjXmRvoUgAzqzYTA3Wrjkx9wcWhjP0G4ZnnqRamA.js"></script>
<![endif]-->


</head>
<body>
<a href="#main-content" class="visually-hidden focusable">
Skip to main content
</a>

  <div class="dialog-off-canvas-main-canvas" data-off-canvas-main-canvas>
    

<div class="redhat-cookie-banner">
<section id="redhat-cookie-privacy-banner" class="redhat-cookie-banner-wrapper" style="display: block;">
  <div class="container my-3 pr-5">
    <p>We use cookies on our websites to deliver our online services. Details about how we use cookies and how you may disable them are set out in our <a href="http://www.redhat.com/en/about/privacy-policy#cookies">Privacy Statement</a>. By using this website you agree to our use of cookies.
    <span class="cookie-more">
    <a id="redhat-cookie-privacy-banner-close" href="javascript:void(0);" class="cookie-close">&times;</a>
    </span>
    </p>
  </div>
</section>
</div>

<div class="page">

  <div class="navbar navbar-expand-lg justify-content-between navbar-dark bg-dark">
    <div class="container">
                
  <div class="block block--sysadmin-navbar-branding">

  
    

    
  <a href="https://www.redhat.com/" class="navbar-brand ">
            <img src="/sysadmin/themes/custom/sysadmin/logo.svg" width="135" height="31" class="d-inline-block align-top" alt="Red Hat logo" />

        
  </a>


  </div>


      
      <div>
        <button class="navbar-toggler" type="button" data-toggle="collapse"  data-parent="#collapse-parent" data-target="#search-collapse" aria-controls="search-collapse" aria-expanded="false" aria-label="Toggle search">
          <svg class="icon-collapsed" width="30" height="30" viewBox="0 0 30 30" xmlns="http://www.w3.org/2000/svg"><line x1="18.95" y1="19.15" x2="25.25" y2="25.75"/><circle cx="13.25" cy="12.75" r="8.5"/></svg>
          <svg class="icon-expanded" width="30" height="30" viewBox="0 0 30 30" xmlns="http://www.w3.org/2000/svg"><line x1="7.25" y1="7.25" x2="22.75" y2="22.75"/><line x1="7.25" y1="22.75" x2="22.75" y2="7.25"/></svg>
          <span style="vertical-align: middle;">Search</span>
        </button>
        <button class="navbar-toggler" type="button" data-toggle="collapse" data-parent="#collapse-parent" data-target="#mobilenav-collapse" aria-controls="mobilenav-collapse" aria-expanded="false" aria-label="Toggle navigation">
          <svg class="icon-collapsed" width="30" height="30" viewBox="0 0 30 30" xmlns="http://www.w3.org/2000/svg"><path d="M4 7h22M4 15h22M4 23h22"/></svg>
          <svg class="icon-expanded" width="30" height="30" viewBox="0 0 30 30" xmlns="http://www.w3.org/2000/svg"><line x1="7.25" y1="7.25" x2="22.75" y2="22.75"/><line x1="7.25" y1="22.75" x2="22.75" y2="7.25"/></svg>
        </button>
      </div>
    </div>
  </div>

  <div id="collapse-parent">
    <div id="search-collapse" class="search-collapse collapse" data-parent="#collapse-parent">
      <div class="py-4 px-3">
        <form class="form-inline m-2" action="/sysadmin/search/node" accept-charset="UTF-8" method="get">
          <div class="input-group flex-fill">
            <input class="form-control" type="search" name="keys" id="search" value="" placeholder="Search this site…" aria-label="Search this site…">
            <div class="input-group-append">
              <button class="btn btn-secondary font-weight-bold" type="submit">Search</button>
            </div>
          </div>
        </form>
      </div>
    </div>

    <div id="mobilenav-collapse" class="mobilenav-collapse d-lg-none collapse" data-parent="#collapse-parent">
                
  <div class="block block--sysadmin-navbar-sitename sitename">

  
    

    
  <a href="/sysadmin/" class="navbar-brand sitename">
        Enable Sysadmin
  </a>

  <span class="d-none d-lg-inline ml-1 mr-3 h5 navbar-sitename-divider">&nbsp;</span>

  </div>

  <div class="block block--sysadmin-main-menu">

  
    

      
  


  <ul class="nav navbar-nav">
                                  <li class="nav-item  dropdown">
                      <a href="/sysadmin/" class="nav-link dropdown-toggle" data-toggle="dropdown" data-drupal-link-system-path="&lt;front&gt;">Articles</a>
                          <div class="dropdown-menu">
          <a href="/sysadmin/topics/automation" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/146">Automation</a>
          <a href="/sysadmin/topics/career" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/51">Career</a>
          <a href="/sysadmin/topics/sysadmin-culture" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/41">Culture</a>
          <a href="/sysadmin/topics/linux" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/21">Linux</a>
          <a href="/sysadmin/topics/programming" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/71"> Programming</a>
          <a href="/sysadmin/topics/security" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/96">Security</a>
  </div>
                              </li>
                              <li class="nav-item  dropdown">
                      <a href="/sysadmin/about" class="nav-link dropdown-toggle" data-toggle="dropdown" data-drupal-link-system-path="node/71">About</a>
                          <div class="dropdown-menu">
          <a href="/sysadmin/about" class="dropdown-item" data-drupal-link-system-path="node/71">Topics</a>
          <a href="/sysadmin/email" class="dropdown-item" data-drupal-link-system-path="node/376">Email newsletter</a>
          <a href="/sysadmin/join-community" class="dropdown-item" data-drupal-link-system-path="node/641">Join the community</a>
          <a href="/sysadmin/community-guidelines" class="dropdown-item" data-drupal-link-system-path="node/156">Community guidelines</a>
  </div>
                              </li>
                              <li class="nav-item  ">
                      <a href="/sysadmin/welcome" class="nav-link">Welcome</a>
                  </li>
            </ul>


  
  </div>


      
              
          </div>
  </div>

  


<nav class="navbar navbar-expand-lg justify-content-between navbar-light  d-none d-lg-block text-dark bg-light border-bottom-light-gray">
      <div class="container">
  
      
  
  <button class="navbar-toggler" type="button" data-toggle="collapse" data-target=".navbar-collapse" aria-controls="navbar-collapse" aria-expanded="false" aria-label="Toggle navigation">
    <span class="navbar-toggler-icon"></span>
  </button>

  <div class="collapse navbar-collapse">
                  <div class="mr-auto d-flex navbar-desktop">
            
  <div class="block block--sysadmin-navbar-sitename sitename">

  
    

    
  <a href="/sysadmin/" class="navbar-brand sitename">
        Enable Sysadmin
  </a>

  <span class="d-none d-lg-inline ml-1 mr-3 h5 navbar-sitename-divider">&nbsp;</span>

  </div>

  <div class="block block--sysadmin-main-menu">

  
    

      
  


  <ul class="nav navbar-nav">
                                  <li class="nav-item  dropdown">
                      <a href="/sysadmin/" class="nav-link dropdown-toggle" data-toggle="dropdown" data-drupal-link-system-path="&lt;front&gt;">Articles</a>
                          <div class="dropdown-menu">
          <a href="/sysadmin/topics/automation" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/146">Automation</a>
          <a href="/sysadmin/topics/career" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/51">Career</a>
          <a href="/sysadmin/topics/sysadmin-culture" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/41">Culture</a>
          <a href="/sysadmin/topics/linux" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/21">Linux</a>
          <a href="/sysadmin/topics/programming" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/71"> Programming</a>
          <a href="/sysadmin/topics/security" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/96">Security</a>
  </div>
                              </li>
                              <li class="nav-item  dropdown">
                      <a href="/sysadmin/about" class="nav-link dropdown-toggle" data-toggle="dropdown" data-drupal-link-system-path="node/71">About</a>
                          <div class="dropdown-menu">
          <a href="/sysadmin/about" class="dropdown-item" data-drupal-link-system-path="node/71">Topics</a>
          <a href="/sysadmin/email" class="dropdown-item" data-drupal-link-system-path="node/376">Email newsletter</a>
          <a href="/sysadmin/join-community" class="dropdown-item" data-drupal-link-system-path="node/641">Join the community</a>
          <a href="/sysadmin/community-guidelines" class="dropdown-item" data-drupal-link-system-path="node/156">Community guidelines</a>
  </div>
                              </li>
                              <li class="nav-item  ">
                      <a href="/sysadmin/welcome" class="nav-link">Welcome</a>
                  </li>
            </ul>


  
  </div>


        </div>
          
                  
      
      <div class="dropdown show text-align-right">
  <a href="/sysadmin/subscribe" class="navbar-util navbar-util--rss" aria-label="Subscribe to our feed or newsletter blast">
    <svg width="22" height="23" viewBox="0 0 22 23" xmlns="http://www.w3.org/2000/svg"><title>Subscribe to our RSS feed or Email blast</title><path d="M0 4.23c9.79 0 17.75 8 17.75 17.84h4.23A22.05 22.05 0 0 0 0 0v4.23z M0 7.67v4.23c2.74 0 5.33 1.07 7.27 3.03a10.26 10.26 0 0 1 3 7.3h4.24c0-8.02-6.5-14.56-14.51-14.56M2.93 16.87a2.94 2.94 0 0 0 0 5.85 2.93 2.93 0 1 0 0-5.85" fill-rule="evenodd"/></svg>

    <span class="sr-only">Subscribe to our RSS feed or Email blast.</span>
  </a>

    <a id="dropdownSearchLink" href="/sysadmin/search/node" class="navbar-util navbar-util--search" role="button" aria-label="Search this site…" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false">
    <svg width="30" height="30" viewBox="0 0 30 30" xmlns="http://www.w3.org/2000/svg" style="fill:none;stroke-width:3;stroke:#000;stroke-linecap:round;"><line x1="18.95" y1="19.15" x2="25.25" y2="25.75"/><circle cx="13.25" cy="12.75" r="8.5"/></svg>

  </a>
  <div class="dropdown-menu dropdown-menu-right p-1 pt-2" aria-labelledby="dropdownSearchLink">
    <form class="form-inline m-2" action="/sysadmin/search/node" accept-charset="UTF-8" method="get">
      <div class="input-group flex-fill">
        <input class="form-control" type="search" name="keys" id="search" value="" placeholder="Search this site…" aria-label="Search this site…">
        <div class="input-group-append">
          <button class="btn btn-secondary font-weight-bold" type="submit">GO</button>
        </div>
      </div>
    </form>
  </div>
  </div>
      </div>

      </div>
  </nav>

  <main class="pb-5">
                  <header class="page__header">
          <div class="container">
              <div data-drupal-messages-fallback class="hidden"></div>


          </div>
        </header>
          
    <a name="main-content" tabindex="-1"></a>

                  <div class="page__content">
                  
  <div class="block block--sysadmin-content">

  
    

      <article data-history-node-id="1391" role="article" about="/sysadmin/unicorn-project" typeof="schema:Article" class="full full--article node node--promoted">
  
    <span property="schema:name" content="4 lessons for sysadmins from The Unicorn Project" class="hidden"></span>
  <span property="schema:interactionCount" content="UserComments:0" class="hidden"></span>


      <div  class="section my-5 narrow">
  <div class="container">
    <div >
      
  <div data-layout-content-preview-placeholder-label="&quot;Title&quot; field" class="block">

  
    

      <span property="schema:name"><h1 class="font-weight-bold">4 lessons for sysadmins from The Unicorn Project</h1>
</span>

  
  </div>

  <div data-layout-content-preview-placeholder-label="&quot;Subhead&quot; field" class="block">

  
    

      
            <div class="article__field-subhead">Lessons for sysadmins and DevOps from the novel &quot;The Unicorn Project.&quot;</div>
      
  
  </div>

    </div>
  </div>
</div>
<div  class="section pb-5 narrow">
  <div class="container">
    <div >
      
  <div data-layout-content-preview-placeholder-label="&quot;Article Byline&quot; block" class="block">

  
    

      <p class="article-byline">
  <span class="article-date">
          Posted January 7, 2020
      </span>
    <span aria-hidden="true">|</span>
  <span class="article-authors">
    <strong class="sr-only">by</strong>
          <a href="/sysadmin/users/jhibbets" class="article-author article-author--primary">Jason Hibbets<span class="author-affiliate"> (Red Hat)</span></a>      </span>
  </p>

  
  </div>

  <div data-layout-content-preview-placeholder-label="&quot;Media&quot; field" class="block">

  
    

      
            <div class="article__field-media"><figure>
  
  
  <div class="image__field-media-image">
    <div class="field__label font-weight-bold visually-hidden">
      Image    </div>
                  <div class="field__item">  
<img src="/sysadmin/sites/default/files/styles/full/public/2019-12/unicorn-project.jpg?itok=gldRBWIF" width="1000" height="600" typeof="foaf:Image" loading="lazy" class="img-thumbnail" src="/sysadmin/sites/default/files/styles/full/public/2019-12/unicorn-project.jpg?itok=gldRBWIF" alt="Unicorn project with snowy tree" />


</div>
              </div>

  <figcaption>
    
            <div class="image__field-media-description">Image by <a href="https://pixabay.com/users/JACLOU-DL-5602247/&gt;JacLou DL&lt;/a&gt; from &lt;a href=" https:="">Pixabay</a></div>
      
  </figcaption>
</figure>
</div>
      
  
  </div>

  <div data-layout-content-preview-placeholder-label="&quot;Body&quot; field" class="block">

  
    

      
            <div property="schema:text" class="article__body"><p>Most people practicing DevOps are familiar with the work of Gene Kim. You might have been introduced to DevOps and "The Three Ways" through <a href="https://itrevolution.com/book/the-phoenix-project/" target="_blank"><em>The Phoenix Project</em></a>, or you might rely on <a href="https://itrevolution.com/book/the-devops-handbook/" target="_blank"><em>The DevOps Handbook</em></a> as a guide to change your team’s culture and increase their productivity. Kim is back with a new volume from the perspective of a lead developer and architect in <a href="https://itrevolution.com/book/the-unicorn-project/" target="_blank"><em>The Unicorn Project</em></a>.</p>

<div data-embed-button="resource_list" data-entity-embed-display="view_mode:resource_list.link" data-entity-type="resource_list" data-entity-uuid="dae9de57-962d-4c70-a7f0-b5eda7100a3d" data-langcode="en" class="align-right embedded-entity embedded-entity--resources embedded-entity--resources--link"><aside class="eck-entity mt-2 py-3 pr-3 border-top border-danger"><h2 class="h4">
      More about automation
  </h2>

<ul class="pl-3 mb-0"><li class="my-2"><a href="https://www.ansible.com/resources/get-started?intcmp=701f20000012ngPAAQ">An introduction to Ansible</a></li>
      <li class="my-2"><a href="https://www.ansible.com/products/tower/trial?intcmp=701f20000012ngPAAQ">3 ways to try Ansible Tower free</a></li>
      <li class="my-2"><a href="https://www.ansible.com/resources/ebooks?intcmp=701f2000000h4RcAAI">Free Ansible e-books</a></li>
      <li class="my-2"><a href="https://www.redhat.com/en/engage/technical-ansible-network-s-201903140421?intcmp=701f2000000h4RcAAI">Getting started with network automation</a></li>
  </ul></aside></div>
<p>The book is described as "a novel about developers, digital disruption, and thriving in the age of data." I was hooked on the storyline from the beginning when the lead character, Maxine, was exiled from a great engineering position in the fictional company Parts Unlimited because of a mistake that was made in production.</p>

<p>Maxine took on her new role in the "Phoenix Project" with a smile (and a fair bit of skepticism). Her first challenge was to get the developer build environment up and running on her laptop. This proved to be no easy task as she ran into issue after issue and kept creating tickets with the internal help desk requesting access to certain share folders or license keys. She was getting nowhere fast, but she was determined.</p>

<p>Maxine’s persistence got the attention of others. While instructed to "lay low" by management, that was not her style. She had quite the adventure throughout the rest of the story as she was invited to join "The Rebellion"—a group of the best and brightest engineers in the company training in secret to become a learning organization.</p>

<p>One of my favorite aspects of this book is the realistic scenarios that the teams are facing. It’s the journey they are on that many sysadmins are all too familiar with. The step-by-step task of growing from no build process to an automated one is a key journey with multiple learning opportunities and chances for missteps. There are numerous takeaways here from the perspective of a sysadmin. Let’s take a look at them.</p>

<h2 id="repeatability-and-consistency">Repeatability and consistency</h2>

<p>Maxine was desperately trying to get a build environment, but no one in the entire company was able to replicate. Every developer was checking in code based only on their local environment. Not good.</p>

<div data-embed-button="resource_list" data-entity-embed-display="view_mode:resource_list.link" data-entity-type="resource_list" data-entity-uuid="4bbf9114-d385-4baa-a483-9f41143e1378" data-langcode="en" class="align-right embedded-entity embedded-entity--resources embedded-entity--resources--link"><aside class="eck-entity mt-2 py-3 pr-3 border-top border-danger"><h2 class="h4">
      Great DevOps Downloads
  </h2>

<ul class="pl-3 mb-0"><li class="my-2"><a href="https://opensource.com/downloads/devops-hiring-guide?intcmp=701f20000012ngPAAQ">The ultimate DevOps hiring guide</a></li>
      <li class="my-2"><a href="https://opensource.com/downloads/devops-monitoring-guide?intcmp=701f20000012ngPAAQ">DevOps monitoring tools guide</a></li>
      <li class="my-2"><a href="https://opensource.com/downloads/devsecops?intcmp=701f20000012ngPAAQ">Getting started with DevSecOps</a></li>
  </ul></aside></div>
<p>Her documentation on creating a build environment, notably where the gaps and blockers were, helped members of The Rebellion reach a state of repeatability and standardization. More importantly, having a consistent build experience for each developer was critical to the success of the project. Sysadmins strive to create standardized, repeatable builds for their users to provide a consistent experience.</p>

<h2 id="creating-a-culture-of-learning">Creating a culture of learning</h2>

<p>Eventually, the journey led the teams to deploy code to production. The Unicorn Project was so large, and with so many moving parts, that deploying code was not a pretty task. Imagine multiple conference rooms of people (war rooms) and lots of fingers being crossed during code deployment. Needless to say, there were failures, but they learned from them.</p>

<p>Monitoring, alerting, and lots of log files were involved in the first and future deployments. The team set up tools to help them understand what was happening during code deployments so they could learn faster and fix any problems that popped up. While highly stressful, the team was successful in getting code out. And ultimately, more predictable and more often.</p>

<h2 id="avoid-the-lone-wolf-sysadmin">Avoiding the lone wolf sysadmin</h2>

<p>There was a character in the book, Brent, who was the sysadmin who knew it all. Network question, call Brent. Database issue, call Brent. The server just went down, call Brent. He was the type of employee who couldn’t take a vacation without getting paged. And it wasn’t that Brent was trying to be the lone wolf, it just kind of happened that way because of management.</p>

<p>Thankfully, the storyline improves for Brent, but it leaves a valuable lesson in this story: Lone wolves won’t last long in traditional organizations and the lack of <a href="https://www.redhat.com/sysadmin/poor-documentation">documentation is not job security</a>. Sharing knowledge and workload is critical for successful teams practicing DevOps.</p>

<h2 id="work-harder-not-smarter-with-automation">Working harder not smarter with automation</h2>

<p>No DevOps book would be complete unless we touched on the topic of automation. Maxine and her team were definitely interested in automating those mundane tasks. With the challenges of their build and deployment processes, there was definitely experimentation around what tasks could be automated. I like how the team took baby steps to their automation approach. They didn’t see automation as a way to replace their jobs, they instead saw automation as a way to let them work on more challenging issues.</p>

<h2 id="time-to-give-devops-a-go">Time to give DevOps a go</h2>

<p>In conclusion, I think this is a great read for sysadmins with a desire to help create or be part of a learning culture. You’ll definitely come across a few scenarios in the book where you’ll say, been there, done that. If you’re ready to jump into DevOps practices, step away from the terminal window for a bit, get the download from Gene Kim, and pick up a copy of <em>The Unicorn Project</em>.</p>
</div>
      
  
  </div>

  <div data-layout-content-preview-placeholder-label="&quot;Listicle&quot; views block" class="block">

  
    

      <div class="views-element-container"><div class="listicle-view js-view-dom-id-fd311734a8d4fbeae592ae3062a838978b34ab6653ada66bf33cbe02ff69f9c7">
  
  
  

  
  
  

    <h3>What to read next</h3>
    <div class="listicle-row"><div class="views-field views-field-field-listicle"><div class="field-content"><article data-history-node-id="1321" role="article" about="/sysadmin/optimize-devops" typeof="schema:Article" class="listicle listicle--article node node--promoted">
  <div class="row align-items-center">
    <div class="col-md-6 listicle-image">
            <div class="article__field-media"><article>
  
      
  <div class="image__field-media-image">
    <div class="field__label font-weight-bold visually-hidden">
      Image    </div>
                  <div class="field__item">  
<img src="/sysadmin/sites/default/files/styles/card/public/2019-12/high-angle-photo-of-robot-2599244.jpg?itok=lJwWaecT" width="700" height="420" typeof="foaf:Image" loading="lazy" class="img-thumbnail" src="/sysadmin/sites/default/files/styles/card/public/2019-12/high-angle-photo-of-robot-2599244.jpg?itok=lJwWaecT" alt="happy robot" />


</div>
              </div>

  </article>
</div>
      </div>
    <div class="col-md-6 listicle-body">
      <div class="h4 listicle-title pt-4 pt-md-0"><a href="/sysadmin/optimize-devops"><span property="schema:name">How automation can optimize DevOps</span>
</a></div>
      <div class="listicle-text font-weight-light py-2">
        
            <div property="schema:text" class="article__body">Learn where DevOps stands in the automation process, and how to build automation longevity into your DevOps strategy.</div>
      
      </div>

      <div class="listicle-footer">
        <div class="article-date">
          <span class="label">Posted:</span>
          December 18, 2019
        </div>
        <div class="article-authors">
                      <span class="label">Author:</span>
                                <a href="/sysadmin/users/tazb" class="article-author article-author--primary">Taz Brown</a>                  </div>
      </div>
    </div>
  </div>
</article>
</div></div></div>

    

  
  

  
  
</div>
</div>

  
  </div>

  <div data-layout-content-preview-placeholder-label="&quot;Topics&quot; field" class="block">

  
    

      <div class="topics">
  <strong>Topics:</strong>&nbsp;&nbsp;
      <a href="/sysadmin/topics/devops" class="btn btn-primary btn-sm font-weight-bold">DevOps</a>&nbsp;&nbsp;
      <a href="/sysadmin/topics/automation" class="btn btn-primary btn-sm font-weight-bold">Automation</a>&nbsp;&nbsp;
  </div>
  
  </div>

    </div>
  </div>
</div>
<div >
  <div >
    
  <div data-layout-content-preview-placeholder-label="&quot;Entity view (Content)&quot; block" class="block">

  
    

      
<section data-history-node-id="1391" role="article" about="/sysadmin/unicorn-project" typeof="schema:Article" class="section my-5 py-5 bg-light-gray authors-bio authors-bio--article">
  <div class="container">
          <div class="row">
        <div class="col-md-2 text-center">
                      
<img data-affiliation="Red Hat" src="/sysadmin/sites/default/files/styles/user_picture_square/public/pictures/2019-05/jhibbets_headshot_sm.jpg?itok=ekjsEjuc" width="240" height="240" typeof="foaf:Image" loading="lazy" class="rounded-circle img-thumbnail" src="/sysadmin/sites/default/files/styles/user_picture_square/public/pictures/2019-05/jhibbets_headshot_sm.jpg?itok=ekjsEjuc" alt="Author’s photo" />


          
        </div>
        <div class="col-md-10 col-lg-8">
          <h2 class="font-weight-light text-center text-md-left">
                          Jason Hibbets
                      </h2>
          <div>
                          <p>
                Jason Hibbets is a senior community architect at Red Hat which means he is a mash-up of a community manager and project manager. He works with the Enable Sysadmin community, but also dabbles with Opensource.com and the Open Organization community.
                                  <a href="/sysadmin/users/jhibbets" class="author-more-link">More about me</a>
                              </p>
                      </div>
        </div>
      </div>
      </div>
</section>



  
  </div>

  <div data-layout-content-preview-placeholder-label="&quot;Contributors&quot; block" class="block">

  
    

      

  
  </div>

  </div>
</div>
<div  class="section">
  <div class="container">
    <div >
      
  <div data-layout-content-preview-placeholder-label="&quot;Related Content&quot; views block" class="block">

  
    

      <div class="views-element-container"><div class="js-view-dom-id-f24b599592d17dfbf5232a724e806a506b4fc9880b995dc8f0ddb027e9e5dbeb">
  
  
  

  
  
  

    <h2>Related Content</h2>
                        <div class="card-deck my-4">
                        <article data-history-node-id="1281" role="article" about="/sysadmin/skills-web-developers" typeof="schema:Article" class="card card--article node node--promoted">
      <div class="card-img-top">
            <div class="article__field-media"><article>
  
      
  <div class="image__field-media-image">
    <div class="field__label font-weight-bold visually-hidden">
      Image    </div>
                  <div class="field__item">    <picture>
                <!--[if IE 9]><video style="display: none;"><![endif]-->
              <source srcset="/sysadmin/sites/default/files/styles/card/public/2019-12/grayscale-photo-of-computer-laptop-near-white-notebook-and-169573.webp?itok=V9Ev6NJz 1x" type="image/webp"/>
              <source srcset="/sysadmin/sites/default/files/styles/card/public/2019-12/grayscale-photo-of-computer-laptop-near-white-notebook-and-169573.jpg?itok=V9Ev6NJz 1x" type="image/jpeg"/>
            <!--[if IE 9]></video><![endif]-->
            
<img srcset="/sysadmin/sites/default/files/styles/card/public/2019-12/grayscale-photo-of-computer-laptop-near-white-notebook-and-169573.jpg?itok=V9Ev6NJz 1x" src="/sysadmin/sites/default/files/styles/card/public/2019-12/grayscale-photo-of-computer-laptop-near-white-notebook-and-169573.jpg?itok=V9Ev6NJz" typeof="foaf:Image" loading="lazy" class="img-thumbnail" src="/sysadmin/sites/default/files/styles/card/public/2019-12/grayscale-photo-of-computer-laptop-near-white-notebook-and-169573.jpg?itok=V9Ev6NJz" alt="laptop notebook and coffee mug" />

  </picture>

</div>
              </div>

  </article>
</div>
      </div>
      <div class="card-body">
    <div class="h4 card-title"><a href="/sysadmin/skills-web-developers"><span property="schema:name">6 sysadmin skills web developers need</span>
</a></div>
    <div class="card-text">
            <div property="schema:text" class="article__body">Developers don't work in a vacuum. Here are sysadmin skills that can make any web developer's life easier.</div>
      </div>
  </div>
  <div class="card-footer">
    <div class="article-date">
      <span class="label">Posted:</span>
      December 19, 2019
    </div>
    <div class="article-authors">
              <span class="label">Author:</span>
                    <a href="/sysadmin/user/151801" class="article-author article-author--primary">Suresh Prasanna</a>          </div>
  </div>
</article>


                            <article data-history-node-id="1386" role="article" about="/sysadmin/ansible-guides" typeof="schema:Article" class="card card--article node node--promoted">
      <div class="card-img-top">
            <div class="article__field-media"><article>
  
      
  <div class="image__field-media-image">
    <div class="field__label font-weight-bold visually-hidden">
      Image    </div>
                  <div class="field__item">    <picture>
                <!--[if IE 9]><video style="display: none;"><![endif]-->
              <source srcset="/sysadmin/sites/default/files/styles/card/public/2019-12/automate-machine.webp?itok=s_x2Eq5z 1x" type="image/webp"/>
              <source srcset="/sysadmin/sites/default/files/styles/card/public/2019-12/automate-machine.jpg?itok=s_x2Eq5z 1x" type="image/jpeg"/>
            <!--[if IE 9]></video><![endif]-->
            
<img srcset="/sysadmin/sites/default/files/styles/card/public/2019-12/automate-machine.jpg?itok=s_x2Eq5z 1x" src="/sysadmin/sites/default/files/styles/card/public/2019-12/automate-machine.jpg?itok=s_x2Eq5z" typeof="foaf:Image" loading="lazy" class="img-thumbnail" src="/sysadmin/sites/default/files/styles/card/public/2019-12/automate-machine.jpg?itok=s_x2Eq5z" alt="Automation machine" />

  </picture>

</div>
              </div>

  </article>
</div>
      </div>
      <div class="card-body">
    <div class="h4 card-title"><a href="/sysadmin/ansible-guides"><span property="schema:name">9 Ansible guides to help you ease into automation</span>
</a></div>
    <div class="card-text">
            <div property="schema:text" class="article__body">If you're looking for a way to bring more task automation skills into your toolbox, these guides will bring you up to speed on Ansible.</div>
      </div>
  </div>
  <div class="card-footer">
    <div class="article-date">
      <span class="label">Posted:</span>
      January 1, 2020
    </div>
    <div class="article-authors">
              <span class="label">Author:</span>
                    <a href="/sysadmin/users/jhibbets" class="article-author article-author--primary">Jason Hibbets<span class="author-affiliate"> (Red Hat)</span></a>          </div>
  </div>
</article>


                            <article data-history-node-id="1321" role="article" about="/sysadmin/optimize-devops" typeof="schema:Article" class="card card--article node node--promoted">
      <div class="card-img-top">
            <div class="article__field-media"><article>
  
      
  <div class="image__field-media-image">
    <div class="field__label font-weight-bold visually-hidden">
      Image    </div>
                  <div class="field__item">    <picture>
                <!--[if IE 9]><video style="display: none;"><![endif]-->
              <source srcset="/sysadmin/sites/default/files/styles/card/public/2019-12/high-angle-photo-of-robot-2599244.webp?itok=lJwWaecT 1x" type="image/webp"/>
              <source srcset="/sysadmin/sites/default/files/styles/card/public/2019-12/high-angle-photo-of-robot-2599244.jpg?itok=lJwWaecT 1x" type="image/jpeg"/>
            <!--[if IE 9]></video><![endif]-->
            
<img srcset="/sysadmin/sites/default/files/styles/card/public/2019-12/high-angle-photo-of-robot-2599244.jpg?itok=lJwWaecT 1x" src="/sysadmin/sites/default/files/styles/card/public/2019-12/high-angle-photo-of-robot-2599244.jpg?itok=lJwWaecT" typeof="foaf:Image" loading="lazy" class="img-thumbnail" src="/sysadmin/sites/default/files/styles/card/public/2019-12/high-angle-photo-of-robot-2599244.jpg?itok=lJwWaecT" alt="happy robot" />

  </picture>

</div>
              </div>

  </article>
</div>
      </div>
      <div class="card-body">
    <div class="h4 card-title"><a href="/sysadmin/optimize-devops"><span property="schema:name">How automation can optimize DevOps</span>
</a></div>
    <div class="card-text">
            <div property="schema:text" class="article__body">Learn where DevOps stands in the automation process, and how to build automation longevity into your DevOps strategy.</div>
      </div>
  </div>
  <div class="card-footer">
    <div class="article-date">
      <span class="label">Posted:</span>
      December 18, 2019
    </div>
    <div class="article-authors">
              <span class="label">Author:</span>
                    <a href="/sysadmin/users/tazb" class="article-author article-author--primary">Taz Brown</a>          </div>
  </div>
</article>


                              </div>
            
    

  
  

  
  
</div>
</div>

  
  </div>

    </div>
  </div>
</div>
<div  class="section my-5 pb-5 narrow">
  <div class="container">
    <div >
      
    </div>
  </div>
</div>
<div  class="section my-5 pb-5 ">
  <div class="container">
    <div >
      

  <div data-layout-content-preview-placeholder-label="&quot;CTA Subscribe (Red on Black)&quot; block" class="block block--cta cta cta--red-on-black cta-- my-5 p-3 text-center">

  
    

    <div class="d-md-flex justify-content-around align-items-center flex-wrap">
    <div class="cta__content my-2">
      
            <div class="cta__field-content p-2"><p class="h4 mb-4 mt-3 font-weight-bold">OUR BEST CONTENT, DELIVERED TO YOUR INBOX</p>

<p><iframe title="Subscribe to our newsletter" aria-label="Embedded form to subscribe to our email newsletter" frameborder="0" height="50" scrolling="no" src="/sysadmin/eloqua-embedded-subscribe.html?offer_id=701f20000012gE7AAI" style="max-width:670px;margin:0 auto;" width="100%"></iframe></p>
</div>
      
    </div>
      </div>
  
  </div>

    </div>
  </div>
</div>

  </article>

  
  </div>


              </div>
        </main>

            <footer>
              <div class="page__colophon bg-dark-gray py-4 bg-dark-gray">
          <div class="container">
              
  <div class="block block--basic block--sysadmin-colophon-disclaimer">

  
    

      
            <div class="basic__body"><p>The opinions expressed on this website are those of each author, not of the author's employer or of Red Hat.</p>

<p>Red Hat and the Red Hat logo are trademarks of Red Hat, Inc., registered in the United States and other countries.</p>
</div>
      
  
  </div>


          </div>
        </div>
                    <div class="page__footer bg-dark py-3">
        <div class="container">
          <div class="d-sm-flex justify-content-between align-items-center">
              

  
    

    
  <a href="https://www.redhat.com/" class="navbar-brand mr-0 mr-lg-auto mb-3 mb-sm-0">
            <img src="/sysadmin/themes/custom/sysadmin/logo.svg" width="135" height="31" class="d-inline-block align-top" alt="Red Hat logo" />

        
  </a>



  <div class="block block--basic block--copyright my-0 mx-sm-3 mb-1 mb-sm-0">

  
    

      
            <div class="basic__body"><p>Copyright ©2020 Red Hat, Inc.</p>
</div>
      
  
  </div>

  <div class="block block--sysadmin-footer my-0 mb-1 mb-sm-0">

  
    

      
  


  <ul class="nav d-flex d-sm-block d-md-flex justify-content-center align-items-center">
                                  <li class="nav-item  ">
                      <a href="https://www.redhat.com/en/about/privacy-policy" class="nav-link">Privacy Policy</a>
                  </li>
                              <li class="nav-item  ">
                      <a href="https://www.redhat.com/en/about/terms-use" class="nav-link">Terms of Use</a>
                  </li>
                              <li class="nav-item  ">
                      <a href="https://www.redhat.com/en/about/all-policies-guidelines" class="nav-link">All policies and guidelines</a>
                  </li>
            </ul>


  
  </div>

  <div class="block block--sharelinks">

  
    

      <div class="a2a_kit a2a_kit_size_32 a2a_floating_style a2a_vertical_style" data-a2a-url="https://www.redhat.com/sysadmin/unicorn-project">
  <a class="a2a_button_twitter a2a_counter"></a>
  <a class="a2a_button_facebook a2a_counter"></a>
  <a class="a2a_button_linkedin a2a_counter"></a>
  <a class="a2a_button_reddit a2a_counter"></a>
  <a class="a2a_button_email a2a_counter"></a>
</div>
<div class="a2a_kit a2a_kit_size_32 a2a_floating_style a2a_default_style">
  <a class="a2a_button_twitter a2a_counter"></a>
  <a class="a2a_button_facebook a2a_counter"></a>
  <a class="a2a_button_linkedin a2a_counter"></a>
  <a class="a2a_button_reddit a2a_counter"></a>
  <a class="a2a_button_email a2a_counter"></a>
</div>

<script>
  var a2a_config = a2a_config || {};
  a2a_config.templates = a2a_config.templates || {};
  a2a_config.templates.twitter = {
    text: "4 lessons for sysadmins from The Unicorn Project https://red.ht/2QwZvPv via #EnableSysadmin by @jhibbets",
  };
  a2a_config.templates.facebook = {
    hashtag: "#EnableSysadmin",
  };
</script>
  
  </div>


  <div class="block block--cta block--ctasubscribesidebar cta cta--blue-on-white cta-- my-5 p-3 text-center">

  
    

    <div class="d-md-flex justify-content-around align-items-center flex-wrap">
    <div class="cta__content my-2">
      
            <div class="cta__field-content p-2"><div class="subscribe-sidebar">
<div class="target-band-never-show-button">x</div>

<h4>Subscribe now</h4>

<p class="eloqua-email-capture-text">Get the highlights in your inbox every week.</p>

<p><iframe aria-label="Embedded form to subscribe to our email newsletter" frameborder="0" height="50" scrolling="no" src="/sysadmin/eloqua-embedded-email-capture-block.html?offer_id=701f20000012gE7AAI" style="max-width:670px;margin:0 auto;" title="Subscribe to our newsletter" width="100%"></iframe></p>
</div>
</div>
      
    </div>
      </div>
  
  </div>


          </div>
        </div>
            </footer>
      </div>

  </div>


<script type="application/json" data-drupal-selector="drupal-settings-json">{"path":{"baseUrl":"\/sysadmin\/","scriptPath":null,"pathPrefix":"","currentPath":"node\/1391","currentPathIsAdmin":false,"isFront":false,"currentLanguage":"en"},"pluralDelimiter":"\u0003","ckeditorheight":{"offset":1,"line_height":1.5,"unit":"em"},"user":{"uid":0,"permissionsHash":"653231f2fd62822d854a459f8c9bd92cdd388cedec8e99ad361c1430eee2d8b2"}}</script>
<script src="/sysadmin/sites/default/files/js/js_9eb-EnvnGXlvzduK6BukFzfAEqF9VdfUbhP4wF58USQ.js"></script>

  <script type="text/javascript">
    if (("undefined" !== typeof _satellite) && ("function" === typeof _satellite.pageBottom)) {
      _satellite.pageBottom();
    }
  </script>
</body>
</html>
