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Introduction

The following chapters describe how to deal with classic/old style of JSF and Struts development. We recommend
users to use JBoss Seam [http://www.redhat.com/devel opers/jbds/Getting_Started/GetStartSeamGen.html] to sim-
plify development, but until then you can read about classical JSF and Struts usage here.
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Getting Started Guide for Creating a JSF Application

2.1. Creating a Simple JSF Application

We are going to show you how to create a simple JSF application using the JBoss Developer Studio plug-in for Ec-
lipse. The completed application will ask a user to enter a name and click a button. The resulting new page will dis-
play the familiar message, "Hello <name>!" This document will show you how to create such an application from
the beginning, along the way demonstrating some of the powerful features of JBoss Developer Studio. You will
design the JSF application and then run the application from inside JBoss Developer Studio. We'll assume that you
have already launched Eclipse with JBoss Developer Studio installed and also that the JBoss Developer Studio per-
spective is the current one. (If not, make it active by selecting Window > Open Perspective > Web Devel opment
from the menu bar or by selecting Window > Open Perspective > Other... from the menu bar and then selecting
Web Devel opment from the Select Perspective dialog box.)

2.2. Setting Up the Project

We arefirst going to create a new project for the application.

Go to the menu bar and select File > New > Project...

Select JBoss Tools Web > JSF > JSF Project in the New Project dialog box

Click Next

Enter "jsfHello" as the project name.

» Leaveeverything else asis, and click Finish

2.3. The JSF Application Configuration File

A jsfHello node should appear in the upper-left Package Explorer view.

JBoss Version: 1.0.0.GA 2
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Figure 2.1. Package Explorer View

Click the plus sign next to jsfHello to reveal the child nodes

Click the plus sign next to WebContent under jsfHello

Click the plus sign next to WEB-INF under WebContent

Then double-click on the faces-config.xml node to display the JSF application configuration file editor
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Figure 2.2. Configuration File Editor

2.4. Adding Navigation to the Application

In our simple application, the flow is defined as a single navigation rule connecting two views (presentation files).
At this point, we will create the placeholders for the two JSP presentation files and then the navigation rule to con-
nect them as views. Later, we will complete the coding for the JSP presentation files. With JBoss Developer Stu-
dio, we can do all of thisin the Diagram mode of the configuration file editor.

2.4.1. Adding Two Views (JSP Pages)

Right-click anywhere on the diagram and select New View... from the pop-up menu
« Inthe dialog box, type pages/inputname as the value for From-view-id

» Leaveeverything elseasis

* Click Finish

If you look in the Package Explorer view you should see a pages folder under WebContent. Opening it will re-
veal the JSP file you just created

« Back on the diagram, right-click anywhere and select New View... from the pop-up menu

* Inthedialog box, type pages/greeting as the value for From-view-id

JBoss Version: 1.0.0.GA 4
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* Leaveeverything elseasis

» Click Finish

2.4.1.1. Creating the Transition (Navigation Rule)

* Inthediagram, select the connection icon third from the top along the upper |eft side of the diagram

1

Figure 2.3. Connection Icon

to get an arrow cursor with atwo-pronged plug at the arrow's bottom.

 Click on the pages/inputname page icon and then click on the pages/greeting page icon

A transition should appear between the two icons.

* *faces-config.xmi &3 =0

ks

r
i
o

{page 5/l nputname.|sp
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L+

[pagesgreating.jsp

Diagram | Tree | Source

Figure 2.4. Transition Between Two I cons
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* Select File> Save from the menu bar

2.5. Adding a Managed Bean to the Application

To store datain the application, we will use a managed bean.

« Click onthe Treetab at the bottom of the editing window

» Select the Managed Beans node and then click the Add... button displayed aong the right side of the editor win-
dow

» Typein jsfHello.PersonBean for Class and personBean for Name. Leave Scope as is and Generate Source Code
asis (checked)

* Click Finish

» personBean will now be selected and three sections of information: Managed Bean, Properties, and Advanced,
will be displayed about it. Under the Properties section, click the Add... button

« Type in name for Property-Name. Leave everything else as is. (When Property- Class is not filled in, String is
the assumed type)

 Click Finish
» Select the personBean node in the tree

Y ou should see this now:

| faces-configxml & o0 inputname jsp =8

Faces Config Editor

= faces-config ~ Managed Bean
= A faces-config.xml Managed-Bean-Name: |PersanBear1 |
2] Application
_ Managed-Bean-Class: ||erello.F!ersanEean | Browse... ]
55 Components —
& Converters Managed-Bean-Scope: | |:]
= kg Managed Beans Description: <]
B
o name -
= Lk Navigation Rules Ll
= W jpagesfinputname jsp name class value . Add... .
g N ... | -
k& Referenced Beans
=7 Render Kits | Edt... J
i Validators
% Extensions
(] [1») =

Diagram Tree  Source
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Figure2.5. Tree View in Config Editor

* Sdlect File > Save from the menu bar

Y ou have now registered the managed bean and created a stub-coded classfile for it.

2.6. Editing the JSP View Files

Now we will finish editing the JSP files for our two "views" using JSP Visual Page.
2.6.1. inputname.jsp

* Click on the Diagramtab for the configuration file editor
« Open the editor for thisfirst JSP file by double-clicking on the /pages/inputname. jsp icon

The Visua Page Editor will open in a screen split between source code along the top and a WY SIWIG view along
the bottom:

JBoss Version: 1.0.0.GA 7
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Figure 2.6. Visual Page Editor

Some JSF code is already in the file, because we have chosen atemplate to create a page.

» Select the Visual tab, so we can work with the editor completely inits WY SIWY G mode

» Totheright of the editor, in the JBoss Tools Paette, expand the JSF HTML palette folder by selecting it
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Figure 2.7. JBoss Tools Palette

 Click on formwithin this folder, drag the cursor over to the editor, and drop it inside the red box in the editor
» Another red box will appear inside the first red box

¢ Right-click on the innermost box and select <h:form> Attributes from the menu

* Inthevaluefield next toid, type greeting and click on the Close button

» Type "Please enter name:" inside the boxes

o Select inputText within the JSF HTML palette folder and drag it into the innermost box in the editor after "Please
enter name:"

JBoss Version: 1.0.0.GA 9



Getting Started Guide for Creating a JSF Application

 Intheattributes dialog, click in the value field next to the value attribute and click on the ... button
* Then, select the Managed Beans > personBean > name node and click on the Ok button

e Back in the attributes dialog, select the Advanced tab, type in name as the value for the "id" attribute, and then
click on the Finish button

¢ Select commandButton within the JSF HTML palette folder and drag it into the innermost box in the editor after
the input box

* Intheattributes dialog, click in the value field next to the "action™" attribute and click on the ... button
» Then, select the View Actions > greeting node and click on the OK button

» Back in the attributes dialog box, type in "Say Hello" as the value for the value attribute ("Say Hello") and then
click on the Finish button

The source coding should be something like this now:

<y@taglib uri="
<U@taglib uri="
<htm >

<head>
<title></title>
</ head>

<body>

<f:view
<h:formid="greeting">

<par a>Pl ease enter a nane: </ par a>

<h:i nput Text id="nane" val ue="#{personBean. nane}"/>

<h: conmandBut t on val ue=" Say Hello " action="greeting"/>
</ h: form

</f:view

</ body>

</htm >

ttp://java.sun.com jsf/htm" prefix="h" %
ttp://java.sun.conljsf/core" prefix="f" %

=r =r

The editor should look like this;

JBoss Version: 1.0.0.GA 10
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M faces-config.xmi <o *inputmame jsp 23 =0
-

X Please enter name: |#{Fersnnﬂean.name} Say Hello |

%

Tl

h:form x

Visual/Source Visual Source Preview

Figure 2.8. Visual Page Editor

« Savethefile by selecting File > Save from the menu bar
2.6.2. greeting.jsp

* Click on the faces-config.xml tab to bring the diagram back

* Open the editor for the second file by double-clicking on the /pages/greeting.jsp icon

» Select the Visual tab, so we can work with the editor completely inits WY SIWY G mode
« Type"Héllo " (note space after Hello) into the box

e Select outputText within the JSF HTML palette folder and drag it into the innermost box in the editor after
"Hello"

« Intheattributes dialog, click in value field next to the value attribute and click on the ... (Browse) button

» Then, select the Managed Beans > personBean > name node, click on the Ok button, and then click on the Fin-
ish button

» Right after the output field, type an exclamation point (1)
The source coding should be something like this now:

<Y@taglib uri="http://java.sun.conljsf/htm" prefix="h" %

JBoss Version: 1.0.0.GA 11
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<U@taglib uri="http://java.sun.conljsf/core" prefix="f" %
<htm >

<head>

<title></title>

</ head>

<body>

<f:view>

Hel | o <h: out put Text val ue="#{per sonBean. nane}"/>!
</f:view

</ body>

</htm >

* Savethefile

2.7. Creating the Start Page

Y ou also need to create a start page as an entry point into the application.

* Inthe Package Explorer view to the left, right-click jsfHello > WebContent and select New > JSP File
« For Name type in index, for Template select JSPRedirect and click Finish

A JSP editor will open up on the newly created file.

 Inthe Source part of the split screen, type /pages/inputname.jsf in between the quotes for the page attribute

The source coding should look like this now:

<ldoctype html public "-//w3c//dtd htm 4.0 transitional//en">
<htm >

<head></ head>

<body>

<j sp: forward page="/pages/inputnane.jsf" />

</ body>

</htm >

Note the .jsf extension for the file name. Thisis a mapping defined in the web.xml file for the project for invoking
JavaServer Faces when you run the application.

* Select File > Save from the menu bar

2.8. Running the Application

Everything is now ready for running our application without having to leave JBoss Developer Studio by using the
JBoss engine that comes with the JBoss Developer Studio plug-in. For controlling JBoss server within JBoss De-
veloper Studio thereis JBoss Server view:

JBoss Version: 1.0.0.GA 12
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“J JBoss Server View I3 =0

¥ 0

Figure 2.9. JBoss Server View

« Start up JBoss by clicking on the icon in JBoss Server view. (If JBoss is already running, stop it by clicking on
the red icon and then start it again. Remember, the JSF run-time requires restarting the servlet engine when any
changes have been made.) After the messages in the Consol e tabbed view stop scrolling, JBossis available

* Click the Runicon or right click your project folder and select Run As> Run on Server:

{&r id -

|Flur‘| Ag .

Figure 2.10. Run Icon

This is the equivalent of launching the browser and typing http://localhost:8080/jsfHello into your browser. Our
JSF application should now appear.

2.9. Other relevant resources on the topic

JSF on Sun; JavaServer Faces Technology [http://java.sun.com/javaee/javaserverfaces/]

Core JSF: Core JavaServer Faces [http://www.horstmann.com/corejsf/]

API: JSF API [http://java.sun.com/javaeel/javaserverfaces/1.1/docs/api/index.html]

JSF Tags: JSF Core Tags [ http://www.horstmann.com/corejsf/jsf-tags.html]

HTML Tags Reference: JISF HTML Tags Reference [http://www.exadel .com/tutorial/jsf/jsftags-guide.html]
JSF Central: JSF Centra - Y our JavaServer Faces Community [http://www.jsfcentral.com/]

FAQ: JSF FAQ [http://wiki.java.net/bin/view/Projects/ JavaServerFacesSpeckaq]

Download: JavaServer Faces Technology - Download [http://java.sun.com/javaee/javaserverfaces/download.html]

JBoss Version: 1.0.0.GA 13
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Getting Started Guide for Creating a Struts Applica-
tion

We are going to show you how to create a simple Sruts application using the JBoss Developer Studio. The com-
pleted application will ask a user to enter a name and click a button. The resulting new page will display the famili-
ar message, "Hello <name>!"

This document will show you how to create such an application from the beginning, along the way demonstrating
some of the powerful features of JBoss Developer Studio. Y ou will design the application, generate stub code for
the application, fill in the stub coding, compile the application, and run the application all from inside JBoss De-
veloper Studio.

We assume that you have aready launched Eclipse with JBoss Developer Studio installed and also that the Web
Development perspective is the current perspective. (If not, make it active by selecting Window > Open Per spect-
ive > Other > Web Development from the menu bar.)

3.1. Starting Up

We are first going to create a new project for the application.

» Go to the menu bar and select File > New > Project....

» Select JBoss Tools Web > Sruts > Struts Project in the New Project dialog box
» Click Next

» Enter "StrutsHello" as the project name

« Leave everything else asis, and click Next

» Click Next again

» Make sure that struts-bean.tld, struts-html.tld, and struts-logic.tld are checked in the list of included tag libraries
and then click Finish

A "StrutsHello" node should appear in the upper-left Package Explorer view.

¢ Click the plus sign next to SrutsHello to reveal the child nodes

* Click the plus sign next to WebContent under StrutsHello

JBoss Version: 1.0.0.GA 14
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¢ Click the plus sign next to WEB-INF under WebContent

¢ Then, double-click on the struts-config.xml node to display a diagram of the Struts application configuration file
in the editing area

At this point, its empty except for the background grid lines.

3.2. Creating the Application Components

Now, we will design the application by creating the individual components as placeholders first. (We dont have to
complete al of the details inside the components until afterwards.)

3.2.1. Creating JSP Page Placeholders

Next, let's create and place two JSP pages. We will not write any code for the files, but only create them as place-
holders so that we can create links to them in the diagram. We will write the code alittle bit later.

3.2.1.1. Creating the Page Placeholders

» Bring the Web Projects view to the front of the Package Explorer view by selecting the Web Projects tab next to
that tab.

» Right-click the SrutsHello > WEB-ROOT (WebContent) folder in the Web Projects view and select New >
Folder...

» Enter pages for afolder name and click Finish
* Wewill keep our presentation files in this folder
« Right-click the pages folder and select New > Fila> JSP...

e For Name type in inputname (the JSP extension will be automatically added to the file), for Template select
SrutsForm and then click on the Finish button

» Right-click the pages folder again and select New > File > JSP...

For Nametypein greeting, for Template leave as Blank, and then click on the Finish button

Just leave these files asis for now.
3.2.1.2. Placing the Page Placeholders

Lets now place the two pages just created on the diagram.

¢ Click on the struts-config.xml tab in the Editing area to bring the diagram to the front

« Click on the inputname.jsp page in the Web Projects view, drag it onto the diagram, and drop it

JBoss Version: 1.0.0.GA 15



Getting Started Guide for Creating a Struts Application

 Click on the greeting.jsp page in the Web Projects view, drag it onto the diagram, and drop it to the right of the/
pages/inputname.jsp icon with some extra space

Y ou should now have two JSP pages in the diagram.

3.2.2. Creating an Action Mappings

Using a context menu on the diagram, we are next going to create an Action mapping.

* Right-click between the two icons and select Add > Action

» Enter the following values:

Table3.1.
path /greeting
name GetNameForm
scope request
type sample.GreetingAction
validate <leave blank>

("GetNameForm" is the name for aform bean that we will create later.)

* Click Finish

The /greeting action should appear in four places, in the diagram, under the action-mappings node, under the struts-
config.xml node in Tree view, in Web Projects view and in the Outline view. Also, note the asterisk to the right of
the name, struts-config.xml, in the Outline view showing that the file has been changed, but not saved to disk.

3.2.3. Creating a Link

Let'snow create alink from the inputname.jsp page to the action.

« Ontheleft-hand side of the diagram in the column of icons, click on thisicon:

1

Figure 3.1. Create New Connection I con

« |n the connect-the-components mode you are in now, click on the /pages/inputname.jsp icon in the diagram and
then click on the /greeting action

JBoss Version: 1.0.0.GA 16
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A link will be created from the page to the action.

3.2.4. Creating a Forward

Next, we are going to create a forward for the action.

¢ On theleft-hand side of the diagram in the column of icons, click on thisicon, again:

1

Figure 3.2. Create New Connection Icon

« Click on the /greeting action icon in the diagram and then click on the pages/greeting.jsp icon

e That'sit. A link will be drawn from the actions new greeting forward to the greeting.jsp JSP page. Note that the
forwards name will be set based on the name of the target JSP file name. If you don't like it, you can easily
changeit

» Select the Tree tab at the bottom of the editor window (between Diagram and Source)

« Expand the struts-config.xml/action-mappings/greeting node and then select the greeting forward

 |Inthe Properties Editor to the right, change the text to "sayHello" in the Name field

» Select the Diagram tab at the bottom of the editor window and see how the diagram is also updated to reflect the

change

3.2.5. Creating a Global Forward

One last component that we need to create in the diagram is a global forward.

» Somewherein the top-left corner of diagram, right-click and select Add > Global Forward...

» Enter getName in the Name field

» Select the Change...button for Path

« |n the Edit Path window, switch to the Pages tab

« Expand the SrutsHello > WEB-ROOT (WebContent) > pages node and then select the inputname.jsp page
* Click Ok.

» Leavetherest of thefields blank and click OK

A forward object now appears on the diagram and also in the global-forwards folder in the Outline view.
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« Tidy up the diagram, by clicking and dragging around each icon, so that the diagram looks something like this:

| ¢ | gethame

/pages/inputname.|sp
=

fgraating

GetNameaFor...

sayhelk

[ J—
L i ]

/pagesigresting.jsp

@] &

Figure 3.3. Diagram View

3.2.6. Creating a Form Bean

One last thing that we need to do isto create aform bean.

« Switch to the Tree viewer in the editor for the struts-config.xml file, by selecting the Tree tab at the bottom of
the editor window

* Right-click struts-config.xml > form-beans and select Create Form Bean

» Enter GetNameFormin the name field and sample.GetNameForm for type

* Click Finish

« To save your changes to struts-config.xml, select File > Save from the menu bar

Note the disappearance of the asterisk next to the name, struts-config.xml.

3.3. Generating Stub Coding

We are done with designing the application through the diagram. Now we need to write code for the action com-
ponent. We also need to write an action class for the /greeting mapping along with a FormBean. To aid in the cod-
ing phase, JBoss Developer Studio can generate Java class stubs for all of the components shown in the diagram.
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« Switch back to the diagram, by selecting the Diagram tab at the bottom of the editor window
* Right-click ablank space in the diagram and select Generate Java Code

» Leaveeverything asisin the dialog box and click Generate

Y ou should see a screen that says:

Generated classes; 2

Actions: 1

Form beans: 1

 Click Finish

The Javafiles will be generated in a JavaSource > sample folder that you can see in the Package Explorer view un-
der the "StrutsHello" node. One Action stub and one FormBean stub will have been generated.

3.4. Coding the Various Files

We will now code both the Java stub classes just generated, the JSP files left in as placeholders from previous
steps, and a new start JSP page we will have to create.

3.4.1. Java Stub Classes

To finish the two Java classes, switch to the Package Explorer view and expand the JavaSource > sample folder

3.4.1.1. GetNameForm.java

Double-click GetNameForm.java for editing

« You are looking at a Java stub class that was generated by JBoss Developer Studio. Now we are going to edit the
file

Add the following attributes at the beginning of the class:

private String name = "";
private String greetNane = ""

* |nside the reset method, delete the TO DO and throw lines and add:

this.nane = "";
this.greetName = ""

Inside the validate method, delete the TO DO and throw lines and add:
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ActionErrors errors = new ActionErrors();
return errors;

* Right-click and select Source > Generate Getters and Setters...from the context menu

« In the dialog box, check the check boxes for name and greetName, select First method for Insertion point, and

click on the OK button
The final GetNameForm.java file should look like this:

package sanpl €;

i mport javax.servlet.http. HtpServl et Request;
i mport org.apache. struts. action. Acti onErrors;

i mport org.apache. struts. action. Acti onMappi ng;

public class Get NameFor m ext ends org. apache. struts. acti on. Acti onForm

{
private String nane = ""
private String greetName = "";
public String getNane()
{
return nane;
}
public void set Nanme(String nane)
{
thi s. nane = nane;
}
public String get G eet Nane()
{
return greet Nane;
}
public void set G eetName(String greetNane)
{
t hi s. greet Name = greet Naneg;
}
publ i ¢ Get NameFor n()
{
}
public void reset (Acti onMappi ng acti onMappi ng, HttpServl et Request request)
{
this.name = "";
this.greetName = ""
}
public ActionErrors validate(Acti onMappi ng acti onMappi ng, Htt pServl et Request request)
{
ActionErrors errors = new Acti onErrors();
return errors;
}
}
» Savethefile

3.4.1.2. GreetingAction.java
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« Open GreetingAction.javafor editing
« |Inside the execute method, delete the TO DO lines and add the following:

String nane = ((Get NameForm forn).get Name();
String greeting = "Hello, "+name+"!";

((Get NaneForm) f orm) . set Nanme( gr eeti ng);

return mappi ng. fi ndFor war d( FORWARD _sayHel | 0) ;

Thefinal version of GreetingAction.java should look like this:

package sanpl €;

i mport javax.servlet.http. HtpServl et Request;
i mport javax.servlet.http. HtpServl et Response;
i mport org. apache. struts. action. Acti onForm

i mport org.apache. struts. action. Acti onForwar d;
i mport org.apache. struts. action. Acti onMappi ng;

public class G eetingAction extends org.apache.struts. action. Action

{
/1 d obal Forwards
public static final String GLOBAL_FORWARD get Name = "get Nane";
/1 Local Forwards
public static final String FORWARD sayHel |l o = "sayHel | 0o";
public G eetingAction()
{
}
public ActionForward execute(Acti onMappi ng mappi ng, ActionForm form
Ht t pSer vl et Request request, HttpServl et Response response) throws Exception
{
String name = ((Get NameForn)form.get Nane();
String greeting = "Hello, "+nane+"!";
((Get NameForm f orm) . set Nanme(greeting);
return mappi ng. fi ndForwar d( FORWARD _sayHel | 0) ;
}
}
» Savethefile

* Close the editors for the two Javafiles

The last thing left to do is to code the JSP files whose editors should still be open from having been created as
placeholders.

3.4.2. JSP Pages

3.4.2.1. inputname.jsp

In this page, the user will enter any name and click the submit button. Then, the greeting action will be called
through the form.

I nput name:

JBoss Version: 1.0.0.GA 21



Getting Started Guide for Creating a Struts Application

 Click on the inputname.jsp tab in the Editing areato bring its editor forward

* In the Web Projects view, expand SrutsHello > Configuration > default > struts-config.xml > action-mappings
and select /greeting

« Drag it and drop it between the quotes for the "action” attribute to the <html:form> element in the Source pane
of the editor

« Then typethistext on anew line just below thisline:
e Select the Visual pane of the editor

» Then, in the JBoss Tools Pa ette, expand the Sruts Form library, select text, and drag it onto the box

Note:

By default there are only four groups on the JBoss Tools Palette. If you wish to make some group visible
click the Show/Hide button on the top of palette and in the prompted dialog check the group (or groups)
you want to be shown.
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Figure 3.4. JBoss Tools Palette

In the Insert Tag dialog box, type in name for property and select Finish

In the StrutsForm library in the JBoss Tools Palette, select submit, and drag it to right after the text box in the
Visual pane of the editor

Right-click the submit button and select <html:submit> Attributes from the context menu

In the Attributes dialog box, select the value field and type in "Say Hello!" for its value

After tidying the page source, the Editor window for the file should look something like this:
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 struts-config xmi | inputname jsp 3

<%@d taglib wri="/WEB-INF/struts-html® prefix="html"® %=

<html:html==

<head=
ctitles</title=

</head=

=hody=
<html:Torm action="/greeting.do™>
Input name:
<html:text property="name" /=
=html:submit value="Say Hello!" /=
=f/html: form=

</body =

=/html: himl=

0| 1|

L |
=
by
—_
=1

- ]| ==

Say Hello! I

X Input name: |
e

iy

htrml:form

Visual/Source Visual Source Preview

Figure 3.5. Editor Window

3.4.2.2. greeting.jsp

Next, we will fill in the result page.

* Click on the greeting.jsp tab in the Editing area to bring its editor forward

» Typein the following code:

<htm >
<head>
<title>Greeting</title>
</ head>
<body>
<p>
</ p>
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</ body>
</htm >

To complete editing of this file, we will use macros from the JBoss Tools Palette. This palette is a view that should
be available to the right of the editing area.

¢ Click on the Sruts Common folder in the JBoss Tools Palette to open it

« Position the cursor at the beginning of the greeting.jsp file in the Source pane and then click on bean taglib in the
JBoss Taools Palette

Thiswill insert the following line at the top of thefile:

<U@taglib uri="/WEB-|NF/struts-bean.tld" prefix="bean" %

Click on the Sruts Bean folder in the JBoss Tools Palette to open it

Position the cursor inside the <p> element
* Click onwritein the JBoss Tools Palette
* Typein "GetNameForm" for the "name" attribute and add a "property" attribute with "greetName" asits value

The editor should now look likethis:
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Ep struts-config.xml o inputname jsp |0z *gresting jsp &2 =0
%@ taglib uri="/WEB-INF/struts-bean.tld” prefix="bean" %=
<html=

«head=>

<titlexGresting</titlex

=/head=

<hean:write name="GetNameForm®™ property="greetNama" />

=/p=
body:
= html= -
b

(<]

-
ﬂ I]JI'{LI"Li".“-‘l'.'l.I!' b
% -
B
html body p bean-write X

VisualfSource  Visual Source | Preview

Figure 3.6. Editor Window

3.4.2.3. index.jsp

Finally, we will need to create and edit an index.jsp page. This page will use a Struts forward to simply redirect us
to the getName global forward.

« In the Web Projects view, right-click on SrutsHello > WEB-ROOT(WebContent) node and select New > File >
JSP..

» Typeindex for Name and click on the Finish button
« Onthe JBoss Taools Palette, select the Sruts Common folder of macros by clicking on it in the pal ette
» Click onthelogic taglib icon

» Pressthe Enter key in the editor to go to the next line

JBoss Version: 1.0.0.GA 26



Getting Started Guide for Creating a Struts Application

« Back on the palette, select the Sruts Logic folder of macros
* Click on redirect

« Delete the ending tag, put a forward slash in front of the closing angle bracket, and type "forward=getName" in
front of the slash

The finished code for the page is shown below:

<v@taglib uri="/WEB-INF/struts-logic.tld" prefix="logic" %
<l ogi c: redirect forward="getName"/>

* To saveall the edits to files, select File>Save All from the menu bar

3.5. Compiling the Classes

Because this is the Eclipse environment, no explicit compilation step is required. By default, Eclipse compiles as
you go.

3.6. Running the Application

Everything is now ready for running our application without having to leave JBoss Developer Studio by using the

JBoss Application Server engine that comes with the JBoss Developer Studio. For controlling JBoss AS within
JBoss Developer Studio, there is JBoss Server view.

“J |Boss Server View I3 =0
¥ 0

Figure 3.7. JBoss Server Panel

e Start up JBoss AS by clicking on the icon in JBoss Server view. (If JBoss ASis aready running, stop it by click-
ing on the red icon and then start it again. Remember, the Struts run-time requires restarting the servlet engine
when any changes have been made.)

« After the messages in the Console tabbed view stop scrolling, JBoss AS is available. At this point, right-click on
the getName global forward in the struts-config.xml diagram view and select Run on Server.

The browser should appear with the application started.

3.7. Other relevant resources on the topic

Apache Struts: Struts Technology [http://struts.apache.org/]
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Struts 2: Apache Struts 2 [http://struts.apache.org/2.x/]
Get Started: Struts Getting Started [http://struts.apache.org/2.x/docs/home.html]

Struts on IBM: Struts - An open-source MVC
tp:/iwww.ibm.com/devel operworks/library/j-struts/]

FAQ: Struts FAQ [http://struts.apache.org/2.x/docs/fags.html]

Download: Release of Apache Struts [http://struts.apache.org/downl oad.cgi#struts206]

implementation

[ht-

JBoss Version: 1.0.0.GA

28


http://struts.apache.org/2.x/
http://struts.apache.org/2.x/
http://struts.apache.org/2.x/docs/home.html
http://struts.apache.org/2.x/docs/home.html
http://www.ibm.com/developerworks/library/j-struts/
http://www.ibm.com/developerworks/library/j-struts/
http://www.ibm.com/developerworks/library/j-struts/
http://struts.apache.org/2.x/docs/faqs.html
http://struts.apache.org/2.x/docs/faqs.html
http://struts.apache.org/download.cgi#struts206
http://struts.apache.org/download.cgi#struts206

Getting Started Struts Validation Examples

Validation of input is an important part of any Web application. All Apache Jakarta frameworks, including Struts,
can use a common Jakarta Validation Framework for streamlining this aspect of Web application development. The
Vdidation Framework alows you to define validation rules and then apply these rules on the client-side or the
server-side.

JBoss Developer Studio makes using the Validation Framework in Struts even easier with the help of a specialized
editor for the XML files that controls validation in a project. In this document, we'll show you how this all works
by creating some simple client-side validation and server-side validation examples.

4.1. Starting Point

The example assumes that you have already created our sample "StrutsHello" application from the Getting Started
Guide for Creating a Struts Application. You should have the JBoss Developer Studio perspective open on this
StrutsHello project.

4.2. Defining the Validation Rule

In these steps you will set up the validation that can be used for either client-side or server side validation. You
need to enable validation as a part of the project, define an error message, and tie it into an appropriate part of the
application.

* Right-click on a"plug-ins' node under the StrutsHello > Configuration > default > struts-config.xml node in the
Web Projects view and select Create Special Plugin > Validators from the context menu

« Further down in the Web Projects view, right-click on the StrutsHello > ResourceBundles node and select New
> Properties File...from the context menu

* Inthedialog box, click on the Browse...button next to the Folder field, expand the JavaSource folder in this next
dialog box, select the sample subfolder, and click on the OK button

» Back in thefirst dialog box, type in "applResources’ for the Name field and click on the Finish button

» Right-click on anewly created file and select Add > Default Error Messages from the context menu

« Drag up the sample.applResourcesicon until you can drop it on the resources folder under struts-config.xml
» Select File> Save All from the menu bar

» Select validation.xml under the StrutsHello > Validation node and double-click it to open it with the JBoss Tools
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XML Editor
* Here you must create a Formset.
 Inthevalidation.xml file editor click the button Create Formset on the panel Formsets

» |In the dialog Add Formset fill the fields Language and Country or just leave them empty to create a default
formset. Click OK

5 applResources properties W s =08

Formsels
i=

T Add Formset ®

Validation Formset
Mo ane fra
Leave the Melds empty to create a default fomMmset.
Language: b |
Country: b |

a L1+

Figure4.1. Create Formset

« Expand the "form-beans' node under the SrutsHello > Configuration > default > struts-config.xml node. Then,
drag the form bean "GetNameForm™ and drop it onto aformset in the XML Editor

 Inthe Validation Editor, expand the formset node, right-click GetNameForm, and select Create Field... from the
context menu

« Enter aname for Property in the dialog box. A new property will be created:
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Ha oA ' ) —

. Indexed List Prope Edit ]

- |=F t (default
- formst (defaull) Msg - Corresponded Message Template

Constants
nanme key resource Add |

= o GetMameForm

= MewProperty

Arg - Replacement Value for Message Template
nane arg ey resource | Add

Var - Valldator Parameter

var-name var-valua Bdd

(2] ' [*]

Farmsets  Valldators | Constants  Tree | Source

Figure4.2. New Property |s Added

* In the Properties view for the name field to the right of the "tree" for the validation.xml file, click on the
Change...button next to the Depends entry field

* Inthedisplayed double list, select required from the left list and then click Add

* Click Ok

* Right-click name and select Add Arg... from the context menu

* Inthe Add Arg dialog box, click on the Change...button next to the Key field

* IntheKey dialog box that appears now, click on the Add button

* Enter "name.required” in the Name field, and enter a person's name in the Value field
¢ Click Finish, then Ok, and then Ok again

¢ Sdlect File> Save All from the menu bar

4.3. Client-Side Validation
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Client-side validation uses a scripting language (like JavaScript) running in the client browser to actually do the
validation. In a Struts application using the Validation Framework, however, you don't actually have to do any of
the script coding. The Validation Framework handles this.

To see how thisworks in our application, you'll just need to make a couple of maodifications to one of the JSP files.

* Double-click inputname.jsp under StrutsHello > WEB-ROOT(WebContent) > pages to open it for editing
« Find the tag near the top and hit Return to make a new line under it
« Inthe JBoss Tools Palette view to the right, open the Struts HTML folder and click on the javascript tag

e Back in the editor, just in front of the closing slash for this inserted tag, hit Ctrl+Space and select "formName"
from the prompting menu

* Over in the Web Projects view, select GetNameForm under the StrutsHello > Configuration > default > struts-
config.xml > form-beans node, drag it, and drop it between the quotes in the editor

* Modify the <html:form> tag by inserting this attribute:

onsubm t="return val i dat eGet NaneFor n(this)"

The file should now look like this:

<U@taglib uri="/WEB-|INF/struts-htm .tld" prefix="htm" %
<htm : htm >
<head>

<title> nput name</title>

<htm :javascri pt formName="Get NaneFor ni'/ >

</ head>
<body>
<htm : form acti on="/greeting.do" onsubmt="return
<par a>val i dat eGet NaneFor n('t hi s) " ></ par a>
<tabl e border="0" cel |l spaci ng="0" cel | paddi ng="0">
<tr>
<t d><b>| nput name: </ b></td>
</tr>
<tr>
<t d>
<htm :text property="name" />
<htm :subnmit value=" Say Hello! " />
</td>
</tr>
</t abl e>
</htm :fornp
</ body>
</htm :htm >

» Select File> Save from the menu bar
» Start JBoss Application Server by clicking on itsicon (aright-pointing arrow) in the tool bar

» Click the Runicon or right click your project folder and select Run As> Run on Server
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Figure4.3. Run Icon

 Inthe browser window, click on the "Say Hello!" button without having entered any name in the form

A JavaScript error message should be displayed in an alert box.

4.4. Server Side Validation

Server side validation does the validation inside the application on the server. In a Struts application using the Val-
idation Framework, you still don't have to do any of the actual validation coding. The Validation Framework
handles this. You will though have to make a few changes to the JSP file you modified for client-side validation
along with a change to an action and a few changes to the form bean class.

4.5. Editing the JSP File

» Reopen inputname.jsp for editing

» Delete the "onsubmit" attribute in the <html:form> element that you put in for client-side validation
¢ Add an <html:errors> tag after the <html:form> tag

The JSP file should now look like this:

<v@taglib uri="/WEB-INF/struts-htm .tld" prefix="htm" %
<htm :htm >
<head>

<title> nput name</title>

<htm :javascri pt fornmName="Get NaneFor ni'/ >

</ head>
<body>
<htnm :form acti on="/greeting. do">
<tabl e border="0" cel |l spaci ng="0" cel | paddi ng="0">
<tr>
<t d><b>| nput nane: </ b></td>
</tr>
<tr>
<t d>
<htm :text property="nane" />
<htm :submit value=" Say Hello! " />
</td>
</tr>
</t abl e>
</htm :fornp
<htm :errors />
</ body>
</htm :htm >
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4.6. Editing the Action

* In the Web Projects view, expand the node under the StrutsHello > Configuration > default > struts-config.xml
> action-mappings node, right-click the /greeting action, and then select Properties...from the context menu

* In the Edit Properties window, insert the cursor into the value column for the input property and click on the ...
button

* Inthe dialog box, make sure the Pages tab is selected, select SrutsHello > WEB-ROOT(WebContent) > pages >
inputname.jsp, click the Ok button, and then click on the Close button

4.7. Editing the Form Bean

* Right-click the /greeting action again and select Open Form-bean Source to open the GetNameForm.java file for
editing

* Change the class that it extends from: org.apache.struts.action.ActionForm to
org.apache.struts.validator.Validator Form

« Comment out avalidate method
The file should now look like this:

package sanpl e;

i mport javax.servlet.http. HtpServl et Request;
i mport org. apache. struts. action. ActionErrors;

i mport org. apache. struts. acti on. Acti onMappi ng;
public class Get NameFor m ext ends

org. apache. struts. val i dator. Val i dat or Form

{
private String name = ""

/**

* @eturn Returns the nane.
=

public String get Nane()

{

}

return nane;

/**
* @aram nane The nanme to set.
*/
public void setNane(String nane)
{
t hi s. name = nane;
}
publ i c Get NaneForm ()
{
}

public void reset (Acti onMappi ng acti onMappi ng,
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Ht t pSer vl et Request request)
{

}

this.nane = ""

/1 public ActionErrors validate(Acti onvappi ng acti onMappi ng,
Ht t pSer vl et Request request)
{

/1 ActionErrors errors = new ActionErrors();
/] return errors;
I}

* Select File> Save All from the menu bar

* Reload the application into JBoss AS by clicking on the "Change Time Stamp" icon (a finger pointing with a
little star) in the toolbar

* Run the application
* Inthe browser window, click on the "Say Hello!" button without having entered any name in the form

The error message should appear in arefreshed version of the form.

4.8. Other Resources

You can also read Struts [http://www.redhat.com/devel opers/jbds/JSFT ools/Struts.html] chapter in our "JBoss JSF
Tools' guide for more information on this topic.
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