<!DOCTYPE html>
<html lang="en" dir="ltr" prefix="content: http://purl.org/rss/1.0/modules/content/  dc: http://purl.org/dc/terms/  foaf: http://xmlns.com/foaf/0.1/  og: http://ogp.me/ns#  rdfs: http://www.w3.org/2000/01/rdf-schema#  schema: http://schema.org/  sioc: http://rdfs.org/sioc/ns#  sioct: http://rdfs.org/sioc/types#  skos: http://www.w3.org/2004/02/skos/core#  xsd: http://www.w3.org/2001/XMLSchema# ">
<head>
<script id="dpal" src="https://www.redhat.com/ma/dpal.js"></script>
<meta charset="utf-8" /><script type="text/javascript">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</script>
<link rel="canonical" href="https://www.redhat.com/sysadmin/pki-protection" />
<meta property="og:site_name" content="Enable Sysadmin" />
<meta name="twitter:card" content="photo" />
<meta name="dcterms.title" content="Exploring PKI weaknesses and how to combat them" />
<meta name="twitter:title" content="Exploring PKI weaknesses and how to combat them" />
<meta name="dcterms.creator" content="Joerg Kastning" />
<meta name="description" content="Public key infrastructure has some known weaknesses. See how Certificate Authority Authorization and Certificate Transparency help strengthen certificate infrastructures." />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.redhat.com/sysadmin/pki-protection" />
<meta name="twitter:site:id" content="14627400" />
<meta property="og:title" content="Exploring PKI weaknesses and how to combat them" />
<meta name="twitter:creator" content="@JoergKastning" />
<meta name="dcterms.publisher" content="Red Hat, Inc." />
<meta name="twitter:url" content="https://www.redhat.com/sysadmin/pki-protection" />
<meta name="twitter:image" content="https://www.redhat.com/sysadmin/sites/default/files/styles/full/public/2021-04/Counter_Measure.jpg?itok=YvsL8E5f" />
<meta name="twitter:image:width" content="600" />
<meta name="twitter:image:height" content="1000" />
<meta name="twitter:image:alt" content="Red Hat, Inc." />
<meta property="og:image" content="https://www.redhat.com/sysadmin/sites/default/files/styles/google_discover/public/2021-04/Counter_Measure.jpg?itok=Q5T37CKF" />
<meta property="og:image:secure_url" content="https://www.redhat.com/sysadmin/sites/default/files/styles/google_discover/public/2021-04/Counter_Measure.jpg?itok=Q5T37CKF" />
<meta name="dcterms.language" content="en" />
<meta property="og:image:type" content="image/jpeg" />
<meta property="og:video:width" content="600" />
<meta property="og:image:width" content="1000" />
<meta property="og:image:height" content="675" />
<meta property="og:image:alt" content="https://www.redhat.com/sysadmin/sites/default/files/styles/google_discover/public/2021-04/Counter_Measure.jpg?itok=Q5T37CKF" />
<meta property="og:updated_time" content="2021-05-07T09:00:00+0000" />
<meta property="og:street_address" content="100 East Davie Street" />
<meta property="og:locality" content="Raleigh" />
<meta property="og:region" content="NC" />
<meta property="og:postal_code" content="27601" />
<meta property="og:country_name" content="United States" />
<meta property="og:phone_number" content="+1 919 754 4950" />
<meta property="og:fax_number" content="+1 919 800 3804" />
<meta property="og:locale" content="en_US" />
<meta property="article:author" content="https://www.redhat.com/sysadmin/users/joerg-kastning" />
<meta property="article:publisher" content="https://www.facebook.com/redhatinc" />
<meta property="article:section" content="Enable Sysadmin" />
<meta property="article:tag" content="Linux" />
<meta property="article:tag" content="Security" />
<meta property="article:tag" content="Linux Administration" />
<meta property="article:modified_time" content="2021-05-07T09:00:00+0000" />
<meta name="Generator" content="Drupal 8 (https://www.drupal.org)" />
<meta name="MobileOptimized" content="width" />
<meta name="HandheldFriendly" content="true" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<script type="application/ld+json">{
    "@context": "https://schema.org",
    "@graph": [
        {
            "@type": "TechArticle",
            "headline": "Exploring PKI weaknesses and how to combat them",
            "name": "Exploring PKI weaknesses and how to combat them",
            "about": [
                "Linux",
                "Security",
                "Linux Administration"
            ],
            "description": "Public key infrastructure has some known weaknesses. See how Certificate Authority Authorization and Certificate Transparency help strengthen certificate infrastructures.",
            "image": {
                "@type": "ImageObject",
                "url": "https://www.redhat.com/sysadmin/sites/default/files/styles/full/public/2021-04/Counter_Measure.jpg?itok=YvsL8E5f",
                "width": "1000",
                "height": "600"
            },
            "dateModified": "2021-05-07T09:00:00+0000",
            "author": {
                "@type": "Person",
                "@id": "https://www.redhat.com/sysadmin/users/joerg-kastning",
                "name": "Joerg Kastning",
                "url": "https://www.redhat.com/sysadmin/users/joerg-kastning",
                "sameAs": "https://twitter.com/JoergKastning"
            },
            "publisher": {
                "@type": "Organization",
                "@id": "https://www.redhat.com/"
            },
            "mainEntityOfPage": "https://www.redhat.com/sysadmin/pki-protection"
        },
        {
            "@type": "WebPage",
            "@id": "https://www.redhat.com/sysadmin/pki-protection",
            "publisher": {
                "@type": "Organization",
                "@id": "https://www.redhat.com/"
            }
        },
        {
            "@type": "Person",
            "name": "Jörg Kastning",
            "sameAs": "https://twitter.com/JoergKastning",
            "image": {
                "@type": "ImageObject",
                "url": "https://www.redhat.com/sysadmin/sites/default/files/styles/user_picture_square/public/pictures/2019-07/Profil_im_Buero2.jpg?itok=sT9B8A7a",
                "width": "240",
                "height": "240"
            }
        },
        {
            "@type": "Corporation",
            "@id": "https://www.redhat.com/",
            "name": "Red Hat, Inc.",
            "url": "https://www.redhat.com/",
            "sameAs": [
                "https://en.wikipedia.org/wiki/Red_Hat",
                "http://www.linkedin.com/company/red-hat",
                "http://www.youtube.com/user/RedHatVideos",
                "https://www.facebook.com/redhatinc",
                "https://twitter.com/RedHat"
            ],
            "telephone": "+1 919 754 4950",
            "contactPoint": {
                "@type": "ContactPoint",
                "telephone": "+1-888-RED-HAT1",
                "availableLanguage": "English",
                "contactType": "sales",
                "faxnumber": "+1 919 800 3804"
            },
            "logo": {
                "@type": "ImageObject",
                "url": "https://www.redhat.com/sysadmin/themes/custom/sysadmin/assets/images/red-hat-logo.png",
                "width": "254",
                "height": "60"
            },
            "address": {
                "@type": "PostalAddress",
                "streetAddress": "100 East Davie Street",
                "addressLocality": "Raleigh",
                "addressRegion": "NC",
                "postalCode": "27601",
                "addressCountry": "United States"
            }
        },
        {
            "@type": "WebSite",
            "@id": "https://www.redhat.com/sysadmin/",
            "name": "Enable Sysadmin",
            "url": "https://www.redhat.com/sysadmin/",
            "publisher": {
                "@type": "Organization",
                "@id": "https://www.redhat.com/"
            }
        }
    ]
}</script>
<meta name="robots" content="max-image-preview:large" />
<link rel="shortcut icon" href="/sysadmin/themes/custom/sysadmin/favicon.ico" type="image/vnd.microsoft.icon" />
<link rel="revision" href="https://www.redhat.com/sysadmin/pki-protection" />
<link rel="apple-touch-icon" sizes="180x180" href="/sysadmin/themes/custom/sysadmin/assets/favicon/apple-touch-icon.png">
<link rel="icon" type="image/png" sizes="32x32" href="/sysadmin/themes/custom/sysadmin/assets/favicon/favicon-32x32.png">
<link rel="icon" type="image/png" sizes="16x16" href="/sysadmin/themes/custom/sysadmin/assets/favicon/favicon-16x16.png">
<link rel="manifest" href="/sysadmin/themes/custom/sysadmin/assets/favicon/site.webmanifest">
<link rel="mask-icon" href="/sysadmin/themes/custom/sysadmin/assets/favicon/safari-pinned-tab.svg" color="#ee0000">
<meta name="msapplication-TileColor" content="#1a1a1a">
<meta name="theme-color" content="#ffffff">
<title>Exploring PKI weaknesses and how to combat them | Enable Sysadmin</title>
<link rel="stylesheet" media="all" href="/sysadmin/sites/default/files/css/css_2Ew0_ikik0izh0qMFMR7w68r84J2tIix6ef-CYJmkec.css" />
<link rel="stylesheet" media="all" href="/sysadmin/sites/default/files/css/css_gGRMdr75XlcR9J0iJo8mIghgaz02dh2Sp6Oexln3n2g.css" />


<!--[if lte IE 8]>
<script src="/sysadmin/sites/default/files/js/js_VtafjXmRvoUgAzqzYTA3Wrjkx9wcWhjP0G4ZnnqRamA.js"></script>
<![endif]-->
<script src="/sysadmin/sites/default/files/js/js_QHqjxhGPGgZFwOfW92tmrVpssmC1sbO0zDG4TgLmaEI.js"></script>


</head>
<body>
<a href="#main-content" class="visually-hidden focusable">
Skip to main content
</a>

  <div class="dialog-off-canvas-main-canvas" data-off-canvas-main-canvas>
    

<div class="redhat-cookie-banner">
<section id="redhat-cookie-privacy-banner" class="redhat-cookie-banner-wrapper" style="display: block;">
  <div class="container my-3 pr-5">
    <p>We use cookies on our websites to deliver our online services. Details about how we use cookies and how you may disable them are set out in our <a href="http://www.redhat.com/en/about/privacy-policy#cookies">Privacy Statement</a>. By using this website you agree to our use of cookies.
    <span class="cookie-more">
    <a id="redhat-cookie-privacy-banner-close" href="javascript:void(0);" class="cookie-close">&times;</a>
    </span>
    </p>
  </div>
</section>
</div>

<div class="page d-flex flex-column">
  <div class="navbar navbar-expand-lg justify-content-between navbar-dark bg-dark">
    <div class="container">
                
  <div class="block block--sysadmin-navbar-branding">

  
    

    
  <a href="https://www.redhat.com/" class="navbar-brand ">
            <img src="/sysadmin/themes/custom/sysadmin/logo.svg" width="135" height="31" class="d-inline-block align-top" alt="Red Hat logo" />

        
  </a>


  </div>


      
      <div class="navbar-toggler-wrapper">
        <button class="navbar-toggler" type="button" data-toggle="collapse"  data-parent="#collapse-parent" data-target="#search-collapse" aria-controls="search-collapse" aria-expanded="false" aria-label="Toggle search">
          <svg class="icon-collapsed" width="30" height="30" viewBox="0 0 30 30" xmlns="http://www.w3.org/2000/svg"><line x1="18.95" y1="19.15" x2="25.25" y2="25.75"/><circle cx="13.25" cy="12.75" r="8.5"/></svg>
          <svg class="icon-expanded" width="30" height="30" viewBox="0 0 30 30" xmlns="http://www.w3.org/2000/svg"><line x1="7.25" y1="7.25" x2="22.75" y2="22.75"/><line x1="7.25" y1="22.75" x2="22.75" y2="7.25"/></svg>
          <span style="vertical-align: middle;">Search</span>
        </button>
        <button class="navbar-toggler" type="button" data-toggle="collapse" data-parent="#collapse-parent" data-target="#mobilenav-collapse" aria-controls="mobilenav-collapse" aria-expanded="false" aria-label="Toggle navigation">
          <svg class="icon-collapsed" width="30" height="30" viewBox="0 0 30 30" xmlns="http://www.w3.org/2000/svg"><path d="M4 7h22M4 15h22M4 23h22"/></svg>
          <svg class="icon-expanded" width="30" height="30" viewBox="0 0 30 30" xmlns="http://www.w3.org/2000/svg"><line x1="7.25" y1="7.25" x2="22.75" y2="22.75"/><line x1="7.25" y1="22.75" x2="22.75" y2="7.25"/></svg>
        </button>
      </div>
    </div>
  </div>

  <div id="collapse-parent">
    <div id="search-collapse" class="search-collapse collapse" data-parent="#collapse-parent">
      <div class="py-4 px-3">
        <form class="form-inline m-2" action="/sysadmin/search/node" accept-charset="UTF-8" method="get">
          <div class="input-group flex-fill">
            <input class="form-control" type="search" name="keys" id="search" value="" placeholder="Search this site…" aria-label="Search this site…">
            <div class="input-group-append">
              <button class="btn btn-secondary font-weight-bold" type="submit">Search</button>
            </div>
          </div>
        </form>
      </div>
    </div>

    <div id="mobilenav-collapse" class="mobilenav-collapse d-lg-none collapse" data-parent="#collapse-parent">
                
  <div class="block block--sysadmin-navbar-sitename sitename">

  
    

    
  <a href="/sysadmin/" class="navbar-brand sitename">
        Enable Sysadmin
  </a>

  <span class="d-none d-lg-inline ml-1 mr-3 h5 navbar-sitename-divider">&nbsp;</span>

  </div>

  <div class="block block--sysadmin-main-menu">

  
    

      
  


  <ul class="nav navbar-nav">
                                          <li class="nav-item  dropdown">
                      <a href="/sysadmin/" class="nav-link dropdown-toggle" data-toggle="dropdown" data-drupal-link-system-path="&lt;front&gt;">Articles</a>
                          <div class="dropdown-menu">
              <a href="/sysadmin/topics/automation" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/146">Automation</a>
              <a href="/sysadmin/topics/career" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/51">Career</a>
              <a href="/sysadmin/topics/containers" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/36"> Containers</a>
              <a href="/sysadmin/topics/sysadmin-culture" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/41">Culture</a>
              <a href="/sysadmin/topics/kubernetes" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/66">Kubernetes</a>
              <a href="/sysadmin/topics/linux" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/21">Linux</a>
              <a href="/sysadmin/topics/programming" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/71"> Programming</a>
              <a href="/sysadmin/topics/security" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/96">Security</a>
  </div>
                              </li>
                                      <li class="nav-item  dropdown">
                      <a href="/sysadmin/about" class="nav-link dropdown-toggle" data-toggle="dropdown" data-drupal-link-system-path="node/71">About</a>
                          <div class="dropdown-menu">
              <a href="/sysadmin/about" class="dropdown-item" data-drupal-link-system-path="node/71">Topics</a>
              <a href="/sysadmin/email" class="dropdown-item" data-drupal-link-system-path="node/376">Email newsletter</a>
              <a href="/sysadmin/join-community" class="dropdown-item" data-drupal-link-system-path="node/641">Join the community</a>
              <a href="/sysadmin/community-guidelines" class="dropdown-item" data-drupal-link-system-path="node/156">Community guidelines</a>
              <a href="/sysadmin/sudoers-program" class="dropdown-item" data-drupal-link-system-path="node/2106">Sudoers program</a>
              <a href="/sysadmin/meet-team" class="dropdown-item" data-drupal-link-system-path="node/2316">Meet the team</a>
              <a href="/sysadmin/faq" class="dropdown-item" data-drupal-link-system-path="node/1526">FAQs</a>
  </div>
                              </li>
                                      <li class="nav-item  ">
                      <a href="/sysadmin/welcome-enable-sysadmin" title="A Red Hat community publication for sysadmins, by sysadmins" class="nav-link">Welcome</a>
                  </li>
            </ul>


  
  </div>


      
              
          </div>
  </div>

  


<nav class="navbar navbar-expand-lg justify-content-between navbar-light  d-none d-lg-block text-dark bg-light border-bottom-light-gray">
      <div class="container">
  
      
  
  <button class="navbar-toggler" type="button" data-toggle="collapse" data-target=".navbar-collapse" aria-controls="navbar-collapse" aria-expanded="false" aria-label="Toggle navigation">
    <span class="navbar-toggler-icon"></span>
  </button>

  <div class="collapse navbar-collapse">
                  <div class="mr-auto d-flex navbar-desktop">
            
  <div class="block block--sysadmin-navbar-sitename sitename">

  
    

    
  <a href="/sysadmin/" class="navbar-brand sitename">
        Enable Sysadmin
  </a>

  <span class="d-none d-lg-inline ml-1 mr-3 h5 navbar-sitename-divider">&nbsp;</span>

  </div>

  <div class="block block--sysadmin-main-menu">

  
    

      
  


  <ul class="nav navbar-nav">
                                          <li class="nav-item  dropdown">
                      <a href="/sysadmin/" class="nav-link dropdown-toggle" data-toggle="dropdown" data-drupal-link-system-path="&lt;front&gt;">Articles</a>
                          <div class="dropdown-menu">
              <a href="/sysadmin/topics/automation" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/146">Automation</a>
              <a href="/sysadmin/topics/career" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/51">Career</a>
              <a href="/sysadmin/topics/containers" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/36"> Containers</a>
              <a href="/sysadmin/topics/sysadmin-culture" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/41">Culture</a>
              <a href="/sysadmin/topics/kubernetes" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/66">Kubernetes</a>
              <a href="/sysadmin/topics/linux" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/21">Linux</a>
              <a href="/sysadmin/topics/programming" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/71"> Programming</a>
              <a href="/sysadmin/topics/security" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/96">Security</a>
  </div>
                              </li>
                                      <li class="nav-item  dropdown">
                      <a href="/sysadmin/about" class="nav-link dropdown-toggle" data-toggle="dropdown" data-drupal-link-system-path="node/71">About</a>
                          <div class="dropdown-menu">
              <a href="/sysadmin/about" class="dropdown-item" data-drupal-link-system-path="node/71">Topics</a>
              <a href="/sysadmin/email" class="dropdown-item" data-drupal-link-system-path="node/376">Email newsletter</a>
              <a href="/sysadmin/join-community" class="dropdown-item" data-drupal-link-system-path="node/641">Join the community</a>
              <a href="/sysadmin/community-guidelines" class="dropdown-item" data-drupal-link-system-path="node/156">Community guidelines</a>
              <a href="/sysadmin/sudoers-program" class="dropdown-item" data-drupal-link-system-path="node/2106">Sudoers program</a>
              <a href="/sysadmin/meet-team" class="dropdown-item" data-drupal-link-system-path="node/2316">Meet the team</a>
              <a href="/sysadmin/faq" class="dropdown-item" data-drupal-link-system-path="node/1526">FAQs</a>
  </div>
                              </li>
                                      <li class="nav-item  ">
                      <a href="/sysadmin/welcome-enable-sysadmin" title="A Red Hat community publication for sysadmins, by sysadmins" class="nav-link">Welcome</a>
                  </li>
            </ul>


  
  </div>


        </div>
          
                  
      
      

<div class="dropdown show text-align-right">
    <a href="/sysadmin/subscribe" class="navbar-util navbar-util--rss" aria-label="Subscribe to our feed or newsletter blast">
    <svg width="22" height="23" viewBox="0 0 22 23" xmlns="http://www.w3.org/2000/svg"><title>Subscribe to our RSS feed or Email newsletter</title><path d="M0 4.23c9.79 0 17.75 8 17.75 17.84h4.23A22.05 22.05 0 0 0 0 0v4.23z M0 7.67v4.23c2.74 0 5.33 1.07 7.27 3.03a10.26 10.26 0 0 1 3 7.3h4.24c0-8.02-6.5-14.56-14.51-14.56M2.93 16.87a2.94 2.94 0 0 0 0 5.85 2.93 2.93 0 1 0 0-5.85" fill-rule="evenodd"/></svg>

    <span class="sr-only">Subscribe to our RSS feed or Email newsletter.</span>
  </a>

    <a id="dropdownSearchLink" href="/sysadmin/search/node" class="navbar-util navbar-util--search" role="button" aria-label="Search this site…" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false">
    <svg width="30" height="30" viewBox="0 0 30 30" xmlns="http://www.w3.org/2000/svg" style="fill:none;stroke-width:3;stroke:#000;stroke-linecap:round;"><line x1="18.95" y1="19.15" x2="25.25" y2="25.75"/><circle cx="13.25" cy="12.75" r="8.5"/></svg>

  </a>
  <div class="dropdown-menu dropdown-menu-right p-1 pt-2" aria-labelledby="dropdownSearchLink">
    <form class="form-inline m-2" action="/sysadmin/search/node" accept-charset="UTF-8" method="get">
      <div class="input-group flex-fill">
        <input class="form-control" type="search" name="keys" id="search" value="" placeholder="Search this site…" aria-label="Search this site…">
        <div class="input-group-append">
          <button class="btn btn-secondary font-weight-bold" type="submit">GO</button>
        </div>
      </div>
    </form>
  </div>
  </div>
      </div>

      </div>
  </nav>

  <main class="pb-5">
                  <header class="page__header">
          <div class="container">
              <div data-drupal-messages-fallback class="hidden"></div>


          </div>
        </header>
          
    <a name="main-content" tabindex="-1"></a>

                  <div class="page__content">
                  
  <div class="block block--sysadmin-content">

  
    

      <article data-history-node-id="4291" role="article" about="/sysadmin/pki-protection" typeof="schema:Article" id="node--article--4291" class="full full--article node node--promoted">
  
    <span property="schema:name" content="Exploring PKI weaknesses and how to combat them" class="hidden"></span>
  <span property="schema:interactionCount" content="UserComments:0" class="hidden"></span>


      <div  class="section my-5 narrow">
  <div class="container">
    <div >
      
  <div class="block">

  
    

      <span property="schema:name"><h1 class="font-weight-bold">Exploring PKI weaknesses and how to combat them</h1>
</span>

  
  </div>

  <div class="block">

  
    

      
            <div class="article__field-subhead">Public key infrastructure has some known weaknesses. See how Certificate Authority Authorization and Certificate Transparency help strengthen certificate infrastructures.</div>
      
  
  </div>

    </div>
  </div>
</div>
<div  class="section pb-5 narrow">
  <div class="container">
    <div >
      
  <div class="block">

  
    

      <p class="article-byline">
  <span class="article-date">
    <span class="label">Posted:</span>
    May 7, 2021
  </span>
    <span aria-hidden="true">|</span>
  <span class="article-authors">
    <strong class="sr-only">by</strong>
          <a href="/sysadmin/users/joerg-kastning" class="article-author article-author--primary">Jörg Kastning<span class="author-affiliate"> (Red Hat Accelerator, Sudoer)</span></a>      </span>
  </p>

  
  </div>

  <div class="block">

  
    

      
            <div class="article__field-media"><figure>
  
  
  <div class="blazy image__field-media-image" data-blazy="">
    <div class="field__label font-weight-bold visually-hidden">
      Image    </div>
                  <div class="field__item">



                    <div class="media media--blazy media--loading media--image">
      
<img class="b-lazy media__image media__element img-fluid" data-src="/sysadmin/sites/default/files/styles/full/public/2021-04/Counter_Measure.jpg?itok=YvsL8E5f" height="600" width="1000" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" typeof="foaf:Image" loading="lazy" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" alt="PKI weakness and possible countermeasures" />

        
      
    </div>
        
  
</div>
              </div>

  <figcaption>
    
            <div class="image__field-media-description">Image by <a href="https://pixabay.com/users/loschmi-150602/?utm_source=link-attribution&amp;utm_medium=referral&amp;utm_campaign=image&amp;utm_content=429308">LoSchmi</a> from <a href="https://pixabay.com/?utm_source=link-attribution&amp;utm_medium=referral&amp;utm_campaign=image&amp;utm_content=429308">Pixabay</a></div>
      
  </figcaption>
</figure>
</div>
      
  
  </div>

  <div class="block">

  
    

      
            <div property="schema:text" class="article__body"><p>This article is Part 3 out of three in my series about SSL/TLS encryption. <a href="https://www.redhat.com/sysadmin/basic-concepts-encryption-cryptography">Part 1</a> covers the basics of well-known encryption concepts. <a href="https://www.redhat.com/sysadmin/openssl-and-internet-pki">Part 2</a> gives a brief introduction to OpenSSL and PKI. This part broaches the issue of PKI weakness and introduces two countermeasures.</p>

<p>First, I would like to introduce the term <em>relying party</em>. A relying party is a web browser, email client, chat application, etc., that is trying to validate an x.509 certificate. Most of the time, the relying party achieves that by checking whether a CA in its trust anchors signed the certificate.</p>

<p><em><strong>[ You might also like: <a href="https://www.redhat.com/sysadmin/manage-multiple-ssh-key-pairs" target="_blank">How to manage multiple SSH key pairs</a> ]</strong></em></p>

<h2>Excursion: Protect your private key</h2>

<p>As you may know from Part 1, the private key is the one you must protect. This starts with the creation, which should happen on a trustworthy machine.</p>

<p>Now you might ask: "What's a trustworthy machine?"</p>

<p>Well, an online service run by someone you don't know is certainly not trustworthy. You must never create your private key using some web service in your browser because you simply don't know if the service provider keeps a copy of the created key. To prevent that from happening, you could use an offline machine instead.</p>

<div data-embed-button="resource_list" data-entity-embed-display="view_mode:resource_list.link" data-entity-type="resource_list" data-entity-uuid="1897dfca-7f38-4001-b8c8-c572fe4609b3" data-langcode="en" class="align-right embedded-entity embedded-entity--resources embedded-entity--resources--link"><aside id="resource-list-kubernetes-and-openshift" class="eck-entity mt-2 py-3 pr-3 border-top border-danger"><h2 class="h4">
      Kubernetes and OpenShift
  </h2>

<ul class="pl-3 mb-0"><li class="my-2"><a href="https://developers.redhat.com/cheat-sheets/kubernetes?intcmp=7013a0000026EKuAAM">Free cheatsheet: Kubernetes and Minikube</a></li>
      <li class="my-2"><a href="https://developers.redhat.com/books/kubernetes-patterns?intcmp=7013a0000026EKuAAM">Free ebook: Designing Cloud-Native Applications</a></li>
      <li class="my-2"><a href="https://developers.redhat.com/courses/openshift/getting-started?intcmp=7013a0000026EKuAAM">Interactive course: Getting Started with OpenShift</a></li>
      <li class="my-2"><a href="https://developers.redhat.com/books/knative-cookbook?intcmp=7013a0000026EKuAAM">Free ebook: Build Applications with Kubernetes and Openshift</a></li>
  </ul></aside></div>
<p>Store your private key only where you need it and keep it safe. A directory on some anonymous FTP server is certainly not a safe place. A network share where only privileged users have access to or a password manager allowing to store attachments is certainly a better place to put it.</p>

<p>In case you accidentally copied your unprotected private key to some network share or public Git repo, just drop it and create a new one. You cannot be certain that it has not been compromised. Even if you delete it immediately, you cannot be sure that some kind of snapshot mechanism has not already stored it.</p>

<h2>PKI weaknesses</h2>

<p>What PKI is and how it works was discussed in Part 2 of this series. In case you don't know, read that part first.</p>

<p>In a nutshell, the whole reason that we deal with this certificate mess is that we want to help the relying party to ensure that it communicates with the correct server and not some fraud. So we get a certificate signed by some CA the relying party trusts, and we're all happy, right?</p>

<p>Well, we could be if there wasn't a serious design flaw in PKI.</p>

<p>There are several hundred CAs that have the trust of our relying party out there on the Internet. Some of these CAs even have Sub CAs capable of signing certificates and having the trust of the relying party. And all of these CAs can issue a certificate for any valid domain name.</p>

<p>So, in general, any CA could issue a certificate for your domain, and you wouldn't even know about it. This certificate could be used for man-in-the-middle attacks on your domain because the relying party would trust this certificate since it was signed by a trusted CA.</p>

<p>And this is not a theoretical threat. In March 2015, some unauthorized certificates issued by CNNIC used to decrypt traffic passing through the Great Firewall. In 2012, a security company admitted that they have issued at least one certificate to a private company that used it to spy on their employees. And back in 2011, a certificate authority company experienced a devastating hack where some of their signing certificates were stolen.</p>

<h2>Possible countermeasures</h2>

<p>The three examples above show you what's wrong with PKI at its core. The design is flawed. So how to fix it? The following are two techniques that could help to mitigate the issue.</p>

<h3>Certificate Authority Authorization (CAA)</h3>

<p>From the abstract of <a href="https://tools.ietf.org/html/rfc8659" target="_blank">DNS Certification Authority Authorization (CAA) Resource Record in RFC 8659</a>: "The Certification Authority Authorization (CAA) DNS Resource Record allows a DNS domain name holder to specify one or more Certification Authorities (CAs) authorized to issue certificates for that domain name. CAA Resource Records allow a public CA to implement additional controls to reduce the risk of unintended certificate mis-issue."</p>

<p>Well, I couldn't have explained it any better. CAA enables domain name holders to specify which CAs are allowed to issue certificates for our domain, and the CAs themselves promise us to respect our CAA records. The RFC 8659 defines the following three properties:</p>

<ul><li>issue contains as value the domain of the CA, which is authorized by the CAA record to issue certificates for a certain domain.</li>
	<li>issuewild is basically the same as issue but for wildcard certificates. If no issuewild is set, the value from issue is used instead.</li>
	<li>iodef contains contact information to be used in case there are any issues regarding the CAA policy.</li>
</ul><p>Let us look at the following example records:</p>

<pre>
<code class="language-shell">example.com. IN CAA 0 issue "letsencrypt.org"
example.com. IN CAA 0 iodef "mailto:webmaster@example.com"</code></pre>

<p>The first line from the example above means that only the CA Let's Encrypt would be allowed to issue certificates for any host under the domain example.com. Any other CA MUST NOT issue certificates for this domain. The second line gives you an email address you could contact in case of any problems.</p>

<p>Since DNS is hierarchically organized, the above CAA record applies to web.example.com as well as to host.web.example.com and host.sub.web.example.com. Let's look at another example:</p>

<pre>
<code class="language-shell">example.com. IN CAA 0 issue "letsencrypt.org"
example.com. IN CAA 0 iodef "mailto:webmaster@example.com"
sub.web.example.com IN CAA 0 issue "example-pki.org"</code></pre>

<p>Here only the CA example-pki.org is allowed to issue certificates for, e.g., host.sub.web.example.com. The record in the third line overwrites the policy from example.com. I think you got the idea.</p>

<div data-embed-button="resource_list" data-entity-embed-display="view_mode:resource_list.link" data-entity-type="resource_list" data-entity-uuid="dae9de57-962d-4c70-a7f0-b5eda7100a3d" data-langcode="en" class="align-right embedded-entity embedded-entity--resources embedded-entity--resources--link"><aside id="resource-list-more-about-automation" class="eck-entity mt-2 py-3 pr-3 border-top border-danger"><h2 class="h4">
      More about automation
  </h2>

<ul class="pl-3 mb-0"><li class="my-2"><a href="https://www.ansible.com/resources/get-started?intcmp=701f20000012ngPAAQ">An introduction to Ansible</a></li>
      <li class="my-2"><a href="https://www.ansible.com/products/tower/trial?intcmp=701f20000012ngPAAQ">3 ways to try Ansible Tower free</a></li>
      <li class="my-2"><a href="https://www.ansible.com/resources/ebooks?intcmp=701f2000000h4RcAAI">Free Ansible e-books</a></li>
      <li class="my-2"><a href="https://www.redhat.com/en/engage/technical-ansible-network-s-201903140421?intcmp=701f2000000h4RcAAI">Getting started with network automation</a></li>
  </ul></aside></div>
<p>Of course, CAA resource records wouldn't prevent non-compliant CAs from issuing certificates for domains they don't have permission for. But they would risk being removed from embedded trust anchors, which would mean going out of business in most cases.</p>

<p>And there is still a chance that an authorized CA could mis-issue a certificate to someone who is not authorized to use it. Choose some CA of your trust and choose wisely.</p>

<p>As you see, CAA does not bring 100% security, but it's easy to implement and mitigates the risk of certificate mis-issuance.</p>

<h3>Certificate Transparency (CT)</h3>

<p>Certificate Transparency is "...an experimental protocol for publicly logging the existence of Transport Layer Security (TLS) certificates as they are issued or observed, in a manner that allows anyone to audit certificate authority (CA) activity and notice the issuance of suspect certificates as well as to audit the certificate logs themselves. The intent is that eventually, clients would refuse to honor certificates that do not appear in a log, effectively forcing CAs to add all issued certificates to the logs." (<a href="https://tools.ietf.org/html/rfc6962" target="_blank">Abstract RFC 6962</a>)</p>

<p>CT offers a form of accounting for TLS certificates and enables you to examine which CA-issued certs for your domain names. To do so, you could use services like <a href="https://sslmate.com/certspotter/" target="_blank">Cert Spotter</a> by sslmate, which is available as an <a href="https://github.com/SSLMate/certspotter" target="_blank">on-premises version</a>, too. I used to run the on-premises version on my virtual private server, but due to the <a href="https://sslmate.com/labs/ct_growth/" target="_blank">log growth</a> over the past two years, it seems impossible to crawl the logs from start to end. The job ran for weeks and didn't finish; it was aborted when I needed to restart my host to complete updates.</p>

<p>Today no CA is forced to add issued certs to CT logs, but the log growth suggests that many of them already add their certs. In my opinion, it's only a matter of time until major browsers start only to trust certs with a CT log entry and make them mandatory.</p>

<p><em><strong>[ Get this free ebook: <a href="https://www.redhat.com/en/resources/managing-kubernetes-clusters-dummies-ebook?intcmp=7013a0000026EKuAAM" target="_blank">Managing your Kubernetes clusters for dummies</a>. ]</strong></em></p>

<h2>Wrapping up</h2>

<p>The original design of the PKI is flawed and not very trustworthy anymore. With RFC 8659 and RFC 6962, two methods are offered to regain trust and help domain name holders keep track of who issued certificates for their domains.</p>

<p>So from now on, keep in mind to protect your private keys, set CAA resource records for your domains, and start monitoring CT logs.</p>
</div>
      
  
  </div>

  <div class="block">

  
    

      <div class="views-element-container"><div class="listicle-view js-view-dom-id-5e86a7b4b0f44d6ce8d31e223eca716508ef426a3efb071a51459819160c81a3">
  
  
  

  
  
  

    <h3>Check out these related articles on Enable Sysadmin</h3>
    <div class="listicle-row"><div class="views-field views-field-field-listicle"><div class="field-content"><article data-history-node-id="4181" role="article" about="/sysadmin/openssl-and-internet-pki" typeof="schema:Article" id="node--article--4181" class="listicle listicle--article node node--promoted">
  <div class="row align-items-center">
    <div class="col-md-6 listicle-image">
            <div class="article__field-media"><article>
  
      
  <div class="blazy image__field-media-image" data-blazy="">
    <div class="field__label font-weight-bold visually-hidden">
      Image    </div>
                  <div class="field__item">



                    <div class="media media--blazy media--loading media--image">
      
<img class="b-lazy media__image media__element img-fluid" data-src="/sysadmin/sites/default/files/styles/card/public/2021-03/Encryption.jpg?itok=POOjIuvB" height="420" width="700" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" typeof="foaf:Image" loading="lazy" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" alt="How to use OpenSSL and the Internet PKI on Linux systems" />

        
      
    </div>
        
  
</div>
              </div>

  </article>
</div>
      </div>
    <div class="col-md-6 listicle-body">
      <div class="h4 listicle-title pt-4 pt-md-0"><a href="/sysadmin/openssl-and-internet-pki"><span property="schema:name">How to use OpenSSL and the Internet PKI on Linux systems</span>
</a></div>
      <div class="listicle-text font-weight-light py-2">
        
            <div property="schema:text" class="article__body">A high-level overview of TLS/SSL and the OpenSSL tool, creating private keys and CSRs, and an introduction to the Internet PKI.</div>
      
      </div>

      <div class="listicle-footer">
        <div class="article-date">
          <span class="label">Posted:</span>
          April 1, 2021
        </div>
        <div class="article-authors">
                      <span class="label">Author:</span>
                                <a href="/sysadmin/users/joerg-kastning" class="article-author article-author--primary">Jörg Kastning<span class="author-affiliate"> (Red Hat Accelerator, Sudoer)</span></a>                  </div>
      </div>
    </div>
  </div>
</article>
<article data-history-node-id="1786" role="article" about="/sysadmin/ca-certificates-cli" typeof="schema:Article" id="node--article--1786" class="listicle listicle--article node node--promoted">
  <div class="row align-items-center">
    <div class="col-md-6 listicle-image">
            <div class="article__field-media"><article>
  
      
  <div class="blazy image__field-media-image" data-blazy="">
    <div class="field__label font-weight-bold visually-hidden">
      Image    </div>
                  <div class="field__item">



                    <div class="media media--blazy media--loading media--image">
      
<img class="b-lazy media__image media__element img-fluid" data-src="/sysadmin/sites/default/files/styles/card/public/2020-02/girl-holding-a-certificate-1792617%20Cropped.jpg?itok=foeBhJGc" height="420" width="700" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" typeof="foaf:Image" loading="lazy" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" alt="Making certificates available to CLI Tools" />

        
      
    </div>
        
  
</div>
              </div>

  </article>
</div>
      </div>
    <div class="col-md-6 listicle-body">
      <div class="h4 listicle-title pt-4 pt-md-0"><a href="/sysadmin/ca-certificates-cli"><span property="schema:name">Making CA certificates available to Linux command-line tools</span>
</a></div>
      <div class="listicle-text font-weight-light py-2">
        
            <div property="schema:text" class="article__body">How to use the ca-certificates package to manage Certificate Authority certificates for command-line utilities.</div>
      
      </div>

      <div class="listicle-footer">
        <div class="article-date">
          <span class="label">Posted:</span>
          March 3, 2020
        </div>
        <div class="article-authors">
                      <span class="label">Author:</span>
                                <a href="/sysadmin/users/slauber" class="article-author article-author--primary">Susan Lauber</a>                  </div>
      </div>
    </div>
  </div>
</article>
<article data-history-node-id="3966" role="article" about="/sysadmin/cert-manager-operator-openshift" typeof="schema:Article" id="node--article--3966" class="listicle listicle--article node node--promoted">
  <div class="row align-items-center">
    <div class="col-md-6 listicle-image">
            <div class="article__field-media"><article>
  
      
  <div class="blazy image__field-media-image" data-blazy="">
    <div class="field__label font-weight-bold visually-hidden">
      Image    </div>
                  <div class="field__item">



                    <div class="media media--blazy media--loading media--image">
      
<img class="b-lazy media__image media__element img-fluid" data-src="/sysadmin/sites/default/files/styles/card/public/2021-02/Certificate.jpg?itok=PcIE-Fjw" height="420" width="700" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" typeof="foaf:Image" loading="lazy" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" alt="How to create a TLS/SSL certificate with a Cert-Manager Operator on OpenShift" />

        
      
    </div>
        
  
</div>
              </div>

  </article>
</div>
      </div>
    <div class="col-md-6 listicle-body">
      <div class="h4 listicle-title pt-4 pt-md-0"><a href="/sysadmin/cert-manager-operator-openshift"><span property="schema:name">How to create a TLS/SSL certificate with a Cert-Manager Operator on OpenShift</span>
</a></div>
      <div class="listicle-text font-weight-light py-2">
        
            <div property="schema:text" class="article__body">Use cert-manager to deploy certificates to your OpenStack or Kubernetes environment.</div>
      
      </div>

      <div class="listicle-footer">
        <div class="article-date">
          <span class="label">Posted:</span>
          February 18, 2021
        </div>
        <div class="article-authors">
                      <span class="label">Author:</span>
                                <a href="/sysadmin/users/bryant-son" class="article-author article-author--primary">Bryant Son<span class="author-affiliate"> (Red Hat, Sudoer)</span></a>                  </div>
      </div>
    </div>
  </div>
</article>
</div></div></div>

    

  
  

  
  
</div>
</div>

  
  </div>

  <div class="block">

  
    

      <div class="topics">
  <strong>Topics:</strong>&nbsp;&nbsp;
      <a href="/sysadmin/topics/linux" class="btn btn-primary btn-sm font-weight-bold">Linux</a>&nbsp;&nbsp;
      <a href="/sysadmin/topics/security" class="btn btn-primary btn-sm font-weight-bold">Security</a>&nbsp;&nbsp;
      <a href="/sysadmin/topics/linux-administration" class="btn btn-primary btn-sm font-weight-bold">Linux Administration</a>&nbsp;&nbsp;
  </div>
  
  </div>

    </div>
  </div>
</div>
<div >
  <div >
    
  <div class="block">

  
    

      
<section data-history-node-id="4291" role="article" about="/sysadmin/pki-protection" typeof="schema:Article" id="node--article--4291" class="section my-5 py-5 bg-light-gray authors-bio authors-bio--article">
  <div class="container">
          <div class="row">
        <div class="col-md-2 text-center">
                      
<img data-affiliation="Red Hat Accelerator, Sudoer" src="/sysadmin/sites/default/files/styles/user_picture_square/public/pictures/2019-07/Profil_im_Buero2.jpg?itok=sT9B8A7a" width="240" height="240" typeof="foaf:Image" loading="lazy" class="rounded-circle img-fluid" src="/sysadmin/sites/default/files/styles/user_picture_square/public/pictures/2019-07/Profil_im_Buero2.jpg?itok=sT9B8A7a" alt="Author’s photo" />


          
        </div>
        <div class="col-md-10 col-lg-8">
          <h2 class="font-weight-light text-center text-md-left">
                          Jörg Kastning
                      </h2>
          <div>
                          <p>
                Jörg has been a Sysadmin for over ten years now. His fields of operation include Virtualization (VMware), Linux System Administration and Automation (RHEL), Firewalling (Forcepoint), and Loadbalancing (F5).
                                  <a href="/sysadmin/users/joerg-kastning" class="author-more-link">More about me</a>
                              </p>
                      </div>
        </div>
      </div>
      </div>
</section>



  
  </div>

  <div class="block">

  
    

      

  
  </div>

  </div>
</div>
<div >
  <div >
    

  <div class="block block--cta cta cta--red-on-black cta-- my-5 p-3 text-center">

  
    

    <div class="d-md-flex justify-content-around align-items-center flex-wrap">
    <div class="cta__content my-2">
      
            <div class="cta__field-content p-2"><h4>Free Event: Red Hat Summit 2021 Virtual Experience</h4>

<p>Join Red Hat Summit Virtual Experience for live demos, keynotes, and technical<br />
sessions from experts around the globe—happening April 27–28 and June 15–16.</p>
</div>
      
    </div>
        <div class="cta__link my-2">
      <a
        href="https://www.redhat.com/en/summit?intcmp=7013a0000026RhqAAE"
        target="_blank"
        class="btn btn-lg btn-danger font-weight-bold">
        Register Now
      </a>
    </div>
      </div>
  
  </div>

  </div>
</div>
<div  class="section">
  <div class="container">
    <div >
      
  <div class="block">

  
    

      <div class="views-element-container"><div class="js-view-dom-id-f0fee04861d3cf807e8d883ff26c122b1f9219cd8b2550bc20b78ffe0e0feafb">
  
  
  

  
  
  

    <h2>Related Content</h2>
                        <div class="card-deck my-4">
                        <article data-history-node-id="4421" role="article" about="/sysadmin/april-2021-roundup" typeof="schema:Article" id="node--article--4421" class="card card--article node node--promoted">
      <div class="card-img-top">
            <div class="article__field-media"><article>
  
      
  <div class="blazy image__field-media-image" data-blazy="">
    <div class="field__label font-weight-bold visually-hidden">
      Image    </div>
                  <div class="field__item">



                    <div class="media media--blazy media--loading media--responsive media--image">
        
<img class="media__image media__element b-lazy b-responsive img-fluid" srcset="" data-srcset="/sysadmin/sites/default/files/styles/card/public/2021-05/Roundup.jpg?itok=Aignu42k 1x" data-src="/sysadmin/sites/default/files/styles/card/public/2021-05/Roundup.jpg?itok=Aignu42k" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" typeof="foaf:Image" loading="lazy" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" alt="April 2021 Roundup" />


        
      
    </div>
        
  
</div>
              </div>

  </article>
</div>
      </div>
      <div class="card-body">
    <div class="h4 card-title"><a href="/sysadmin/april-2021-roundup"><span property="schema:name">10 great sysadmin articles you might have missed from April 2021</span>
</a></div>
    <div class="card-text">
            <div property="schema:text" class="article__body">The best of April 2021 from Enable Sysadmin. Thank you to our contributors and to our readers.</div>
      </div>
  </div>
  <div class="card-footer">
    <div class="article-date">
      <span class="label">Posted:</span>
      May 4, 2021
    </div>
    <div class="article-authors">
              <span class="label">Author:</span>
                    <a href="/sysadmin/users/tcarriga" class="article-author article-author--primary">Tyler Carrigan<span class="author-affiliate"> (Red Hat)</span></a>          </div>
  </div>
</article>


                            <article data-history-node-id="4411" role="article" about="/sysadmin/may-fourth-podman" typeof="schema:Article" id="node--article--4411" class="card card--article node node--promoted">
      <div class="card-img-top">
            <div class="article__field-media"><article>
  
      
  <div class="blazy image__field-media-image" data-blazy="">
    <div class="field__label font-weight-bold visually-hidden">
      Image    </div>
                  <div class="field__item">



                    <div class="media media--blazy media--loading media--responsive media--image">
        
<img class="media__image media__element b-lazy b-responsive img-fluid" srcset="" data-srcset="/sysadmin/sites/default/files/styles/card/public/2021-04/Maythe4th.jpg?itok=wWD0zWP8 1x" data-src="/sysadmin/sites/default/files/styles/card/public/2021-04/Maythe4th.jpg?itok=wWD0zWP8" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" typeof="foaf:Image" loading="lazy" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" alt="May the Fourth be with you via Podman" />


        
      
    </div>
        
  
</div>
              </div>

  </article>
</div>
      </div>
      <div class="card-body">
    <div class="h4 card-title"><a href="/sysadmin/may-fourth-podman"><span property="schema:name">May the Fourth be with you via Podman</span>
</a></div>
    <div class="card-text">
            <div property="schema:text" class="article__body">A unique approach to rewatching the original Star Wars movie in a container.</div>
      </div>
  </div>
  <div class="card-footer">
    <div class="article-date">
      <span class="label">Posted:</span>
      May 4, 2021
    </div>
    <div class="article-authors">
              <span class="label">Author:</span>
                    <a href="/sysadmin/users/tsweeney" class="article-author article-author--primary">Tom Sweeney<span class="author-affiliate"> (Red Hat)</span></a>          </div>
  </div>
</article>


                            <article data-history-node-id="4386" role="article" about="/sysadmin/racked-server" typeof="schema:Article" id="node--article--4386" class="card card--article node node--promoted">
      <div class="card-img-top">
            <div class="article__field-media"><article>
  
      
  <div class="blazy image__field-media-image" data-blazy="">
    <div class="field__label font-weight-bold visually-hidden">
      Image    </div>
                  <div class="field__item">



                    <div class="media media--blazy media--loading media--responsive media--image">
        
<img class="media__image media__element b-lazy b-responsive img-fluid" srcset="" data-srcset="/sysadmin/sites/default/files/styles/card/public/2021-04/Server.jpg?itok=lf1WfG-T 1x" data-src="/sysadmin/sites/default/files/styles/card/public/2021-04/Server.jpg?itok=lf1WfG-T" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" typeof="foaf:Image" loading="lazy" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" alt="Have you ever racked a server?" />


        
      
    </div>
        
  
</div>
              </div>

  </article>
</div>
      </div>
      <div class="card-body">
    <div class="h4 card-title"><a href="/sysadmin/racked-server"><span property="schema:name">Have you ever racked a server? </span>
</a></div>
    <div class="card-text">
            <div property="schema:text" class="article__body">There are sysadmins who have to rack servers as part of their jobs while others have never stepped foot inside a chilly data center.</div>
      </div>
  </div>
  <div class="card-footer">
    <div class="article-date">
      <span class="label">Posted:</span>
      April 23, 2021
    </div>
    <div class="article-authors">
              <span class="label">Author:</span>
                    <a href="/sysadmin/users/tcarriga" class="article-author article-author--primary">Tyler Carrigan<span class="author-affiliate"> (Red Hat)</span></a>          </div>
  </div>
</article>


                              </div>
            
    

  
  

  
  
</div>
</div>

  
  </div>

    </div>
  </div>
</div>
<div  class="section my-5 pb-5 narrow">
  <div class="container">
    <div >
      
    </div>
  </div>
</div>
<div  class="section my-5 pb-5 ">
  <div class="container">
    <div >
      

  <div class="block block--cta cta cta--red-on-black cta-- my-5 p-3 text-center">

  
    

    <div class="d-md-flex justify-content-around align-items-center flex-wrap">
    <div class="cta__content my-2">
      
            <div class="cta__field-content p-2"><p class="h4 mb-4 mt-3 font-weight-bold">OUR BEST CONTENT, DELIVERED TO YOUR INBOX</p>

<p><iframe title="Subscribe to our newsletter" aria-label="Embedded form to subscribe to our email newsletter" frameborder="0" height="50" scrolling="no" src="/sysadmin/eloqua-embedded-subscribe.html?offer_id=701f20000012gE7AAI" style="max-width:670px;margin:0 auto;" width="100%"></iframe></p>
</div>
      
    </div>
      </div>
  
  </div>

    </div>
  </div>
</div>

  </article>

  
  </div>


              </div>
        </main>

            <footer>
              <div class="page__colophon bg-dark-gray py-4 bg-dark-gray">
          <div class="container">
              
  <div class="block block--basic block--sysadmin-colophon-disclaimer">

  
    

      
            <div class="basic__body"><p>The opinions expressed on this website are those of each author, not of the author's employer or of Red Hat. The content published on this site are community contributions and are for informational purpose only AND ARE NOT, AND ARE NOT INTENDED TO BE, RED HAT DOCUMENTATION, SUPPORT, OR ADVICE.</p>

<p>Red Hat and the Red Hat logo are trademarks of Red Hat, Inc., registered in the United States and other countries.</p>
</div>
      
  
  </div>


          </div>
        </div>
                    <div class="page__footer bg-dark py-3">
        <div class="container">
          <div class="d-sm-flex justify-content-between align-items-center">
              

  
    

    
  <a href="https://www.redhat.com/" class="navbar-brand mr-0 mr-lg-auto mb-3 mb-sm-0">
            <img src="/sysadmin/themes/custom/sysadmin/logo.svg" width="135" height="31" class="d-inline-block align-top" alt="Red Hat logo" />

        
  </a>



  <div class="block block--basic block--copyright my-0 mx-sm-3 mb-1 mb-sm-0">

  
    

      
            <div class="basic__body"><p>Copyright ©2020 Red Hat, Inc.</p>
</div>
      
  
  </div>

  <div class="block block--sysadmin-footer my-0 mb-1 mb-sm-0">

  
    

      
  


  <ul class="nav d-flex d-sm-block d-md-flex justify-content-center align-items-center">
                                          <li class="nav-item  ">
                      <a href="https://www.redhat.com/en/about/privacy-policy" class="nav-link">Privacy Policy</a>
                  </li>
                                      <li class="nav-item  ">
                      <a href="https://www.redhat.com/en/about/terms-use" class="nav-link">Terms of Use</a>
                  </li>
                                      <li class="nav-item  ">
                      <a href="https://www.redhat.com/en/about/all-policies-guidelines" class="nav-link">All policies and guidelines</a>
                  </li>
            </ul>


  
  </div>

  <div class="block block--basic block--footerredhatsummit">

  
    

      
            <div class="basic__body"><div style="margin-left: 1rem"><a href="https://www.redhat.com/en/summit?intcmp=7013a0000026RhqAAE" target="_blank"><img alt="Red Hat Summit" src="https://www.redhat.com/cms/managed-files/Logo-Red_Hat-Summit-A-Standard-RGB-02_0.svg" width="72px" /></a></div>
</div>
      
  
  </div>

  <div class="block block--sharelinks">

  
    

      <div class="a2a_kit a2a_kit_size_32 a2a_floating_style a2a_vertical_style" data-a2a-url="https://www.redhat.com/sysadmin/pki-protection">
  <a class="a2a_button_twitter a2a_counter"></a>
  <a class="a2a_button_facebook a2a_counter"></a>
  <a class="a2a_button_linkedin a2a_counter"></a>
  <a class="a2a_button_reddit a2a_counter"></a>
  <a class="a2a_button_email a2a_counter"></a>
</div>
<div class="a2a_kit a2a_kit_size_32 a2a_floating_style a2a_default_style">
  <a class="a2a_button_twitter a2a_counter"></a>
  <a class="a2a_button_facebook a2a_counter"></a>
  <a class="a2a_button_linkedin a2a_counter"></a>
  <a class="a2a_button_reddit a2a_counter"></a>
  <a class="a2a_button_email a2a_counter"></a>
</div>

<script>
  var a2a_config = a2a_config || {};
  a2a_config.templates = a2a_config.templates || {};
  a2a_config.templates.twitter = {
    text: "Exploring PKI weaknesses and how to combat them https://red.ht/3h8r9jn via #EnableSysadmin by @JoergKastning",
  };
    a2a_config.templates.facebook = {
    hashtag: "#EnableSysadmin",
  };
  </script>

  
  </div>


  <div class="block block--cta block--ctasubscribesidebar cta cta--blue-on-white cta-- my-5 p-3 text-center">

  
    

    <div class="d-md-flex justify-content-around align-items-center flex-wrap">
    <div class="cta__content my-2">
      
            <div class="cta__field-content p-2"><div class="subscribe-sidebar">
<div class="target-band-never-show-button">x</div>

<h4>Subscribe now</h4>

<p class="eloqua-email-capture-text">Get the highlights in your inbox every week.</p>

<p><iframe aria-label="Embedded form to subscribe to our email newsletter" frameborder="0" height="50" scrolling="no" src="/sysadmin/eloqua-embedded-email-capture-block.html?offer_id=701f20000012gE7AAI" style="max-width:670px;margin:0 auto;" title="Subscribe to our newsletter" width="100%"></iframe></p>
</div>
</div>
      
    </div>
      </div>
  
  </div>


          </div>
        </div>
            </footer>
      </div>

  </div>


<script type="application/json" data-drupal-selector="drupal-settings-json">{"path":{"baseUrl":"\/sysadmin\/","scriptPath":null,"pathPrefix":"","currentPath":"node\/4291","currentPathIsAdmin":false,"isFront":false,"currentLanguage":"en"},"pluralDelimiter":"\u0003","suppressDeprecationErrors":true,"ckeditorheight":{"offset":1,"line_height":1.5,"unit":"em","disable_autogrow":null},"colorbox":{"opacity":"0.85","current":"{current} of {total}","previous":"\u00ab Prev","next":"Next \u00bb","close":"Close","maxWidth":"98%","maxHeight":"98%","fixed":true,"mobiledetect":true,"mobiledevicewidth":"480px"},"blazy":{"loadInvisible":false,"offset":100,"saveViewportOffsetDelay":50,"validateDelay":25},"blazyIo":{"enabled":false,"disconnect":false,"rootMargin":"0px","threshold":[0]},"user":{"uid":0,"permissionsHash":"2ddc6cf1f04642fe2dbcaf7b6d1801d17bf0f6ec0ae19d4cc9e10b02dea0f05e"}}</script>

<!--[if lte IE 9]>
<script src="/sysadmin/sites/default/files/js/js_VhqXmo4azheUjYC30rijnR_Dddo0WjWkF27k5gTL8S4.js"></script>
<![endif]-->
<script src="/sysadmin/sites/default/files/js/js_qKbBp7VmIM6TETo0l6XPr_mkukgpu-YgxJKEO-_sGzI.js"></script>

  <script type="text/javascript">
    if (("undefined" !== typeof _satellite) && ("function" === typeof _satellite.pageBottom)) {
      _satellite.pageBottom();
    }
  </script>
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam-cell.nr-data.net","licenseKey":"a03a21ae8a","applicationID":"467345710","transactionName":"ZlNTbUBQDxZUWxJRVl8ZcFpGWA4LGnwUTUlQWm1XXVUEOXZXCExLXlpdXEBtLwpRXTBRXEZ1XldGQw4JWV0UFQdHX1RO","queueTime":0,"applicationTime":662,"atts":"ShRQGwhKHBg=","errorBeacon":"bam-cell.nr-data.net","agent":""}</script><script type="text/javascript" >var _cf = _cf || [];  _cf.push(['_setFsp', true]);  _cf.push(['_setBm', true]);  _cf.push(['_setAu', '/webcontent/d44b8c97ui202408e99291818f15c3']); </script><script type="text/javascript"  src="/webcontent/d44b8c97ui202408e99291818f15c3"></script></body>
</html>
