<!DOCTYPE html>
<html lang="en" dir="ltr" prefix="content: http://purl.org/rss/1.0/modules/content/  dc: http://purl.org/dc/terms/  foaf: http://xmlns.com/foaf/0.1/  og: http://ogp.me/ns#  rdfs: http://www.w3.org/2000/01/rdf-schema#  schema: http://schema.org/  sioc: http://rdfs.org/sioc/ns#  sioct: http://rdfs.org/sioc/types#  skos: http://www.w3.org/2004/02/skos/core#  xsd: http://www.w3.org/2001/XMLSchema# ">
<head>
<script id="dpal" src="https://www.redhat.com/ma/dpal.js"></script>
<meta charset="utf-8" /><script type="text/javascript">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</script>
<meta name="title" content="The first six warning signs that a technical project might fail | Enable Sysadmin" />
<link rel="canonical" href="https://www.redhat.com/sysadmin/tech-failure" />
<meta property="og:site_name" content="Enable Sysadmin" />
<meta name="twitter:card" content="photo" />
<meta name="dcterms.title" content="The first six warning signs that a technical project might fail" />
<meta name="twitter:title" content="The first six warning signs that a technical project might fail" />
<meta name="dcterms.creator" content="Joachim Haller" />
<meta name="twitter:description" content="Is your project destined to fail? These first six of twelve indicators might say otherwise." />
<meta name="description" content="Is your project destined to fail? These first six of twelve indicators might say otherwise." />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.redhat.com/sysadmin/tech-failure" />
<meta name="twitter:site:id" content="14627400" />
<meta property="og:title" content="The first six warning signs that a technical project might fail" />
<meta name="twitter:creator" content="@JoachimHaller" />
<meta name="dcterms.publisher" content="Red Hat, Inc." />
<meta name="twitter:url" content="https://www.redhat.com/sysadmin/tech-failure" />
<meta name="twitter:image" content="https://www.redhat.com/sysadmin/sites/default/files/styles/full/public/2020-04/failure_success%20Cropped.jpg?itok=XmWYPpoP" />
<meta name="twitter:image:width" content="600" />
<meta name="twitter:image:height" content="1000" />
<meta name="twitter:image:alt" content="Red Hat, Inc." />
<meta property="og:image" content="https://www.redhat.com/sysadmin/sites/default/files/styles/full/public/2020-04/failure_success%20Cropped.jpg?itok=XmWYPpoP" />
<meta property="og:image:secure_url" content="https://www.redhat.com/sysadmin/sites/default/files/styles/full/public/2020-04/failure_success%20Cropped.jpg?itok=XmWYPpoP" />
<meta name="dcterms.language" content="en" />
<meta property="og:image:type" content="image/jpeg" />
<meta property="og:video:width" content="600" />
<meta property="og:image:width" content="1000" />
<meta property="og:image:height" content="675" />
<meta property="og:image:alt" content="https://www.redhat.com/sysadmin/sites/default/files/styles/full/public/2020-04/failure_success%20Cropped.jpg?itok=XmWYPpoP" />
<meta property="og:updated_time" content="2020-05-05T09:00:00+0000" />
<meta property="og:street_address" content="100 East Davie Street" />
<meta property="og:locality" content="Raleigh" />
<meta property="og:region" content="NC" />
<meta property="og:postal_code" content="27601" />
<meta property="og:country_name" content="United States" />
<meta property="og:phone_number" content="+1 919 754 4950" />
<meta property="og:fax_number" content="+1 919 800 3804" />
<meta property="og:locale" content="en_US" />
<meta property="article:author" content="https://www.redhat.com/sysadmin/users/joachimhaller" />
<meta property="article:publisher" content="https://www.facebook.com/redhatinc" />
<meta property="article:section" content="Enable Sysadmin" />
<meta property="article:tag" content="Sysadmin culture" />
<meta property="article:tag" content="Problem solving" />
<meta property="article:modified_time" content="2020-05-05T09:00:00+0000" />
<meta name="Generator" content="Drupal 8 (https://www.drupal.org)" />
<meta name="MobileOptimized" content="width" />
<meta name="HandheldFriendly" content="true" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<script type="application/ld+json">{
    "@context": "https://schema.org",
    "@graph": [
        {
            "@type": "TechArticle",
            "headline": "The first six warning signs that a technical project might fail",
            "name": "The first six warning signs that a technical project might fail",
            "about": [
                "Sysadmin culture",
                "Problem solving"
            ],
            "description": "Is your project destined to fail? These first six of twelve indicators might say otherwise.",
            "image": {
                "@type": "ImageObject",
                "url": "https://www.redhat.com/sysadmin/sites/default/files/styles/full/public/2020-04/failure_success%20Cropped.jpg?itok=XmWYPpoP",
                "width": "1000",
                "height": "600"
            },
            "dateModified": "2020-05-05T09:00:00+0000",
            "author": {
                "@type": "Person",
                "@id": "https://www.redhat.com/sysadmin/users/joachimhaller",
                "name": "Joachim Haller",
                "url": "https://www.redhat.com/sysadmin/users/joachimhaller",
                "sameAs": "https://twitter.com/JoachimHaller"
            },
            "publisher": {
                "@type": "Organization",
                "@id": "https://www.redhat.com/"
            },
            "mainEntityOfPage": "https://www.redhat.com/sysadmin/tech-failure"
        },
        {
            "@type": "WebPage",
            "@id": "https://www.redhat.com/sysadmin/tech-failure",
            "publisher": {
                "@type": "Organization",
                "@id": "https://www.redhat.com/"
            }
        },
        {
            "@type": "Person",
            "name": "Joachim Haller",
            "sameAs": "https://twitter.com/JoachimHaller",
            "image": {
                "@type": "ImageObject",
                "url": "https://www.redhat.com/sysadmin/sites/default/files/styles/user_picture_square/public/pictures/2019-11/joachimh.jpg?itok=VHaofu0S",
                "width": "240",
                "height": "240"
            }
        },
        {
            "@type": "Corporation",
            "@id": "https://www.redhat.com/",
            "name": "Red Hat, Inc.",
            "url": "https://www.redhat.com/",
            "sameAs": [
                "https://en.wikipedia.org/wiki/Red_Hat",
                "http://www.linkedin.com/company/red-hat",
                "http://www.youtube.com/user/RedHatVideos",
                "https://www.facebook.com/redhatinc",
                "https://twitter.com/RedHat"
            ],
            "telephone": "+1 919 754 4950",
            "contactPoint": {
                "@type": "ContactPoint",
                "telephone": "+1-888-RED-HAT1",
                "availableLanguage": "English",
                "contactType": "sales",
                "faxnumber": "+1 919 800 3804"
            },
            "logo": {
                "@type": "ImageObject",
                "url": "https://www.redhat.com/sysadmin/themes/custom/sysadmin/assets/images/red-hat-logo.png",
                "width": "254",
                "height": "60"
            },
            "address": {
                "@type": "PostalAddress",
                "streetAddress": "100 East Davie Street",
                "addressLocality": "Raleigh",
                "addressRegion": "NC",
                "postalCode": "27601",
                "addressCountry": "United States"
            }
        },
        {
            "@type": "WebSite",
            "@id": "https://www.redhat.com/sysadmin/",
            "name": "Enable Sysadmin",
            "url": "https://www.redhat.com/sysadmin/",
            "publisher": {
                "@type": "Organization",
                "@id": "https://www.redhat.com/"
            }
        }
    ]
}</script>
<link rel="shortcut icon" href="/sysadmin/themes/custom/sysadmin/favicon.ico" type="image/vnd.microsoft.icon" />
<link rel="revision" href="https://www.redhat.com/sysadmin/tech-failure" />
<link rel="apple-touch-icon" sizes="180x180" href="/sysadmin/themes/custom/sysadmin/assets/favicon/apple-touch-icon.png">
<link rel="icon" type="image/png" sizes="32x32" href="/sysadmin/themes/custom/sysadmin/assets/favicon/favicon-32x32.png">
<link rel="icon" type="image/png" sizes="16x16" href="/sysadmin/themes/custom/sysadmin/assets/favicon/favicon-16x16.png">
<link rel="manifest" href="/sysadmin/themes/custom/sysadmin/assets/favicon/site.webmanifest">
<link rel="mask-icon" href="/sysadmin/themes/custom/sysadmin/assets/favicon/safari-pinned-tab.svg" color="#ee0000">
<meta name="msapplication-TileColor" content="#1a1a1a">
<meta name="theme-color" content="#ffffff">
<title>The first six warning signs that a technical project might fail | Enable Sysadmin</title>
<link rel="stylesheet" media="all" href="/sysadmin/sites/default/files/css/css_y3Xr5G8fIRYFF5ceJ8PSWt5P0C14zqhCAJrGX41FquU.css?q98wfo" />
<link rel="stylesheet" media="all" href="/sysadmin/sites/default/files/css/css_JXhuUUBYvhy4Hjmpd00amxoZ7dYzqFu-rFBds1SyWmM.css?q98wfo" />


<!--[if lte IE 8]>
<script src="/sysadmin/sites/default/files/js/js_VtafjXmRvoUgAzqzYTA3Wrjkx9wcWhjP0G4ZnnqRamA.js"></script>
<![endif]-->


</head>
<body>
<a href="#main-content" class="visually-hidden focusable">
Skip to main content
</a>

  <div class="dialog-off-canvas-main-canvas" data-off-canvas-main-canvas>
    

<div class="redhat-cookie-banner">
<section id="redhat-cookie-privacy-banner" class="redhat-cookie-banner-wrapper" style="display: block;">
  <div class="container my-3 pr-5">
    <p>We use cookies on our websites to deliver our online services. Details about how we use cookies and how you may disable them are set out in our <a href="http://www.redhat.com/en/about/privacy-policy#cookies">Privacy Statement</a>. By using this website you agree to our use of cookies.
    <span class="cookie-more">
    <a id="redhat-cookie-privacy-banner-close" href="javascript:void(0);" class="cookie-close">&times;</a>
    </span>
    </p>
  </div>
</section>
</div>

<div class="page">

  <div class="navbar navbar-expand-lg justify-content-between navbar-dark bg-dark">
    <div class="container">
                
  <div class="block block--sysadmin-navbar-branding">

  
    

    
  <a href="https://www.redhat.com/" class="navbar-brand ">
            <img src="/sysadmin/themes/custom/sysadmin/logo.svg" width="135" height="31" class="d-inline-block align-top" alt="Red Hat logo" />

        
  </a>


  </div>


      
      <div>
        <button class="navbar-toggler" type="button" data-toggle="collapse"  data-parent="#collapse-parent" data-target="#search-collapse" aria-controls="search-collapse" aria-expanded="false" aria-label="Toggle search">
          <svg class="icon-collapsed" width="30" height="30" viewBox="0 0 30 30" xmlns="http://www.w3.org/2000/svg"><line x1="18.95" y1="19.15" x2="25.25" y2="25.75"/><circle cx="13.25" cy="12.75" r="8.5"/></svg>
          <svg class="icon-expanded" width="30" height="30" viewBox="0 0 30 30" xmlns="http://www.w3.org/2000/svg"><line x1="7.25" y1="7.25" x2="22.75" y2="22.75"/><line x1="7.25" y1="22.75" x2="22.75" y2="7.25"/></svg>
          <span style="vertical-align: middle;">Search</span>
        </button>
        <button class="navbar-toggler" type="button" data-toggle="collapse" data-parent="#collapse-parent" data-target="#mobilenav-collapse" aria-controls="mobilenav-collapse" aria-expanded="false" aria-label="Toggle navigation">
          <svg class="icon-collapsed" width="30" height="30" viewBox="0 0 30 30" xmlns="http://www.w3.org/2000/svg"><path d="M4 7h22M4 15h22M4 23h22"/></svg>
          <svg class="icon-expanded" width="30" height="30" viewBox="0 0 30 30" xmlns="http://www.w3.org/2000/svg"><line x1="7.25" y1="7.25" x2="22.75" y2="22.75"/><line x1="7.25" y1="22.75" x2="22.75" y2="7.25"/></svg>
        </button>
      </div>
    </div>
  </div>

  <div id="collapse-parent">
    <div id="search-collapse" class="search-collapse collapse" data-parent="#collapse-parent">
      <div class="py-4 px-3">
        <form class="form-inline m-2" action="/sysadmin/search/node" accept-charset="UTF-8" method="get">
          <div class="input-group flex-fill">
            <input class="form-control" type="search" name="keys" id="search" value="" placeholder="Search this site…" aria-label="Search this site…">
            <div class="input-group-append">
              <button class="btn btn-secondary font-weight-bold" type="submit">Search</button>
            </div>
          </div>
        </form>
      </div>
    </div>

    <div id="mobilenav-collapse" class="mobilenav-collapse d-lg-none collapse" data-parent="#collapse-parent">
                
  <div class="block block--sysadmin-navbar-sitename sitename">

  
    

    
  <a href="/sysadmin/" class="navbar-brand sitename">
        Enable Sysadmin
  </a>

  <span class="d-none d-lg-inline ml-1 mr-3 h5 navbar-sitename-divider">&nbsp;</span>

  </div>

  <div class="block block--sysadmin-main-menu">

  
    

      
  


  <ul class="nav navbar-nav">
                                  <li class="nav-item  dropdown">
                      <a href="/sysadmin/" class="nav-link dropdown-toggle" data-toggle="dropdown" data-drupal-link-system-path="&lt;front&gt;">Articles</a>
                          <div class="dropdown-menu">
          <a href="/sysadmin/topics/automation" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/146">Automation</a>
          <a href="/sysadmin/topics/career" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/51">Career</a>
          <a href="/sysadmin/topics/sysadmin-culture" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/41">Culture</a>
          <a href="/sysadmin/topics/linux" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/21">Linux</a>
          <a href="/sysadmin/topics/programming" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/71"> Programming</a>
          <a href="/sysadmin/topics/security" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/96">Security</a>
  </div>
                              </li>
                              <li class="nav-item  dropdown">
                      <a href="/sysadmin/about" class="nav-link dropdown-toggle" data-toggle="dropdown" data-drupal-link-system-path="node/71">About</a>
                          <div class="dropdown-menu">
          <a href="/sysadmin/about" class="dropdown-item" data-drupal-link-system-path="node/71">Topics</a>
          <a href="/sysadmin/email" class="dropdown-item" data-drupal-link-system-path="node/376">Email newsletter</a>
          <a href="/sysadmin/join-community" class="dropdown-item" data-drupal-link-system-path="node/641">Join the community</a>
          <a href="/sysadmin/community-guidelines" class="dropdown-item" data-drupal-link-system-path="node/156">Community guidelines</a>
          <a href="/sysadmin/sudoers-program" class="dropdown-item" data-drupal-link-system-path="node/2106">Sudoers program</a>
          <a href="/sysadmin/faq" class="dropdown-item" data-drupal-link-system-path="node/1526">FAQs</a>
  </div>
                              </li>
                              <li class="nav-item  ">
                      <a href="/sysadmin/welcome" class="nav-link">Welcome</a>
                  </li>
            </ul>


  
  </div>


      
              
          </div>
  </div>

  


<nav class="navbar navbar-expand-lg justify-content-between navbar-light  d-none d-lg-block text-dark bg-light border-bottom-light-gray">
      <div class="container">
  
      
  
  <button class="navbar-toggler" type="button" data-toggle="collapse" data-target=".navbar-collapse" aria-controls="navbar-collapse" aria-expanded="false" aria-label="Toggle navigation">
    <span class="navbar-toggler-icon"></span>
  </button>

  <div class="collapse navbar-collapse">
                  <div class="mr-auto d-flex navbar-desktop">
            
  <div class="block block--sysadmin-navbar-sitename sitename">

  
    

    
  <a href="/sysadmin/" class="navbar-brand sitename">
        Enable Sysadmin
  </a>

  <span class="d-none d-lg-inline ml-1 mr-3 h5 navbar-sitename-divider">&nbsp;</span>

  </div>

  <div class="block block--sysadmin-main-menu">

  
    

      
  


  <ul class="nav navbar-nav">
                                  <li class="nav-item  dropdown">
                      <a href="/sysadmin/" class="nav-link dropdown-toggle" data-toggle="dropdown" data-drupal-link-system-path="&lt;front&gt;">Articles</a>
                          <div class="dropdown-menu">
          <a href="/sysadmin/topics/automation" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/146">Automation</a>
          <a href="/sysadmin/topics/career" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/51">Career</a>
          <a href="/sysadmin/topics/sysadmin-culture" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/41">Culture</a>
          <a href="/sysadmin/topics/linux" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/21">Linux</a>
          <a href="/sysadmin/topics/programming" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/71"> Programming</a>
          <a href="/sysadmin/topics/security" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/96">Security</a>
  </div>
                              </li>
                              <li class="nav-item  dropdown">
                      <a href="/sysadmin/about" class="nav-link dropdown-toggle" data-toggle="dropdown" data-drupal-link-system-path="node/71">About</a>
                          <div class="dropdown-menu">
          <a href="/sysadmin/about" class="dropdown-item" data-drupal-link-system-path="node/71">Topics</a>
          <a href="/sysadmin/email" class="dropdown-item" data-drupal-link-system-path="node/376">Email newsletter</a>
          <a href="/sysadmin/join-community" class="dropdown-item" data-drupal-link-system-path="node/641">Join the community</a>
          <a href="/sysadmin/community-guidelines" class="dropdown-item" data-drupal-link-system-path="node/156">Community guidelines</a>
          <a href="/sysadmin/sudoers-program" class="dropdown-item" data-drupal-link-system-path="node/2106">Sudoers program</a>
          <a href="/sysadmin/faq" class="dropdown-item" data-drupal-link-system-path="node/1526">FAQs</a>
  </div>
                              </li>
                              <li class="nav-item  ">
                      <a href="/sysadmin/welcome" class="nav-link">Welcome</a>
                  </li>
            </ul>


  
  </div>


        </div>
          
                  
      
      <div class="dropdown show text-align-right">
  <a href="/sysadmin/subscribe" class="navbar-util navbar-util--rss" aria-label="Subscribe to our feed or newsletter blast">
    <svg width="22" height="23" viewBox="0 0 22 23" xmlns="http://www.w3.org/2000/svg"><title>Subscribe to our RSS feed or Email blast</title><path d="M0 4.23c9.79 0 17.75 8 17.75 17.84h4.23A22.05 22.05 0 0 0 0 0v4.23z M0 7.67v4.23c2.74 0 5.33 1.07 7.27 3.03a10.26 10.26 0 0 1 3 7.3h4.24c0-8.02-6.5-14.56-14.51-14.56M2.93 16.87a2.94 2.94 0 0 0 0 5.85 2.93 2.93 0 1 0 0-5.85" fill-rule="evenodd"/></svg>

    <span class="sr-only">Subscribe to our RSS feed or Email blast.</span>
  </a>

    <a id="dropdownSearchLink" href="/sysadmin/search/node" class="navbar-util navbar-util--search" role="button" aria-label="Search this site…" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false">
    <svg width="30" height="30" viewBox="0 0 30 30" xmlns="http://www.w3.org/2000/svg" style="fill:none;stroke-width:3;stroke:#000;stroke-linecap:round;"><line x1="18.95" y1="19.15" x2="25.25" y2="25.75"/><circle cx="13.25" cy="12.75" r="8.5"/></svg>

  </a>
  <div class="dropdown-menu dropdown-menu-right p-1 pt-2" aria-labelledby="dropdownSearchLink">
    <form class="form-inline m-2" action="/sysadmin/search/node" accept-charset="UTF-8" method="get">
      <div class="input-group flex-fill">
        <input class="form-control" type="search" name="keys" id="search" value="" placeholder="Search this site…" aria-label="Search this site…">
        <div class="input-group-append">
          <button class="btn btn-secondary font-weight-bold" type="submit">GO</button>
        </div>
      </div>
    </form>
  </div>
  </div>
      </div>

      </div>
  </nav>

  <main class="pb-5">
                  <header class="page__header">
          <div class="container">
              <div data-drupal-messages-fallback class="hidden"></div>


          </div>
        </header>
          
    <a name="main-content" tabindex="-1"></a>

                  <div class="page__content">
                  
  <div class="block block--sysadmin-content">

  
    

      <article data-history-node-id="2141" role="article" about="/sysadmin/tech-failure" typeof="schema:Article" class="full full--article node node--promoted">
  
    <span property="schema:name" content="The first six warning signs that a technical project might fail" class="hidden"></span>
  <span property="schema:interactionCount" content="UserComments:0" class="hidden"></span>


      <div  class="section my-5 narrow">
  <div class="container">
    <div >
      
  <div data-layout-content-preview-placeholder-label="&quot;Title&quot; field" class="block">

  
    

      <span property="schema:name"><h1 class="font-weight-bold">The first six warning signs that a technical project might fail</h1>
</span>

  
  </div>

  <div data-layout-content-preview-placeholder-label="&quot;Subhead&quot; field" class="block">

  
    

      
            <div class="article__field-subhead">Is your project destined to fail? These first six of twelve indicators might say otherwise.</div>
      
  
  </div>

    </div>
  </div>
</div>
<div  class="section pb-5 narrow">
  <div class="container">
    <div >
      
  <div data-layout-content-preview-placeholder-label="&quot;Article Byline&quot; block" class="block">

  
    

      <p class="article-byline">
  <span class="article-date">
          Posted May 5, 2020
      </span>
    <span aria-hidden="true">|</span>
  <span class="article-authors">
    <strong class="sr-only">by</strong>
          <a href="/sysadmin/users/joachimhaller" class="article-author article-author--primary">Joachim Haller<span class="author-affiliate"> (Red Hat Accelerator)</span></a>      </span>
  </p>

  
  </div>

  <div data-layout-content-preview-placeholder-label="&quot;Media&quot; field" class="block">

  
    

      
            <div class="article__field-media"><figure>
  
  
  <div class="image__field-media-image">
    <div class="field__label font-weight-bold visually-hidden">
      Image    </div>
                  <div class="field__item">  
<img src="/sysadmin/sites/default/files/styles/full/public/2020-04/failure_success%20Cropped.jpg?itok=XmWYPpoP" width="1000" height="600" typeof="foaf:Image" loading="lazy" class="img-thumbnail" src="/sysadmin/sites/default/files/styles/full/public/2020-04/failure_success%20Cropped.jpg?itok=XmWYPpoP" alt="Project fail points" />


</div>
              </div>

  <figcaption>
    
            <div class="image__field-media-description"><a href="https://www.flickr.com/photos/14558526@N03/27554690005" rel="noopener" target="_blank">"Take Big Risks and Learn Fast From Your Failures"</a> by <a href="https://www.flickr.com/photos/14558526@N03" rel="noopener" target="_blank">keepitsurreal</a> is licensed under <a href="https://ccsearch.creativecommons.org/photos/null?ref=ccsearch&amp;atype=rich">CC BY-SA 2.0 </a>
</div>
      
  </figcaption>
</figure>
</div>
      
  
  </div>

  <div data-layout-content-preview-placeholder-label="&quot;Body&quot; field" class="block">

  
    

      
            <div property="schema:text" class="article__body"><div data-embed-button="resource_list" data-entity-embed-display="view_mode:resource_list.link" data-entity-type="resource_list" data-entity-uuid="fa7b02cd-605a-450a-a022-fc9948302fa2" data-langcode="en" class="align-right embedded-entity embedded-entity--resources embedded-entity--resources--link"><aside class="eck-entity mt-2 py-3 pr-3 border-top border-danger"><h2 class="h4">
      Career Advice
  </h2>

<ul class="pl-3 mb-0"><li class="my-2"><a href="https://www.redhat.com/rhtapps/assessment/?intcmp=701f20000012ngPAAQ">Take a sysadmin skills assessment</a></li>
      <li class="my-2"><a href="https://www.redhat.com/en/services/training/all-courses-exams?intcmp=701f20000012ngPAAQ">Explore training and certification options</a></li>
      <li class="my-2"><a href="https://opensource.com/article/19/9/communication-sysadmins?intcmp=701f20000012ngPAAQ">Read a guide to human communication for sysadmins</a></li>
  </ul></aside></div>
<p>Being a sysadmin means that you, from time to time, will be called into IT projects, and your role will most likely be that of Subject Matter Expert (SME). A sysadmin usually gets called in (too) late in the process, after the goals and milestones are already set. Most likely, these targets are, from a sysadmin point of view, too ambitious both when it comes to timelines as well as resource allocation.</p>

<p>The phrase,<em> "We just need you to check on some documents and verify that they are OK," </em>could be an introduction to your expected participation as a sysadmin in the project. Naturally, you have already figured out that your involvement will be much more extensive thanks to the already complete technical analysis that, in your view, looks like a barren wasteland. In this article, I explore the caveats behind the expressions "underestimate" and "overconfident" in technical projects.</p>

<p>So let's look at different components that build the picture. These pieces all revolve around the warning signs that an IT project already is or will soon be in trouble.</p>

<p><strong>Note</strong>: This content is the first in a two-part article series.</p>

<p class="h2">It's shiny</p>

<p>Many IT projects are the result of skilled salespersons or proficient companies that have, across several meetings and communications, presented many colorful slides showing speed, progress, and above all, substantial potential savings. One or more product demos and perhaps even a visit to a reference customer have been undertaken, and those involved have agreed that this new software product is the best thing since Spam in a can.</p>

<p>Speed, progress, and big savings are the classic trigger-points for management buy-in. The subsequent business case is followed by a <em>Proof-of-Concept</em> (POC) from the provider. Given the right context, the product is probably brilliant, well needed, and a step in the right direction, so the concern is more about the context, the technical landscape, the organization, and the legacy application environment that dampens the ability for the new product to shine and deliver.</p>

<p class="h2">Wow-to-production</p>

<p>In a worst-case scenario, the POC is completed without the sysadmin's involvement. It is not until the product is live in production that the sysadmin is called in because the project has hit some technical snag or other barriers which the project owners can't resolve on their own. For example, in an international deployment, the POC installation-gone-production will by now behave like an obstinate donkey on a hippodrome. You are stuck with something that belongs in a small test lab but is now stretched until all control is lost. You are tasked with fixing it, and now tempers are running high, together with cost. This situation is the perfect playground for finger-pointing in a prestige-filled drama of name and shame.</p>

<p>It is surprisingly common for POCs to morph into production, which inevitably causes issues. With no real launch plan, production setup, capacity for scaling, or any thought on the user experience in other countries, everyone is in for a bumpy ride. Sysadmins have the experience and knowledge to advise and prepare for how a real production environment should look.</p>

<p class="h2">Our business is unique</p>

<p><em>"You can't compare us to other companies because we manufacture the things we sell."</em> What I'm pointing to here is the urge to modify and customize products, so they EXACTLY fit the very specific way of working or thinking that the product is intended to match. This view is, of course, not a very future-oriented way of implementing something, but it does protect most colleagues from having to change either mindset or way of working. So without even trying the product as-is, extensive changes are made, and existing ways of working and thinking are handcrafted into the software product.</p>

<p>It's better to use it as-is for the first few months and only then apply a handful of adaptations that will not in any way affect the manufacturer's release schedule for the software product. Examples of drastic changes could be: changing some sort of back-end database, modifying user interfaces and views, rewriting standard queries, and changing tables. As a sysadmin, you know all too well the risks of turning to the dark side and starting to use free text fields to store keywords, dates, names, or time stamps.</p>

<p>Changes can, at this early stage, be implemented without using the standard change management process, which also means necessary documentation is missing, thus leaving a huge gap to fill once the project is handed over to production.</p>

<p>Surely all of the changes are done in good faith and the project team has no doubt a burning desire to create something truly awesome. But surprisingly, there is often no consideration as to what happens when the base product is upgraded.</p>

<p>Developers and sysadmins can together make a significant impact on managing changes that determine how easy (or hard) the software product is to update.</p>

<p class="h2">License cost</p>

<p>Many POCs are successful and the results are often very promising. As an example, going to the cloud usually looks very convincing in the early stages. Another opportunity might be some clever analysis tool that collects data and turn it into valuable information.</p>

<p>So the initial expansion of a new solution software is often positive, and there is no concern, but once the real production volumes start to enter the stage, the cost takes off. Many software releases have per-user licenses, while other services have a cost-per-Megabyte or a mix of both.  Then there are things like developer licenses, support licenses, and server licenses - which can be tricky in virtual or on the cloud. Licensing cost is a topic where sysadmins and finance need to collaborate to avoid unpleasant surprises.</p>

<p class="h2">Backups (not) included</p>

<p>When setting up a POC in a test environment, there are seldom any discussions about backup. Once the solution enters production, those sorts of things are already handled, and "everything is being backed up anyway." This mindset is what I would refer to as "overconfident," where the lack of understanding of how backups actually work, how long backup jobs take, and what the actual backup costs are is overlooked. With new technology, there is often the need for new types of backup that might require significant investments in service or hardware.</p>

<p class="h2">Security and Anti-whoops</p>

<p>Unwillingly placed in the back of the bus are teams that have perhaps the most significant role in the company when it comes to protecting assets such as information and business operations. I am referring to teams that are responsible for security and antivirus. If the IT project is initiated or driven by a business unit, chances are good that nobody thought to include them. But once these teams are included or become aware of the new project, they have loads of questions and concerns that can easily be perceived as blocking progress. Naturally, the situation would have been vastly different had these teams been involved from the start. Through daily operations, sysadmins are in contact with both security and antivirus teams and again play a pivotal role in the overall technical landscape.</p>

<p class="h2">Wrapping up</p>

<p>These are the first six signs of a failing project. Just addressing the above topics will take you a long way toward resolving problems with IT projects. In a followup article, I will discuss the remaining six issues, as well as provide a checklist that you can use to help make your life easier.</p>

<p><em><strong>[ Want to test your sysadmin skills? Take a <a href="https://www.redhat.com/rhtapps/assessment/?intcmp=701f20000012ngPAAQ">skills assessment today</a>. ]</strong></em></p>
</div>
      
  
  </div>

  <div data-layout-content-preview-placeholder-label="&quot;Listicle&quot; views block" class="block">

  
    

      <div class="views-element-container"><div class="listicle-view js-view-dom-id-370feafd13b31b0cd5031af4dea17470b7e5949f58ffba56ef69fd0b71e24a81">
  
  
  

  
  
  

      <div class="listicle-row"><div class="views-field views-field-field-listicle"><div class="field-content"></div></div></div>

    

  
  

  
  
</div>
</div>

  
  </div>

  <div data-layout-content-preview-placeholder-label="&quot;Topics&quot; field" class="block">

  
    

      <div class="topics">
  <strong>Topics:</strong>&nbsp;&nbsp;
      <a href="/sysadmin/topics/sysadmin-culture" class="btn btn-primary btn-sm font-weight-bold">Sysadmin culture</a>&nbsp;&nbsp;
      <a href="/sysadmin/topics/problem-solving" class="btn btn-primary btn-sm font-weight-bold">Problem solving</a>&nbsp;&nbsp;
  </div>
  
  </div>

    </div>
  </div>
</div>
<div >
  <div >
    
  <div data-layout-content-preview-placeholder-label="&quot;Entity view (Content)&quot; block" class="block">

  
    

      
<section data-history-node-id="2141" role="article" about="/sysadmin/tech-failure" typeof="schema:Article" class="section my-5 py-5 bg-light-gray authors-bio authors-bio--article">
  <div class="container">
          <div class="row">
        <div class="col-md-2 text-center">
                      
<div class="red-hat-accelerator-wrapper">
  <div class="red-hat-accelerator-ribbon-back"></div>
  
<img data-affiliation="Red Hat Accelerator" src="/sysadmin/sites/default/files/styles/user_picture_square/public/pictures/2019-11/joachimh.jpg?itok=VHaofu0S" width="240" height="240" typeof="foaf:Image" loading="lazy" class="rounded-circle img-thumbnail" src="/sysadmin/sites/default/files/styles/user_picture_square/public/pictures/2019-11/joachimh.jpg?itok=VHaofu0S" alt="Author’s photo" />

  <div class="red-hat-accelerator-ribbon-front"></div>
</div>

          
        </div>
        <div class="col-md-10 col-lg-8">
          <h2 class="font-weight-light text-center text-md-left">
                          Joachim Haller
                      </h2>
          <div>
                          <p>
                Member of the Red Hat Accelerators and Red Hat Chapter Lead at Capgemini.
                                  <a href="/sysadmin/users/joachimhaller" class="author-more-link">More about me</a>
                              </p>
                      </div>
        </div>
      </div>
      </div>
</section>



  
  </div>

  <div data-layout-content-preview-placeholder-label="&quot;Contributors&quot; block" class="block">

  
    

      

  
  </div>

  </div>
</div>
<div  class="section my-5 pb-5">
  <div class="container">
    <div >
      
  <div data-layout-content-preview-placeholder-label="&quot;Related Content&quot; views block" class="block">

  
    

      <div class="views-element-container"><div class="js-view-dom-id-b0cc95560cd487183b35faca1390bedf60f38f48607c3eef3b28224e625d9176">
  
  
  

  
  
  

    <h2>Related Content</h2>
                        <div class="card-deck my-4">
                        <article data-history-node-id="2236" role="article" about="/sysadmin/teamwork-trail" typeof="schema:Article" class="card card--article node node--promoted">
      <div class="card-img-top">
            <div class="article__field-media"><article>
  
      
  <div class="image__field-media-image">
    <div class="field__label font-weight-bold visually-hidden">
      Image    </div>
                  <div class="field__item">    <picture>
                <!--[if IE 9]><video style="display: none;"><![endif]-->
              <source srcset="/sysadmin/sites/default/files/styles/card/public/2020-05/outdoors-1251160_1280.webp?itok=yRSXdfcG 1x" type="image/webp"/>
              <source srcset="/sysadmin/sites/default/files/styles/card/public/2020-05/outdoors-1251160_1280.jpg?itok=yRSXdfcG 1x" type="image/jpeg"/>
            <!--[if IE 9]></video><![endif]-->
            
<img srcset="/sysadmin/sites/default/files/styles/card/public/2020-05/outdoors-1251160_1280.jpg?itok=yRSXdfcG 1x" src="/sysadmin/sites/default/files/styles/card/public/2020-05/outdoors-1251160_1280.jpg?itok=yRSXdfcG" typeof="foaf:Image" loading="lazy" class="img-thumbnail" src="/sysadmin/sites/default/files/styles/card/public/2020-05/outdoors-1251160_1280.jpg?itok=yRSXdfcG" alt="apalachian mountains" />

  </picture>

</div>
              </div>

  </article>
</div>
      </div>
      <div class="card-body">
    <div class="h4 card-title"><a href="/sysadmin/teamwork-trail"><span property="schema:name">Everything I need to know about teamwork I learned in the woods</span>
</a></div>
    <div class="card-text">
            <div property="schema:text" class="article__body">Lessons learned on a 2200 mile hike up the Appalachian Trail.</div>
      </div>
  </div>
  <div class="card-footer">
    <div class="article-date">
      <span class="label">Posted:</span>
      May 6, 2020
    </div>
    <div class="article-authors">
              <span class="label">Author:</span>
                    <a href="/sysadmin/users/tburke" class="article-author article-author--primary">Tim Burke</a>          </div>
  </div>
</article>


                            <article data-history-node-id="2186" role="article" about="/sysadmin/sysadmin-follow-twitter" typeof="schema:Article" class="card card--article node node--promoted">
      <div class="card-img-top">
            <div class="article__field-media"><article>
  
      
  <div class="image__field-media-image">
    <div class="field__label font-weight-bold visually-hidden">
      Image    </div>
                  <div class="field__item">    <picture>
                <!--[if IE 9]><video style="display: none;"><![endif]-->
              <source srcset="/sysadmin/sites/default/files/styles/card/public/2020-04/twitter%20Cropped_0.webp?itok=BLfhM2zV 1x" type="image/webp"/>
              <source srcset="/sysadmin/sites/default/files/styles/card/public/2020-04/twitter%20Cropped_0.jpg?itok=BLfhM2zV 1x" type="image/jpeg"/>
            <!--[if IE 9]></video><![endif]-->
            
<img srcset="/sysadmin/sites/default/files/styles/card/public/2020-04/twitter%20Cropped_0.jpg?itok=BLfhM2zV 1x" src="/sysadmin/sites/default/files/styles/card/public/2020-04/twitter%20Cropped_0.jpg?itok=BLfhM2zV" typeof="foaf:Image" loading="lazy" class="img-thumbnail" src="/sysadmin/sites/default/files/styles/card/public/2020-04/twitter%20Cropped_0.jpg?itok=BLfhM2zV" alt="Sysadmin Twitter accounts to follow" />

  </picture>

</div>
              </div>

  </article>
</div>
      </div>
      <div class="card-body">
    <div class="h4 card-title"><a href="/sysadmin/sysadmin-follow-twitter"><span property="schema:name">16 sysadmin accounts I follow on Twitter</span>
</a></div>
    <div class="card-text">
            <div property="schema:text" class="article__body">One sysadmin gives up his Twitter faves. Check them out.</div>
      </div>
  </div>
  <div class="card-footer">
    <div class="article-date">
      <span class="label">Posted:</span>
      May 7, 2020
    </div>
    <div class="article-authors">
              <span class="label">Author:</span>
                    <a href="/sysadmin/users/darkaxl" class="article-author article-author--primary">Alex Callejas<span class="author-affiliate"> (Red Hat)</span></a>          </div>
  </div>
</article>


                            <article data-history-node-id="2126" role="article" about="/sysadmin/scrum-master-day" typeof="schema:Article" class="card card--article node node--promoted">
      <div class="card-img-top">
            <div class="article__field-media"><article>
  
      
  <div class="image__field-media-image">
    <div class="field__label font-weight-bold visually-hidden">
      Image    </div>
                  <div class="field__item">    <picture>
                <!--[if IE 9]><video style="display: none;"><![endif]-->
              <source srcset="/sysadmin/sites/default/files/styles/card/public/2020-04/scrum-master%20Cropped.webp?itok=-RgURKLF 1x" type="image/webp"/>
              <source srcset="/sysadmin/sites/default/files/styles/card/public/2020-04/scrum-master%20Cropped.jpg?itok=-RgURKLF 1x" type="image/jpeg"/>
            <!--[if IE 9]></video><![endif]-->
            
<img srcset="/sysadmin/sites/default/files/styles/card/public/2020-04/scrum-master%20Cropped.jpg?itok=-RgURKLF 1x" src="/sysadmin/sites/default/files/styles/card/public/2020-04/scrum-master%20Cropped.jpg?itok=-RgURKLF" typeof="foaf:Image" loading="lazy" class="img-thumbnail" src="/sysadmin/sites/default/files/styles/card/public/2020-04/scrum-master%20Cropped.jpg?itok=-RgURKLF" alt="A day in the life of a scrum master" />

  </picture>

</div>
              </div>

  </article>
</div>
      </div>
      <div class="card-body">
    <div class="h4 card-title"><a href="/sysadmin/scrum-master-day"><span property="schema:name">A day in the life of a Scrum Master </span>
</a></div>
    <div class="card-text">
            <div property="schema:text" class="article__body">What does life actually look like for a Scrum Master in an IT environment? Take a look.</div>
      </div>
  </div>
  <div class="card-footer">
    <div class="article-date">
      <span class="label">Posted:</span>
      April 27, 2020
    </div>
    <div class="article-authors">
              <span class="label">Author:</span>
                    <a href="/sysadmin/users/tazb" class="article-author article-author--primary">Taz Brown</a>          </div>
  </div>
</article>


                              </div>
            
    

  
  

  
  
</div>
</div>

  
  </div>

    </div>
  </div>
</div>
<div  class="section my-5 pb-5 narrow">
  <div class="container">
    <div >
      
    </div>
  </div>
</div>
<div  class="section my-5 pb-5 ">
  <div class="container">
    <div >
      

  <div data-layout-content-preview-placeholder-label="&quot;CTA Subscribe (Red on Black)&quot; block" class="block block--cta cta cta--red-on-black cta-- my-5 p-3 text-center">

  
    

    <div class="d-md-flex justify-content-around align-items-center flex-wrap">
    <div class="cta__content my-2">
      
            <div class="cta__field-content p-2"><p class="h4 mb-4 mt-3 font-weight-bold">OUR BEST CONTENT, DELIVERED TO YOUR INBOX</p>

<p><iframe title="Subscribe to our newsletter" aria-label="Embedded form to subscribe to our email newsletter" frameborder="0" height="50" scrolling="no" src="/sysadmin/eloqua-embedded-subscribe.html?offer_id=701f20000012gE7AAI" style="max-width:670px;margin:0 auto;" width="100%"></iframe></p>
</div>
      
    </div>
      </div>
  
  </div>

    </div>
  </div>
</div>

  </article>

  
  </div>


              </div>
        </main>

            <footer>
              <div class="page__colophon bg-dark-gray py-4 bg-dark-gray">
          <div class="container">
              
  <div class="block block--basic block--sysadmin-colophon-disclaimer">

  
    

      
            <div class="basic__body"><p>The opinions expressed on this website are those of each author, not of the author's employer or of Red Hat. The content published on this site are community contributions and are for informational purpose only AND ARE NOT, AND ARE NOT INTENDED TO BE, RED HAT DOCUMENTATION, SUPPORT, OR ADVICE.</p>

<p>Red Hat and the Red Hat logo are trademarks of Red Hat, Inc., registered in the United States and other countries.</p>
</div>
      
  
  </div>


          </div>
        </div>
                    <div class="page__footer bg-dark py-3">
        <div class="container">
          <div class="d-sm-flex justify-content-between align-items-center">
              

  
    

    
  <a href="https://www.redhat.com/" class="navbar-brand mr-0 mr-lg-auto mb-3 mb-sm-0">
            <img src="/sysadmin/themes/custom/sysadmin/logo.svg" width="135" height="31" class="d-inline-block align-top" alt="Red Hat logo" />

        
  </a>



  <div class="block block--basic block--copyright my-0 mx-sm-3 mb-1 mb-sm-0">

  
    

      
            <div class="basic__body"><p>Copyright ©2020 Red Hat, Inc.</p>
</div>
      
  
  </div>

  <div class="block block--sysadmin-footer my-0 mb-1 mb-sm-0">

  
    

      
  


  <ul class="nav d-flex d-sm-block d-md-flex justify-content-center align-items-center">
                                  <li class="nav-item  ">
                      <a href="https://www.redhat.com/en/about/privacy-policy" class="nav-link">Privacy Policy</a>
                  </li>
                              <li class="nav-item  ">
                      <a href="https://www.redhat.com/en/about/terms-use" class="nav-link">Terms of Use</a>
                  </li>
                              <li class="nav-item  ">
                      <a href="https://www.redhat.com/en/about/all-policies-guidelines" class="nav-link">All policies and guidelines</a>
                  </li>
            </ul>


  
  </div>

  <div class="block block--sharelinks">

  
    

      <div class="a2a_kit a2a_kit_size_32 a2a_floating_style a2a_vertical_style" data-a2a-url="https://www.redhat.com/sysadmin/tech-failure">
  <a class="a2a_button_twitter a2a_counter"></a>
  <a class="a2a_button_facebook a2a_counter"></a>
  <a class="a2a_button_linkedin a2a_counter"></a>
  <a class="a2a_button_reddit a2a_counter"></a>
  <a class="a2a_button_email a2a_counter"></a>
</div>
<div class="a2a_kit a2a_kit_size_32 a2a_floating_style a2a_default_style">
  <a class="a2a_button_twitter a2a_counter"></a>
  <a class="a2a_button_facebook a2a_counter"></a>
  <a class="a2a_button_linkedin a2a_counter"></a>
  <a class="a2a_button_reddit a2a_counter"></a>
  <a class="a2a_button_email a2a_counter"></a>
</div>

<script>
  var a2a_config = a2a_config || {};
  a2a_config.templates = a2a_config.templates || {};
  a2a_config.templates.twitter = {
    text: "The first six warning signs that a technical project might fail https://red.ht/3fkNBm1 via #EnableSysadmin by @JoachimHaller ",
  };
  a2a_config.templates.facebook = {
    hashtag: "#EnableSysadmin",
  };
</script>
  
  </div>


  <div class="block block--cta block--ctasubscribesidebar cta cta--blue-on-white cta-- my-5 p-3 text-center">

  
    

    <div class="d-md-flex justify-content-around align-items-center flex-wrap">
    <div class="cta__content my-2">
      
            <div class="cta__field-content p-2"><div class="subscribe-sidebar">
<div class="target-band-never-show-button">x</div>

<h4>Subscribe now</h4>

<p class="eloqua-email-capture-text">Get the highlights in your inbox every week.</p>

<p><iframe aria-label="Embedded form to subscribe to our email newsletter" frameborder="0" height="50" scrolling="no" src="/sysadmin/eloqua-embedded-email-capture-block.html?offer_id=701f20000012gE7AAI" style="max-width:670px;margin:0 auto;" title="Subscribe to our newsletter" width="100%"></iframe></p>
</div>
</div>
      
    </div>
      </div>
  
  </div>


          </div>
        </div>
            </footer>
      </div>

  </div>


<script type="application/json" data-drupal-selector="drupal-settings-json">{"path":{"baseUrl":"\/sysadmin\/","scriptPath":null,"pathPrefix":"","currentPath":"node\/2141","currentPathIsAdmin":false,"isFront":false,"currentLanguage":"en"},"pluralDelimiter":"\u0003","ckeditorheight":{"offset":1,"line_height":1.5,"unit":"em","disable_autogrow":null},"user":{"uid":0,"permissionsHash":"653231f2fd62822d854a459f8c9bd92cdd388cedec8e99ad361c1430eee2d8b2"}}</script>
<script src="/sysadmin/sites/default/files/js/js_TIYAxpTFEL_kS48WayyEk27Vx-QETmJFIM7eqab5NYQ.js"></script>

  <script type="text/javascript">
    if (("undefined" !== typeof _satellite) && ("function" === typeof _satellite.pageBottom)) {
      _satellite.pageBottom();
    }
  </script>
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"a03a21ae8a","applicationID":"467345710","transactionName":"ZlNTbUBQDxZUWxJRVl8ZcFpGWA4LGkwJU1xfaUFLV24TAFtcA0pmV19UVVZuFQpeXQg=","queueTime":0,"applicationTime":438,"atts":"ShRQGwhKHBg=","errorBeacon":"bam.nr-data.net","agent":""}</script></body>
</html>
