<!DOCTYPE html>
<html lang="en" dir="ltr" prefix="content: http://purl.org/rss/1.0/modules/content/  dc: http://purl.org/dc/terms/  foaf: http://xmlns.com/foaf/0.1/  og: http://ogp.me/ns#  rdfs: http://www.w3.org/2000/01/rdf-schema#  schema: http://schema.org/  sioc: http://rdfs.org/sioc/ns#  sioct: http://rdfs.org/sioc/types#  skos: http://www.w3.org/2004/02/skos/core#  xsd: http://www.w3.org/2001/XMLSchema# ">
<head>
<script id="dpal" src="https://www.redhat.com/ma/dpal.js"></script>
<meta charset="utf-8" /><script type="text/javascript">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</script>
<link rel="canonical" href="https://www.redhat.com/sysadmin/get-started-vi-editor" />
<meta name="description" content="Once you&#039;ve committed Vi&#039;s keyboard shortcuts to muscle memory, watch how fast you work." />
<meta name="dcterms.title" content="How to get started with the Vi editor" />
<meta name="dcterms.creator" content="skenlon" />
<meta name="dcterms.publisher" content="Red Hat, Inc." />
<meta name="dcterms.language" content="en" />
<meta property="og:site_name" content="Enable Sysadmin" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.redhat.com/sysadmin/get-started-vi-editor" />
<meta property="og:title" content="How to get started with the Vi editor" />
<meta property="og:image" content="https://www.redhat.com/sysadmin/sites/default/files/styles/google_discover/public/2022-01/text-editor-typing.jpg?itok=R5QzeqNK" />
<meta property="og:image:secure_url" content="https://www.redhat.com/sysadmin/sites/default/files/styles/google_discover/public/2022-01/text-editor-typing.jpg?itok=R5QzeqNK" />
<meta property="og:image:type" content="image/jpeg" />
<meta property="og:image:width" content="1000" />
<meta property="og:video:width" content="600" />
<meta property="og:image:height" content="675" />
<meta property="og:updated_time" content="2022-01-25T10:00:00+0000" />
<meta property="og:image:alt" content="https://www.redhat.com/sysadmin/sites/default/files/styles/google_discover/public/2022-01/text-editor-typing.jpg?itok=R5QzeqNK" />
<meta property="og:street_address" content="100 East Davie Street" />
<meta property="og:locality" content="Raleigh" />
<meta property="og:region" content="NC" />
<meta property="og:postal_code" content="27601" />
<meta property="og:country_name" content="United States" />
<meta property="og:phone_number" content="+1 919 754 4950" />
<meta property="og:fax_number" content="+1 919 800 3804" />
<meta property="og:locale" content="en_US" />
<meta property="article:author" content="https://www.redhat.com/sysadmin/users/skenlon" />
<meta property="article:publisher" content="https://www.facebook.com/redhatinc" />
<meta property="article:section" content="Enable Sysadmin" />
<meta property="article:tag" content="Text editors" />
<meta property="article:tag" content="Command line utilities" />
<meta property="article:modified_time" content="2022-01-25T10:00:00+0000" />
<meta name="twitter:card" content="photo" />
<meta name="twitter:title" content="How to get started with the Vi editor" />
<meta name="twitter:site:id" content="14627400" />
<meta name="twitter:creator" content="@" />
<meta name="twitter:url" content="https://www.redhat.com/sysadmin/get-started-vi-editor" />
<meta name="twitter:image:alt" content="Red Hat, Inc." />
<meta name="twitter:image:height" content="1000" />
<meta name="twitter:image:width" content="600" />
<meta name="twitter:image" content="https://www.redhat.com/sysadmin/sites/default/files/styles/full/public/2022-01/text-editor-typing.jpg?itok=vCdtuKZr" />
<meta name="Generator" content="Drupal 9 (https://www.drupal.org)" />
<meta name="MobileOptimized" content="width" />
<meta name="HandheldFriendly" content="true" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<script type="application/ld+json">{
    "@context": "https://schema.org",
    "@graph": [
        {
            "@type": "TechArticle",
            "headline": "How to get started with the Vi editor",
            "name": "How to get started with the Vi editor",
            "about": [
                "\u003Ca href=\u0022/sysadmin/topics/text-editors\u0022 hreflang=\u0022en\u0022\u003EText editors\u003C/a\u003E",
                "\u003Ca href=\u0022/sysadmin/topics/command-line-utilities\u0022 hreflang=\u0022en\u0022\u003ECommand line utilities\u003C/a\u003E"
            ],
            "description": "Once you\u0027ve committed Vi\u0027s keyboard shortcuts to muscle memory, watch how fast you work.",
            "image": {
                "@type": "ImageObject",
                "url": "https://www.redhat.com/sysadmin/sites/default/files/styles/full/public/2022-01/text-editor-typing.jpg?itok=vCdtuKZr",
                "width": "1000",
                "height": "600"
            },
            "dateModified": "2022-01-25T10:00:00+0000",
            "author": {
                "@type": "Person",
                "@id": "https://www.redhat.com/sysadmin/users/skenlon",
                "name": "skenlon",
                "url": "https://www.redhat.com/sysadmin/users/skenlon",
                "sameAs": "https://twitter.com/"
            },
            "publisher": {
                "@type": "Organization",
                "@id": "https://www.redhat.com/"
            },
            "mainEntityOfPage": "https://www.redhat.com/sysadmin/get-started-vi-editor"
        },
        {
            "@type": "Corporation",
            "@id": "https://www.redhat.com/",
            "name": "Red Hat, Inc.",
            "sameAs": [
                "https://en.wikipedia.org/wiki/Red_Hat",
                "http://www.linkedin.com/company/red-hat",
                "http://www.youtube.com/user/RedHatVideos",
                "https://www.facebook.com/redhatinc",
                "https://twitter.com/RedHat"
            ],
            "url": "https://www.redhat.com/",
            "telephone": "+1 919 754 4950",
            "contactPoint": {
                "@type": "ContactPoint",
                "telephone": "+1-888-RED-HAT1",
                "availableLanguage": "English",
                "contactType": "sales",
                "faxnumber": "+1 919 800 3804"
            },
            "logo": {
                "@type": "ImageObject",
                "url": "https://www.redhat.com/sysadmin/themes/custom/sysadmin/assets/images/red-hat-logo.png",
                "width": "254",
                "height": "60"
            },
            "address": {
                "@type": "PostalAddress",
                "streetAddress": "100 East Davie Street",
                "addressLocality": "Raleigh",
                "addressRegion": "NC",
                "postalCode": "27601",
                "addressCountry": "United States"
            }
        },
        {
            "@type": "Person",
            "name": "Seth Kenlon",
            "sameAs": "https://twitter.com/",
            "image": {
                "@type": "ImageObject",
                "url": "https://www.redhat.com/sysadmin/sites/default/files/styles/user_picture_square/public/pictures/2021-06/sethKenlon-headshot.jpg?itok=L4lRrrIw",
                "width": "240",
                "height": "240"
            }
        },
        {
            "@type": "WebPage",
            "@id": "https://www.redhat.com/sysadmin/get-started-vi-editor",
            "publisher": {
                "@type": "Organization",
                "@id": "https://www.redhat.com/"
            }
        },
        {
            "@type": "WebSite",
            "@id": "https://www.redhat.com/sysadmin/",
            "name": "Enable Sysadmin",
            "url": "https://www.redhat.com/sysadmin/",
            "publisher": {
                "@type": "Organization",
                "@id": "https://www.redhat.com/"
            }
        }
    ]
}</script>
<meta name="robots" content="max-image-preview:large" />
<link rel="shortcut icon" href="/sysadmin/themes/custom/sysadmin/favicon.ico" type="image/vnd.microsoft.icon" />
<link rel="revision" href="https://www.redhat.com/sysadmin/get-started-vi-editor" />
<link rel="apple-touch-icon" sizes="180x180" href="/sysadmin/themes/custom/sysadmin/assets/favicon/apple-touch-icon.png">
<link rel="icon" type="image/png" sizes="32x32" href="/sysadmin/themes/custom/sysadmin/assets/favicon/favicon-32x32.png">
<link rel="icon" type="image/png" sizes="16x16" href="/sysadmin/themes/custom/sysadmin/assets/favicon/favicon-16x16.png">
<link rel="manifest" href="/sysadmin/themes/custom/sysadmin/assets/favicon/site.webmanifest">
<link rel="mask-icon" href="/sysadmin/themes/custom/sysadmin/assets/favicon/safari-pinned-tab.svg" color="#ee0000">
<meta name="msapplication-TileColor" content="#1a1a1a">
<meta name="theme-color" content="#ffffff">
<title>How to get started with the Vi editor | Enable Sysadmin</title>
<link rel="stylesheet" media="all" href="/sysadmin/sites/default/files/css/css_K-etweG1PGH6xQ8c1GPXlg7Kf-iQ9nD5hOKFOqg1DI0.css" />
<link rel="stylesheet" media="all" href="/sysadmin/sites/default/files/css/css_wL5vQsqSGZeeFvsRIov4xFil8zWkEzY2DL19yeqGeqw.css" />

<script src="/sysadmin/sites/default/files/js/js_QHqjxhGPGgZFwOfW92tmrVpssmC1sbO0zDG4TgLmaEI.js"></script>


</head>
<body>
<a href="#main-content" class="visually-hidden focusable">
Skip to main content
</a>

  <div class="dialog-off-canvas-main-canvas" data-off-canvas-main-canvas>
    

<div class="redhat-cookie-banner">
<section id="redhat-cookie-privacy-banner" class="redhat-cookie-banner-wrapper" style="display: block;">
  <div class="container my-3 pr-5">
    <p>We use cookies on our websites to deliver our online services. Details about how we use cookies and how you may disable them are set out in our <a href="http://www.redhat.com/en/about/privacy-policy#cookies">Privacy Statement</a>. By using this website you agree to our use of cookies.
    <span class="cookie-more">
    <a id="redhat-cookie-privacy-banner-close" href="javascript:void(0);" class="cookie-close">&times;</a>
    </span>
    </p>
  </div>
</section>
</div>

<div class="page d-flex flex-column">
  <div class="navbar navbar-expand-lg justify-content-between navbar-dark bg-dark">
    <div class="container">
                
  <div class="block block--sysadmin-navbar-branding">

  
    

    
  <a href="https://www.redhat.com/" class="navbar-brand ">
            <img src="/sysadmin/themes/custom/sysadmin/logo.svg" width="135" height="31" class="d-inline-block align-top" alt="Red Hat logo" />

        
  </a>


  </div>


      
      <div class="navbar-toggler-wrapper">
        <button class="navbar-toggler" type="button" data-toggle="collapse"  data-parent="#collapse-parent" data-target="#search-collapse" aria-controls="search-collapse" aria-expanded="false" aria-label="Toggle search">
          <svg class="icon-collapsed" width="30" height="30" viewBox="0 0 30 30" xmlns="http://www.w3.org/2000/svg"><line x1="18.95" y1="19.15" x2="25.25" y2="25.75"/><circle cx="13.25" cy="12.75" r="8.5"/></svg>
          <svg class="icon-expanded" width="30" height="30" viewBox="0 0 30 30" xmlns="http://www.w3.org/2000/svg"><line x1="7.25" y1="7.25" x2="22.75" y2="22.75"/><line x1="7.25" y1="22.75" x2="22.75" y2="7.25"/></svg>
          <span style="vertical-align: middle;">Search</span>
        </button>
        <button class="navbar-toggler" type="button" data-toggle="collapse" data-parent="#collapse-parent" data-target="#mobilenav-collapse" aria-controls="mobilenav-collapse" aria-expanded="false" aria-label="Toggle navigation">
          <svg class="icon-collapsed" width="30" height="30" viewBox="0 0 30 30" xmlns="http://www.w3.org/2000/svg"><path d="M4 7h22M4 15h22M4 23h22"/></svg>
          <svg class="icon-expanded" width="30" height="30" viewBox="0 0 30 30" xmlns="http://www.w3.org/2000/svg"><line x1="7.25" y1="7.25" x2="22.75" y2="22.75"/><line x1="7.25" y1="22.75" x2="22.75" y2="7.25"/></svg>
        </button>
      </div>
    </div>
  </div>

  <div id="collapse-parent">
    <div id="search-collapse" class="search-collapse collapse" data-parent="#collapse-parent">
      <div class="py-4 px-3">
        <form class="form-inline m-2" action="/sysadmin/search/node" accept-charset="UTF-8" method="get">
          <div class="input-group flex-fill">
            <input class="form-control" type="search" name="keys" id="search" value="" placeholder="Search this site…" aria-label="Search this site…">
            <div class="input-group-append">
              <button class="btn btn-secondary font-weight-bold" type="submit">Search</button>
            </div>
          </div>
        </form>
      </div>
    </div>

    <div id="mobilenav-collapse" class="mobilenav-collapse d-lg-none collapse" data-parent="#collapse-parent">
                
  <div class="block block--sysadmin-navbar-sitename sitename">

  
    

    
  <a href="/sysadmin/" class="navbar-brand sitename">
        Enable Sysadmin
  </a>

  <span class="d-none d-lg-inline ml-1 mr-3 h5 navbar-sitename-divider">&nbsp;</span>

  </div>

  <div class="block block--sysadmin-main-menu">

  
    

      
  


  <ul class="nav navbar-nav">
                                          <li class="nav-item  dropdown">
                      <a href="/sysadmin/" class="nav-link dropdown-toggle" data-toggle="dropdown" data-drupal-link-system-path="&lt;front&gt;">Articles</a>
                          <div class="dropdown-menu">
              <a href="/sysadmin/topics/automation" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/146">Automation</a>
              <a href="/sysadmin/topics/career" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/51">Career</a>
              <a href="/sysadmin/topics/containers" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/36"> Containers</a>
              <a href="/sysadmin/topics/sysadmin-culture" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/41">Culture</a>
              <a href="/sysadmin/topics/kubernetes" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/66">Kubernetes</a>
              <a href="/sysadmin/topics/linux" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/21">Linux</a>
              <a href="/sysadmin/topics/programming" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/71"> Programming</a>
              <a href="/sysadmin/topics/security" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/96">Security</a>
  </div>
                              </li>
                                      <li class="nav-item  dropdown">
                      <a href="/sysadmin/about" class="nav-link dropdown-toggle" data-toggle="dropdown" data-drupal-link-system-path="node/71">About</a>
                          <div class="dropdown-menu">
              <a href="/sysadmin/about" class="dropdown-item" data-drupal-link-system-path="node/71">Topics</a>
              <a href="/sysadmin/email" class="dropdown-item" data-drupal-link-system-path="node/376">Email newsletter</a>
              <a href="/sysadmin/join-community" class="dropdown-item" data-drupal-link-system-path="node/641">Join the community</a>
              <a href="/sysadmin/community-guidelines" class="dropdown-item" data-drupal-link-system-path="node/156">Community guidelines</a>
              <a href="/sysadmin/sudoers-program" class="dropdown-item" data-drupal-link-system-path="node/2106">Sudoers program</a>
              <a href="/sysadmin/meet-team" class="dropdown-item" data-drupal-link-system-path="node/2316">Meet the team</a>
              <a href="/sysadmin/faq" class="dropdown-item" data-drupal-link-system-path="node/1526">FAQs</a>
  </div>
                              </li>
                                      <li class="nav-item  ">
                      <a href="/sysadmin/welcome-enable-sysadmin" title="A Red Hat community publication for sysadmins, by sysadmins" class="nav-link">Welcome</a>
                  </li>
            </ul>


  
  </div>


      
              
          </div>
  </div>

  


<nav class="navbar navbar-expand-lg justify-content-between navbar-light  d-none d-lg-block text-dark bg-light border-bottom-light-gray">
      <div class="container">
  
      
  
  <button class="navbar-toggler" type="button" data-toggle="collapse" data-target=".navbar-collapse" aria-controls="navbar-collapse" aria-expanded="false" aria-label="Toggle navigation">
    <span class="navbar-toggler-icon"></span>
  </button>

  <div class="collapse navbar-collapse">
                  <div class="mr-auto d-flex navbar-desktop">
            
  <div class="block block--sysadmin-navbar-sitename sitename">

  
    

    
  <a href="/sysadmin/" class="navbar-brand sitename">
        Enable Sysadmin
  </a>

  <span class="d-none d-lg-inline ml-1 mr-3 h5 navbar-sitename-divider">&nbsp;</span>

  </div>

  <div class="block block--sysadmin-main-menu">

  
    

      
  


  <ul class="nav navbar-nav">
                                          <li class="nav-item  dropdown">
                      <a href="/sysadmin/" class="nav-link dropdown-toggle" data-toggle="dropdown" data-drupal-link-system-path="&lt;front&gt;">Articles</a>
                          <div class="dropdown-menu">
              <a href="/sysadmin/topics/automation" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/146">Automation</a>
              <a href="/sysadmin/topics/career" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/51">Career</a>
              <a href="/sysadmin/topics/containers" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/36"> Containers</a>
              <a href="/sysadmin/topics/sysadmin-culture" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/41">Culture</a>
              <a href="/sysadmin/topics/kubernetes" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/66">Kubernetes</a>
              <a href="/sysadmin/topics/linux" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/21">Linux</a>
              <a href="/sysadmin/topics/programming" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/71"> Programming</a>
              <a href="/sysadmin/topics/security" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/96">Security</a>
  </div>
                              </li>
                                      <li class="nav-item  dropdown">
                      <a href="/sysadmin/about" class="nav-link dropdown-toggle" data-toggle="dropdown" data-drupal-link-system-path="node/71">About</a>
                          <div class="dropdown-menu">
              <a href="/sysadmin/about" class="dropdown-item" data-drupal-link-system-path="node/71">Topics</a>
              <a href="/sysadmin/email" class="dropdown-item" data-drupal-link-system-path="node/376">Email newsletter</a>
              <a href="/sysadmin/join-community" class="dropdown-item" data-drupal-link-system-path="node/641">Join the community</a>
              <a href="/sysadmin/community-guidelines" class="dropdown-item" data-drupal-link-system-path="node/156">Community guidelines</a>
              <a href="/sysadmin/sudoers-program" class="dropdown-item" data-drupal-link-system-path="node/2106">Sudoers program</a>
              <a href="/sysadmin/meet-team" class="dropdown-item" data-drupal-link-system-path="node/2316">Meet the team</a>
              <a href="/sysadmin/faq" class="dropdown-item" data-drupal-link-system-path="node/1526">FAQs</a>
  </div>
                              </li>
                                      <li class="nav-item  ">
                      <a href="/sysadmin/welcome-enable-sysadmin" title="A Red Hat community publication for sysadmins, by sysadmins" class="nav-link">Welcome</a>
                  </li>
            </ul>


  
  </div>


        </div>
          
                  
      
      

<div class="dropdown show text-align-right">
    <a href="/sysadmin/subscribe" class="navbar-util navbar-util--rss" aria-label="Subscribe to our feed or newsletter blast">
    <svg width="22" height="23" viewBox="0 0 22 23" xmlns="http://www.w3.org/2000/svg"><title>Subscribe to our RSS feed or Email newsletter</title><path d="M0 4.23c9.79 0 17.75 8 17.75 17.84h4.23A22.05 22.05 0 0 0 0 0v4.23z M0 7.67v4.23c2.74 0 5.33 1.07 7.27 3.03a10.26 10.26 0 0 1 3 7.3h4.24c0-8.02-6.5-14.56-14.51-14.56M2.93 16.87a2.94 2.94 0 0 0 0 5.85 2.93 2.93 0 1 0 0-5.85" fill-rule="evenodd"/></svg>

    <span class="sr-only">Subscribe to our RSS feed or Email newsletter.</span>
  </a>

    <a id="dropdownSearchLink" href="/sysadmin/search/node" class="navbar-util navbar-util--search" role="button" aria-label="Search this site…" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false">
    <svg width="30" height="30" viewBox="0 0 30 30" xmlns="http://www.w3.org/2000/svg" style="fill:none;stroke-width:3;stroke:#000;stroke-linecap:round;"><line x1="18.95" y1="19.15" x2="25.25" y2="25.75"/><circle cx="13.25" cy="12.75" r="8.5"/></svg>

  </a>
  <div class="dropdown-menu dropdown-menu-right p-1 pt-2" aria-labelledby="dropdownSearchLink">
    <form class="form-inline m-2" action="/sysadmin/search/node" accept-charset="UTF-8" method="get">
      <div class="input-group flex-fill">
        <input class="form-control" type="search" name="keys" id="search" value="" placeholder="Search this site…" aria-label="Search this site…">
        <div class="input-group-append">
          <button class="btn btn-secondary font-weight-bold" type="submit">GO</button>
        </div>
      </div>
    </form>
  </div>
  </div>
      </div>

      </div>
  </nav>

  <main class="pb-5">
                  <header class="page__header">
          <div class="container">
              <div data-drupal-messages-fallback class="hidden"></div>


          </div>
        </header>
          
    <a name="main-content" tabindex="-1"></a>

                  <div class="page__content">
                  
  <div class="block block--sysadmin-content">

  
    

      <article data-history-node-id="5586" role="article" about="/sysadmin/get-started-vi-editor" typeof="schema:Article" id="node--article--5586" class="full full--article node node--promoted">
  
    <span property="schema:name" content="How to get started with the Vi editor" class="hidden"></span>
  <span property="schema:interactionCount" content="UserComments:0" class="hidden"></span>


      <div  class="section my-5 narrow">
  <div class="container">
    <div >
      
  <div class="block">

  
    

      <span property="schema:name"><h1 class="font-weight-bold">How to get started with the Vi editor</h1>
</span>

  
  </div>

  <div class="block">

  
    

      
            <div class="article__field-subhead">Once you&#039;ve committed Vi&#039;s keyboard shortcuts to muscle memory, watch how fast you work.</div>
      
  
  </div>

    </div>
  </div>
</div>
<div  class="section pb-5 narrow">
  <div class="container">
    <div >
      
  <div class="block">

  
    

      <p class="article-byline">
  <span class="article-date">
    <span class="label">Posted:</span>
    January 25, 2022
  </span>
    <span aria-hidden="true">|</span>
  <span class="article-authors">
    <strong class="sr-only">by</strong>
          <a href="/sysadmin/users/skenlon" class="article-author article-author--primary">Seth Kenlon<span class="author-affiliate"> (Red Hat)</span></a>      </span>
  </p>

  
  </div>

  <div class="block">

  
    

      
            <div class="article__field-media"><figure>
  
  
  <div data-blazy="" class="blazy blazy--field blazy--field-media-image image__field-media-image">
    <div class="field__label font-weight-bold visually-hidden">
      Image    </div>
                  <div class="field__item">



                  <div class="media media--blazy media--bundle--image media--loading is-b-loading media--image">
<img alt="Typing on a laptop with headphones next to the computer" class="media__image media__element b-lazy img-fluid" data-src="/sysadmin/sites/default/files/styles/full/public/2022-01/text-editor-typing.jpg?itok=vCdtuKZr" src="data:image/svg+xml;charset=utf-8,%3Csvg%20xmlns%3D&#039;http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg&#039;%20viewBox%3D&#039;0%200%201000%20600&#039;%2F%3E" width="1000" height="600" loading="lazy" typeof="foaf:Image" />
        </div>
        
  
</div>
              </div>

  <figcaption>
    
            <div class="image__field-media-description"><p><sup>Photo by <a href="https://www.pexels.com/@ron-lach?utm_content=attributionCopyText&amp;utm_medium=referral&amp;utm_source=pexels">Ron Lach</a> from <a href="https://www.pexels.com/photo/top-view-shot-of-a-person-typing-on-the-keyboard-of-a-laptop-9909092/?utm_content=attributionCopyText&amp;utm_medium=referral&amp;utm_source=pexels">Pexels</a></sup></p>
</div>
      
  </figcaption>
</figure>
</div>
      
  
  </div>

  <div class="block">

  
    

      
            <div property="schema:text" class="clearfix article__body"><p>The Vi application is the default text editor on most Linux systems, so it's the primary interface you will use when you need to edit a configuration file. If you're used to a graphical text editor, such as Notepad++ or <a href="https://opensource.com/article/20/6/open-source-alternatives-vs-code" target="_blank">VS Code</a>, Vi can be confusing at first.</p>

<p>In its default form, Vi launches and runs in a terminal and is entirely keyboard-driven. But once you learn the basics of Vi, you're likely to find that it's a fast, efficient, and flexible editor.</p>

<h2>Start Vi</h2>

<p>To start Vi, open a terminal and type <code>vi</code> followed by a file path. If the file you provide doesn't exist, it's created when Vi opens:</p>

<pre>
<code class="language-shell">$ vi example.txt</code></pre>

<p>The <code>vi</code> command is usually a symlink to the <code>vim</code> (Vi improved) command, but many users refer to Vi as Vi, not Vim.</p>

<h2>Command mode and insert mode</h2>

<div data-embed-button="resource_list" data-entity-embed-display="view_mode:resource_list.link" data-entity-type="resource_list" data-entity-uuid="60b26066-acd0-4332-afa7-d98c9a079f02" data-langcode="en" class="align-right embedded-entity embedded-entity--resources embedded-entity--resources--link"><aside id="resource-list-more-linux-resources" class="eck-entity mt-2 py-3 pr-3 border-top border-danger"><h2 class="h4">
      More Linux resources
  </h2>

<ul class="pl-3 mb-0"><li class="my-2"><a href="https://developers.redhat.com/cheat-sheets/linux-commands-cheat-sheet/?intcmp=701f20000012ngPAAQ">Basic Linux commands cheat sheet</a></li>
      <li class="my-2"><a href="https://developers.redhat.com/cheat-sheets/advanced-linux-commands/?intcmp=701f20000012ngPAAQ">Advanced Linux commands cheat sheet</a></li>
      <li class="my-2"><a href="https://rhtapps.redhat.com/assessment/?intcmp=701f20000012ngPAAQ">Linux system administration skills assessment</a></li>
      <li class="my-2"><a href="https://www.redhat.com/en/services/training/rh024-red-hat-linux-technical-overview?intcmp=701f20000012ngPAAQ">Free course: RHEL technical overview</a></li>
  </ul></aside></div>
<p>Vi has two different modes. There's command mode and insert mode. Command mode is the default, and you can think of it as Vi's menu. Because Vi doesn't have a menu bar like most applications have, you use command mode to tell Vi what you want to do next (move up or down a line, delete a character or a whole word, copy and paste, and so on.)</p>

<p>You can always get back to command mode by pressing <strong>Esc</strong> on your keyboard. Get used to that; you'll be pressing <strong>Esc </strong>a lot in Vi.</p>

<p>To enter insert mode, press <strong>i</strong>. In insert mode, you can type and edit text and use the arrow keys to navigate around your document. There's not much to say about insert mode. It's very much as its name advertises: In insert mode, you can <em>insert</em> text, so there's nothing to learn except, maybe, touch typing.</p>

<p>Command mode, however, has a wealth of keyboard shortcuts and commands for you to discover. Remember, to enter command mode, press <strong>Esc</strong>. If you're ever in doubt about which mode you're in, just press <strong>Esc</strong>, and you can be sure that you're <em>now</em> in command mode.</p>

<h2>Keyboard shortcuts for command mode</h2>

<p>In Vi, you don't use your mouse or any of the keyboard shortcuts you're used to in other editors. For instance, you don't copy with <strong>Ctrl+C</strong> and paste with <strong>Ctrl+V</strong> because Vi has its own set of quick shortcuts that optimize key presses. It's unquestionably a learning curve, but one that pays dividends. Once you've got the basic keyboard shortcuts committed to muscle memory, you'll work faster in Vi than you've worked in any editor.</p>

<h3>Modes</h3>

<ul><li><strong>i</strong>: for insert mode</li>
	<li><strong>I </strong>(that's an upper-case i):<strong> </strong>insert text at beginning of current line</li>
	<li><strong>a</strong>: append text after cursor</li>
	<li><strong>A</strong>: append text at end of current line</li>
	<li><strong>Esc</strong>: command mode</li>
</ul><p><strong><em>[ Boost your Linux skills by downloading the <a href="https://developers.redhat.com/cheat-sheets/bash-shell-cheat-sheet?intcmp=701f20000012ngPAAQ" target="_blank">Bash shell scripting cheat sheet</a>. ]</em></strong></p>

<h3>Navigation</h3>

<p>Navigation happens on the home row of your QWERTY keyboard:</p>

<ul><li><strong>h</strong>: cursor left</li>
	<li><strong>j</strong>: cursor down (<strong>j</strong> looks trivially like a down arrow)</li>
	<li><strong>k</strong>: cursor up</li>
	<li><strong>l</strong> (that's a lower-case L): cursor right</li>
	<li><strong>b</strong>: cursor to beginning of current word</li>
	<li><strong>e</strong>: cursor to end of current word</li>
	<li><strong>$</strong>: go to end of line</li>
	<li><strong>0</strong> (that's a zero): go to beginning of line</li>
	<li><strong>gg</strong>: go to first line of file</li>
	<li><strong>G</strong>: go to last line of file</li>
	<li><strong>9G</strong>: go to line 9 of file</li>
</ul><h3>Select</h3>

<ul><li><strong>v</strong>: select text</li>
	<li><strong>V</strong>: select line</li>
</ul><h3>Copy and paste</h3>

<ul><li><strong>y</strong>: copy ("yank") selection</li>
	<li><strong>yy</strong>: copy ("yank") the entire line</li>
	<li><strong>p</strong>: paste</li>
</ul><h3>Delete</h3>

<ul><li>
	<div data-embed-button="resource_list" data-entity-embed-display="view_mode:resource_list.link" data-entity-type="resource_list" data-entity-uuid="78d8f7ba-4831-497f-b66d-ec0bb740244e" data-langcode="en" class="align-right embedded-entity embedded-entity--resources embedded-entity--resources--link"><aside id="resource-list-linux-containers" class="eck-entity mt-2 py-3 pr-3 border-top border-danger"><h2 class="h4">
      Linux containers
  </h2>

<ul class="pl-3 mb-0"><li class="my-2"><a href="https://www.redhat.com/en/topics/containers?intcmp=701f20000012ngPAAQ">Understanding Linux containers</a></li>
      <li class="my-2"><a href="https://www.redhat.com/en/services/training/do080-deploying-containerized-applications-technical-overview?intcmp=701f20000012ngPAAQ">Free course: Deploying containerized applications</a></li>
      <li class="my-2"><a href="https://www.redhat.com/en/technologies/cloud-computing/openshift/try-it?intcmp=701f20000012ngPAAQ">Download now: Red Hat OpenShift trial</a></li>
      <li class="my-2"><a href="https://www.redhat.com/en/resources/container-storage-dummies?intcmp=701f20000012ngPAAQ">eBook: Container storage for dummies</a></li>
  </ul></aside></div>
<strong>x</strong>: delete character</li>
	<li><strong>dw</strong>: delete word</li>
	<li><strong>d$</strong>: delete from current position to end of line</li>
	<li><strong>d0</strong>: delete from current position to beginning of line</li>
	<li><strong>dG</strong>: delete to last line of file</li>
</ul><h3>Undo</h3>

<ul><li><strong>u</strong>: undo</li>
</ul><h3>Save</h3>

<ul><li><strong>:w</strong>: save</li>
	<li><strong>:wq</strong> or <strong>:ZZ</strong>: save and quit</li>
	<li><strong>:q!</strong>: force quit without saving</li>
</ul><h2>Get to know Vi</h2>

<p>Knowing Vi is a valuable skill on Linux because it's on nearly every Linux system you're likely to encounter. Once you get comfortable with its key bindings and how they enable you to keep your hands on the keyboard instead of bouncing back and forth to your mouse or even to Function keys, you'll see why Vi has endured for so long.</p>
</div>
      
  
  </div>

  <div class="views-element-container block">

  
    

      <div><div class="listicle-view js-view-dom-id-03163585ce01317f722bc1fc31287a355350a951970dd14169e55c7bde0232ad">
  
  
  

  
  
  

    <h3>Check out these related articles on Enable Sysadmin</h3>
    <div class="listicle-row"><div class="views-field views-field-field-listicle"><div class="field-content"><article data-history-node-id="3636" role="article" about="/sysadmin/text-editor-guides-2020" typeof="schema:Article" id="node--article--3636" class="listicle listicle--article node node--promoted">
  <div class="row align-items-center">
    <div class="col-md-6 listicle-image">
            <div class="article__field-media"><div>
  
  
  <div data-blazy="" class="blazy blazy--field blazy--field-media-image blazy--field-media-image--block-1 blazy--view blazy--view--listicle blazy--view--listicle--block-1 image__field-media-image">
    <div class="field__label font-weight-bold visually-hidden">
      Image    </div>
                  <div class="field__item">



                  <div class="media media--blazy media--bundle--image media--loading is-b-loading media--image">
<img alt="5 Linux commands I&#039;m going to start using" class="media__image media__element b-lazy img-fluid" data-src="/sysadmin/sites/default/files/styles/card/public/2020-12/five-highlighters-text-editors.jpg?itok=HNGUTSFb" src="data:image/svg+xml;charset=utf-8,%3Csvg%20xmlns%3D&#039;http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg&#039;%20viewBox%3D&#039;0%200%20700%20420&#039;%2F%3E" width="700" height="420" loading="lazy" typeof="foaf:Image" />
        </div>
        
  
</div>
              </div>

</div>
</div>
      </div>
    <div class="col-md-6 listicle-body">
      <div class="h4 listicle-title pt-4 pt-md-0"><a href="/sysadmin/text-editor-guides-2020"><span property="schema:name">5 Linux text editor guides</span>
</a></div>
      <div class="listicle-text font-weight-light py-2">
        
            <div property="schema:text" class="clearfix article__body">Make discovering your favorite new text editor the highlight of your year!</div>
      
      </div>

      <div class="listicle-footer">
        <div class="article-date">
          <span class="label">Posted:</span>
          December 28, 2020
        </div>
        <div class="article-authors">
                      <span class="label">Author:</span>
                                <a href="/sysadmin/users/ricardo-gerardi" class="article-author article-author--primary">Ricardo Gerardi<span class="author-affiliate"> (Red Hat, Sudoer)</span></a>                  </div>
      </div>
    </div>
  </div>
</article>
<article data-history-node-id="471" role="article" about="/sysadmin/introduction-vi-editor" typeof="schema:Article" id="node--article--471" class="listicle listicle--article node node--promoted">
  <div class="row align-items-center">
    <div class="col-md-6 listicle-image">
            <div class="article__field-media"><div>
  
  
  <div data-blazy="" class="blazy blazy--field blazy--field-media-image blazy--field-media-image--block-1 blazy--view blazy--view--listicle blazy--view--listicle--block-1 image__field-media-image">
    <div class="field__label font-weight-bold visually-hidden">
      Image    </div>
                  <div class="field__item">



                  <div class="media media--blazy media--bundle--image media--loading is-b-loading media--image">
<img alt="vi vs. emacs" class="media__image media__element b-lazy img-fluid" data-src="/sysadmin/sites/default/files/styles/card/public/2019-07/vi_emacs.png?itok=TaAXcwgf" src="data:image/svg+xml;charset=utf-8,%3Csvg%20xmlns%3D&#039;http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg&#039;%20viewBox%3D&#039;0%200%20700%20420&#039;%2F%3E" width="700" height="420" loading="lazy" typeof="foaf:Image" />
        </div>
        
  
</div>
              </div>

</div>
</div>
      </div>
    <div class="col-md-6 listicle-body">
      <div class="h4 listicle-title pt-4 pt-md-0"><a href="/sysadmin/introduction-vi-editor"><span property="schema:name">An introduction to the vi editor</span>
</a></div>
      <div class="listicle-text font-weight-light py-2">
        
            <div property="schema:text" class="clearfix article__body">The lowly and now middle-aged vi editor is still a favorite among *nix system administrators and remains an essential tool for command-line file creation and editing.</div>
      
      </div>

      <div class="listicle-footer">
        <div class="article-date">
          <span class="label">Posted:</span>
          August 20, 2019
        </div>
        <div class="article-authors">
                      <span class="label">Author:</span>
                                <a href="/sysadmin/users/khess" class="article-author article-author--primary">Ken Hess<span class="author-affiliate"> (Red Hat)</span></a>                  </div>
      </div>
    </div>
  </div>
</article>
</div></div></div>

    

  
  

  
  
</div>
</div>

  
  </div>

  <div class="block">

  
    

      <div class="topics">
  <strong>Topics:</strong>&nbsp;&nbsp;
      <a href="/sysadmin/topics/text-editors" class="btn btn-primary btn-sm font-weight-bold">Text editors</a>&nbsp;&nbsp;
      <a href="/sysadmin/topics/command-line-utilities" class="btn btn-primary btn-sm font-weight-bold">Command line utilities</a>&nbsp;&nbsp;
  </div>
  
  </div>

    </div>
  </div>
</div>
<div >
  <div >
    
  <div class="block">

  
    

      
<section data-history-node-id="5586" role="article" about="/sysadmin/get-started-vi-editor" typeof="schema:Article" id="node--article--5586" class="section my-5 py-5 bg-light-gray authors-bio authors-bio--article">
  <div class="container">
          <div class="row">
        <div class="col-md-2 text-center">
                      
<img alt="Author’s photo" data-affiliation="Red Hat" src="/sysadmin/sites/default/files/styles/user_picture_square/public/pictures/2021-06/sethKenlon-headshot.jpg?itok=L4lRrrIw" width="240" height="240" loading="lazy" typeof="foaf:Image" class="rounded-circle img-fluid" />


          
        </div>
        <div class="col-md-10 col-lg-8">
          <h2 class="font-weight-light text-center text-md-left">
                          Seth Kenlon
                      </h2>
          <div>
                          <p>
                Seth Kenlon is a UNIX geek and free software enthusiast.
                                  <a href="/sysadmin/users/skenlon" class="author-more-link">More about me</a>
                              </p>
                      </div>
        </div>
      </div>
      </div>
</section>



  
  </div>

  <div class="block">

  
    

      

  
  </div>

  </div>
</div>
<div >
  <div >
    

  <div class="block block--cta cta cta--red-on-black cta-- my-5 p-3 text-center">

  
    

    <div class="d-md-flex justify-content-around align-items-center flex-wrap">
    <div class="cta__content my-2">
      
            <div class="cta__field-content p-2"><h4>On Demand: Red Hat Summit 2021 Virtual Experience</h4>

<p>Relive our April event with demos, keynotes, and technical sessions from<br />
experts, all available on demand.</p>
</div>
      
    </div>
        <div class="cta__link my-2">
      <a
        href="https://www.redhat.com/en/summit?intcmp=7013a0000026RhqAAE"
        target="_blank"
        class="btn btn-lg btn-danger font-weight-bold">
        Watch Now
      </a>
    </div>
      </div>
  
  </div>

  </div>
</div>
<div  class="section">
  <div class="container">
    <div >
      
  <div class="views-element-container block">

  
    

      <div><div class="js-view-dom-id-86fcaee96c24b266cdecd2402ad608ad4623407aa900a6784b942ec7e076bb2d">
  
  
  

  
  
  

    <h2>Related Content</h2>
                        <div class="card-deck my-4">
                        <article data-history-node-id="5561" role="article" about="/sysadmin/record-terminal-script-scriptreplay" typeof="schema:Article" id="node--article--5561" class="card card--article node node--promoted">
      <div class="card-img-top">
            <div class="article__field-media"><div>
  
  
  <div data-blazy="" class="blazy blazy--field blazy--field-media-image blazy--field-media-image--card image__field-media-image">
    <div class="field__label font-weight-bold visually-hidden">
      Image    </div>
                  <div class="field__item">



                  <div class="media media--blazy media--bundle--image media--loading is-b-loading media--responsive media--image">  
<img class="media__image media__element b-lazy b-responsive img-fluid" data-src="/sysadmin/sites/default/files/styles/card/public/2022-01/record-terminal-script.jpg?itok=KQIAz-kL" srcset="" data-srcset="/sysadmin/sites/default/files/styles/card/public/2022-01/record-terminal-script.jpg?itok=KQIAz-kL 1x" src="data:image/svg+xml;charset=utf-8,%3Csvg%20xmlns%3D&#039;http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg&#039;%20viewBox%3D&#039;0%200%201000%20600&#039;%2F%3E" alt="Laptop with code, pen, notebook" typeof="foaf:Image" loading="lazy" />

        </div>
        
  
</div>
              </div>

</div>
</div>
      </div>
    <div class="card-body">
    <div class="h4 card-title"><a href="/sysadmin/record-terminal-script-scriptreplay"><span property="schema:name">Record your terminal with script and scriptreplay</span>
</a></div>
    <div class="card-text">
            <div property="schema:text" class="clearfix article__body">Creating documentation? Make an instant, editable video of your terminal to demo a process with these Linux commands.</div>
      </div>
  </div>
  <div class="card-footer">
    <div class="article-date">
      <span class="label">Posted:</span>
      January 18, 2022
    </div>
    <div class="article-authors">
              <span class="label">Author:</span>
                    <a href="/sysadmin/users/skenlon" class="article-author article-author--primary">Seth Kenlon<span class="author-affiliate"> (Red Hat)</span></a>          </div>
  </div>
</article>


                            <article data-history-node-id="5536" role="article" about="/sysadmin/linux-file-management-commands" typeof="schema:Article" id="node--article--5536" class="card card--article node node--promoted">
      <div class="card-img-top">
            <div class="article__field-media"><div>
  
  
  <div data-blazy="" class="blazy blazy--field blazy--field-media-image blazy--field-media-image--card image__field-media-image">
    <div class="field__label font-weight-bold visually-hidden">
      Image    </div>
                  <div class="field__item">



                  <div class="media media--blazy media--bundle--image media--loading is-b-loading media--responsive media--image">  
<img class="media__image media__element b-lazy b-responsive img-fluid" data-src="/sysadmin/sites/default/files/styles/card/public/2022-01/laptop-navigation_0.jpg?itok=1EMud8hg" srcset="" data-srcset="/sysadmin/sites/default/files/styles/card/public/2022-01/laptop-navigation_0.jpg?itok=1EMud8hg 1x" src="data:image/svg+xml;charset=utf-8,%3Csvg%20xmlns%3D&#039;http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg&#039;%20viewBox%3D&#039;0%200%201000%20600&#039;%2F%3E" alt="Laptop displaying text saying &quot;this is where you are&quot;" typeof="foaf:Image" loading="lazy" />

        </div>
        
  
</div>
              </div>

</div>
</div>
      </div>
    <div class="card-body">
    <div class="h4 card-title"><a href="/sysadmin/linux-file-management-commands"><span property="schema:name">8 fundamental Linux file-management commands for new users</span>
</a></div>
    <div class="card-text">
            <div property="schema:text" class="clearfix article__body">Learn how to create, copy, move, rename, and delete files and directories from the Linux command line.</div>
      </div>
  </div>
  <div class="card-footer">
    <div class="article-date">
      <span class="label">Posted:</span>
      January 20, 2022
    </div>
    <div class="article-authors">
              <span class="label">Author:</span>
                    <a href="/sysadmin/users/dgarn" class="article-author article-author--primary">Damon Garn<span class="author-affiliate"> (Red Hat)</span></a>          </div>
  </div>
</article>


                            <article data-history-node-id="5531" role="article" about="/sysadmin/Linux-file-navigation-commands" typeof="schema:Article" id="node--article--5531" class="card card--article node node--promoted">
      <div class="card-img-top">
            <div class="article__field-media"><div>
  
  
  <div data-blazy="" class="blazy blazy--field blazy--field-media-image blazy--field-media-image--card image__field-media-image">
    <div class="field__label font-weight-bold visually-hidden">
      Image    </div>
                  <div class="field__item">



                  <div class="media media--blazy media--bundle--image media--loading is-b-loading media--responsive media--image">  
<img class="media__image media__element b-lazy b-responsive img-fluid" data-src="/sysadmin/sites/default/files/styles/card/public/2020-12/process-laptop-sticky-note-notepad-phone.jpg?itok=NIu89faO" srcset="" data-srcset="/sysadmin/sites/default/files/styles/card/public/2020-12/process-laptop-sticky-note-notepad-phone.jpg?itok=NIu89faO 1x" src="data:image/svg+xml;charset=utf-8,%3Csvg%20xmlns%3D&#039;http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg&#039;%20viewBox%3D&#039;0%200%201000%20600&#039;%2F%3E" alt="Laptop with sticky note, phone, notepad, and coffee" typeof="foaf:Image" loading="lazy" />

        </div>
        
  
</div>
              </div>

</div>
</div>
      </div>
    <div class="card-body">
    <div class="h4 card-title"><a href="/sysadmin/Linux-file-navigation-commands"><span property="schema:name">8 essential Linux file navigation commands for new users</span>
</a></div>
    <div class="card-text">
            <div property="schema:text" class="clearfix article__body">It's straightforward to get around your Linux system if you know these basic commands.</div>
      </div>
  </div>
  <div class="card-footer">
    <div class="article-date">
      <span class="label">Posted:</span>
      January 19, 2022
    </div>
    <div class="article-authors">
              <span class="label">Author:</span>
                    <a href="/sysadmin/users/dgarn" class="article-author article-author--primary">Damon Garn<span class="author-affiliate"> (Red Hat)</span></a>          </div>
  </div>
</article>


                              </div>
            
    

  
  

  
  
</div>
</div>

  
  </div>

    </div>
  </div>
</div>
<div  class="section my-5 pb-5 narrow">
  <div class="container">
    <div >
      
    </div>
  </div>
</div>
<div  class="section my-5 pb-5 ">
  <div class="container">
    <div >
      

  <div class="block block--cta cta cta--red-on-black cta-- my-5 p-3 text-center">

  
    

    <div class="d-md-flex justify-content-around align-items-center flex-wrap">
    <div class="cta__content my-2">
      
            <div class="cta__field-content p-2"><p class="h4 mb-4 mt-3 font-weight-bold">OUR BEST CONTENT, DELIVERED TO YOUR INBOX</p>

<p><iframe title="Subscribe to our newsletter" aria-label="Embedded form to subscribe to our email newsletter" frameborder="0" height="50" scrolling="no" src="/sysadmin/eloqua-embedded-subscribe.html?offer_id=701f20000012gE7AAI" style="max-width:670px;margin:0 auto;" width="100%"></iframe></p>
</div>
      
    </div>
      </div>
  
  </div>

    </div>
  </div>
</div>

  </article>

  
  </div>


              </div>
        </main>

            <footer>
              <div class="page__colophon bg-dark-gray py-4 bg-dark-gray">
          <div class="container">
              
  <div class="block block--basic block--sysadmin-colophon-disclaimer">

  
    

      
            <div class="basic__body"><p>The opinions expressed on this website are those of each author, not of the author's employer or of Red Hat. The content published on this site are community contributions and are for informational purpose only AND ARE NOT, AND ARE NOT INTENDED TO BE, RED HAT DOCUMENTATION, SUPPORT, OR ADVICE.</p>

<p>Red Hat and the Red Hat logo are trademarks of Red Hat, Inc., registered in the United States and other countries.</p>
</div>
      
  
  </div>


          </div>
        </div>
                    <div class="page__footer bg-dark py-3">
        <div class="container">
          <div class="d-sm-flex justify-content-between align-items-center">
              

  
    

    
  <a href="https://www.redhat.com/" class="navbar-brand mr-0 mr-lg-auto mb-3 mb-sm-0">
            <img src="/sysadmin/themes/custom/sysadmin/logo.svg" width="135" height="31" class="d-inline-block align-top" alt="Red Hat logo" />

        
  </a>



  <div class="block block--basic block--copyright my-0 mx-sm-3 mb-1 mb-sm-0">

  
    

      
            <div class="basic__body"><p>Copyright ©2022 Red Hat, Inc.</p>
</div>
      
  
  </div>

  <div class="block block--sysadmin-footer my-0 mb-1 mb-sm-0">

  
    

      
  


  <ul class="nav d-flex d-sm-block d-md-flex justify-content-center align-items-center">
                                          <li class="nav-item  ">
                      <a href="https://www.redhat.com/en/about/privacy-policy" class="nav-link">Privacy Policy</a>
                  </li>
                                      <li class="nav-item  ">
                      <a href="https://www.redhat.com/en/about/terms-use" class="nav-link">Terms of Use</a>
                  </li>
                                      <li class="nav-item  ">
                      <a href="https://www.redhat.com/en/about/all-policies-guidelines" class="nav-link">All policies and guidelines</a>
                  </li>
            </ul>


  
  </div>

  <div class="block block--basic block--footerredhatsummit">

  
    

      
            <div class="basic__body"><div style="margin-left: 1rem"><a href="https://www.redhat.com/en/summit?intcmp=7013a0000026RhqAAE" target="_blank"><img alt="Red Hat Summit" src="https://www.redhat.com/cms/managed-files/Logo-Red_Hat-Summit-A-Standard-RGB-02_0.svg" width="72px" /></a></div>
</div>
      
  
  </div>

  <div class="block block--sharelinks">

  
    

      <div class="a2a_kit a2a_kit_size_32 a2a_floating_style a2a_vertical_style" data-a2a-url="https://www.redhat.com/sysadmin/get-started-vi-editor">
  <a class="a2a_button_twitter"></a>
  <a class="a2a_button_facebook"></a>
  <a class="a2a_button_linkedin"></a>
  <a class="a2a_button_reddit"></a>
  <a class="a2a_button_email"></a>
</div>
<div class="a2a_kit a2a_kit_size_32 a2a_floating_style a2a_default_style">
  <a class="a2a_button_twitter"></a>
  <a class="a2a_button_facebook"></a>
  <a class="a2a_button_linkedin"></a>
  <a class="a2a_button_reddit"></a>
  <a class="a2a_button_email"></a>
</div>

<script>
  var a2a_config = a2a_config || {};
  a2a_config.templates = a2a_config.templates || {};
  a2a_config.templates.twitter = {
    text: "How to get started with the Vi editor https://red.ht/3AvsI2v via #EnableSysadmin",
  };
    a2a_config.templates.facebook = {
    hashtag: "#EnableSysadmin",
  };
  </script>

  
  </div>


  <div class="block block--cta block--ctasubscribesidebar cta cta--blue-on-white cta-- my-5 p-3 text-center">

  
    

    <div class="d-md-flex justify-content-around align-items-center flex-wrap">
    <div class="cta__content my-2">
      
            <div class="cta__field-content p-2"><div class="subscribe-sidebar">
<div class="target-band-never-show-button">x</div>

<h4>Subscribe now</h4>

<p class="eloqua-email-capture-text">Get the highlights in your inbox every week.</p>

<p><iframe aria-label="Embedded form to subscribe to our email newsletter" frameborder="0" height="50" scrolling="no" src="/sysadmin/eloqua-embedded-email-capture-block.html?offer_id=701f20000012gE7AAI" style="max-width:670px;margin:0 auto;" title="Subscribe to our newsletter" width="100%"></iframe></p>
</div>
</div>
      
    </div>
      </div>
  
  </div>


          </div>
        </div>
            </footer>
      </div>

  </div>


<script type="application/json" data-drupal-selector="drupal-settings-json">{"path":{"baseUrl":"\/sysadmin\/","scriptPath":null,"pathPrefix":"","currentPath":"node\/5586","currentPathIsAdmin":false,"isFront":false,"currentLanguage":"en"},"pluralDelimiter":"\u0003","suppressDeprecationErrors":true,"ckeditorheight":{"offset":1,"line_height":1.5,"unit":"em","disable_autogrow":null},"colorbox":{"opacity":"0.85","current":"{current} of {total}","previous":"\u00ab Prev","next":"Next \u00bb","close":"Close","maxWidth":"98%","maxHeight":"98%","fixed":true,"mobiledetect":true,"mobiledevicewidth":"480px"},"blazy":{"loadInvisible":false,"offset":100,"saveViewportOffsetDelay":50,"validateDelay":25},"blazyIo":{"enabled":false,"disconnect":false,"rootMargin":"0px","threshold":[0]},"user":{"uid":0,"permissionsHash":"51f347f394db8c9bda75fb2a6f2d406a82353e6cfb9faf5ace3100b98d716870"}}</script>
<script src="/sysadmin/sites/default/files/js/js_qIDgH_1Ntr3oybBWS5Dii3UJ8C3X9Nh-0RbMnncIcGE.js"></script>

  <script type="text/javascript">
    if (("undefined" !== typeof _satellite) && ("function" === typeof _satellite.pageBottom)) {
      _satellite.pageBottom();
    }
  </script>
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam-cell.nr-data.net","licenseKey":"a03a21ae8a","applicationID":"1020017418","transactionName":"ZlNTbUBQDxZUWxJRVl8ZcFpGWA4LGnwUTUlQWm1XXVUEOXZXCExLXlpdXEBtLwpRXTBRXEZ1XldGQw4JWV0UFQdHX1RO","queueTime":0,"applicationTime":641,"atts":"ShRQGwhKHBg=","errorBeacon":"bam-cell.nr-data.net","agent":""}</script><script type="text/javascript"  src="/tJyrYCt9A1/n2zQSVzeTW/1ba7p2cG/NA9f/PTVkDy/szDAM"></script></body>
</html>
