<!DOCTYPE html>
<html lang="en" dir="ltr" prefix="content: http://purl.org/rss/1.0/modules/content/  dc: http://purl.org/dc/terms/  foaf: http://xmlns.com/foaf/0.1/  og: http://ogp.me/ns#  rdfs: http://www.w3.org/2000/01/rdf-schema#  schema: http://schema.org/  sioc: http://rdfs.org/sioc/ns#  sioct: http://rdfs.org/sioc/types#  skos: http://www.w3.org/2004/02/skos/core#  xsd: http://www.w3.org/2001/XMLSchema# ">
<head>
<script id="dpal" src="https://www.redhat.com/ma/dpal.js"></script>
<meta charset="utf-8" /><script type="text/javascript">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</script>
<link rel="canonical" href="https://www.redhat.com/sysadmin/openstack-ceph-storage" />
<meta property="og:site_name" content="Enable Sysadmin" />
<meta name="twitter:card" content="photo" />
<meta name="dcterms.title" content="How OpenStack uses Ceph for storage" />
<meta name="twitter:title" content="How OpenStack uses Ceph for storage" />
<meta name="dcterms.creator" content="Amy Marrich" />
<meta name="description" content="You may know that OpenStack can use Ceph as back-end storage, but do you know how it works?" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.redhat.com/sysadmin/openstack-ceph-storage" />
<meta name="twitter:site:id" content="14627400" />
<meta property="og:title" content="How OpenStack uses Ceph for storage" />
<meta name="twitter:creator" content="@spotzz_" />
<meta name="dcterms.publisher" content="Red Hat, Inc." />
<meta name="twitter:url" content="https://www.redhat.com/sysadmin/openstack-ceph-storage" />
<meta name="twitter:image" content="https://www.redhat.com/sysadmin/sites/default/files/styles/full/public/2021-08/lockers_3.jpg?itok=x18aUXJP" />
<meta name="twitter:image:width" content="600" />
<meta name="twitter:image:height" content="1000" />
<meta name="twitter:image:alt" content="Red Hat, Inc." />
<meta property="og:image" content="https://www.redhat.com/sysadmin/sites/default/files/styles/google_discover/public/2021-08/lockers_3.jpg?itok=A9On1KIz" />
<meta property="og:image:secure_url" content="https://www.redhat.com/sysadmin/sites/default/files/styles/google_discover/public/2021-08/lockers_3.jpg?itok=A9On1KIz" />
<meta name="dcterms.language" content="en" />
<meta property="og:image:type" content="image/jpeg" />
<meta property="og:video:width" content="600" />
<meta property="og:image:width" content="1000" />
<meta property="og:image:height" content="675" />
<meta property="og:image:alt" content="https://www.redhat.com/sysadmin/sites/default/files/styles/google_discover/public/2021-08/lockers_3.jpg?itok=A9On1KIz" />
<meta property="og:updated_time" content="2021-08-23T12:41:09+0000" />
<meta property="og:street_address" content="100 East Davie Street" />
<meta property="og:locality" content="Raleigh" />
<meta property="og:region" content="NC" />
<meta property="og:postal_code" content="27601" />
<meta property="og:country_name" content="United States" />
<meta property="og:phone_number" content="+1 919 754 4950" />
<meta property="og:fax_number" content="+1 919 800 3804" />
<meta property="og:locale" content="en_US" />
<meta property="article:author" content="https://www.redhat.com/sysadmin/users/amy-marrich" />
<meta property="article:publisher" content="https://www.facebook.com/redhatinc" />
<meta property="article:section" content="Enable Sysadmin" />
<meta property="article:tag" content="Storage" />
<meta property="article:tag" content="OpenStack" />
<meta property="article:tag" content="Ceph" />
<meta property="article:tag" content="Infrastructure" />
<meta property="article:modified_time" content="2021-08-23T12:41:09+0000" />
<meta name="Generator" content="Drupal 8 (https://www.drupal.org)" />
<meta name="MobileOptimized" content="width" />
<meta name="HandheldFriendly" content="true" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<script type="application/ld+json">{
    "@context": "https://schema.org",
    "@graph": [
        {
            "@type": "TechArticle",
            "headline": "How OpenStack uses Ceph for storage",
            "name": "How OpenStack uses Ceph for storage",
            "about": [
                "Storage",
                "OpenStack",
                "Ceph",
                "Infrastructure"
            ],
            "description": "You may know that OpenStack can use Ceph as back-end storage, but do you know how it works?",
            "image": {
                "@type": "ImageObject",
                "url": "https://www.redhat.com/sysadmin/sites/default/files/styles/full/public/2021-08/lockers_3.jpg?itok=x18aUXJP",
                "width": "1000",
                "height": "600"
            },
            "dateModified": "2021-08-23T12:41:09+0000",
            "author": {
                "@type": "Person",
                "@id": "https://www.redhat.com/sysadmin/users/amy-marrich",
                "name": "Amy Marrich",
                "url": "https://www.redhat.com/sysadmin/users/amy-marrich",
                "sameAs": "https://twitter.com/spotzz_"
            },
            "publisher": {
                "@type": "Organization",
                "@id": "https://www.redhat.com/"
            },
            "mainEntityOfPage": "https://www.redhat.com/sysadmin/openstack-ceph-storage"
        },
        {
            "@type": "WebPage",
            "@id": "https://www.redhat.com/sysadmin/openstack-ceph-storage",
            "publisher": {
                "@type": "Organization",
                "@id": "https://www.redhat.com/"
            }
        },
        {
            "@type": "Person",
            "name": "Amy Marrich",
            "sameAs": "https://twitter.com/spotzz_",
            "image": {
                "@type": "ImageObject",
                "url": "https://www.redhat.com/sysadmin/sites/default/files/styles/user_picture_square/public/pictures/2019-09/Amy_Headshot.jpeg?itok=9n_1-S0Y",
                "width": "240",
                "height": "240"
            }
        },
        {
            "@type": "Corporation",
            "@id": "https://www.redhat.com/",
            "name": "Red Hat, Inc.",
            "url": "https://www.redhat.com/",
            "sameAs": [
                "https://en.wikipedia.org/wiki/Red_Hat",
                "http://www.linkedin.com/company/red-hat",
                "http://www.youtube.com/user/RedHatVideos",
                "https://www.facebook.com/redhatinc",
                "https://twitter.com/RedHat"
            ],
            "telephone": "+1 919 754 4950",
            "contactPoint": {
                "@type": "ContactPoint",
                "telephone": "+1-888-RED-HAT1",
                "availableLanguage": "English",
                "contactType": "sales",
                "faxnumber": "+1 919 800 3804"
            },
            "logo": {
                "@type": "ImageObject",
                "url": "https://www.redhat.com/sysadmin/themes/custom/sysadmin/assets/images/red-hat-logo.png",
                "width": "254",
                "height": "60"
            },
            "address": {
                "@type": "PostalAddress",
                "streetAddress": "100 East Davie Street",
                "addressLocality": "Raleigh",
                "addressRegion": "NC",
                "postalCode": "27601",
                "addressCountry": "United States"
            }
        },
        {
            "@type": "WebSite",
            "@id": "https://www.redhat.com/sysadmin/",
            "name": "Enable Sysadmin",
            "url": "https://www.redhat.com/sysadmin/",
            "publisher": {
                "@type": "Organization",
                "@id": "https://www.redhat.com/"
            }
        }
    ]
}</script>
<meta name="robots" content="max-image-preview:large" />
<link rel="shortcut icon" href="/sysadmin/themes/custom/sysadmin/favicon.ico" type="image/vnd.microsoft.icon" />
<link rel="revision" href="https://www.redhat.com/sysadmin/openstack-ceph-storage" />
<link rel="apple-touch-icon" sizes="180x180" href="/sysadmin/themes/custom/sysadmin/assets/favicon/apple-touch-icon.png">
<link rel="icon" type="image/png" sizes="32x32" href="/sysadmin/themes/custom/sysadmin/assets/favicon/favicon-32x32.png">
<link rel="icon" type="image/png" sizes="16x16" href="/sysadmin/themes/custom/sysadmin/assets/favicon/favicon-16x16.png">
<link rel="manifest" href="/sysadmin/themes/custom/sysadmin/assets/favicon/site.webmanifest">
<link rel="mask-icon" href="/sysadmin/themes/custom/sysadmin/assets/favicon/safari-pinned-tab.svg" color="#ee0000">
<meta name="msapplication-TileColor" content="#1a1a1a">
<meta name="theme-color" content="#ffffff">
<title>How OpenStack uses Ceph for storage | Enable Sysadmin</title>
<link rel="stylesheet" media="all" href="/sysadmin/core/themes/stable/css/system/components/ajax-progress.module.css?qx0wr4" />
<link rel="stylesheet" media="all" href="/sysadmin/core/themes/stable/css/system/components/align.module.css?qx0wr4" />
<link rel="stylesheet" media="all" href="/sysadmin/core/themes/stable/css/system/components/autocomplete-loading.module.css?qx0wr4" />
<link rel="stylesheet" media="all" href="/sysadmin/core/themes/stable/css/system/components/fieldgroup.module.css?qx0wr4" />
<link rel="stylesheet" media="all" href="/sysadmin/core/themes/stable/css/system/components/container-inline.module.css?qx0wr4" />
<link rel="stylesheet" media="all" href="/sysadmin/core/themes/stable/css/system/components/clearfix.module.css?qx0wr4" />
<link rel="stylesheet" media="all" href="/sysadmin/core/themes/stable/css/system/components/details.module.css?qx0wr4" />
<link rel="stylesheet" media="all" href="/sysadmin/core/themes/stable/css/system/components/hidden.module.css?qx0wr4" />
<link rel="stylesheet" media="all" href="/sysadmin/core/themes/stable/css/system/components/item-list.module.css?qx0wr4" />
<link rel="stylesheet" media="all" href="/sysadmin/core/themes/stable/css/system/components/js.module.css?qx0wr4" />
<link rel="stylesheet" media="all" href="/sysadmin/core/themes/stable/css/system/components/nowrap.module.css?qx0wr4" />
<link rel="stylesheet" media="all" href="/sysadmin/core/themes/stable/css/system/components/position-container.module.css?qx0wr4" />
<link rel="stylesheet" media="all" href="/sysadmin/core/themes/stable/css/system/components/progress.module.css?qx0wr4" />
<link rel="stylesheet" media="all" href="/sysadmin/core/themes/stable/css/system/components/reset-appearance.module.css?qx0wr4" />
<link rel="stylesheet" media="all" href="/sysadmin/core/themes/stable/css/system/components/resize.module.css?qx0wr4" />
<link rel="stylesheet" media="all" href="/sysadmin/core/themes/stable/css/system/components/sticky-header.module.css?qx0wr4" />
<link rel="stylesheet" media="all" href="/sysadmin/core/themes/stable/css/system/components/system-status-counter.css?qx0wr4" />
<link rel="stylesheet" media="all" href="/sysadmin/core/themes/stable/css/system/components/system-status-report-counters.css?qx0wr4" />
<link rel="stylesheet" media="all" href="/sysadmin/core/themes/stable/css/system/components/system-status-report-general-info.css?qx0wr4" />
<link rel="stylesheet" media="all" href="/sysadmin/core/themes/stable/css/system/components/tabledrag.module.css?qx0wr4" />
<link rel="stylesheet" media="all" href="/sysadmin/core/themes/stable/css/system/components/tablesort.module.css?qx0wr4" />
<link rel="stylesheet" media="all" href="/sysadmin/core/themes/stable/css/system/components/tree-child.module.css?qx0wr4" />
<link rel="stylesheet" media="all" href="/sysadmin/core/themes/stable/css/views/views.module.css?qx0wr4" />
<link rel="stylesheet" media="all" href="/sysadmin/modules/contrib/blazy/css/components/blazy.loading.css?qx0wr4" />
<link rel="stylesheet" media="all" href="/sysadmin/core/themes/stable/css/filter/filter.caption.css?qx0wr4" />
<link rel="stylesheet" media="all" href="/sysadmin/modules/contrib/entity_embed/css/entity_embed.filter.caption.css?qx0wr4" />
<link rel="stylesheet" media="all" href="/sysadmin/modules/contrib/colorbox/styles/default/colorbox_style.css?qx0wr4" />
<link rel="stylesheet" media="all" href="/sysadmin/themes/contrib/radix/assets/css/radix.style.css?qx0wr4" />
<link rel="stylesheet" media="all" href="/sysadmin/themes/custom/sysadmin/assets/css/sysadmin.style.css?qx0wr4" />
<link rel="stylesheet" media="all" href="/sysadmin/themes/custom/sysadmin/assets/css/share-links.css?qx0wr4" />
<link rel="stylesheet" media="all" href="/sysadmin/themes/custom/sysadmin/assets/js/stacktable/stacktable.css?qx0wr4" />
<link rel="stylesheet" media="all" href="/sysadmin/themes/custom/sysadmin/assets/css/listicle.css?qx0wr4" />
<link rel="stylesheet" media="all" href="/sysadmin/themes/custom/sysadmin/assets/css/cookie-banner.css?qx0wr4" />
<link rel="stylesheet" media="all" href="/sysadmin/themes/custom/sysadmin/assets/css/syntax-highlighting.css?qx0wr4" />
<link rel="stylesheet" media="all" href="/sysadmin/themes/custom/sysadmin/assets/css/highlightjs-github.css?qx0wr4" />


<!--[if lte IE 8]>
<script src="/sysadmin/core/assets/vendor/html5shiv/html5shiv.min.js?v=3.7.3"></script>
<![endif]-->
<script src="/sysadmin/libraries/blazy/blazy.js?v=1.x"></script>


</head>
<body>
<a href="#main-content" class="visually-hidden focusable">
Skip to main content
</a>

  <div class="dialog-off-canvas-main-canvas" data-off-canvas-main-canvas>
    

<div class="redhat-cookie-banner">
<section id="redhat-cookie-privacy-banner" class="redhat-cookie-banner-wrapper" style="display: block;">
  <div class="container my-3 pr-5">
    <p>We use cookies on our websites to deliver our online services. Details about how we use cookies and how you may disable them are set out in our <a href="http://www.redhat.com/en/about/privacy-policy#cookies">Privacy Statement</a>. By using this website you agree to our use of cookies.
    <span class="cookie-more">
    <a id="redhat-cookie-privacy-banner-close" href="javascript:void(0);" class="cookie-close">&times;</a>
    </span>
    </p>
  </div>
</section>
</div>

<div class="page d-flex flex-column">
  <div class="navbar navbar-expand-lg justify-content-between navbar-dark bg-dark">
    <div class="container">
                
  <div class="block block--sysadmin-navbar-branding">

  
    

    
  <a href="https://www.redhat.com/" class="navbar-brand ">
            <img src="/sysadmin/themes/custom/sysadmin/logo.svg" width="135" height="31" class="d-inline-block align-top" alt="Red Hat logo" />

        
  </a>


  </div>


      
      <div class="navbar-toggler-wrapper">
        <button class="navbar-toggler" type="button" data-toggle="collapse"  data-parent="#collapse-parent" data-target="#search-collapse" aria-controls="search-collapse" aria-expanded="false" aria-label="Toggle search">
          <svg class="icon-collapsed" width="30" height="30" viewBox="0 0 30 30" xmlns="http://www.w3.org/2000/svg"><line x1="18.95" y1="19.15" x2="25.25" y2="25.75"/><circle cx="13.25" cy="12.75" r="8.5"/></svg>
          <svg class="icon-expanded" width="30" height="30" viewBox="0 0 30 30" xmlns="http://www.w3.org/2000/svg"><line x1="7.25" y1="7.25" x2="22.75" y2="22.75"/><line x1="7.25" y1="22.75" x2="22.75" y2="7.25"/></svg>
          <span style="vertical-align: middle;">Search</span>
        </button>
        <button class="navbar-toggler" type="button" data-toggle="collapse" data-parent="#collapse-parent" data-target="#mobilenav-collapse" aria-controls="mobilenav-collapse" aria-expanded="false" aria-label="Toggle navigation">
          <svg class="icon-collapsed" width="30" height="30" viewBox="0 0 30 30" xmlns="http://www.w3.org/2000/svg"><path d="M4 7h22M4 15h22M4 23h22"/></svg>
          <svg class="icon-expanded" width="30" height="30" viewBox="0 0 30 30" xmlns="http://www.w3.org/2000/svg"><line x1="7.25" y1="7.25" x2="22.75" y2="22.75"/><line x1="7.25" y1="22.75" x2="22.75" y2="7.25"/></svg>
        </button>
      </div>
    </div>
  </div>

  <div id="collapse-parent">
    <div id="search-collapse" class="search-collapse collapse" data-parent="#collapse-parent">
      <div class="py-4 px-3">
        <form class="form-inline m-2" action="/sysadmin/search/node" accept-charset="UTF-8" method="get">
          <div class="input-group flex-fill">
            <input class="form-control" type="search" name="keys" id="search" value="" placeholder="Search this site…" aria-label="Search this site…">
            <div class="input-group-append">
              <button class="btn btn-secondary font-weight-bold" type="submit">Search</button>
            </div>
          </div>
        </form>
      </div>
    </div>

    <div id="mobilenav-collapse" class="mobilenav-collapse d-lg-none collapse" data-parent="#collapse-parent">
                
  <div class="block block--sysadmin-navbar-sitename sitename">

  
    

    
  <a href="/sysadmin/" class="navbar-brand sitename">
        Enable Sysadmin
  </a>

  <span class="d-none d-lg-inline ml-1 mr-3 h5 navbar-sitename-divider">&nbsp;</span>

  </div>

  <div class="block block--sysadmin-main-menu">

  
    

      
  


  <ul class="nav navbar-nav">
                                          <li class="nav-item  dropdown">
                      <a href="/sysadmin/" class="nav-link dropdown-toggle" data-toggle="dropdown" data-drupal-link-system-path="&lt;front&gt;">Articles</a>
                          <div class="dropdown-menu">
              <a href="/sysadmin/topics/automation" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/146">Automation</a>
              <a href="/sysadmin/topics/career" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/51">Career</a>
              <a href="/sysadmin/topics/containers" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/36"> Containers</a>
              <a href="/sysadmin/topics/sysadmin-culture" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/41">Culture</a>
              <a href="/sysadmin/topics/kubernetes" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/66">Kubernetes</a>
              <a href="/sysadmin/topics/linux" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/21">Linux</a>
              <a href="/sysadmin/topics/programming" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/71"> Programming</a>
              <a href="/sysadmin/topics/security" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/96">Security</a>
  </div>
                              </li>
                                      <li class="nav-item  dropdown">
                      <a href="/sysadmin/about" class="nav-link dropdown-toggle" data-toggle="dropdown" data-drupal-link-system-path="node/71">About</a>
                          <div class="dropdown-menu">
              <a href="/sysadmin/about" class="dropdown-item" data-drupal-link-system-path="node/71">Topics</a>
              <a href="/sysadmin/email" class="dropdown-item" data-drupal-link-system-path="node/376">Email newsletter</a>
              <a href="/sysadmin/join-community" class="dropdown-item" data-drupal-link-system-path="node/641">Join the community</a>
              <a href="/sysadmin/community-guidelines" class="dropdown-item" data-drupal-link-system-path="node/156">Community guidelines</a>
              <a href="/sysadmin/sudoers-program" class="dropdown-item" data-drupal-link-system-path="node/2106">Sudoers program</a>
              <a href="/sysadmin/meet-team" class="dropdown-item" data-drupal-link-system-path="node/2316">Meet the team</a>
              <a href="/sysadmin/faq" class="dropdown-item" data-drupal-link-system-path="node/1526">FAQs</a>
  </div>
                              </li>
                                      <li class="nav-item  ">
                      <a href="/sysadmin/welcome-enable-sysadmin" title="A Red Hat community publication for sysadmins, by sysadmins" class="nav-link">Welcome</a>
                  </li>
            </ul>


  
  </div>


      
              
          </div>
  </div>

  


<nav class="navbar navbar-expand-lg justify-content-between navbar-light  d-none d-lg-block text-dark bg-light border-bottom-light-gray">
      <div class="container">
  
      
  
  <button class="navbar-toggler" type="button" data-toggle="collapse" data-target=".navbar-collapse" aria-controls="navbar-collapse" aria-expanded="false" aria-label="Toggle navigation">
    <span class="navbar-toggler-icon"></span>
  </button>

  <div class="collapse navbar-collapse">
                  <div class="mr-auto d-flex navbar-desktop">
            
  <div class="block block--sysadmin-navbar-sitename sitename">

  
    

    
  <a href="/sysadmin/" class="navbar-brand sitename">
        Enable Sysadmin
  </a>

  <span class="d-none d-lg-inline ml-1 mr-3 h5 navbar-sitename-divider">&nbsp;</span>

  </div>

  <div class="block block--sysadmin-main-menu">

  
    

      
  


  <ul class="nav navbar-nav">
                                          <li class="nav-item  dropdown">
                      <a href="/sysadmin/" class="nav-link dropdown-toggle" data-toggle="dropdown" data-drupal-link-system-path="&lt;front&gt;">Articles</a>
                          <div class="dropdown-menu">
              <a href="/sysadmin/topics/automation" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/146">Automation</a>
              <a href="/sysadmin/topics/career" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/51">Career</a>
              <a href="/sysadmin/topics/containers" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/36"> Containers</a>
              <a href="/sysadmin/topics/sysadmin-culture" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/41">Culture</a>
              <a href="/sysadmin/topics/kubernetes" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/66">Kubernetes</a>
              <a href="/sysadmin/topics/linux" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/21">Linux</a>
              <a href="/sysadmin/topics/programming" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/71"> Programming</a>
              <a href="/sysadmin/topics/security" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/96">Security</a>
  </div>
                              </li>
                                      <li class="nav-item  dropdown">
                      <a href="/sysadmin/about" class="nav-link dropdown-toggle" data-toggle="dropdown" data-drupal-link-system-path="node/71">About</a>
                          <div class="dropdown-menu">
              <a href="/sysadmin/about" class="dropdown-item" data-drupal-link-system-path="node/71">Topics</a>
              <a href="/sysadmin/email" class="dropdown-item" data-drupal-link-system-path="node/376">Email newsletter</a>
              <a href="/sysadmin/join-community" class="dropdown-item" data-drupal-link-system-path="node/641">Join the community</a>
              <a href="/sysadmin/community-guidelines" class="dropdown-item" data-drupal-link-system-path="node/156">Community guidelines</a>
              <a href="/sysadmin/sudoers-program" class="dropdown-item" data-drupal-link-system-path="node/2106">Sudoers program</a>
              <a href="/sysadmin/meet-team" class="dropdown-item" data-drupal-link-system-path="node/2316">Meet the team</a>
              <a href="/sysadmin/faq" class="dropdown-item" data-drupal-link-system-path="node/1526">FAQs</a>
  </div>
                              </li>
                                      <li class="nav-item  ">
                      <a href="/sysadmin/welcome-enable-sysadmin" title="A Red Hat community publication for sysadmins, by sysadmins" class="nav-link">Welcome</a>
                  </li>
            </ul>


  
  </div>


        </div>
          
                  
      
      

<div class="dropdown show text-align-right">
    <a href="/sysadmin/subscribe" class="navbar-util navbar-util--rss" aria-label="Subscribe to our feed or newsletter blast">
    <svg width="22" height="23" viewBox="0 0 22 23" xmlns="http://www.w3.org/2000/svg"><title>Subscribe to our RSS feed or Email newsletter</title><path d="M0 4.23c9.79 0 17.75 8 17.75 17.84h4.23A22.05 22.05 0 0 0 0 0v4.23z M0 7.67v4.23c2.74 0 5.33 1.07 7.27 3.03a10.26 10.26 0 0 1 3 7.3h4.24c0-8.02-6.5-14.56-14.51-14.56M2.93 16.87a2.94 2.94 0 0 0 0 5.85 2.93 2.93 0 1 0 0-5.85" fill-rule="evenodd"/></svg>

    <span class="sr-only">Subscribe to our RSS feed or Email newsletter.</span>
  </a>

    <a id="dropdownSearchLink" href="/sysadmin/search/node" class="navbar-util navbar-util--search" role="button" aria-label="Search this site…" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false">
    <svg width="30" height="30" viewBox="0 0 30 30" xmlns="http://www.w3.org/2000/svg" style="fill:none;stroke-width:3;stroke:#000;stroke-linecap:round;"><line x1="18.95" y1="19.15" x2="25.25" y2="25.75"/><circle cx="13.25" cy="12.75" r="8.5"/></svg>

  </a>
  <div class="dropdown-menu dropdown-menu-right p-1 pt-2" aria-labelledby="dropdownSearchLink">
    <form class="form-inline m-2" action="/sysadmin/search/node" accept-charset="UTF-8" method="get">
      <div class="input-group flex-fill">
        <input class="form-control" type="search" name="keys" id="search" value="" placeholder="Search this site…" aria-label="Search this site…">
        <div class="input-group-append">
          <button class="btn btn-secondary font-weight-bold" type="submit">GO</button>
        </div>
      </div>
    </form>
  </div>
  </div>
      </div>

      </div>
  </nav>

  <main class="pb-5">
                  <header class="page__header">
          <div class="container">
              <div data-drupal-messages-fallback class="hidden"></div>


          </div>
        </header>
          
    <a name="main-content" tabindex="-1"></a>

                  <div class="page__content">
                  
  <div class="block block--sysadmin-content">

  
    

      <article data-history-node-id="4976" role="article" about="/sysadmin/openstack-ceph-storage" typeof="schema:Article" id="node--article--4976" class="full full--article node node--promoted">
  
    <span property="schema:name" content="How OpenStack uses Ceph for storage" class="hidden"></span>
  <span property="schema:interactionCount" content="UserComments:0" class="hidden"></span>


      <div  class="section my-5 narrow">
  <div class="container">
    <div >
      
  <div class="block">

  
    

      <span property="schema:name"><h1 class="font-weight-bold">How OpenStack uses Ceph for storage</h1>
</span>

  
  </div>

  <div class="block">

  
    

      
            <div class="article__field-subhead">You may know that OpenStack can use Ceph as back-end storage, but do you know how it works?</div>
      
  
  </div>

    </div>
  </div>
</div>
<div  class="section pb-5 narrow">
  <div class="container">
    <div >
      
  <div class="block">

  
    

      <p class="article-byline">
  <span class="article-date">
    <span class="label">Posted:</span>
    August 23, 2021
  </span>
    <span aria-hidden="true">|</span>
  <span class="article-authors">
    <strong class="sr-only">by</strong>
          <a href="/sysadmin/users/amy-marrich" class="article-author article-author--primary">Amy Marrich<span class="author-affiliate"> (Red Hat, Sudoer)</span></a>      </span>
  </p>

  
  </div>

  <div class="block">

  
    

      
            <div class="article__field-media"><figure>
  
  
  <div class="blazy image__field-media-image" data-blazy="">
    <div class="field__label font-weight-bold visually-hidden">
      Image    </div>
                  <div class="field__item">



                    <div class="media media--blazy media--loading media--image">
      
<img class="b-lazy media__image media__element img-fluid" data-src="/sysadmin/sites/default/files/styles/full/public/2021-08/lockers_3.jpg?itok=x18aUXJP" height="600" width="1000" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" typeof="foaf:Image" loading="lazy" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" alt="Lockers for storage" />

        
      
    </div>
        
  
</div>
              </div>

  <figcaption>
    
            <div class="image__field-media-description"><p>Photo by <a href="https://www.pexels.com/@paulita?utm_content=attributionCopyText&amp;utm_medium=referral&amp;utm_source=pexels" target="_blank">Paula</a> from <a href="https://www.pexels.com/photo/grey-metal-lockers-is-open-170453/?utm_content=attributionCopyText&amp;utm_medium=referral&amp;utm_source=pexels" target="_blank">Pexels</a></p>
</div>
      
  </figcaption>
</figure>
</div>
      
  
  </div>

  <div class="block">

  
    

      
            <div property="schema:text" class="clearfix article__body"><p>Ceph is often deployed with OpenStack as a back-end storage method. These two open source projects work together to make a well-integrated and robust solution for infrastructure.</p>

<div data-embed-button="resource_list" data-entity-embed-display="view_mode:resource_list.link" data-entity-type="resource_list" data-entity-uuid="fd0687fc-6b5d-42ec-b562-590819b2f60a" data-langcode="en" class="align-right embedded-entity embedded-entity--resources embedded-entity--resources--link"><aside id="resource-list-in-the-cloud" class="eck-entity mt-2 py-3 pr-3 border-top border-danger"><h2 class="h4">
      In the cloud
  </h2>

<ul class="pl-3 mb-0"><li class="my-2"><a href="https://www.redhat.com/en/topics/cloud?intcmp=7013a000002vzpLAAQ">Understanding cloud computing</a></li>
      <li class="my-2"><a href="https://www.redhat.com/en/services/training/cl010-red-hat-openstack-technical-overview?intcmp=7013a000002vzpLAAQ">Free course: Red Hat OpenStack technical overview</a></li>
      <li class="my-2"><a href="https://www.redhat.com/en/engage/hybrid-cloud-strategies-20180403?intcmp=7013a000002vzpLAAQ">Free eBook: Hybrid cloud strategy for dummies</a></li>
  </ul></aside></div>
<p><a href="https://www.openstack.org/" target="_blank">OpenStack</a> is an open source Infrastructure-as-a-Service (IaaS) platform that can provide public and private clouds in your datacenter or on the edge. OpenStack contains multiple projects; the most commonly installed are Nova (compute), Keystone (identity), Neutron (networking), Glance (image), Cinder (block storage), and Swift (object storage).</p>

<p><a href="https://ceph.io/" target="_blank">Ceph</a> is an open source project that provides software-defined storage with unified (object, block, and file) storage. You can scale out this storage, and it is self-healing with the ability to anticipate failures.</p>

<p><em><strong>[ Get an overview of <a href="https://www.redhat.com/sysadmin/openstacks-history-community-and-7-its-core-projects" target="_blank">OpenStack's history, community, and 7 of its core projects</a>. ]</strong></em></p>

<h2>How Ceph and OpenStack work together</h2>

<p>Ceph Storage Clusters, which are based on Reliable Autonomic Distributed Object Store (RADOS), can provide back-end storage for OpenStack. This image shows how they work together.</p>


<figure class="figure align-center"><div data-embed-button="media_entity_embed" data-entity-embed-display="view_mode:media.embed_medium" data-entity-type="media" data-entity-uuid="ef90b35f-44b4-40f3-90cc-b3068c18a8fd" data-langcode="en" class="embedded-entity embedded-entity--image embedded-entity--image--embed-medium"><article><div class="blazy image__field-media-image" data-blazy="">
    <div class="field__label font-weight-bold visually-hidden">
      Image    </div>
                  <div class="field__item">



                    <div class="media media--blazy media--loading media--image">
      
<img class="b-lazy media__image media__element img-fluid" data-src="/sysadmin/sites/default/files/styles/embed_medium/public/2021-08/Ceph-storage-cluster-%28RADOS%29.png?itok=fUNXH04c" height="810" width="1080" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" typeof="foaf:Image" loading="lazy" alt="Ceph Storage Cluster for OpenStack" /></div>
        
  
</div>
              </div>

  </article></div>
<figcaption class="figure-caption">(Amy Marrich, CC BY-SA 4.0)</figcaption></figure><p>OpenStack's <a href="https://docs.openstack.org/keystone/latest/" target="_blank">Keystone</a> and <a href="https://docs.openstack.org/swift/latest/" target="_blank">Swift</a> take advantage of Ceph by using the Ceph Object Gateway (a RADOS Rest Gateway, or RGW). This integration with Keystone allows the gateway to accept Keystone tokens for validation. This same gateway enables Swift to store its objects within Ceph.</p>

<div data-embed-button="resource_list" data-entity-embed-display="view_mode:resource_list.link" data-entity-type="resource_list" data-entity-uuid="78d8f7ba-4831-497f-b66d-ec0bb740244e" data-langcode="en" class="align-right embedded-entity embedded-entity--resources embedded-entity--resources--link"><aside id="resource-list-linux-containers" class="eck-entity mt-2 py-3 pr-3 border-top border-danger"><h2 class="h4">
      Linux containers
  </h2>

<ul class="pl-3 mb-0"><li class="my-2"><a href="https://www.redhat.com/en/services/training/do080-deploying-containerized-applications-technical-overview?intcmp=701f20000012ngPAAQ">Free course: Deploying containerized applications</a></li>
      <li class="my-2"><a href="https://www.redhat.com/en/technologies/cloud-computing/openshift/try-it?intcmp=701f20000012ngPAAQ">Download now: Red Hat OpenShift trial</a></li>
      <li class="my-2"><a href="https://www.kubernetesbyexample.com/?intcmp=701f20000012ngPAAQ">Learn Kubernetes by example</a></li>
  </ul></aside></div>
<p>On the other hand, <a href="https://docs.openstack.org/cinder/latest/" target="_blank">Cinder</a>, <a href="https://docs.openstack.org/glance/latest/" target="_blank">Glance</a>, and <a href="https://docs.openstack.org/nova/latest/" target="_blank">Nova</a> utilize Ceph block devices (RADOS block devices, or RBDs) for their back-end storage needs. Glance stores its images within Ceph, building virtual machines (VMs). Block storage devices created within Cinder for these VMs are provisioned within Ceph. And finally, Nova stores the virtual disk images of the running VMs within Ceph.</p>

<p>Open source makes it possible for these projects to integrate smoothly now and to maintain and improve their integration over time.</p>

<p><strong><em>[ Download now: <a href="https://www.redhat.com/en/engage/system-administrator-guide-s-202107300146?intcmp=701f20000012ngPAAQ" target="_blank">A system administrator's guide to IT automation</a>. ]</em></strong></p>

<h3>Helpful resources</h3>

<p>The following resources are a good place to start to learn more about Ceph and OpenStack:</p>

<ul><li><a href="https://www.rdoproject.org/use/" target="_blank">Getting started with RDO</a> (community-supported version of OpenStack)</li>
	<li><a href="https://twitter.com/RDOcommunity/" target="_blank">RDO Twitter</a></li>
	<li><a href="https://rdo.wpengine.com/" target="_blank">RDO community blog</a></li>
	<li><a href="https://www.slideshare.net/alohamora/ceph-and-openstack-in-a-nutshell" target="_blank">Ceph and OpenStack in a nutshell</a></li>
	<li><a href="https://docs.openstack.org/kolla-ansible/latest/reference/storage/external-ceph-guide.html" target="_blank">Storing containers with Kolla and Ceph</a></li>
	<li><a href="https://docs.openstack.org/openstack-helm/latest/install/developer/deploy-with-ceph.html" target="_blank">Deploy OpenStack and Ceph on Kubernetes with Helm Charts</a></li>
</ul></div>
      
  
  </div>

  <div class="block">

  
    

      <div class="views-element-container"><div class="listicle-view js-view-dom-id-a602055be63caf7a39a7ed59f9b8420143060e0baf47317f43f59e9cfd18487f">
  
  
  

  
  
  

    <h3>Check out these related articles on Enable Sysadmin</h3>
    <div class="listicle-row"><div class="views-field views-field-field-listicle"><div class="field-content"><article data-history-node-id="3781" role="article" about="/sysadmin/tripleo-standalone-system" typeof="schema:Article" id="node--article--3781" class="listicle listicle--article node node--promoted">
  <div class="row align-items-center">
    <div class="col-md-6 listicle-image">
            <div class="article__field-media"><article>
  
      
  <div class="blazy image__field-media-image" data-blazy="">
    <div class="field__label font-weight-bold visually-hidden">
      Image    </div>
                  <div class="field__item">



                    <div class="media media--blazy media--loading media--image">
      
<img class="b-lazy media__image media__element img-fluid" data-src="/sysadmin/sites/default/files/styles/card/public/2021-01/TripleO%20Deployment.jpg?itok=txdr6_Ns" height="420" width="700" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" typeof="foaf:Image" loading="lazy" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" alt="Deploying a virtual TripleO standalone system" />

        
      
    </div>
        
  
</div>
              </div>

  </article>
</div>
      </div>
    <div class="col-md-6 listicle-body">
      <div class="h4 listicle-title pt-4 pt-md-0"><a href="/sysadmin/tripleo-standalone-system"><span property="schema:name">Deploying a virtual TripleO standalone OpenStack system</span>
</a></div>
      <div class="listicle-text font-weight-light py-2">
        
            <div property="schema:text" class="clearfix article__body">A walk-through on how to deploy a virtualized TripleO standalone system, including creating the components need to launch and connect to a VM. Also included is how to cleanup the deployment.</div>
      
      </div>

      <div class="listicle-footer">
        <div class="article-date">
          <span class="label">Posted:</span>
          January 13, 2021
        </div>
        <div class="article-authors">
                      <span class="label">Author:</span>
                                <a href="/sysadmin/users/amy-marrich" class="article-author article-author--primary">Amy Marrich<span class="author-affiliate"> (Red Hat, Sudoer)</span></a>                  </div>
      </div>
    </div>
  </div>
</article>
<article data-history-node-id="2631" role="article" about="/sysadmin/container-namespaces-nsenter" typeof="schema:Article" id="node--article--2631" class="listicle listicle--article node node--promoted">
  <div class="row align-items-center">
    <div class="col-md-6 listicle-image">
            <div class="article__field-media"><article>
  
      
  <div class="blazy image__field-media-image" data-blazy="">
    <div class="field__label font-weight-bold visually-hidden">
      Image    </div>
                  <div class="field__item">



                    <div class="media media--blazy media--loading media--image">
      
<img class="b-lazy media__image media__element img-fluid" data-src="/sysadmin/sites/default/files/styles/card/public/2020-06/luggage-stacked.jpg?itok=eHVRixgv" height="420" width="700" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" typeof="foaf:Image" loading="lazy" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" alt="Stacked luggage container" />

        
      
    </div>
        
  
</div>
              </div>

  </article>
</div>
      </div>
    <div class="col-md-6 listicle-body">
      <div class="h4 listicle-title pt-4 pt-md-0"><a href="/sysadmin/container-namespaces-nsenter"><span property="schema:name">Manage containers in namespaces by using nsenter</span>
</a></div>
      <div class="listicle-text font-weight-light py-2">
        
            <div property="schema:text" class="clearfix article__body">Isolate Linux container resources by using namespaces. Manage your namespaces by using nsenter.</div>
      
      </div>

      <div class="listicle-footer">
        <div class="article-date">
          <span class="label">Posted:</span>
          July 8, 2020
        </div>
        <div class="article-authors">
                      <span class="label">Author:</span>
                                <a href="/sysadmin/users/sreejith" class="article-author article-author--primary">Sreejith Anujan<span class="author-affiliate"> (Red Hat)</span></a>                  </div>
      </div>
    </div>
  </div>
</article>
<article data-history-node-id="4256" role="article" about="/sysadmin/openstacks-history-community-and-7-its-core-projects" typeof="schema:Article" id="node--article--4256" class="listicle listicle--article node node--promoted">
  <div class="row align-items-center">
    <div class="col-md-6 listicle-image">
            <div class="article__field-media"><article>
  
      
  <div class="blazy image__field-media-image" data-blazy="">
    <div class="field__label font-weight-bold visually-hidden">
      Image    </div>
                  <div class="field__item">



                    <div class="media media--blazy media--loading media--image">
      
<img class="b-lazy media__image media__element img-fluid" data-src="/sysadmin/sites/default/files/styles/card/public/2021-03/Stack.jpg?itok=JgIryGr-" height="420" width="700" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" typeof="foaf:Image" loading="lazy" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" alt="Openstack&amp;#039;s history, community, and 7 of its core projects" />

        
      
    </div>
        
  
</div>
              </div>

  </article>
</div>
      </div>
    <div class="col-md-6 listicle-body">
      <div class="h4 listicle-title pt-4 pt-md-0"><a href="/sysadmin/openstacks-history-community-and-7-its-core-projects"><span property="schema:name">OpenStack&#039;s history, community, and 7 of its core projects</span>
</a></div>
      <div class="listicle-text font-weight-light py-2">
        
            <div property="schema:text" class="clearfix article__body">A relatively high overview of what OpenStack is, how it came to be, and its most commonly installed services.</div>
      
      </div>

      <div class="listicle-footer">
        <div class="article-date">
          <span class="label">Posted:</span>
          April 13, 2021
        </div>
        <div class="article-authors">
                      <span class="label">Author:</span>
                                <a href="/sysadmin/users/amy-marrich" class="article-author article-author--primary">Amy Marrich<span class="author-affiliate"> (Red Hat, Sudoer)</span></a>                  </div>
      </div>
    </div>
  </div>
</article>
</div></div></div>

    

  
  

  
  
</div>
</div>

  
  </div>

  <div class="block">

  
    

      <div class="topics">
  <strong>Topics:</strong>&nbsp;&nbsp;
      <a href="/sysadmin/topics/storage" class="btn btn-primary btn-sm font-weight-bold">Storage</a>&nbsp;&nbsp;
      <a href="/sysadmin/topics/openstack" class="btn btn-primary btn-sm font-weight-bold">OpenStack</a>&nbsp;&nbsp;
      <a href="/sysadmin/topics/ceph" class="btn btn-primary btn-sm font-weight-bold">Ceph</a>&nbsp;&nbsp;
      <a href="/sysadmin/topics/infrastructure" class="btn btn-primary btn-sm font-weight-bold">Infrastructure</a>&nbsp;&nbsp;
  </div>
  
  </div>

    </div>
  </div>
</div>
<div >
  <div >
    
  <div class="block">

  
    

      
<section data-history-node-id="4976" role="article" about="/sysadmin/openstack-ceph-storage" typeof="schema:Article" id="node--article--4976" class="section my-5 py-5 bg-light-gray authors-bio authors-bio--article">
  <div class="container">
          <div class="row">
        <div class="col-md-2 text-center">
                      
<img data-affiliation="Red Hat, Sudoer" src="/sysadmin/sites/default/files/styles/user_picture_square/public/pictures/2019-09/Amy_Headshot.jpeg?itok=9n_1-S0Y" width="240" height="240" typeof="foaf:Image" loading="lazy" class="rounded-circle img-fluid" src="/sysadmin/sites/default/files/styles/user_picture_square/public/pictures/2019-09/Amy_Headshot.jpeg?itok=9n_1-S0Y" alt="Author’s photo" />


          
        </div>
        <div class="col-md-10 col-lg-8">
          <h2 class="font-weight-light text-center text-md-left">
                          Amy Marrich
                      </h2>
          <div>
                          <p>
                Amy Marrich is a Principal Technical Marketing Manager at Red Hat.
                                  <a href="/sysadmin/users/amy-marrich" class="author-more-link">More about me</a>
                              </p>
                      </div>
        </div>
      </div>
      </div>
</section>



  
  </div>

  <div class="block">

  
    

      

  
  </div>

  </div>
</div>
<div >
  <div >
    

  <div class="block block--cta cta cta--red-on-black cta-- my-5 p-3 text-center">

  
    

    <div class="d-md-flex justify-content-around align-items-center flex-wrap">
    <div class="cta__content my-2">
      
            <div class="cta__field-content p-2"><h4>On Demand: Red Hat Summit 2021 Virtual Experience</h4>

<p>Relive our April event with demos, keynotes, and technical sessions from<br />
experts, all available on demand.</p>
</div>
      
    </div>
        <div class="cta__link my-2">
      <a
        href="https://www.redhat.com/en/summit?intcmp=7013a0000026RhqAAE"
        target="_blank"
        class="btn btn-lg btn-danger font-weight-bold">
        Watch Now
      </a>
    </div>
      </div>
  
  </div>

  </div>
</div>
<div  class="section">
  <div class="container">
    <div >
      
  <div class="block">

  
    

      <div class="views-element-container"><div class="js-view-dom-id-11e6df47f438a2859b23be7d60201979eee38d9aa24098f0cff328bcbd89e568">
  
  
  

  
  
  

    <h2>Related Content</h2>
                        <div class="card-deck my-4">
                        <article data-history-node-id="4456" role="article" about="/sysadmin/capacity-plan-strategy" typeof="schema:Article" id="node--article--4456" class="card card--article node node--promoted">
      <div class="card-img-top">
            <div class="article__field-media"><article>
  
      
  <div class="blazy image__field-media-image" data-blazy="">
    <div class="field__label font-weight-bold visually-hidden">
      Image    </div>
                  <div class="field__item">



                    <div class="media media--blazy media--loading media--responsive media--image">
        
<img class="media__image media__element b-lazy b-responsive img-fluid" srcset="" data-srcset="/sysadmin/sites/default/files/styles/card/public/2021-05/water.jpg?itok=lX7DseDl 1x" data-src="/sysadmin/sites/default/files/styles/card/public/2021-05/water.jpg?itok=lX7DseDl" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" typeof="foaf:Image" loading="lazy" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" alt="What is your capacity planning strategy?" />


        
      
    </div>
        
  
</div>
              </div>

  </article>
</div>
      </div>
    <div class="card-body">
    <div class="h4 card-title"><a href="/sysadmin/capacity-plan-strategy"><span property="schema:name">What is your capacity planning strategy?</span>
</a></div>
    <div class="card-text">
            <div property="schema:text" class="clearfix article__body">Having a good capacity plan and strategy in place should be standard practice. For many businesses, it isn't.</div>
      </div>
  </div>
  <div class="card-footer">
    <div class="article-date">
      <span class="label">Posted:</span>
      May 25, 2021
    </div>
    <div class="article-authors">
              <span class="label">Author:</span>
                    <a href="/sysadmin/users/khess" class="article-author article-author--primary">Ken Hess<span class="author-affiliate"> (Red Hat)</span></a>          </div>
  </div>
</article>


                            <article data-history-node-id="4356" role="article" about="/sysadmin/resize-lvm-simple" typeof="schema:Article" id="node--article--4356" class="card card--article node node--promoted">
      <div class="card-img-top">
            <div class="article__field-media"><article>
  
      
  <div class="blazy image__field-media-image" data-blazy="">
    <div class="field__label font-weight-bold visually-hidden">
      Image    </div>
                  <div class="field__item">



                    <div class="media media--blazy media--loading media--responsive media--image">
        
<img class="media__image media__element b-lazy b-responsive img-fluid" srcset="" data-srcset="/sysadmin/sites/default/files/styles/card/public/2021-04/Pads.jpg?itok=QzhBLJqp 1x" data-src="/sysadmin/sites/default/files/styles/card/public/2021-04/Pads.jpg?itok=QzhBLJqp" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" typeof="foaf:Image" loading="lazy" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" alt="How to manage logical volumes with 5 simple LVM commands" />


        
      
    </div>
        
  
</div>
              </div>

  </article>
</div>
      </div>
    <div class="card-body">
    <div class="h4 card-title"><a href="/sysadmin/resize-lvm-simple"><span property="schema:name">How to resize a logical volume with 5 simple LVM commands</span>
</a></div>
    <div class="card-text">
            <div property="schema:text" class="clearfix article__body">It's easy to add capacity to logical volumes with a few simple commands.</div>
      </div>
  </div>
  <div class="card-footer">
    <div class="article-date">
      <span class="label">Posted:</span>
      April 21, 2021
    </div>
    <div class="article-authors">
              <span class="label">Author:</span>
                    <a href="/sysadmin/users/shehu-awwal" class="article-author article-author--primary">Shehu Awwal</a>          </div>
  </div>
</article>


                            <article data-history-node-id="4256" role="article" about="/sysadmin/openstacks-history-community-and-7-its-core-projects" typeof="schema:Article" id="node--article--4256" class="card card--article node node--promoted">
      <div class="card-img-top">
            <div class="article__field-media"><article>
  
      
  <div class="blazy image__field-media-image" data-blazy="">
    <div class="field__label font-weight-bold visually-hidden">
      Image    </div>
                  <div class="field__item">



                    <div class="media media--blazy media--loading media--responsive media--image">
        
<img class="media__image media__element b-lazy b-responsive img-fluid" srcset="" data-srcset="/sysadmin/sites/default/files/styles/card/public/2021-03/Stack.jpg?itok=JgIryGr- 1x" data-src="/sysadmin/sites/default/files/styles/card/public/2021-03/Stack.jpg?itok=JgIryGr-" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" typeof="foaf:Image" loading="lazy" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" alt="Openstack&amp;#039;s history, community, and 7 of its core projects" />


        
      
    </div>
        
  
</div>
              </div>

  </article>
</div>
      </div>
    <div class="card-body">
    <div class="h4 card-title"><a href="/sysadmin/openstacks-history-community-and-7-its-core-projects"><span property="schema:name">OpenStack&#039;s history, community, and 7 of its core projects</span>
</a></div>
    <div class="card-text">
            <div property="schema:text" class="clearfix article__body">A relatively high overview of what OpenStack is, how it came to be, and its most commonly installed services.</div>
      </div>
  </div>
  <div class="card-footer">
    <div class="article-date">
      <span class="label">Posted:</span>
      April 13, 2021
    </div>
    <div class="article-authors">
              <span class="label">Author:</span>
                    <a href="/sysadmin/users/amy-marrich" class="article-author article-author--primary">Amy Marrich<span class="author-affiliate"> (Red Hat, Sudoer)</span></a>          </div>
  </div>
</article>


                              </div>
            
    

  
  

  
  
</div>
</div>

  
  </div>

    </div>
  </div>
</div>
<div  class="section my-5 pb-5 narrow">
  <div class="container">
    <div >
      
    </div>
  </div>
</div>
<div  class="section my-5 pb-5 ">
  <div class="container">
    <div >
      

  <div class="block block--cta cta cta--red-on-black cta-- my-5 p-3 text-center">

  
    

    <div class="d-md-flex justify-content-around align-items-center flex-wrap">
    <div class="cta__content my-2">
      
            <div class="cta__field-content p-2"><p class="h4 mb-4 mt-3 font-weight-bold">OUR BEST CONTENT, DELIVERED TO YOUR INBOX</p>

<p><iframe title="Subscribe to our newsletter" aria-label="Embedded form to subscribe to our email newsletter" frameborder="0" height="50" scrolling="no" src="/sysadmin/eloqua-embedded-subscribe.html?offer_id=701f20000012gE7AAI" style="max-width:670px;margin:0 auto;" width="100%"></iframe></p>
</div>
      
    </div>
      </div>
  
  </div>

    </div>
  </div>
</div>

  </article>

  
  </div>


              </div>
        </main>

            <footer>
              <div class="page__colophon bg-dark-gray py-4 bg-dark-gray">
          <div class="container">
              
  <div class="block block--basic block--sysadmin-colophon-disclaimer">

  
    

      
            <div class="basic__body"><p>The opinions expressed on this website are those of each author, not of the author's employer or of Red Hat. The content published on this site are community contributions and are for informational purpose only AND ARE NOT, AND ARE NOT INTENDED TO BE, RED HAT DOCUMENTATION, SUPPORT, OR ADVICE.</p>

<p>Red Hat and the Red Hat logo are trademarks of Red Hat, Inc., registered in the United States and other countries.</p>
</div>
      
  
  </div>


          </div>
        </div>
                    <div class="page__footer bg-dark py-3">
        <div class="container">
          <div class="d-sm-flex justify-content-between align-items-center">
              

  
    

    
  <a href="https://www.redhat.com/" class="navbar-brand mr-0 mr-lg-auto mb-3 mb-sm-0">
            <img src="/sysadmin/themes/custom/sysadmin/logo.svg" width="135" height="31" class="d-inline-block align-top" alt="Red Hat logo" />

        
  </a>



  <div class="block block--basic block--copyright my-0 mx-sm-3 mb-1 mb-sm-0">

  
    

      
            <div class="basic__body"><p>Copyright ©2021 Red Hat, Inc.</p>
</div>
      
  
  </div>

  <div class="block block--sysadmin-footer my-0 mb-1 mb-sm-0">

  
    

      
  


  <ul class="nav d-flex d-sm-block d-md-flex justify-content-center align-items-center">
                                          <li class="nav-item  ">
                      <a href="https://www.redhat.com/en/about/privacy-policy" class="nav-link">Privacy Policy</a>
                  </li>
                                      <li class="nav-item  ">
                      <a href="https://www.redhat.com/en/about/terms-use" class="nav-link">Terms of Use</a>
                  </li>
                                      <li class="nav-item  ">
                      <a href="https://www.redhat.com/en/about/all-policies-guidelines" class="nav-link">All policies and guidelines</a>
                  </li>
            </ul>


  
  </div>

  <div class="block block--basic block--footerredhatsummit">

  
    

      
            <div class="basic__body"><div style="margin-left: 1rem"><a href="https://www.redhat.com/en/summit?intcmp=7013a0000026RhqAAE" target="_blank"><img alt="Red Hat Summit" src="https://www.redhat.com/cms/managed-files/Logo-Red_Hat-Summit-A-Standard-RGB-02_0.svg" width="72px" /></a></div>
</div>
      
  
  </div>

  <div class="block block--sharelinks">

  
    

      <div class="a2a_kit a2a_kit_size_32 a2a_floating_style a2a_vertical_style" data-a2a-url="https://www.redhat.com/sysadmin/openstack-ceph-storage">
  <a class="a2a_button_twitter"></a>
  <a class="a2a_button_facebook"></a>
  <a class="a2a_button_linkedin"></a>
  <a class="a2a_button_reddit"></a>
  <a class="a2a_button_email"></a>
</div>
<div class="a2a_kit a2a_kit_size_32 a2a_floating_style a2a_default_style">
  <a class="a2a_button_twitter"></a>
  <a class="a2a_button_facebook"></a>
  <a class="a2a_button_linkedin"></a>
  <a class="a2a_button_reddit"></a>
  <a class="a2a_button_email"></a>
</div>

<script>
  var a2a_config = a2a_config || {};
  a2a_config.templates = a2a_config.templates || {};
  a2a_config.templates.twitter = {
    text: "How OpenStack uses Ceph for storage https://red.ht/3yaF5OE via #EnableSysadmin by @spotzz_",
  };
    a2a_config.templates.facebook = {
    hashtag: "#EnableSysadmin",
  };
  </script>

  
  </div>


  <div class="block block--cta block--ctasubscribesidebar cta cta--blue-on-white cta-- my-5 p-3 text-center">

  
    

    <div class="d-md-flex justify-content-around align-items-center flex-wrap">
    <div class="cta__content my-2">
      
            <div class="cta__field-content p-2"><div class="subscribe-sidebar">
<div class="target-band-never-show-button">x</div>

<h4>Subscribe now</h4>

<p class="eloqua-email-capture-text">Get the highlights in your inbox every week.</p>

<p><iframe aria-label="Embedded form to subscribe to our email newsletter" frameborder="0" height="50" scrolling="no" src="/sysadmin/eloqua-embedded-email-capture-block.html?offer_id=701f20000012gE7AAI" style="max-width:670px;margin:0 auto;" title="Subscribe to our newsletter" width="100%"></iframe></p>
</div>
</div>
      
    </div>
      </div>
  
  </div>


          </div>
        </div>
            </footer>
      </div>

  </div>


<script type="application/json" data-drupal-selector="drupal-settings-json">{"path":{"baseUrl":"\/sysadmin\/","scriptPath":null,"pathPrefix":"","currentPath":"node\/4976","currentPathIsAdmin":false,"isFront":false,"currentLanguage":"en"},"pluralDelimiter":"\u0003","suppressDeprecationErrors":true,"ckeditorheight":{"offset":1,"line_height":1.5,"unit":"em","disable_autogrow":null},"colorbox":{"opacity":"0.85","current":"{current} of {total}","previous":"\u00ab Prev","next":"Next \u00bb","close":"Close","maxWidth":"98%","maxHeight":"98%","fixed":true,"mobiledetect":true,"mobiledevicewidth":"480px"},"blazy":{"loadInvisible":false,"offset":100,"saveViewportOffsetDelay":50,"validateDelay":25},"blazyIo":{"enabled":false,"disconnect":false,"rootMargin":"0px","threshold":[0]},"user":{"uid":0,"permissionsHash":"51f347f394db8c9bda75fb2a6f2d406a82353e6cfb9faf5ace3100b98d716870"}}</script>

<!--[if lte IE 9]>
<script src="/sysadmin/core/assets/vendor/classList/classList.min.js?v=2014-12-13"></script>
<![endif]-->
<script src="/sysadmin/core/assets/vendor/jquery/jquery.min.js?v=3.5.1"></script>
<script src="/sysadmin/core/assets/vendor/jquery-once/jquery.once.min.js?v=2.2.3"></script>
<script src="/sysadmin/core/misc/drupalSettingsLoader.js?v=8.9.14"></script>
<script src="/sysadmin/core/misc/drupal.js?v=8.9.14"></script>
<script src="/sysadmin/core/misc/drupal.init.js?v=8.9.14"></script>
<script src="/sysadmin/core/assets/vendor/picturefill/picturefill.min.js?v=3.0.3"></script>
<script src="/sysadmin/modules/contrib/blazy/js/dblazy.js?qx0wr4"></script>
<script src="/sysadmin/modules/contrib/blazy/js/bio.js?qx0wr4"></script>
<script src="/sysadmin/modules/contrib/blazy/js/bio.media.js?qx0wr4"></script>
<script src="/sysadmin/modules/contrib/blazy/js/blazy.load.js?qx0wr4"></script>
<script src="/sysadmin/libraries/colorbox/jquery.colorbox-min.js?v=8.9.14"></script>
<script src="/sysadmin/modules/contrib/colorbox/js/colorbox.js?v=8.9.14"></script>
<script src="/sysadmin/modules/contrib/colorbox/styles/default/colorbox_style.js?v=8.9.14"></script>
<script src="/sysadmin/modules/contrib/colorbox_inline/js/colorbox_inline.js?qx0wr4"></script>
<script src="/sysadmin/themes/custom/sysadmin/assets/js/sysadmin.script.js?v=8.9.14"></script>
<script src="/sysadmin/modules/custom/sysadmin_social/js/addtoany-page.js?v=8.9.14"></script>
<script src="/sysadmin/core/assets/vendor/matchMedia/matchMedia.min.js?v=0.2.0"></script>
<script src="/sysadmin/themes/custom/sysadmin/assets/js/stacktable/stacktable.js?v=8.9.14"></script>
<script src="/sysadmin/themes/custom/sysadmin/assets/js/responsive-tables.js?v=8.9.14"></script>
<script src="/sysadmin/themes/custom/sysadmin/assets/js/cookie-banner.js?v=8.9.14"></script>
<script src="/sysadmin/themes/custom/sysadmin/assets/js/rh-waypoints.js?v=8.9.14"></script>
<script src="/sysadmin/themes/custom/sysadmin/../../../libraries/waypoints/lib/noframework.waypoints.js?v=8.9.14"></script>
<script src="/sysadmin/libraries/codesnippet/lib/highlight/highlight.pack.js?v=8.9.14"></script>
<script src="/sysadmin/modules/contrib/codesnippet/js/codesnippet.js?v=8.9.14"></script>

  <script type="text/javascript">
    if (("undefined" !== typeof _satellite) && ("function" === typeof _satellite.pageBottom)) {
      _satellite.pageBottom();
    }
  </script>
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam-cell.nr-data.net","licenseKey":"a03a21ae8a","applicationID":"467345710","transactionName":"ZlNTbUBQDxZUWxJRVl8ZcFpGWA4LGnwUTUlQWm1XXVUEOXZXCExLXlpdXEBtLwpRXTBRXEZ1XldGQw4JWV0UFQdHX1RO","queueTime":0,"applicationTime":574,"atts":"ShRQGwhKHBg=","errorBeacon":"bam-cell.nr-data.net","agent":""}</script><script type="text/javascript"  src="/d4zSvfkD/aUECJaG/IpPS_mo/SL/auYhz2D6L3a1/fAl3awE/F20DKT5g/UB0"></script></body>
</html>
