<!DOCTYPE html>
<html lang="en" dir="ltr" prefix="content: http://purl.org/rss/1.0/modules/content/  dc: http://purl.org/dc/terms/  foaf: http://xmlns.com/foaf/0.1/  og: http://ogp.me/ns#  rdfs: http://www.w3.org/2000/01/rdf-schema#  schema: http://schema.org/  sioc: http://rdfs.org/sioc/ns#  sioct: http://rdfs.org/sioc/types#  skos: http://www.w3.org/2004/02/skos/core#  xsd: http://www.w3.org/2001/XMLSchema# ">
<head>
<script id="dpal" src="https://www.redhat.com/ma/dpal.js"></script>
<meta charset="utf-8" /><script type="text/javascript">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</script>
<link rel="canonical" href="https://www.redhat.com/sysadmin/podman-features-1" />
<meta name="description" content="Improve how you use containers with these new Podman features: --latest, --replace, --all, --ignore, and --tz." />
<meta name="dcterms.title" content="5 Podman features to try now" />
<meta name="dcterms.creator" content="Dan Walsh" />
<meta name="dcterms.publisher" content="Red Hat, Inc." />
<meta name="dcterms.language" content="en" />
<meta property="og:site_name" content="Enable Sysadmin" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.redhat.com/sysadmin/podman-features-1" />
<meta property="og:title" content="5 Podman features to try now" />
<meta property="og:image" content="https://www.redhat.com/sysadmin/sites/default/files/styles/google_discover/public/2020-03/business-coffee-computer-desk-374006%20Cropped.jpg?itok=WZyCw5Nr" />
<meta property="og:image:secure_url" content="https://www.redhat.com/sysadmin/sites/default/files/styles/google_discover/public/2020-03/business-coffee-computer-desk-374006%20Cropped.jpg?itok=WZyCw5Nr" />
<meta property="og:image:type" content="image/jpeg" />
<meta property="og:image:width" content="1000" />
<meta property="og:video:width" content="600" />
<meta property="og:image:height" content="675" />
<meta property="og:updated_time" content="2022-02-15T10:00:00+0000" />
<meta property="og:image:alt" content="https://www.redhat.com/sysadmin/sites/default/files/styles/google_discover/public/2020-03/business-coffee-computer-desk-374006%20Cropped.jpg?itok=WZyCw5Nr" />
<meta property="og:street_address" content="100 East Davie Street" />
<meta property="og:locality" content="Raleigh" />
<meta property="og:region" content="NC" />
<meta property="og:postal_code" content="27601" />
<meta property="og:country_name" content="United States" />
<meta property="og:phone_number" content="+1 919 754 4950" />
<meta property="og:fax_number" content="+1 919 800 3804" />
<meta property="og:locale" content="en_US" />
<meta property="article:author" content="https://www.redhat.com/sysadmin/users/dwalsh" />
<meta property="article:publisher" content="https://www.facebook.com/redhatinc" />
<meta property="article:section" content="Enable Sysadmin" />
<meta property="article:tag" content="Podman" />
<meta property="article:tag" content="Containers" />
<meta property="article:modified_time" content="2022-02-15T10:00:00+0000" />
<meta name="twitter:card" content="photo" />
<meta name="twitter:title" content="5 Podman features to try now" />
<meta name="twitter:site:id" content="14627400" />
<meta name="twitter:creator" content="@rhatdan" />
<meta name="twitter:url" content="https://www.redhat.com/sysadmin/podman-features-1" />
<meta name="twitter:image:alt" content="Red Hat, Inc." />
<meta name="twitter:image:height" content="1000" />
<meta name="twitter:image:width" content="600" />
<meta name="twitter:image" content="https://www.redhat.com/sysadmin/sites/default/files/styles/full/public/2020-03/business-coffee-computer-desk-374006%20Cropped.jpg?itok=tKcULiAm" />
<meta name="Generator" content="Drupal 9 (https://www.drupal.org)" />
<meta name="MobileOptimized" content="width" />
<meta name="HandheldFriendly" content="true" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<script type="application/ld+json">{
    "@context": "https://schema.org",
    "@graph": [
        {
            "@type": "TechArticle",
            "headline": "5 Podman features to try now",
            "name": "5 Podman features to try now",
            "about": [
                "\u003Ca href=\u0022/sysadmin/topics/podman\u0022 hreflang=\u0022en\u0022\u003EPodman\u003C/a\u003E",
                "\u003Ca href=\u0022/sysadmin/topics/containers\u0022 hreflang=\u0022en\u0022\u003EContainers\u003C/a\u003E"
            ],
            "description": "Improve how you use containers with these new Podman features: --latest, --replace, --all, --ignore, and --tz.",
            "image": {
                "@type": "ImageObject",
                "url": "https://www.redhat.com/sysadmin/sites/default/files/styles/full/public/2020-03/business-coffee-computer-desk-374006%20Cropped.jpg?itok=tKcULiAm",
                "width": "1000",
                "height": "600"
            },
            "dateModified": "2022-02-15T10:00:00+0000",
            "author": {
                "@type": "Person",
                "@id": "https://www.redhat.com/sysadmin/users/dwalsh",
                "name": "Dan Walsh",
                "url": "https://www.redhat.com/sysadmin/users/dwalsh",
                "sameAs": "https://twitter.com/rhatdan"
            },
            "publisher": {
                "@type": "Organization",
                "@id": "https://www.redhat.com/"
            },
            "mainEntityOfPage": "https://www.redhat.com/sysadmin/podman-features-1"
        },
        {
            "@type": "Corporation",
            "@id": "https://www.redhat.com/",
            "name": "Red Hat, Inc.",
            "sameAs": [
                "https://en.wikipedia.org/wiki/Red_Hat",
                "http://www.linkedin.com/company/red-hat",
                "http://www.youtube.com/user/RedHatVideos",
                "https://www.facebook.com/redhatinc",
                "https://twitter.com/RedHat"
            ],
            "url": "https://www.redhat.com/",
            "telephone": "+1 919 754 4950",
            "contactPoint": {
                "@type": "ContactPoint",
                "telephone": "+1-888-RED-HAT1",
                "availableLanguage": "English",
                "contactType": "sales",
                "faxnumber": "+1 919 800 3804"
            },
            "logo": {
                "@type": "ImageObject",
                "url": "https://www.redhat.com/sysadmin/themes/custom/sysadmin/assets/images/red-hat-logo.png",
                "width": "254",
                "height": "60"
            },
            "address": {
                "@type": "PostalAddress",
                "streetAddress": "100 East Davie Street",
                "addressLocality": "Raleigh",
                "addressRegion": "NC",
                "postalCode": "27601",
                "addressCountry": "United States"
            }
        },
        {
            "@type": "Person",
            "name": "Dan Walsh",
            "sameAs": "https://twitter.com/rhatdan",
            "image": {
                "@type": "ImageObject",
                "url": "https://www.redhat.com/sysadmin/sites/default/files/styles/user_picture_square/public/pictures/2019-10/DanWalsh.jpg?itok=YkqGIoHm",
                "width": "240",
                "height": "240"
            }
        },
        {
            "@type": "WebPage",
            "@id": "https://www.redhat.com/sysadmin/podman-features-1",
            "publisher": {
                "@type": "Organization",
                "@id": "https://www.redhat.com/"
            }
        },
        {
            "@type": "WebSite",
            "@id": "https://www.redhat.com/sysadmin/",
            "name": "Enable Sysadmin",
            "url": "https://www.redhat.com/sysadmin/",
            "publisher": {
                "@type": "Organization",
                "@id": "https://www.redhat.com/"
            }
        }
    ]
}</script>
<meta name="robots" content="max-image-preview:large" />
<link rel="shortcut icon" href="/sysadmin/themes/custom/sysadmin/favicon.ico" type="image/vnd.microsoft.icon" />
<link rel="revision" href="https://www.redhat.com/sysadmin/podman-features-1" />
<link rel="apple-touch-icon" sizes="180x180" href="/sysadmin/themes/custom/sysadmin/assets/favicon/apple-touch-icon.png">
<link rel="icon" type="image/png" sizes="32x32" href="/sysadmin/themes/custom/sysadmin/assets/favicon/favicon-32x32.png">
<link rel="icon" type="image/png" sizes="16x16" href="/sysadmin/themes/custom/sysadmin/assets/favicon/favicon-16x16.png">
<link rel="manifest" href="/sysadmin/themes/custom/sysadmin/assets/favicon/site.webmanifest">
<link rel="mask-icon" href="/sysadmin/themes/custom/sysadmin/assets/favicon/safari-pinned-tab.svg" color="#ee0000">
<meta name="msapplication-TileColor" content="#1a1a1a">
<meta name="theme-color" content="#ffffff">
<title>5 Podman features to try now | Enable Sysadmin</title>
<link rel="stylesheet" media="all" href="/sysadmin/sites/default/files/css/css_K-etweG1PGH6xQ8c1GPXlg7Kf-iQ9nD5hOKFOqg1DI0.css" />
<link rel="stylesheet" media="all" href="/sysadmin/sites/default/files/css/css_wL5vQsqSGZeeFvsRIov4xFil8zWkEzY2DL19yeqGeqw.css" />

<script src="/sysadmin/sites/default/files/js/js_QHqjxhGPGgZFwOfW92tmrVpssmC1sbO0zDG4TgLmaEI.js"></script>


</head>
<body>
<a href="#main-content" class="visually-hidden focusable">
Skip to main content
</a>

  <div class="dialog-off-canvas-main-canvas" data-off-canvas-main-canvas>
    

<div class="redhat-cookie-banner">
<section id="redhat-cookie-privacy-banner" class="redhat-cookie-banner-wrapper" style="display: block;">
  <div class="container my-3 pr-5">
    <p>We use cookies on our websites to deliver our online services. Details about how we use cookies and how you may disable them are set out in our <a href="http://www.redhat.com/en/about/privacy-policy#cookies">Privacy Statement</a>. By using this website you agree to our use of cookies.
    <span class="cookie-more">
    <a id="redhat-cookie-privacy-banner-close" href="javascript:void(0);" class="cookie-close">&times;</a>
    </span>
    </p>
  </div>
</section>
</div>

<div class="page d-flex flex-column">
  <div class="navbar navbar-expand-lg justify-content-between navbar-dark bg-dark">
    <div class="container">
                
  <div class="block block--sysadmin-navbar-branding">

  
    

    
  <a href="https://www.redhat.com/" class="navbar-brand ">
            <img src="/sysadmin/themes/custom/sysadmin/logo.svg" width="135" height="31" class="d-inline-block align-top" alt="Red Hat logo" />

        
  </a>


  </div>


      
      <div class="navbar-toggler-wrapper">
        <button class="navbar-toggler" type="button" data-toggle="collapse"  data-parent="#collapse-parent" data-target="#search-collapse" aria-controls="search-collapse" aria-expanded="false" aria-label="Toggle search">
          <svg class="icon-collapsed" width="30" height="30" viewBox="0 0 30 30" xmlns="http://www.w3.org/2000/svg"><line x1="18.95" y1="19.15" x2="25.25" y2="25.75"/><circle cx="13.25" cy="12.75" r="8.5"/></svg>
          <svg class="icon-expanded" width="30" height="30" viewBox="0 0 30 30" xmlns="http://www.w3.org/2000/svg"><line x1="7.25" y1="7.25" x2="22.75" y2="22.75"/><line x1="7.25" y1="22.75" x2="22.75" y2="7.25"/></svg>
          <span style="vertical-align: middle;">Search</span>
        </button>
        <button class="navbar-toggler" type="button" data-toggle="collapse" data-parent="#collapse-parent" data-target="#mobilenav-collapse" aria-controls="mobilenav-collapse" aria-expanded="false" aria-label="Toggle navigation">
          <svg class="icon-collapsed" width="30" height="30" viewBox="0 0 30 30" xmlns="http://www.w3.org/2000/svg"><path d="M4 7h22M4 15h22M4 23h22"/></svg>
          <svg class="icon-expanded" width="30" height="30" viewBox="0 0 30 30" xmlns="http://www.w3.org/2000/svg"><line x1="7.25" y1="7.25" x2="22.75" y2="22.75"/><line x1="7.25" y1="22.75" x2="22.75" y2="7.25"/></svg>
        </button>
      </div>
    </div>
  </div>

  <div id="collapse-parent">
    <div id="search-collapse" class="search-collapse collapse" data-parent="#collapse-parent">
      <div class="py-4 px-3">
        <form class="form-inline m-2" action="/sysadmin/search/node" accept-charset="UTF-8" method="get">
          <div class="input-group flex-fill">
            <input class="form-control" type="search" name="keys" id="search" value="" placeholder="Search this site…" aria-label="Search this site…">
            <div class="input-group-append">
              <button class="btn btn-secondary font-weight-bold" type="submit">Search</button>
            </div>
          </div>
        </form>
      </div>
    </div>

    <div id="mobilenav-collapse" class="mobilenav-collapse d-lg-none collapse" data-parent="#collapse-parent">
                
  <div class="block block--sysadmin-navbar-sitename sitename">

  
    

    
  <a href="/sysadmin/" class="navbar-brand sitename">
        Enable Sysadmin
  </a>

  <span class="d-none d-lg-inline ml-1 mr-3 h5 navbar-sitename-divider">&nbsp;</span>

  </div>

  <div class="block block--sysadmin-main-menu">

  
    

      
  


  <ul class="nav navbar-nav">
                                          <li class="nav-item  dropdown">
                      <a href="/sysadmin/" class="nav-link dropdown-toggle" data-toggle="dropdown" data-drupal-link-system-path="&lt;front&gt;">Articles</a>
                          <div class="dropdown-menu">
              <a href="/sysadmin/topics/automation" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/146">Automation</a>
              <a href="/sysadmin/topics/career" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/51">Career</a>
              <a href="/sysadmin/topics/containers" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/36"> Containers</a>
              <a href="/sysadmin/topics/sysadmin-culture" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/41">Culture</a>
              <a href="/sysadmin/topics/kubernetes" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/66">Kubernetes</a>
              <a href="/sysadmin/topics/linux" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/21">Linux</a>
              <a href="/sysadmin/topics/programming" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/71"> Programming</a>
              <a href="/sysadmin/topics/security" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/96">Security</a>
  </div>
                              </li>
                                      <li class="nav-item  dropdown">
                      <a href="/sysadmin/about" class="nav-link dropdown-toggle" data-toggle="dropdown" data-drupal-link-system-path="node/71">About</a>
                          <div class="dropdown-menu">
              <a href="/sysadmin/about" class="dropdown-item" data-drupal-link-system-path="node/71">Topics</a>
              <a href="/sysadmin/email" class="dropdown-item" data-drupal-link-system-path="node/376">Email newsletter</a>
              <a href="/sysadmin/join-community" class="dropdown-item" data-drupal-link-system-path="node/641">Join the community</a>
              <a href="/sysadmin/community-guidelines" class="dropdown-item" data-drupal-link-system-path="node/156">Community guidelines</a>
              <a href="/sysadmin/sudoers-program" class="dropdown-item" data-drupal-link-system-path="node/2106">Sudoers program</a>
              <a href="/sysadmin/meet-team" class="dropdown-item" data-drupal-link-system-path="node/2316">Meet the team</a>
              <a href="/sysadmin/faq" class="dropdown-item" data-drupal-link-system-path="node/1526">FAQs</a>
  </div>
                              </li>
                                      <li class="nav-item  ">
                      <a href="/sysadmin/welcome-enable-sysadmin" title="A Red Hat community publication for sysadmins, by sysadmins" class="nav-link">Welcome</a>
                  </li>
            </ul>


  
  </div>


      
              
          </div>
  </div>

  


<nav class="navbar navbar-expand-lg justify-content-between navbar-light  d-none d-lg-block text-dark bg-light border-bottom-light-gray">
      <div class="container">
  
      
  
  <button class="navbar-toggler" type="button" data-toggle="collapse" data-target=".navbar-collapse" aria-controls="navbar-collapse" aria-expanded="false" aria-label="Toggle navigation">
    <span class="navbar-toggler-icon"></span>
  </button>

  <div class="collapse navbar-collapse">
                  <div class="mr-auto d-flex navbar-desktop">
            
  <div class="block block--sysadmin-navbar-sitename sitename">

  
    

    
  <a href="/sysadmin/" class="navbar-brand sitename">
        Enable Sysadmin
  </a>

  <span class="d-none d-lg-inline ml-1 mr-3 h5 navbar-sitename-divider">&nbsp;</span>

  </div>

  <div class="block block--sysadmin-main-menu">

  
    

      
  


  <ul class="nav navbar-nav">
                                          <li class="nav-item  dropdown">
                      <a href="/sysadmin/" class="nav-link dropdown-toggle" data-toggle="dropdown" data-drupal-link-system-path="&lt;front&gt;">Articles</a>
                          <div class="dropdown-menu">
              <a href="/sysadmin/topics/automation" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/146">Automation</a>
              <a href="/sysadmin/topics/career" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/51">Career</a>
              <a href="/sysadmin/topics/containers" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/36"> Containers</a>
              <a href="/sysadmin/topics/sysadmin-culture" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/41">Culture</a>
              <a href="/sysadmin/topics/kubernetes" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/66">Kubernetes</a>
              <a href="/sysadmin/topics/linux" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/21">Linux</a>
              <a href="/sysadmin/topics/programming" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/71"> Programming</a>
              <a href="/sysadmin/topics/security" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/96">Security</a>
  </div>
                              </li>
                                      <li class="nav-item  dropdown">
                      <a href="/sysadmin/about" class="nav-link dropdown-toggle" data-toggle="dropdown" data-drupal-link-system-path="node/71">About</a>
                          <div class="dropdown-menu">
              <a href="/sysadmin/about" class="dropdown-item" data-drupal-link-system-path="node/71">Topics</a>
              <a href="/sysadmin/email" class="dropdown-item" data-drupal-link-system-path="node/376">Email newsletter</a>
              <a href="/sysadmin/join-community" class="dropdown-item" data-drupal-link-system-path="node/641">Join the community</a>
              <a href="/sysadmin/community-guidelines" class="dropdown-item" data-drupal-link-system-path="node/156">Community guidelines</a>
              <a href="/sysadmin/sudoers-program" class="dropdown-item" data-drupal-link-system-path="node/2106">Sudoers program</a>
              <a href="/sysadmin/meet-team" class="dropdown-item" data-drupal-link-system-path="node/2316">Meet the team</a>
              <a href="/sysadmin/faq" class="dropdown-item" data-drupal-link-system-path="node/1526">FAQs</a>
  </div>
                              </li>
                                      <li class="nav-item  ">
                      <a href="/sysadmin/welcome-enable-sysadmin" title="A Red Hat community publication for sysadmins, by sysadmins" class="nav-link">Welcome</a>
                  </li>
            </ul>


  
  </div>


        </div>
          
                  
      
      

<div class="dropdown show text-align-right">
    <a href="/sysadmin/subscribe" class="navbar-util navbar-util--rss" aria-label="Subscribe to our feed or newsletter blast">
    <svg width="22" height="23" viewBox="0 0 22 23" xmlns="http://www.w3.org/2000/svg"><title>Subscribe to our RSS feed or Email newsletter</title><path d="M0 4.23c9.79 0 17.75 8 17.75 17.84h4.23A22.05 22.05 0 0 0 0 0v4.23z M0 7.67v4.23c2.74 0 5.33 1.07 7.27 3.03a10.26 10.26 0 0 1 3 7.3h4.24c0-8.02-6.5-14.56-14.51-14.56M2.93 16.87a2.94 2.94 0 0 0 0 5.85 2.93 2.93 0 1 0 0-5.85" fill-rule="evenodd"/></svg>

    <span class="sr-only">Subscribe to our RSS feed or Email newsletter.</span>
  </a>

    <a id="dropdownSearchLink" href="/sysadmin/search/node" class="navbar-util navbar-util--search" role="button" aria-label="Search this site…" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false">
    <svg width="30" height="30" viewBox="0 0 30 30" xmlns="http://www.w3.org/2000/svg" style="fill:none;stroke-width:3;stroke:#000;stroke-linecap:round;"><line x1="18.95" y1="19.15" x2="25.25" y2="25.75"/><circle cx="13.25" cy="12.75" r="8.5"/></svg>

  </a>
  <div class="dropdown-menu dropdown-menu-right p-1 pt-2" aria-labelledby="dropdownSearchLink">
    <form class="form-inline m-2" action="/sysadmin/search/node" accept-charset="UTF-8" method="get">
      <div class="input-group flex-fill">
        <input class="form-control" type="search" name="keys" id="search" value="" placeholder="Search this site…" aria-label="Search this site…">
        <div class="input-group-append">
          <button class="btn btn-secondary font-weight-bold" type="submit">GO</button>
        </div>
      </div>
    </form>
  </div>
  </div>
      </div>

      </div>
  </nav>

  <main class="pb-5">
                  <header class="page__header">
          <div class="container">
              <div data-drupal-messages-fallback class="hidden"></div>


          </div>
        </header>
          
    <a name="main-content" tabindex="-1"></a>

                  <div class="page__content">
                  
  <div class="block block--sysadmin-content">

  
    

      <article data-history-node-id="5691" role="article" about="/sysadmin/podman-features-1" typeof="schema:Article" id="node--article--5691" class="full full--article node node--promoted">
  
    <span property="schema:name" content="5 Podman features to try now" class="hidden"></span>
  <span property="schema:interactionCount" content="UserComments:0" class="hidden"></span>


      <div  class="section my-5 narrow">
  <div class="container">
    <div >
      
  <div class="block">

  
    

      <span property="schema:name"><h1 class="font-weight-bold">5 Podman features to try now</h1>
</span>

  
  </div>

  <div class="block">

  
    

      
            <div class="article__field-subhead">Improve how you use containers with these new Podman features: --latest, --replace, --all, --ignore, and --tz.</div>
      
  
  </div>

    </div>
  </div>
</div>
<div  class="section pb-5 narrow">
  <div class="container">
    <div >
      
  <div class="block">

  
    

      <p class="article-byline">
  <span class="article-date">
    <span class="label">Posted:</span>
    February 15, 2022
  </span>
    <span aria-hidden="true">|</span>
  <span class="article-authors">
    <strong class="sr-only">by</strong>
          <a href="/sysadmin/users/dwalsh" class="article-author article-author--primary">Dan Walsh<span class="author-affiliate"> (Red Hat)</span></a>      </span>
  </p>

  
  </div>

  <div class="block">

  
    

      
            <div class="article__field-media"><figure>
  
  
  <div data-blazy="" class="blazy blazy--field blazy--field-media-image image__field-media-image">
    <div class="field__label font-weight-bold visually-hidden">
      Image    </div>
                  <div class="field__item">



                  <div class="media media--blazy media--bundle--image media--loading is-b-loading media--image">
<img alt="World backup day" class="media__image media__element b-lazy img-fluid" data-src="/sysadmin/sites/default/files/styles/full/public/2020-03/business-coffee-computer-desk-374006%20Cropped.jpg?itok=tKcULiAm" src="data:image/svg+xml;charset=utf-8,%3Csvg%20xmlns%3D&#039;http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg&#039;%20viewBox%3D&#039;0%200%201000%20600&#039;%2F%3E" width="1000" height="600" loading="lazy" typeof="foaf:Image" />
        </div>
        
  
</div>
              </div>

  <figcaption>
    
            <div class="image__field-media-description"><p>Photo by <strong><a href="https://www.pexels.com/@burst?utm_content=attributionCopyText&amp;utm_medium=referral&amp;utm_source=pexels">Burst</a></strong> from <strong><a href="https://www.pexels.com/photo/business-coffee-computer-desk-374006/?utm_content=attributionCopyText&amp;utm_medium=referral&amp;utm_source=pexels">Pexels</a></strong></p>
</div>
      
  </figcaption>
</figure>
</div>
      
  
  </div>

  <div class="block">

  
    

      
            <div property="schema:text" class="clearfix article__body"><p>The Podman team has added many cool new features to Podman that you might not be aware of. So, this is the first in a series of articles that cover some of the large and small features that make Podman great.</p>

<div data-embed-button="resource_list" data-entity-embed-display="view_mode:resource_list.link" data-entity-type="resource_list" data-entity-uuid="78d8f7ba-4831-497f-b66d-ec0bb740244e" data-langcode="en" class="align-right embedded-entity embedded-entity--resources embedded-entity--resources--link"><aside id="resource-list-linux-containers" class="eck-entity mt-2 py-3 pr-3 border-top border-danger"><h2 class="h4">
      Linux containers
  </h2>

<ul class="pl-3 mb-0"><li class="my-2"><a href="https://www.redhat.com/en/topics/containers?intcmp=701f20000012ngPAAQ">Understanding Linux containers</a></li>
      <li class="my-2"><a href="https://developers.redhat.com/blog/2018/02/22/container-terminology-practical-introduction?intcmp=701f20000012ngPAAQ">A practical introduction to container terminology</a></li>
      <li class="my-2"><a href="https://www.redhat.com/en/services/training/do080-deploying-containerized-applications-technical-overview?intcmp=701f20000012ngPAAQ">Free course: Deploying containerized applications</a></li>
      <li class="my-2"><a href="https://www.redhat.com/en/technologies/cloud-computing/openshift/try-it?intcmp=701f20000012ngPAAQ">Download now: Red Hat OpenShift trial</a></li>
      <li class="my-2"><a href="https://www.redhat.com/en/resources/container-storage-dummies?intcmp=701f20000012ngPAAQ">eBook: Container storage for dummies</a></li>
  </ul></aside></div>
<p>When we first started building Podman, we wanted to match the Docker command-line interface (CLI), and we added features to match. We even have a page on the Podman GitHub called <a href="https://github.com/containers/podman/blob/main/transfer.md" target="_blank">transfer.md</a> that lists Docker's commands, the completed features, and which are still in progress. Now that Podman is basically complete and matches Docker, we rarely update the page.</p>

<p>Last year, we added the Podman service to Podman 3.0, which replicates Docker's REST API. The Podman service supports any tools needed to communicate with the Docker daemon, like <code>Docker-compose</code> and <code>Docker.py</code>. The Podman service also supports its own REST API for advanced Podman features, like pods.</p>

<p>We feel Podman is feature-complete as a Docker replacement. However, I think we sell Podman short when we talk only about features that match Docker. While we were building compatibility, the Podman developers and open source community added large and small features that improve the project. Sometimes we add features just to scratch an itch.</p>

<p>This first article covers five Podman options that I love to use. We want to hear from you about features you love in Podman and features you would like to see added, so reach out to us through our usual <a href="https://github.com/containers/podman#communications" target="_blank">communication channels</a>.</p>

<h2>1. The --latest flag</h2>

<p>The first option I want to discuss is the <code>--latest</code> (<code>-l</code>) flag. The basic idea of the flag is to use the latest or last container that Podman created.</p>

<p>I did not like the idea when this flag was first introduced, but here's why the option has become indispensable. When playing with Podman containers or developing and testing Podman, users constantly create containers and then start, stop, inspect, and remove them.</p>

<p>When creating or running a container, the container gets a default name and ID (although you can override this with the <code>--name</code> option):</p>

<pre>
<code class="language-bash">$ podman create ubi8 echo hi
Ef3a2d8500b998847cd898af8f5b4580186716a920b6d0c151553da702289c7a</code></pre>

<p>To start the container, you need to cut and paste the ID:</p>

<pre>
<code class="language-bash">$ podman start --attach ef3a2d8500b9988
hi</code></pre>

<p>To inspect the container, you <em>also</em> need to cut and paste the container ID:</p>

<pre>
<code class="language-bash">$ podman inspect ef3a2d8500b9988 –format ‘{{ .Id }}’
ef3a2d8500b998847cd898af8f5b4580186716a920b6d0c151553da702289c7a</code></pre>

<p>Finally, to remove it, you once again cut and paste:</p>

<pre>
<code class="language-bash">podman rm ef3a2d8500b9988
ef3a2d8500b998847cd898af8f5b4580186716a920b6d0c151553da702289c7a</code></pre>

<p>You could have named the container and referred to it by name, but this can be a pain if the container is short lived.</p>

<p>Using <code>-l</code> (<code>--latest</code>) makes this much easier to deal with. Here's the same set of events:</p>

<pre>
<code class="language-bash">$ podman create ubi8 echo hi
5649a881c12fd26e34febce00887329a9031164733490aef28e7b627cbaaa48c

$ podman start --attach -l
hi

$ podman inspect -l --format '{{ .Id }}'
5649a881c12fd26e34febce00887329a9031164733490aef28e7b627cbaaa48c

$ podman rm -l
5649a881c12fd26e34febce00887329a9031164733490aef28e7b627cbaaa48c</code></pre>

<p>You could even do this in a script. At first, I did not like this because it theoretically could be racey. If some other container is created between my creation and inspection, I could end up inspecting a different container. But usually, I am sitting on my own system and just working with the same container over and over, and the <code>--latest</code> option is a great time saver.</p>

<p>Bottom line, I use the <code>-l</code> option all the time now. Unfortunately, we don't support <code>-l</code> on remote, which means you are out of luck if you are on a Mac.</p>

<p><strong><em>[ Learn what it takes to develop cloud-native applications using modern tools such as microservices. Download the eBook <a href="https://developers.redhat.com/e-books/kubernetes-native-microservices-quarkus-and-microprofile?intcmp=701f20000012ngPAAQ" target="_blank">Kubernetes Native Microservices with Quarkus and MicroProfile</a>. ] </em></strong></p>

<h2>2. The --replace flag</h2>

<p>I was at a talk a couple of weeks ago with one of our engineers, <a href="https://www.redhat.com/sysadmin/users/valentin-rothberg" target="_blank">Valentin Rothberg</a>, and he was doing a demonstration. He ran a container with the <code>--replace</code> option. I had never noticed that this option existed, and when I looked it up, I realized it was a game-changer for me:</p>

<pre>
<code class="language-bash">$ man podman run
…
   --replace
   	If another container with the same name already exists, replace and remove it. The default is false.</code></pre>

<p>Eureka! Have you ever run a container with the <code>--name</code> option and then screwed up the command line option somewhere? The container runs, but it is not what you want:</p>

<pre>
<code class="language-bash">$ podman run --name test ubi8 echo hello
hello</code></pre>

<p>Oops. I mean to say <em>goodbye</em>:</p>

<pre>
<code class="language-bash">$ podman run --name test ubi8 echo goodbye
Error: error creating container storage: the container name "test" is already in use by "bd0aff185153c8ae63a876da3fab3010ffdbae5e0413340a62482a49da077336". You have to remove that container to be able to reuse that name.: that name is already in use</code></pre>

<p>Oh no, now I need to remove the container:</p>

<pre>
<code class="language-bash">$ podman run --replace --name test ubi8 echo hi
672bcfe2dee6c871f9f8fa8a8a17a8863adff3e322fc282f13fd2c076175620a
hi</code></pre>

<p>The <code>--replace</code> option builds this operation all into a single command:</p>

<pre>
<code class="language-bash">$ podman run --replace --name test ubi8 echo goodbye
672bcfe2dee6c871f9f8fa8a8a17a8863adff3e322fc282f13fd2c076175620a
d3d1d23782a0daf95654c6b9dbdb3c29c60a0943c0d96d5acfb60bb23b44aaee
goodbye</code></pre>

<p>This option brings me joy.</p>

<h2>3. The --all flag</h2>

<p>The <code>--all</code> option is also something that I believe you will "all" find useful.</p>

<p>If you google <em>How to stop all Docker containers</em>, you end up with a command like:</p>

<pre>
<code class="language-bash"># docker stop $(docker ps -aq)</code></pre>

<p>If you ask, <em>How do I remove all Docker containers?</em> the command is:</p>

<pre>
<code class="language-bash"># docker rm $(docker ps -aq)</code></pre>

<p>Or, <em>How do I remove all Docker images?</em> this command appears:</p>

<pre>
<code class="language-bash"># docker rmi $(docker images -q)</code></pre>

<p>Yikes, do you have to run a couple of weird Docker commands in a subshell and then execute a parent <code>docker</code> command to actually stop or remove the objects?</p>

<p>If you google <em>How to stop all Podman containers,</em> then this command is shown:</p>

<pre>
<code class="language-bash">$ podman stop --all</code></pre>

<p>Or, <em>How do I remove all Podman containers?</em></p>

<pre>
<code class="language-bash">$ podman rm --all</code></pre>

<p>And what about, <em>How do I remove all Podman images?</em></p>

<pre>
<code class="language-bash">$ podman rmi --all</code></pre>

<p>You can remove all containers even if they are running with the Podman command below:</p>

<pre>
<code class="language-bash">$ podman rm --all -t 0 --force</code></pre>

<p>The <code>--force</code> option tells Podman to stop running containers before removing them, and the <code>-t</code> option tells Podman to immediately send the <code>SIGKILL</code> option to running containers.</p>

<p>That shows why I'm "ALL IN" with the <code>--all</code> option. It's just pretty darn useful.</p>

<p><strong><em>[ Download the white paper <a href="https://www.redhat.com/en/resources/layered-approach-container-kubernetes-security-whitepaper?intcmp=701f20000012ngPAAQ" target="_blank">A layered approach to container and Kubernetes security</a>. ]</em></strong></p>

<h2>4. The --ignore flag</h2>

<p>Have you ever wanted to remove a group of containers, and you type in:</p>

<pre>
<code class="language-bash">$ podman rm test1 test2 test3</code></pre>

<p>And get:</p>

<pre>
<code class="language-bash">Error: no container with name or ID "test1" found: no such container</code></pre>

<p>Sometimes this is an error, or perhaps some other process removed <strong>test1</strong>, but <strong>test2</strong> and <strong>test3</strong> still exist. Now you have to edit the command and remove <strong>test1</strong>. What happens if this happens in a script? Bottom line, you want <strong>test1</strong>, <strong>test2</strong>, and <strong>test3</strong> gone. You don't care if one of them is already gone.</p>

<p>The Podman team added a <code>--ignore</code> command, which tells Podman to ignore errors when the object does not exist:</p>

<pre>
<code class="language-bash">$ podman rm --ignore test1 test2 test3
0b739832988300aba6d4423e1cf96d7fc7bc6203543ef4531ba248968800c510
d4ece4d41d0f37e124c46f9436e8569d1fa585e7907f950072ac0ecd688bafb5</code></pre>

<p>All of the <code>podman rm*</code> commands have the <code>--ignore</code> option. I believe this makes scripting commands a lot easier.</p>

<h2>5. The --tz flag</h2>

<p>Have you ever run a containerized application and found the time zone is wrong?</p>

<pre>
<code class="language-bash">$ podman run ubi8 date
Thu Feb 3 19:20:31 UTC 2022</code></pre>

<p>Wait, I don't live in England! Why is the time zone set to UTC? Container images have their time zone set within the image. Most images just default to UTC, which works great if you live at the prime meridian, but what about the rest of us?</p>

<p>Podman has a <code>--tz</code> option to set the time zone:</p>

<pre>
<code class="language-bash">$ podman run --tz=local fedora date
Thu Feb 3 14:21:01 EST 2022</code></pre>

<p>Perfect, I live in Massachusetts, now my time zone is correct. The <code>--tz=local</code> option tells Podman to set the time zone based on the local system's time zone where Podman is running.</p>

<p>You can also pick out any time zone file listed in your system's <code>/usr/share/zoneinfo</code> directory:</p>

<pre>
<code class="language-bash">$ podman run --tz=Iceland fedora date
Thu Feb 3 19:20:55 GMT 2022</code></pre>

<p>If you want to modify any container you create with a time zone automatically, you can just add a <code>timezone.conf</code> file on your system in <code>/etc/containers/containers.conf.d</code> or <code>$HOME/.config/containers/containers.conf.d</code> that looks like this:</p>

<pre>
<code class="language-bash">$ cat $HOME/.config/containers/containers.conf.d/timezone.conf
[containers]
tz=”local”</code></pre>

<p>And now Podman will use that time zone in all of its containers:</p>

<pre>
<code class="language-bash">$ podman run fedora date
Thu Feb 3 14:30:41 EST 2022</code></pre>

<h2>Wrap up</h2>

<div data-embed-button="resource_list" data-entity-embed-display="view_mode:resource_list.link" data-entity-type="resource_list" data-entity-uuid="dae9de57-962d-4c70-a7f0-b5eda7100a3d" data-langcode="en" class="align-right embedded-entity embedded-entity--resources embedded-entity--resources--link"><aside id="resource-list-more-about-automation" class="eck-entity mt-2 py-3 pr-3 border-top border-danger"><h2 class="h4">
      More about automation
  </h2>

<ul class="pl-3 mb-0"><li class="my-2"><a href="https://www.ansible.com/resources/get-started?intcmp=701f20000012ngPAAQ">An introduction to Ansible</a></li>
      <li class="my-2"><a href="https://www.redhat.com/en/technologies/management/ansible/try-it?intcmp=701f20000012ngPAAQ">Try Ansible Automation Platform for free</a></li>
      <li class="my-2"><a href="https://www.redhat.com/en/events/webinar/ansible-101-an-introduction-to-automating-everything-with-training?intcmp=701f20000012ngPAAQ">Ansible 101: An introduction to automating everything with training</a></li>
      <li class="my-2"><a href="https://www.redhat.com/en/engage/system-administrator-guide-s-202107300146?intcmp=701f20000012ngPAAQ">A system administrator's guide to IT automation</a></li>
      <li class="my-2"><a href="https://www.ansible.com/resources/ebooks?intcmp=701f20000012ngPAAQ">Free Ansible eBooks</a></li>
  </ul></aside></div>
<p>These are just simple options added to Podman that I believe make the user experience better and more straightforward. Watch for more articles from the Podman team as we continue to show off the great new features of Podman 3.0. And feel free to submit an article to Enable Architect about your favorite new (or old) features. Email your article idea to <a href="mailto:enable-sysadmin@redhat.com">enable-sysadmin@redhat.com</a>. </p>

<h3>Quick reference</h3>

<ul><li><code>--latest</code> (<code>-l</code>): Apply the command to the latest container.</li>
	<li><code>--replace</code>: Remove the previously named container and create a new container with the same name.</li>
	<li><code>--all</code>: Perform the command on all Podman objects, containers, images, pods, networks, etc.</li>
	<li><code>--ignore</code>: Remove the container object and ignore errors when the object does not exist.</li>
	<li><code>--tz</code>: Set the time zone inside the container.</li>
</ul></div>
      
  
  </div>

  <div class="views-element-container block">

  
    

      <div><div class="listicle-view js-view-dom-id-7940ed038d3580e67b4a518a9ebefc7e2909a4806c922e3a3f0261582d056fcf">
  
  
  

  
  
  

    <h3>Check out these related articles on Enable Sysadmin</h3>
    <div class="listicle-row"><div class="views-field views-field-field-listicle"><div class="field-content"><article data-history-node-id="4091" role="article" about="/sysadmin/replace-docker-podman-macos" typeof="schema:Article" id="node--article--4091" class="listicle listicle--article node node--promoted">
  <div class="row align-items-center">
    <div class="col-md-6 listicle-image">
            <div class="article__field-media"><div>
  
  
  <div data-blazy="" class="blazy blazy--field blazy--field-media-image blazy--field-media-image--block-1 blazy--view blazy--view--listicle blazy--view--listicle--block-1 image__field-media-image">
    <div class="field__label font-weight-bold visually-hidden">
      Image    </div>
                  <div class="field__item">



                  <div class="media media--blazy media--bundle--image media--loading is-b-loading media--image">
<img alt="How to replace Docker with Podman on MacOS" class="media__image media__element b-lazy img-fluid" data-src="/sysadmin/sites/default/files/styles/card/public/2021-03/Pod.jpg?itok=wCxyVLbS" src="data:image/svg+xml;charset=utf-8,%3Csvg%20xmlns%3D&#039;http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg&#039;%20viewBox%3D&#039;0%200%20700%20420&#039;%2F%3E" width="700" height="420" loading="lazy" typeof="foaf:Image" />
        </div>
        
  
</div>
              </div>

</div>
</div>
      </div>
    <div class="col-md-6 listicle-body">
      <div class="h4 listicle-title pt-4 pt-md-0"><a href="/sysadmin/replace-docker-podman-macos"><span property="schema:name">How to replace Docker with Podman on a Mac</span>
</a></div>
      <div class="listicle-text font-weight-light py-2">
        
            <div property="schema:text" class="clearfix article__body">Want to use Podman to work with containers? Here's what you need to know about Podman on a Mac.</div>
      
      </div>

      <div class="listicle-footer">
        <div class="article-date">
          <span class="label">Posted:</span>
          January 26, 2022
        </div>
        <div class="article-authors">
                      <span class="label">Author:</span>
                                <a href="/sysadmin/users/dmeurerredhatcom" class="article-author article-author--primary">Dave Meurer<span class="author-affiliate"> (Red Hat)</span></a>                  </div>
      </div>
    </div>
  </div>
</article>
<article data-history-node-id="5626" role="article" about="/sysadmin/update-container-images-podman" typeof="schema:Article" id="node--article--5626" class="listicle listicle--article node node--promoted">
  <div class="row align-items-center">
    <div class="col-md-6 listicle-image">
            <div class="article__field-media"><div>
  
  
  <div data-blazy="" class="blazy blazy--field blazy--field-media-image blazy--field-media-image--block-1 blazy--view blazy--view--listicle blazy--view--listicle--block-1 image__field-media-image">
    <div class="field__label font-weight-bold visually-hidden">
      Image    </div>
                  <div class="field__item">



                  <div class="media media--blazy media--bundle--image media--loading is-b-loading media--image">
<img alt="Container ships docked" class="media__image media__element b-lazy img-fluid" data-src="/sysadmin/sites/default/files/styles/card/public/2020-12/3-container-ships.jpg?itok=9xYWHCzF" src="data:image/svg+xml;charset=utf-8,%3Csvg%20xmlns%3D&#039;http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg&#039;%20viewBox%3D&#039;0%200%20700%20420&#039;%2F%3E" width="700" height="420" loading="lazy" typeof="foaf:Image" />
        </div>
        
  
</div>
              </div>

</div>
</div>
      </div>
    <div class="col-md-6 listicle-body">
      <div class="h4 listicle-title pt-4 pt-md-0"><a href="/sysadmin/update-container-images-podman"><span property="schema:name">How to update container images with Podman</span>
</a></div>
      <div class="listicle-text font-weight-light py-2">
        
            <div property="schema:text" class="clearfix article__body">Keeping your images current is standard procedure for operating and managing a containerized environment. Here's how to do it.</div>
      
      </div>

      <div class="listicle-footer">
        <div class="article-date">
          <span class="label">Posted:</span>
          February 8, 2022
        </div>
        <div class="article-authors">
                      <span class="label">Author:</span>
                                <a href="/sysadmin/users/alexon-oliveira" class="article-author article-author--primary">Alexon Oliveira<span class="author-affiliate"> (Red Hat, Sudoer)</span></a>                  </div>
      </div>
    </div>
  </div>
</article>
<article data-history-node-id="5231" role="article" about="/sysadmin/sensitive-data-containers" typeof="schema:Article" id="node--article--5231" class="listicle listicle--article node node--promoted">
  <div class="row align-items-center">
    <div class="col-md-6 listicle-image">
            <div class="article__field-media"><div>
  
  
  <div data-blazy="" class="blazy blazy--field blazy--field-media-image blazy--field-media-image--block-1 blazy--view blazy--view--listicle blazy--view--listicle--block-1 image__field-media-image">
    <div class="field__label font-weight-bold visually-hidden">
      Image    </div>
                  <div class="field__item">



                  <div class="media media--blazy media--bundle--image media--loading is-b-loading media--image">
<img alt="Securing SNMP" class="media__image media__element b-lazy img-fluid" data-src="/sysadmin/sites/default/files/styles/card/public/2019-11/Locked%20Cropped.jpg?itok=vlf4RkhT" src="data:image/svg+xml;charset=utf-8,%3Csvg%20xmlns%3D&#039;http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg&#039;%20viewBox%3D&#039;0%200%20700%20420&#039;%2F%3E" width="700" height="420" loading="lazy" typeof="foaf:Image" />
        </div>
        
  
</div>
              </div>

</div>
</div>
      </div>
    <div class="col-md-6 listicle-body">
      <div class="h4 listicle-title pt-4 pt-md-0"><a href="/sysadmin/sensitive-data-containers"><span property="schema:name">Using sensitive data in containers</span>
</a></div>
      <div class="listicle-text font-weight-light py-2">
        
            <div property="schema:text" class="clearfix article__body">New Podman secrets features allow users to fine-tune their secrets settings to their liking. </div>
      
      </div>

      <div class="listicle-footer">
        <div class="article-date">
          <span class="label">Posted:</span>
          November 3, 2021
        </div>
        <div class="article-authors">
                      <span class="label">Author:</span>
                                <a href="/sysadmin/users/acui" class="article-author article-author--primary">Ashley Cui<span class="author-affiliate"> (Red Hat)</span></a>                  </div>
      </div>
    </div>
  </div>
</article>
</div></div></div>

    

  
  

  
  
</div>
</div>

  
  </div>

  <div class="block">

  
    

      <div class="topics">
  <strong>Topics:</strong>&nbsp;&nbsp;
      <a href="/sysadmin/topics/podman" class="btn btn-primary btn-sm font-weight-bold">Podman</a>&nbsp;&nbsp;
      <a href="/sysadmin/topics/containers" class="btn btn-primary btn-sm font-weight-bold">Containers</a>&nbsp;&nbsp;
  </div>
  
  </div>

    </div>
  </div>
</div>
<div >
  <div >
    
  <div class="block">

  
    

      
<section data-history-node-id="5691" role="article" about="/sysadmin/podman-features-1" typeof="schema:Article" id="node--article--5691" class="section my-5 py-5 bg-light-gray authors-bio authors-bio--article">
  <div class="container">
          <div class="row">
        <div class="col-md-2 text-center">
                      
<img alt="Author’s photo" data-affiliation="Red Hat" src="/sysadmin/sites/default/files/styles/user_picture_square/public/pictures/2019-10/DanWalsh.jpg?itok=YkqGIoHm" width="240" height="240" loading="lazy" typeof="foaf:Image" class="rounded-circle img-fluid" />


          
        </div>
        <div class="col-md-10 col-lg-8">
          <h2 class="font-weight-light text-center text-md-left">
                          Dan Walsh
                      </h2>
          <div>
                          <p>
                Daniel Walsh has worked in the computer security field for over 30 years. Dan is a Consulting Engineer at Red Hat. He joined Red Hat in August 2001. Dan leads the Red Hat Container Engineering team since August 2013, but has been working on container technology for several years.
                                  <a href="/sysadmin/users/dwalsh" class="author-more-link">More about me</a>
                              </p>
                      </div>
        </div>
      </div>
      </div>
</section>



  
  </div>

  <div class="block">

  
    

      

  
  </div>

  </div>
</div>
<div >
  <div >
    

  <div class="block block--cta cta cta--red-on-black cta-- my-5 p-3 text-center">

  
    

    <div class="d-md-flex justify-content-around align-items-center flex-wrap">
    <div class="cta__content my-2">
      
            <div class="cta__field-content p-2"><h4>On Demand: Red Hat Summit 2021 Virtual Experience</h4>

<p>Relive our April event with demos, keynotes, and technical sessions from<br />
experts, all available on demand.</p>
</div>
      
    </div>
        <div class="cta__link my-2">
      <a
        href="https://www.redhat.com/en/summit?intcmp=7013a0000026RhqAAE"
        target="_blank"
        class="btn btn-lg btn-danger font-weight-bold">
        Watch Now
      </a>
    </div>
      </div>
  
  </div>

  </div>
</div>
<div  class="section">
  <div class="container">
    <div >
      
  <div class="views-element-container block">

  
    

      <div><div class="js-view-dom-id-a542a2901a564210af564de0f847c7ec0e0abfa561603211439bacbaf2d9bb99">
  
  
  

  
  
  

    <h2>Related Content</h2>
                        <div class="card-deck my-4">
                        <article data-history-node-id="5661" role="article" about="/sysadmin/rootless-podman-jenkins-openshift" typeof="schema:Article" id="node--article--5661" class="card card--article node node--promoted">
      <div class="card-img-top">
            <div class="article__field-media"><div>
  
  
  <div data-blazy="" class="blazy blazy--field blazy--field-media-image blazy--field-media-image--card image__field-media-image">
    <div class="field__label font-weight-bold visually-hidden">
      Image    </div>
                  <div class="field__item">



                  <div class="media media--blazy media--bundle--image media--loading is-b-loading media--responsive media--image">  
<img class="media__image media__element b-lazy b-responsive img-fluid" data-src="/sysadmin/sites/default/files/styles/card/public/2020-06/rootless-rocks.jpg?itok=nWMdq0ci" srcset="" data-srcset="/sysadmin/sites/default/files/styles/card/public/2020-06/rootless-rocks.jpg?itok=nWMdq0ci 1x" src="data:image/svg+xml;charset=utf-8,%3Csvg%20xmlns%3D&#039;http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg&#039;%20viewBox%3D&#039;0%200%201000%20600&#039;%2F%3E" alt="Tree roots on a rock wall" typeof="foaf:Image" loading="lazy" />

        </div>
        
  
</div>
              </div>

</div>
</div>
      </div>
    <div class="card-body">
    <div class="h4 card-title"><a href="/sysadmin/rootless-podman-jenkins-openshift"><span property="schema:name">How to build images with rootless Podman in Jenkins on OpenShift</span>
</a></div>
    <div class="card-text">
            <div property="schema:text" class="clearfix article__body">It requires some configuration, but a rootless user can use Jenkins to create OCI-compliant images on OpenShift.</div>
      </div>
  </div>
  <div class="card-footer">
    <div class="article-date">
      <span class="label">Posted:</span>
      February 14, 2022
    </div>
    <div class="article-authors">
              <span class="label">Author:</span>
                    <a href="/sysadmin/user/708866" class="article-author article-author--primary">Evan "Hippy" Slatis<span class="author-affiliate"> (Red Hat)</span></a>          </div>
  </div>
</article>


                            <article data-history-node-id="5651" role="article" about="/sysadmin/top-sysadmin-articles-january-2022" typeof="schema:Article" id="node--article--5651" class="card card--article node node--promoted">
      <div class="card-img-top">
            <div class="article__field-media"><div>
  
  
  <div data-blazy="" class="blazy blazy--field blazy--field-media-image blazy--field-media-image--card image__field-media-image">
    <div class="field__label font-weight-bold visually-hidden">
      Image    </div>
                  <div class="field__item">



                  <div class="media media--blazy media--bundle--image media--loading is-b-loading media--responsive media--image">  
<img class="media__image media__element b-lazy b-responsive img-fluid" data-src="/sysadmin/sites/default/files/styles/card/public/2022-01/snow-road-mountains-december.jpg?itok=Ni8QgPht" srcset="" data-srcset="/sysadmin/sites/default/files/styles/card/public/2022-01/snow-road-mountains-december.jpg?itok=Ni8QgPht 1x" src="data:image/svg+xml;charset=utf-8,%3Csvg%20xmlns%3D&#039;http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg&#039;%20viewBox%3D&#039;0%200%201000%20600&#039;%2F%3E" alt="Snowy mountain road" typeof="foaf:Image" loading="lazy" />

        </div>
        
  
</div>
              </div>

</div>
</div>
      </div>
    <div class="card-body">
    <div class="h4 card-title"><a href="/sysadmin/top-sysadmin-articles-january-2022"><span property="schema:name">Speed up your Ansible playbooks, create quick containers, and more tips for sysadmins</span>
</a></div>
    <div class="card-text">
            <div property="schema:text" class="clearfix article__body">Check out Enable Sysadmin's top 10 articles from January 2022.</div>
      </div>
  </div>
  <div class="card-footer">
    <div class="article-date">
      <span class="label">Posted:</span>
      February 8, 2022
    </div>
    <div class="article-authors">
              <span class="label">Author:</span>
                    <a href="/sysadmin/users/vwalker" class="article-author article-author--primary">Vicki Walker<span class="author-affiliate"> (Red Hat)</span></a>          </div>
  </div>
</article>


                            <article data-history-node-id="5626" role="article" about="/sysadmin/update-container-images-podman" typeof="schema:Article" id="node--article--5626" class="card card--article node node--promoted">
      <div class="card-img-top">
            <div class="article__field-media"><div>
  
  
  <div data-blazy="" class="blazy blazy--field blazy--field-media-image blazy--field-media-image--card image__field-media-image">
    <div class="field__label font-weight-bold visually-hidden">
      Image    </div>
                  <div class="field__item">



                  <div class="media media--blazy media--bundle--image media--loading is-b-loading media--responsive media--image">  
<img class="media__image media__element b-lazy b-responsive img-fluid" data-src="/sysadmin/sites/default/files/styles/card/public/2020-12/3-container-ships.jpg?itok=9xYWHCzF" srcset="" data-srcset="/sysadmin/sites/default/files/styles/card/public/2020-12/3-container-ships.jpg?itok=9xYWHCzF 1x" src="data:image/svg+xml;charset=utf-8,%3Csvg%20xmlns%3D&#039;http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg&#039;%20viewBox%3D&#039;0%200%201000%20601&#039;%2F%3E" alt="Container ships docked" typeof="foaf:Image" loading="lazy" />

        </div>
        
  
</div>
              </div>

</div>
</div>
      </div>
    <div class="card-body">
    <div class="h4 card-title"><a href="/sysadmin/update-container-images-podman"><span property="schema:name">How to update container images with Podman</span>
</a></div>
    <div class="card-text">
            <div property="schema:text" class="clearfix article__body">Keeping your images current is standard procedure for operating and managing a containerized environment. Here's how to do it.</div>
      </div>
  </div>
  <div class="card-footer">
    <div class="article-date">
      <span class="label">Posted:</span>
      February 8, 2022
    </div>
    <div class="article-authors">
              <span class="label">Author:</span>
                    <a href="/sysadmin/users/alexon-oliveira" class="article-author article-author--primary">Alexon Oliveira<span class="author-affiliate"> (Red Hat, Sudoer)</span></a>          </div>
  </div>
</article>


                              </div>
            
    

  
  

  
  
</div>
</div>

  
  </div>

    </div>
  </div>
</div>
<div  class="section my-5 pb-5 narrow">
  <div class="container">
    <div >
      
    </div>
  </div>
</div>
<div  class="section my-5 pb-5 ">
  <div class="container">
    <div >
      

  <div class="block block--cta cta cta--red-on-black cta-- my-5 p-3 text-center">

  
    

    <div class="d-md-flex justify-content-around align-items-center flex-wrap">
    <div class="cta__content my-2">
      
            <div class="cta__field-content p-2"><p class="h4 mb-4 mt-3 font-weight-bold">OUR BEST CONTENT, DELIVERED TO YOUR INBOX</p>

<p><iframe title="Subscribe to our newsletter" aria-label="Embedded form to subscribe to our email newsletter" frameborder="0" height="50" scrolling="no" src="/sysadmin/eloqua-embedded-subscribe.html?offer_id=701f20000012gE7AAI" style="max-width:670px;margin:0 auto;" width="100%"></iframe></p>
</div>
      
    </div>
      </div>
  
  </div>

    </div>
  </div>
</div>

  </article>

  
  </div>


              </div>
        </main>

            <footer>
              <div class="page__colophon bg-dark-gray py-4 bg-dark-gray">
          <div class="container">
              
  <div class="block block--basic block--sysadmin-colophon-disclaimer">

  
    

      
            <div class="basic__body"><p>The opinions expressed on this website are those of each author, not of the author's employer or of Red Hat. The content published on this site are community contributions and are for informational purpose only AND ARE NOT, AND ARE NOT INTENDED TO BE, RED HAT DOCUMENTATION, SUPPORT, OR ADVICE.</p>

<p>Red Hat and the Red Hat logo are trademarks of Red Hat, Inc., registered in the United States and other countries.</p>
</div>
      
  
  </div>


          </div>
        </div>
                    <div class="page__footer bg-dark py-3">
        <div class="container">
          <div class="d-sm-flex justify-content-between align-items-center">
              

  
    

    
  <a href="https://www.redhat.com/" class="navbar-brand mr-0 mr-lg-auto mb-3 mb-sm-0">
            <img src="/sysadmin/themes/custom/sysadmin/logo.svg" width="135" height="31" class="d-inline-block align-top" alt="Red Hat logo" />

        
  </a>



  <div class="block block--basic block--copyright my-0 mx-sm-3 mb-1 mb-sm-0">

  
    

      
            <div class="basic__body"><p>Copyright ©2022 Red Hat, Inc.</p>
</div>
      
  
  </div>

  <div class="block block--sysadmin-footer my-0 mb-1 mb-sm-0">

  
    

      
  


  <ul class="nav d-flex d-sm-block d-md-flex justify-content-center align-items-center">
                                          <li class="nav-item  ">
                      <a href="https://www.redhat.com/en/about/privacy-policy" class="nav-link">Privacy Policy</a>
                  </li>
                                      <li class="nav-item  ">
                      <a href="https://www.redhat.com/en/about/terms-use" class="nav-link">Terms of Use</a>
                  </li>
                                      <li class="nav-item  ">
                      <a href="https://www.redhat.com/en/about/all-policies-guidelines" class="nav-link">All policies and guidelines</a>
                  </li>
            </ul>


  
  </div>

  <div class="block block--basic block--footerredhatsummit">

  
    

      
            <div class="basic__body"><div style="margin-left: 1rem"><a href="https://www.redhat.com/en/summit?intcmp=7013a0000026RhqAAE" target="_blank"><img alt="Red Hat Summit" src="https://www.redhat.com/cms/managed-files/Logo-Red_Hat-Summit-A-Standard-RGB-02_0.svg" width="72px" /></a></div>
</div>
      
  
  </div>

  <div class="block block--sharelinks">

  
    

      <div class="a2a_kit a2a_kit_size_32 a2a_floating_style a2a_vertical_style" data-a2a-url="https://www.redhat.com/sysadmin/podman-features-1">
  <a class="a2a_button_twitter"></a>
  <a class="a2a_button_facebook"></a>
  <a class="a2a_button_linkedin"></a>
  <a class="a2a_button_reddit"></a>
  <a class="a2a_button_email"></a>
</div>
<div class="a2a_kit a2a_kit_size_32 a2a_floating_style a2a_default_style">
  <a class="a2a_button_twitter"></a>
  <a class="a2a_button_facebook"></a>
  <a class="a2a_button_linkedin"></a>
  <a class="a2a_button_reddit"></a>
  <a class="a2a_button_email"></a>
</div>

<script>
  var a2a_config = a2a_config || {};
  a2a_config.templates = a2a_config.templates || {};
  a2a_config.templates.twitter = {
    text: "5 Podman features to try now https://red.ht/3GQsfcM via #EnableSysadmin by @rhatdan",
  };
    a2a_config.templates.facebook = {
    hashtag: "#EnableSysadmin",
  };
  </script>

  
  </div>


  <div class="block block--cta block--ctasubscribesidebar cta cta--blue-on-white cta-- my-5 p-3 text-center">

  
    

    <div class="d-md-flex justify-content-around align-items-center flex-wrap">
    <div class="cta__content my-2">
      
            <div class="cta__field-content p-2"><div class="subscribe-sidebar">
<div class="target-band-never-show-button">x</div>

<h4>Subscribe now</h4>

<p class="eloqua-email-capture-text">Get the highlights in your inbox every week.</p>

<p><iframe aria-label="Embedded form to subscribe to our email newsletter" frameborder="0" height="50" scrolling="no" src="/sysadmin/eloqua-embedded-email-capture-block.html?offer_id=701f20000012gE7AAI" style="max-width:670px;margin:0 auto;" title="Subscribe to our newsletter" width="100%"></iframe></p>
</div>
</div>
      
    </div>
      </div>
  
  </div>


          </div>
        </div>
            </footer>
      </div>

  </div>


<script type="application/json" data-drupal-selector="drupal-settings-json">{"path":{"baseUrl":"\/sysadmin\/","scriptPath":null,"pathPrefix":"","currentPath":"node\/5691","currentPathIsAdmin":false,"isFront":false,"currentLanguage":"en"},"pluralDelimiter":"\u0003","suppressDeprecationErrors":true,"ckeditorheight":{"offset":1,"line_height":1.5,"unit":"em","disable_autogrow":null},"colorbox":{"opacity":"0.85","current":"{current} of {total}","previous":"\u00ab Prev","next":"Next \u00bb","close":"Close","maxWidth":"98%","maxHeight":"98%","fixed":true,"mobiledetect":true,"mobiledevicewidth":"480px"},"blazy":{"loadInvisible":false,"offset":100,"saveViewportOffsetDelay":50,"validateDelay":25},"blazyIo":{"enabled":false,"disconnect":false,"rootMargin":"0px","threshold":[0]},"user":{"uid":0,"permissionsHash":"51f347f394db8c9bda75fb2a6f2d406a82353e6cfb9faf5ace3100b98d716870"}}</script>
<script src="/sysadmin/sites/default/files/js/js_qIDgH_1Ntr3oybBWS5Dii3UJ8C3X9Nh-0RbMnncIcGE.js"></script>

  <script type="text/javascript">
    if (("undefined" !== typeof _satellite) && ("function" === typeof _satellite.pageBottom)) {
      _satellite.pageBottom();
    }
  </script>
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam-cell.nr-data.net","licenseKey":"a03a21ae8a","applicationID":"1020017418","transactionName":"ZlNTbUBQDxZUWxJRVl8ZcFpGWA4LGnwUTUlQWm1XXVUEOXZXCExLXlpdXEBtLwpRXTBRXEZ1XldGQw4JWV0UFQdHX1RO","queueTime":0,"applicationTime":700,"atts":"ShRQGwhKHBg=","errorBeacon":"bam-cell.nr-data.net","agent":""}</script><script type="text/javascript"  src="/dfiU/yL2Z/OekS/gpkc/pw/5Vu7bJbXaX/PxVSYg/AAw/3DWliKAAB"></script></body>
</html>
