<!DOCTYPE html>
<html lang="en" dir="ltr" prefix="content: http://purl.org/rss/1.0/modules/content/  dc: http://purl.org/dc/terms/  foaf: http://xmlns.com/foaf/0.1/  og: http://ogp.me/ns#  rdfs: http://www.w3.org/2000/01/rdf-schema#  schema: http://schema.org/  sioc: http://rdfs.org/sioc/ns#  sioct: http://rdfs.org/sioc/types#  skos: http://www.w3.org/2004/02/skos/core#  xsd: http://www.w3.org/2001/XMLSchema# ">
<head>
<script id="dpal" src="https://www.redhat.com/ma/dpal.js"></script>
<meta charset="utf-8" />
<meta name="title" content="Getting started with regular expressions: An example | Enable Sysadmin" />
<link rel="canonical" href="https://www.redhat.com/sysadmin/getting-started-regular-expressions-example" />
<meta property="og:site_name" content="Enable Sysadmin" />
<meta name="twitter:card" content="photo" />
<meta name="dcterms.title" content="Getting started with regular expressions: An example" />
<meta name="twitter:title" content="Getting started with regular expressions: An example" />
<meta name="dcterms.creator" content="dboth" />
<meta name="description" content="Dive right into a regular expression example in this second of four regular expression articles." />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.redhat.com/sysadmin/getting-started-regular-expressions-example" />
<meta name="twitter:site:id" content="14627400" />
<meta property="og:title" content="Getting started with regular expressions: An example" />
<meta name="twitter:creator" content="@LinuxGeek46" />
<meta name="dcterms.publisher" content="Red Hat, Inc." />
<meta name="twitter:url" content="https://www.redhat.com/sysadmin/getting-started-regular-expressions-example" />
<meta name="twitter:image" content="https://www.redhat.com/sysadmin/sites/default/files/styles/full/public/2019-10/Starting_Line.jpg?itok=pmnNGf08" />
<meta name="twitter:image:width" content="600" />
<meta name="twitter:image:height" content="1000" />
<meta name="twitter:image:alt" content="Red Hat, Inc." />
<meta property="og:image" content="https://www.redhat.com/sysadmin/sites/default/files/styles/full/public/2019-10/Starting_Line.jpg?itok=pmnNGf08" />
<meta property="og:image:secure_url" content="https://www.redhat.com/sysadmin/sites/default/files/styles/full/public/2019-10/Starting_Line.jpg?itok=pmnNGf08" />
<meta name="dcterms.language" content="en" />
<meta property="og:image:type" content="image/jpeg" />
<meta property="og:video:width" content="600" />
<meta property="og:image:width" content="1000" />
<meta property="og:image:height" content="675" />
<meta property="og:image:alt" content="https://www.redhat.com/sysadmin/sites/default/files/styles/full/public/2019-10/Starting_Line.jpg?itok=pmnNGf08" />
<meta property="og:updated_time" content="2019-10-15T01:00:00+0000" />
<meta property="og:street_address" content="100 East Davie Street" />
<meta property="og:locality" content="Raleigh" />
<meta property="og:region" content="NC" />
<meta property="og:postal_code" content="27601" />
<meta property="og:country_name" content="United States" />
<meta property="og:phone_number" content="+1 919 754 4950" />
<meta property="og:fax_number" content="+1 919 800 3804" />
<meta property="og:locale" content="en_US" />
<meta property="article:author" content="https://www.redhat.com/sysadmin/users/dboth" />
<meta property="article:publisher" content="https://www.facebook.com/redhatinc" />
<meta property="article:section" content="Enable Sysadmin" />
<meta property="article:tag" content="Linux" />
<meta property="article:tag" content="Regular Expressions" />
<meta property="article:modified_time" content="2019-10-15T01:00:00+0000" />
<meta name="Generator" content="Drupal 8 (https://www.drupal.org)" />
<meta name="MobileOptimized" content="width" />
<meta name="HandheldFriendly" content="true" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<script type="application/ld+json">{
    "@context": "https://schema.org",
    "@graph": [
        {
            "@type": "TechArticle",
            "headline": "Getting started with regular expressions: An example",
            "name": "Getting started with regular expressions: An example",
            "about": [
                "Linux",
                "Regular Expressions"
            ],
            "description": "Dive right into a regular expression example in this second of four regular expression articles.",
            "image": {
                "@type": "ImageObject",
                "url": "https://www.redhat.com/sysadmin/sites/default/files/styles/full/public/2019-10/Starting_Line.jpg?itok=pmnNGf08",
                "width": "1000",
                "height": "600"
            },
            "dateModified": "2019-10-15T01:00:00+0000",
            "author": {
                "@type": "Person",
                "@id": "https://www.redhat.com/sysadmin/users/dboth",
                "name": "dboth",
                "url": "https://www.redhat.com/sysadmin/users/dboth",
                "sameAs": "https://twitter.com/LinuxGeek46"
            },
            "publisher": {
                "@type": "Organization",
                "@id": "https://www.redhat.com/"
            },
            "mainEntityOfPage": "https://www.redhat.com/sysadmin/getting-started-regular-expressions-example"
        },
        {
            "@type": "WebPage",
            "@id": "https://www.redhat.com/sysadmin/getting-started-regular-expressions-example",
            "publisher": {
                "@type": "Organization",
                "@id": "https://www.redhat.com/"
            }
        },
        {
            "@type": "Person",
            "name": "David Both",
            "sameAs": "https://twitter.com/LinuxGeek46",
            "image": {
                "@type": "ImageObject",
                "url": "https://www.redhat.com/sysadmin/sites/default/files/styles/user_picture_square/public/pictures/2019-05/david-crop.jpg?itok=imcvpdp0",
                "width": "240",
                "height": "240"
            }
        },
        {
            "@type": "Corporation",
            "@id": "https://www.redhat.com/",
            "name": "Red Hat, Inc.",
            "url": "https://www.redhat.com/",
            "sameAs": [
                "https://en.wikipedia.org/wiki/Red_Hat",
                "http://www.linkedin.com/company/red-hat",
                "http://www.youtube.com/user/RedHatVideos",
                "https://www.facebook.com/redhatinc",
                "https://twitter.com/RedHat"
            ],
            "telephone": "+1 919 754 4950",
            "contactPoint": {
                "@type": "ContactPoint",
                "telephone": "+1-888-RED-HAT1",
                "availableLanguage": "English",
                "contactType": "sales",
                "faxnumber": "+1 919 800 3804"
            },
            "logo": {
                "@type": "ImageObject",
                "url": "https://www.redhat.com/sysadmin/themes/custom/sysadmin/assets/images/red-hat-logo.png",
                "width": "254",
                "height": "60"
            },
            "address": {
                "@type": "PostalAddress",
                "streetAddress": "100 East Davie Street",
                "addressLocality": "Raleigh",
                "addressRegion": "NC",
                "postalCode": "27601",
                "addressCountry": "United States"
            }
        },
        {
            "@type": "WebSite",
            "@id": "https://www.redhat.com/sysadmin/",
            "name": "Enable Sysadmin",
            "url": "https://www.redhat.com/sysadmin/",
            "publisher": {
                "@type": "Organization",
                "@id": "https://www.redhat.com/"
            }
        }
    ]
}</script>
<link rel="shortcut icon" href="/sysadmin/themes/custom/sysadmin/favicon.ico" type="image/vnd.microsoft.icon" />
<link rel="revision" href="https://www.redhat.com/sysadmin/getting-started-regular-expressions-example" />
<link rel="apple-touch-icon" sizes="180x180" href="/sysadmin/themes/custom/sysadmin/assets/favicon/apple-touch-icon.png">
<link rel="icon" type="image/png" sizes="32x32" href="/sysadmin/themes/custom/sysadmin/assets/favicon/favicon-32x32.png">
<link rel="icon" type="image/png" sizes="16x16" href="/sysadmin/themes/custom/sysadmin/assets/favicon/favicon-16x16.png">
<link rel="manifest" href="/sysadmin/themes/custom/sysadmin/assets/favicon/site.webmanifest">
<link rel="mask-icon" href="/sysadmin/themes/custom/sysadmin/assets/favicon/safari-pinned-tab.svg" color="#ee0000">
<meta name="msapplication-TileColor" content="#1a1a1a">
<meta name="theme-color" content="#ffffff">
<title>Getting started with regular expressions: An example | Enable Sysadmin</title>
<link rel="stylesheet" media="all" href="/sysadmin/sites/default/files/css/css_y3Xr5G8fIRYFF5ceJ8PSWt5P0C14zqhCAJrGX41FquU.css?pz5tve" />
<link rel="stylesheet" media="all" href="/sysadmin/sites/default/files/css/css_TjGBCG78x5_q0XdCYHB7NlVjmDlAtmTGO28oOnKzjrk.css?pz5tve" />


<!--[if lte IE 8]>
<script src="/sysadmin/sites/default/files/js/js_VtafjXmRvoUgAzqzYTA3Wrjkx9wcWhjP0G4ZnnqRamA.js"></script>
<![endif]-->


</head>
<body>
<a href="#main-content" class="visually-hidden focusable">
Skip to main content
</a>

  <div class="dialog-off-canvas-main-canvas" data-off-canvas-main-canvas>
    

<div class="redhat-cookie-banner">
<section id="redhat-cookie-privacy-banner" class="redhat-cookie-banner-wrapper" style="display: block;">
  <div class="container my-3 pr-5">
    <p>We use cookies on our websites to deliver our online services. Details about how we use cookies and how you may disable them are set out in our <a href="http://www.redhat.com/en/about/privacy-policy#cookies">Privacy Statement</a>. By using this website you agree to our use of cookies.
    <span class="cookie-more">
    <a id="redhat-cookie-privacy-banner-close" href="javascript:void(0);" class="cookie-close">&times;</a>
    </span>
    </p>
  </div>
</section>
</div>

<div class="page">

  <div class="navbar navbar-expand-lg justify-content-between navbar-dark bg-dark">
    <div class="container">
                
  <div class="block block--sysadmin-navbar-branding">

  
    

    
  <a href="https://www.redhat.com/" class="navbar-brand ">
            <img src="/sysadmin/themes/custom/sysadmin/logo.svg" width="135" height="31" class="d-inline-block align-top" alt="Red Hat logo" />

        
  </a>


  </div>


      
      <div>
        <button class="navbar-toggler" type="button" data-toggle="collapse"  data-parent="#collapse-parent" data-target="#search-collapse" aria-controls="search-collapse" aria-expanded="false" aria-label="Toggle search">
          <svg class="icon-collapsed" width="30" height="30" viewBox="0 0 30 30" xmlns="http://www.w3.org/2000/svg"><line x1="18.95" y1="19.15" x2="25.25" y2="25.75"/><circle cx="13.25" cy="12.75" r="8.5"/></svg>
          <svg class="icon-expanded" width="30" height="30" viewBox="0 0 30 30" xmlns="http://www.w3.org/2000/svg"><line x1="7.25" y1="7.25" x2="22.75" y2="22.75"/><line x1="7.25" y1="22.75" x2="22.75" y2="7.25"/></svg>
          <span style="vertical-align: middle;">Search</span>
        </button>
        <button class="navbar-toggler" type="button" data-toggle="collapse" data-parent="#collapse-parent" data-target="#mobilenav-collapse" aria-controls="mobilenav-collapse" aria-expanded="false" aria-label="Toggle navigation">
          <svg class="icon-collapsed" width="30" height="30" viewBox="0 0 30 30" xmlns="http://www.w3.org/2000/svg"><path d="M4 7h22M4 15h22M4 23h22"/></svg>
          <svg class="icon-expanded" width="30" height="30" viewBox="0 0 30 30" xmlns="http://www.w3.org/2000/svg"><line x1="7.25" y1="7.25" x2="22.75" y2="22.75"/><line x1="7.25" y1="22.75" x2="22.75" y2="7.25"/></svg>
        </button>
      </div>
    </div>
  </div>

  <div id="collapse-parent">
    <div id="search-collapse" class="search-collapse collapse" data-parent="#collapse-parent">
      <div class="py-4 px-3">
        <form class="form-inline m-2" action="/sysadmin/search/node" accept-charset="UTF-8" method="get">
          <div class="input-group flex-fill">
            <input class="form-control" type="search" name="keys" id="search" value="" placeholder="Search this site…" aria-label="Search this site…">
            <div class="input-group-append">
              <button class="btn btn-secondary font-weight-bold" type="submit">Search</button>
            </div>
          </div>
        </form>
      </div>
    </div>

    <div id="mobilenav-collapse" class="mobilenav-collapse d-lg-none collapse" data-parent="#collapse-parent">
                
  <div class="block block--sysadmin-navbar-sitename sitename">

  
    

    
  <a href="/sysadmin/" class="navbar-brand sitename">
        Enable Sysadmin
  </a>

  <span class="d-none d-lg-inline ml-1 mr-3 h5 navbar-sitename-divider">&nbsp;</span>

  </div>

  <div class="block block--sysadmin-main-menu">

  
    

      
  


  <ul class="nav navbar-nav">
                                  <li class="nav-item  dropdown">
                      <a href="/sysadmin/" class="nav-link dropdown-toggle" data-toggle="dropdown" data-drupal-link-system-path="&lt;front&gt;">Articles</a>
                          <div class="dropdown-menu">
          <a href="/sysadmin/topics/automation" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/146">Automation</a>
          <a href="/sysadmin/topics/career" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/51">Career</a>
          <a href="/sysadmin/topics/sysadmin-culture" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/41">Culture</a>
          <a href="/sysadmin/topics/linux" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/21">Linux</a>
          <a href="/sysadmin/topics/programming" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/71"> Programming</a>
          <a href="/sysadmin/topics/security" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/96">Security</a>
  </div>
                              </li>
                              <li class="nav-item  dropdown">
                      <a href="/sysadmin/about" class="nav-link dropdown-toggle" data-toggle="dropdown" data-drupal-link-system-path="node/71">About</a>
                          <div class="dropdown-menu">
          <a href="/sysadmin/about" class="dropdown-item" data-drupal-link-system-path="node/71">Topics</a>
          <a href="/sysadmin/email" class="dropdown-item" data-drupal-link-system-path="node/376">Email newsletter</a>
          <a href="/sysadmin/join-community" class="dropdown-item" data-drupal-link-system-path="node/641">Join the community</a>
          <a href="/sysadmin/community-guidelines" class="dropdown-item" data-drupal-link-system-path="node/156">Community guidelines</a>
  </div>
                              </li>
                              <li class="nav-item  ">
                      <a href="/sysadmin/welcome" class="nav-link">Welcome</a>
                  </li>
            </ul>


  
  </div>


      
              
          </div>
  </div>

  


<nav class="navbar navbar-expand-lg justify-content-between navbar-light  d-none d-lg-block text-dark bg-light border-bottom-light-gray">
      <div class="container">
  
      
  
  <button class="navbar-toggler" type="button" data-toggle="collapse" data-target=".navbar-collapse" aria-controls="navbar-collapse" aria-expanded="false" aria-label="Toggle navigation">
    <span class="navbar-toggler-icon"></span>
  </button>

  <div class="collapse navbar-collapse">
                  <div class="mr-auto d-flex navbar-desktop">
            
  <div class="block block--sysadmin-navbar-sitename sitename">

  
    

    
  <a href="/sysadmin/" class="navbar-brand sitename">
        Enable Sysadmin
  </a>

  <span class="d-none d-lg-inline ml-1 mr-3 h5 navbar-sitename-divider">&nbsp;</span>

  </div>

  <div class="block block--sysadmin-main-menu">

  
    

      
  


  <ul class="nav navbar-nav">
                                  <li class="nav-item  dropdown">
                      <a href="/sysadmin/" class="nav-link dropdown-toggle" data-toggle="dropdown" data-drupal-link-system-path="&lt;front&gt;">Articles</a>
                          <div class="dropdown-menu">
          <a href="/sysadmin/topics/automation" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/146">Automation</a>
          <a href="/sysadmin/topics/career" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/51">Career</a>
          <a href="/sysadmin/topics/sysadmin-culture" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/41">Culture</a>
          <a href="/sysadmin/topics/linux" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/21">Linux</a>
          <a href="/sysadmin/topics/programming" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/71"> Programming</a>
          <a href="/sysadmin/topics/security" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/96">Security</a>
  </div>
                              </li>
                              <li class="nav-item  dropdown">
                      <a href="/sysadmin/about" class="nav-link dropdown-toggle" data-toggle="dropdown" data-drupal-link-system-path="node/71">About</a>
                          <div class="dropdown-menu">
          <a href="/sysadmin/about" class="dropdown-item" data-drupal-link-system-path="node/71">Topics</a>
          <a href="/sysadmin/email" class="dropdown-item" data-drupal-link-system-path="node/376">Email newsletter</a>
          <a href="/sysadmin/join-community" class="dropdown-item" data-drupal-link-system-path="node/641">Join the community</a>
          <a href="/sysadmin/community-guidelines" class="dropdown-item" data-drupal-link-system-path="node/156">Community guidelines</a>
  </div>
                              </li>
                              <li class="nav-item  ">
                      <a href="/sysadmin/welcome" class="nav-link">Welcome</a>
                  </li>
            </ul>


  
  </div>


        </div>
          
                  
      
      <div class="dropdown show text-align-right">
  <a href="/sysadmin/subscribe" class="navbar-util navbar-util--rss" aria-label="Subscribe to our feed or newsletter blast">
    <svg width="22" height="23" viewBox="0 0 22 23" xmlns="http://www.w3.org/2000/svg"><title>Subscribe to our RSS feed or Email blast</title><path d="M0 4.23c9.79 0 17.75 8 17.75 17.84h4.23A22.05 22.05 0 0 0 0 0v4.23z M0 7.67v4.23c2.74 0 5.33 1.07 7.27 3.03a10.26 10.26 0 0 1 3 7.3h4.24c0-8.02-6.5-14.56-14.51-14.56M2.93 16.87a2.94 2.94 0 0 0 0 5.85 2.93 2.93 0 1 0 0-5.85" fill-rule="evenodd"/></svg>

    <span class="sr-only">Subscribe to our RSS feed or Email blast.</span>
  </a>

    <a id="dropdownSearchLink" href="/sysadmin/search/node" class="navbar-util navbar-util--search" role="button" aria-label="Search this site…" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false">
    <svg width="30" height="30" viewBox="0 0 30 30" xmlns="http://www.w3.org/2000/svg" style="fill:none;stroke-width:3;stroke:#000;stroke-linecap:round;"><line x1="18.95" y1="19.15" x2="25.25" y2="25.75"/><circle cx="13.25" cy="12.75" r="8.5"/></svg>

  </a>
  <div class="dropdown-menu dropdown-menu-right p-1 pt-2" aria-labelledby="dropdownSearchLink">
    <form class="form-inline m-2" action="/sysadmin/search/node" accept-charset="UTF-8" method="get">
      <div class="input-group flex-fill">
        <input class="form-control" type="search" name="keys" id="search" value="" placeholder="Search this site…" aria-label="Search this site…">
        <div class="input-group-append">
          <button class="btn btn-secondary font-weight-bold" type="submit">GO</button>
        </div>
      </div>
    </form>
  </div>
  </div>
      </div>

      </div>
  </nav>

  <main class="pb-5">
                  <header class="page__header">
          <div class="container">
              <div data-drupal-messages-fallback class="hidden"></div>


          </div>
        </header>
          
    <a name="main-content" tabindex="-1"></a>

                  <div class="page__content">
                  
  <div class="block block--sysadmin-content">

  
    

      <article data-history-node-id="886" role="article" about="/sysadmin/getting-started-regular-expressions-example" typeof="schema:Article" class="full full--article node node--promoted">
  
    <span property="schema:name" content="Getting started with regular expressions: An example" class="hidden"></span>
  <span property="schema:interactionCount" content="UserComments:0" class="hidden"></span>


      <div  class="section my-5 narrow">
  <div class="container">
    <div >
      
  <div data-layout-content-preview-placeholder-label="&quot;Title&quot; field" class="block">

  
    

      <span property="schema:name"><h1 class="font-weight-bold">Getting started with regular expressions: An example</h1>
</span>

  
  </div>

  <div data-layout-content-preview-placeholder-label="&quot;Subhead&quot; field" class="block">

  
    

      
            <div class="article__field-subhead">Dive right into a regular expression example in this second of four regular expression articles.</div>
      
  
  </div>

    </div>
  </div>
</div>
<div  class="section pb-5 narrow">
  <div class="container">
    <div >
      
  <div data-layout-content-preview-placeholder-label="&quot;Article Byline&quot; block" class="block">

  
    

      <p class="article-byline">
  <span class="article-date">
          Posted October 15, 2019
      </span>
    <span aria-hidden="true">|</span>
  <span class="article-authors">
    <strong class="sr-only">by</strong>
          <a href="/sysadmin/users/dboth" class="article-author article-author--primary">David Both</a>      </span>
  </p>

  
  </div>

  <div data-layout-content-preview-placeholder-label="&quot;Media&quot; field" class="block">

  
    

      
            <div class="article__field-media"><figure>
  
  
  <div class="image__field-media-image">
    <div class="field__label font-weight-bold visually-hidden">
      Image    </div>
                  <div class="field__item">  
<img src="/sysadmin/sites/default/files/styles/full/public/2019-10/Starting_Line.jpg?itok=pmnNGf08" width="1000" height="600" typeof="foaf:Image" loading="lazy" class="img-thumbnail" src="/sysadmin/sites/default/files/styles/full/public/2019-10/Starting_Line.jpg?itok=pmnNGf08" alt="Getting started with regular expressions" />


</div>
              </div>

  <figcaption>
    
            <div class="image__field-media-description"><a href="https://www.flickr.com/photos/53370644@N06/4975884671">"BXP135671"</a> by <a href="https://www.flickr.com/photos/53370644@N06" rel="noopener" target="_blank">tableatny</a> is licensed under <a href="https://creativecommons.org/licenses/by/2.0/?ref=ccsearch&amp;atype=rich">CC BY 2.0</a>
</div>
      
  </figcaption>
</figure>
</div>
      
  
  </div>

  <div data-layout-content-preview-placeholder-label="&quot;Body&quot; field" class="block">

  
    

      
            <div property="schema:text" class="article__body"><p>In <a href="https://www.redhat.com/sysadmin/introducing-regular-expressions"><em>Introducing regular expressions</em></a>, I covered what they are and why they’re useful. Now, we need a real-world example to use as a learning tool. Here is one I encountered several years ago.</p>

<p>This example highlights the power and flexibility of the Linux command line, especially regular expressions, for their ability to automate common tasks. I have administered several listservs during my career and still do. People send me email addresses to add to those lists. In more than one case, I have received a list of names and email addresses in a Microsoft Word format to be added to one of the lists.</p>

<h2 id="the-troublesome-list">The troublesome list</h2>

<p>The list itself was not very long, but it was inconsistent in its formatting. An abbreviated version of that list, with name and domain changes, is shown here:</p>

<pre>
<code class="language-plaintext">Team 1	Apr 3 
Leader  Virginia Jones  vjones88@example.com	
Frank Brown  FBrown398@example.com	
Cindy Williams  cinwill@example.com	
Marge smith   msmith21@example.com 
 [Fred Mack]   edd@example.com	

Team 2	March 14
leader  Alice Wonder  Wonder1@example.com	
John broth  bros34@example.com	
Ray Clarkson  Ray.Clarks@example.com	
Kim West    kimwest@example.com	
[JoAnne Blank]  jblank@example.com	

Team 3	Apr 1 
Leader  Steve Jones  sjones23876@example.com	
Bullwinkle Moose bmoose@example.com	
Rocket Squirrel RJSquirrel@example.com	
Julie Lisbon  julielisbon234@example.com	
[Mary Lastware) mary@example.com</code></pre>

<p>The original list had extra lines, characters like brackets and parentheses that need to be deleted, whitespace such as spaces and tabs, and some empty lines. The format required to add these emails to the list is <code>&lt;first&gt; &lt;last&gt; &lt;email@example.com&gt;</code>. Our task is to transform this list into a format usable by the mailing list software.</p>

<div data-embed-button="resource_list" data-entity-embed-display="view_mode:resource_list.link" data-entity-type="resource_list" data-entity-uuid="60b26066-acd0-4332-afa7-d98c9a079f02" data-langcode="en" class="align-right embedded-entity embedded-entity--resources embedded-entity--resources--link"><aside class="eck-entity mt-2 py-3 pr-3 border-top border-danger"><h2 class="h4">
      More Linux resources
  </h2>

<ul class="pl-3 mb-0"><li class="my-2"><a href="https://developers.redhat.com/promotions/linux-cheatsheet/?intcmp=701f20000012ngPAAQ">Download Now: Linux Commands Cheat Sheet</a></li>
      <li class="my-2"><a href="https://developers.redhat.com/cheat-sheets/advanced-linux-commands/?intcmp=701f20000012ngPAAQ">Advanced Linux Commands Cheat Sheet for Developers</a></li>
      <li class="my-2"><a href="https://www.redhat.com/en/technologies/linux-platforms/enterprise-linux/try-it?intcmp=701f20000012ngPAAQ">Download Red Hat Enterprise Linux Server 8 Trial</a></li>
      <li class="my-2"><a href="https://www.redhat.com/rhtapps/assessment/session/?intcmp=701f20000012ngPAAQ">Linux System Administration Skills Assessment</a></li>
  </ul></aside></div>
<p>It was obvious that I needed to manipulate the data in order to mangle it into an acceptable format for inputting to the list. It is possible to use a text editor or a word processor such as LibreOffice Writer to make the necessary changes to this small file. However, people send me files like this quite often, so it becomes a chore to use a word processor to make these changes. Despite the fact that Writer has a good search and replace function, each character or string must be replaced singly, and there is no way to save previous searches.</p>

<p>Writer does have a powerful macro feature, but I am not familiar with either of its two languages: LibreOffice Basic or Python. I do know Bash shell programming.</p>

<p>I did what comes naturally to a sysadmin—I automated the task. The first thing I did was to copy the address data to a text file so I could work on it using command-line tools. After a few minutes of work, I developed the Bash command-line program shown in the <a href="https://www.redhat.com/sysadmin/introducing-regular-expressions">previous article</a>:</p>

<pre>
<code class="language-shell">$ cat Experiment_6-1.txt | grep -v Team | grep -v "^\s*$" | sed -e "s/[Ll]eader//" -e "s/\[//g" -e "s/\]//g" -e "s/)//g" | awk '{print $1" "$2" &lt;"$3"&gt;"}' &gt; addresses.txt
</code></pre>

<p>This code produced the desired output as the file <code>addresses.txt</code>. I used my normal approach to writing command-line programs like this by building up the pipeline one command at a time.</p>

<p>Let’s break this pipeline down into its component parts to see how it works and fits together. All of the experiments in this series should be performed as a non-privileged user. I also did this on a VM that I created for testing: <code>studentvm1</code>.</p>

<h2 id="the-sample-file">The sample file</h2>

<p>First, we need to create the sample file. Create a directory named <code>testing</code> on your local machine, and then copy the text below into into a new text file named <code>Experiment_6-1.txt</code>, which contains the three team entries shown above.</p>

<pre>
<code class="language-plaintext">Team 1  Apr 3 
Leader  Virginia Jones  vjones88@example.com
Frank Brown  FBrown398@example.com
Cindy Williams  cinwill@example.com
Marge smith   msmith21@example.com 
 [Fred Mack]   edd@example.com  

Team 2  March 14
leader  Alice Wonder  Wonder1@example.com
John broth  bros34@example.com  
Ray Clarkson  Ray.Clarks@example.com
Kim West    kimwest@example.com 
[JoAnne Blank]  jblank@example.com

Team 3  Apr 1 
Leader  Steve Jones  sjones23876@example.com
Bullwinkle Moose bmoose@example.com
Rocket Squirrel RJSquirrel@example.com  
Julie Lisbon  julielisbon234@example.com</code></pre>

<h3>Removing unnecessary lines with grep</h3>

<p>The first things I see that can be done are a couple of easy ones. Since the team names and dates are on lines by themselves, we can use the following to remove those lines that have the word "Team:"</p>

<pre>
<code class="language-shell">[student@studentvm1 testing]$  cat Experiment_6-1.txt | grep -v Team
</code></pre>

<p>I won’t reproduce the results of each stage of building this Bash program, but you should be able to see the changes in the data stream as it shows up on STDOUT, the terminal session. We won’t save it in a file until the end.</p>

<p>In this first step in transforming the data stream into one that is usable, we use the <code>grep</code> command with a simple literal pattern, <code>Team</code>. Literals are the most basic type of pattern we can use as a regular expression, because there is only a single possible match in the data stream being searched, and that is the string <code>Team</code>.</p>

<p>We need to discard empty lines, so we can use another <code>grep</code> statement to eliminate them. I find that enclosing the regular expression for the second <code>grep</code> command in quotes ensures that it gets interpreted properly:</p>

<pre>
<code class="language-shell">[student@studentvm1 testing]$ cat Experiment_6-1.txt | grep -v Team | grep -v "^\s*$"
Leader  Virginia Jones  vjones88@example.com
Frank Brown  FBrown398@example.com
Cindy Williams  cinwill@example.com
Marge smith   msmith21@example.com 
 [Fred Mack]   edd@example.com  
leader  Alice Wonder  Wonder1@example.com
John broth  bros34@example.com  
Ray Clarkson  Ray.Clarks@example.com
Kim West    kimwest@example.com 
[JoAnne Blank]  jblank@example.com
Leader  Steve Jones  sjones23876@example.com
Bullwinkle Moose bmoose@example.com
Rocket Squirrel RJSquirrel@example.com  
Julie Lisbon  julielisbon234@example.com
[Mary Lastware) mary@example.com
[student@studentvm1 testing]$</code></pre>

<p>The expression <code>"^\s*$"</code> illustrates anchors, and using the backslash (\) as an <em>escape character</em> to change the meaning of a literal "s" (in this case) to a metacharacter that means any whitespace such as spaces, tabs, or other characters that are unprintable. We cannot see these characters in the file, but it does contain some of them.</p>

<p>The asterisk, aka splat (*), specifies that we are to match zero or more of the whitespace characters. This addition would match multiple tabs, multiple spaces, or any combination of those in an otherwise empty line.</p>

<h2 id="viewing-extra-whitespace-with-vim">Viewing extra whitespace with Vim</h2>

<p>Next, I configured my Vim editor to display whitespace using visible characters. Do this by adding the following line to your own <code>~.vimrc</code> file, or to the global <code>/etc/vimrc</code> configuration file:</p>

<pre>
<code class="language-plaintext">set listchars=eol:$,nbsp:_,tab:&lt;-&gt;,trail:~,extends:&gt;,space:+
</code></pre>

<p>Then, start—or restart—Vim.</p>

<p>I have found a lot of bad, incomplete, and contradictory information on the internet in my searches for how to do this. The built-in Vim help has the best information, and the data line I created from that above is one that works for me.</p>

<blockquote>
<p><strong>Note:</strong> In the example below, regular spaces are shown as <code>+</code>; tabs are shown as <code>&lt;</code>, <code>&lt;&gt;</code>, or <code>&lt;–&gt;</code>, and fill the length of the space that the tab covers. The end of line (EOL) character is shown as <code>$</code>.</p>
</blockquote>

<p>The result, before any operation on the file, is shown here:</p>

<pre>
<code class="language-plaintext">Team+1&lt;&gt;Apr+3~$
Leader++Virginia+Jones++vjones88@example.com&lt;--&gt;$
Frank+Brown++FBrown398@example.com&lt;----&gt;$
Cindy+Williams++cinwill@example.com&lt;---&gt;$
Marge+smith+++msmith21@example.com~$
+[Fred+Mack]+++edd@example.com&lt;&gt;$
$
Team+2&lt;&gt;March+14$
leader++Alice+Wonder++Wonder1@example.com&lt;-----&gt;$
John+broth++bros34@example.com&lt;&gt;$
Ray+Clarkson++Ray.Clarks@example.com&lt;--&gt;$
Kim+West++++kimwest@example.com&gt;$
[JoAnne+Blank]++jblank@example.com&lt;----&gt;$
$
Team+3&lt;&gt;Apr+1~$
Leader++Steve+Jones++sjones23876@example.com&lt;--&gt;$
Bullwinkle+Moose+bmoose@example.com&lt;---&gt;$
Rocket+Squirrel+RJSquirrel@example.com&lt;&gt;$
Julie+Lisbon++julielisbon234@example.com&lt;------&gt;$
[Mary+Lastware)+mary@example.com$
</code></pre>

<h2 id="removing-unecessary-characters-with-sed">Removing unnecessary characters with sed</h2>

<p>You can see that there are a lot of whitespace characters that need to be removed from our file. We also need to get rid of the word "leader," which appears twice and is capitalized once. Let’s get rid of "leader" first. This time, we will use <code>sed</code> (stream editor) to perform this task by substituting a new string—or a null string in our case—for the pattern it matches.</p>

<p>Adding <code>sed -e "s/[Ll]eader//"</code> to the pipeline does this:</p>

<pre>
<code class="language-shell">[student@studentvm1 testing]$ cat Experiment_6-1.txt | grep -v Team | grep -v "^\s*$" | sed -e "s/[Ll]eader//"
</code></pre>

<p>In this <code>sed</code> command, <code>-e</code> means that the quote-enclosed expression is a script that produces a desired result. In the expression, the <code>s</code> means that this is a substitution. The basic form of a substitution is <code>s/&lt;regex&gt;/&lt;replacement string&gt;/</code>, so <code>/[Ll]eader/</code> is our search string.</p>

<p>The set <code>[Ll]</code> matches <code>L</code> or <code>l</code>, so <code>[Ll]eader</code> matches <code>leader</code> or <code>Leader</code>. In this case, the replacement string is null because it looks like a double forward slash with no characters or whitespace between the two slashes (<code>//</code>).</p>

<p>Let’s also get rid of some of the extraneous characters like <code>[]()</code> that will not be needed:</p>

<pre>
<code class="language-shell">[student@studentvm1 testing]$ cat Experiment_6-1.txt | grep -v Team | grep -v "^\s*$" | sed -e "s/[Ll]eader//" -e "s/\[//g" -e "s/]//g" -e "s/)//g" -e "s/(//g"
</code></pre>

<p>We have added four new expressions to the <code>sed</code> statement. Each one removes a single character. The first of these additional expressions is a bit different, because the left square brace (<code>[</code>) character can mark the beginning of a set. We need to escape the brace to ensure that <code>sed</code> interprets it correctly as a regular character and not a special one.</p>

<h2 id="tidying-up-with-awk">Tidying up with awk</h2>

<p>We could use <code>sed</code> to remove the leading spaces from some of the lines, but the <code>awk</code> command can do that, reorder the fields if necessary, and add the <code>&lt;&gt;</code> characters around the email address:</p>

<pre>
<code class="language-shell">[student@studentvm1 testing]$ cat Experiment_6-1.txt | grep -v Team | grep -v "^\s*$" | sed -e "s/[Ll]eader//" -e "s/\[//g" -e "s/]//g" -e "s/)//g" -e "s/(//g" | awk '{print $1" "$2" &lt;"$3"&gt;"}'
</code></pre>

<p>The <code>awk</code> utility is actually a powerful programming language that can accept data streams on its STDIN. This fact makes it extremely useful in command-line programs and scripts.</p>

<p>The <code>awk</code> utility works on data fields, and the default field separator is spaces—any amount of white space. The data stream we have created so far has three fields separated by whitespace (<code>&lt;first&gt;</code>, <code>&lt;last&gt;</code>, and <code>&lt;email&gt;</code>):</p>

<pre>
<code class="language-shell">awk '{print $1" "$2" &lt;"$3"&gt;"}'
</code></pre>

<p>This little program takes each of the three fields (<code>$1</code>, <code>$2</code>, and <code>$3</code>) and extracts them without leading or trailing whitespace. It then prints them in sequence, adding a single space between each as well as the <code>&lt;&gt;</code> characters needed to enclose the email address.</p>

<h2 id="wrapping-up">Wrapping up</h2>

<p>The last step here would be to redirect the output data stream to a file, but that is trivial, so I leave it with you to perform that step. It is not really necessary that you do so.</p>

<p>I saved the Bash program in an executable file, and now I can run this program anytime I receive a new list. Some of those lists are fairly short, as is the one in this example. Others have been quite long, sometimes containing up to several hundred addresses and many lines of "stuff" that do not contain addresses to be added to the list.</p>

<p><em><strong>Note:</strong> This article is a slightly modified version of Chapter 6 from Volume 2 of my Linux book, Using and Administering Linux: Zero to SysAdmin, due out from Apress in late 2019.</em></p>
</div>
      
  
  </div>

  <div data-layout-content-preview-placeholder-label="&quot;Listicle&quot; views block" class="block">

  
    

      <div class="views-element-container"><div class="listicle-view js-view-dom-id-62e731844078476b22821e6b0e3673f72a7d51caef99615cb257124043e11546">
  
  
  

  
  
  

      <div class="listicle-row"><div class="views-field views-field-field-listicle"><div class="field-content"></div></div></div>

    

  
  

  
  
</div>
</div>

  
  </div>

  <div data-layout-content-preview-placeholder-label="&quot;Topics&quot; field" class="block">

  
    

      <div class="topics">
  <strong>Topics:</strong>&nbsp;&nbsp;
      <a href="/sysadmin/topics/linux" class="btn btn-primary btn-sm font-weight-bold">Linux</a>&nbsp;&nbsp;
      <a href="/sysadmin/topics/regular-expressions" class="btn btn-primary btn-sm font-weight-bold">Regular Expressions</a>&nbsp;&nbsp;
  </div>
  
  </div>

    </div>
  </div>
</div>
<div >
  <div >
    
  <div data-layout-content-preview-placeholder-label="&quot;Entity view (Content)&quot; block" class="block">

  
    

      
<section data-history-node-id="886" role="article" about="/sysadmin/getting-started-regular-expressions-example" typeof="schema:Article" class="section my-5 py-5 bg-light-gray authors-bio authors-bio--article">
  <div class="container">
          <div class="row">
        <div class="col-md-2 text-center">
                      
<img src="/sysadmin/sites/default/files/styles/user_picture_square/public/pictures/2019-05/david-crop.jpg?itok=imcvpdp0" width="240" height="240" typeof="foaf:Image" loading="lazy" class="rounded-circle img-thumbnail" src="/sysadmin/sites/default/files/styles/user_picture_square/public/pictures/2019-05/david-crop.jpg?itok=imcvpdp0" alt="Author’s photo" />


          
        </div>
        <div class="col-md-10 col-lg-8">
          <h2 class="font-weight-light text-center text-md-left">
                          David Both
                      </h2>
          <div>
                          <p>
                David Both is an Open Source Software and GNU/Linux advocate, trainer, writer, and speaker who lives in Raleigh, North Carolina. He is a strong proponent of and evangelist for the &quot;Linux Philosophy.&quot; David has been in the IT industry for nearly 50 years.
                                  <a href="/sysadmin/users/dboth" class="author-more-link">More about me</a>
                              </p>
                      </div>
        </div>
      </div>
      </div>
</section>



  
  </div>

  <div data-layout-content-preview-placeholder-label="&quot;Contributors&quot; block" class="block">

  
    

      

  
  </div>

  </div>
</div>
<div  class="section">
  <div class="container">
    <div >
      
  <div data-layout-content-preview-placeholder-label="&quot;Related Content&quot; views block" class="block">

  
    

      <div class="views-element-container"><div class="js-view-dom-id-3bb7ad00c3c1346ae9ba5067f85b61dfe7cc31b5866750fd1480dc94137b554e">
  
  
  

  
  
  

    <h2>Related Content</h2>
                        <div class="card-deck my-4">
                        <article data-history-node-id="911" role="article" about="/sysadmin/analyzing-linux-server-performance-atop" typeof="schema:Article" class="card card--article node node--promoted">
      <div class="card-img-top">
            <div class="article__field-media"><article>
  
      
  <div class="image__field-media-image">
    <div class="field__label font-weight-bold visually-hidden">
      Image    </div>
                  <div class="field__item">    <picture>
                <!--[if IE 9]><video style="display: none;"><![endif]-->
              <source srcset="/sysadmin/sites/default/files/styles/card/public/2019-10/spinning_top.webp?itok=lR11tIeq 1x" type="image/webp"/>
              <source srcset="/sysadmin/sites/default/files/styles/card/public/2019-10/spinning_top.jpg?itok=lR11tIeq 1x" type="image/jpeg"/>
            <!--[if IE 9]></video><![endif]-->
            
<img srcset="/sysadmin/sites/default/files/styles/card/public/2019-10/spinning_top.jpg?itok=lR11tIeq 1x" src="/sysadmin/sites/default/files/styles/card/public/2019-10/spinning_top.jpg?itok=lR11tIeq" typeof="foaf:Image" loading="lazy" class="img-thumbnail" src="/sysadmin/sites/default/files/styles/card/public/2019-10/spinning_top.jpg?itok=lR11tIeq" alt="Analyzing Linux performance with atop" />

  </picture>

</div>
              </div>

  </article>
</div>
      </div>
      <div class="card-body">
    <div class="h4 card-title"><a href="/sysadmin/analyzing-linux-server-performance-atop"><span property="schema:name">Analyzing Linux server performance with atop</span>
</a></div>
    <div class="card-text">
            <div property="schema:text" class="article__body">The atop command displays you a more anatomized view of your server's performance.</div>
      </div>
  </div>
  <div class="card-footer">
    <div class="article-date">
      <span class="label">Posted:</span>
      October 15, 2019
    </div>
    <div class="article-authors">
              <span class="label">Author:</span>
                    <a href="/sysadmin/users/hydnjames" class="article-author article-author--primary">Hayden James</a>          </div>
  </div>
</article>


                            <article data-history-node-id="881" role="article" about="/sysadmin/introducing-regular-expressions" typeof="schema:Article" class="card card--article node node--promoted">
      <div class="card-img-top">
            <div class="article__field-media"><article>
  
      
  <div class="image__field-media-image">
    <div class="field__label font-weight-bold visually-hidden">
      Image    </div>
                  <div class="field__item">    <picture>
                <!--[if IE 9]><video style="display: none;"><![endif]-->
              <source srcset="/sysadmin/sites/default/files/styles/card/public/2019-10/smiley-2979107_1920.webp?itok=ojroKjT1 1x" type="image/webp"/>
              <source srcset="/sysadmin/sites/default/files/styles/card/public/2019-10/smiley-2979107_1920.jpg?itok=ojroKjT1 1x" type="image/jpeg"/>
            <!--[if IE 9]></video><![endif]-->
            
<img srcset="/sysadmin/sites/default/files/styles/card/public/2019-10/smiley-2979107_1920.jpg?itok=ojroKjT1 1x" src="/sysadmin/sites/default/files/styles/card/public/2019-10/smiley-2979107_1920.jpg?itok=ojroKjT1" typeof="foaf:Image" loading="lazy" class="img-thumbnail" src="/sysadmin/sites/default/files/styles/card/public/2019-10/smiley-2979107_1920.jpg?itok=ojroKjT1" alt="Introduction to regular expressions" />

  </picture>

</div>
              </div>

  </article>
</div>
      </div>
      <div class="card-body">
    <div class="h4 card-title"><a href="/sysadmin/introducing-regular-expressions"><span property="schema:name">Introducing regular expressions</span>
</a></div>
    <div class="card-text">
            <div property="schema:text" class="article__body">Regular expressions don't have to invoke anxiety and fear, although they do for many of us. This part one of four articles takes you from basic globbing to using basic regular expressions.</div>
      </div>
  </div>
  <div class="card-footer">
    <div class="article-date">
      <span class="label">Posted:</span>
      October 14, 2019
    </div>
    <div class="article-authors">
              <span class="label">Author:</span>
                    <a href="/sysadmin/users/dboth" class="article-author article-author--primary">David Both</a>          </div>
  </div>
</article>


                            <article data-history-node-id="856" role="article" about="/sysadmin/troubleshooting-slow-servers" typeof="schema:Article" class="card card--article node node--promoted">
      <div class="card-img-top">
            <div class="article__field-media"><article>
  
      
  <div class="image__field-media-image">
    <div class="field__label font-weight-bold visually-hidden">
      Image    </div>
                  <div class="field__item">    <picture>
                <!--[if IE 9]><video style="display: none;"><![endif]-->
              <source srcset="/sysadmin/sites/default/files/styles/card/public/2019-09/traffic_jam.webp?itok=p2pZRpjq 1x" type="image/webp"/>
              <source srcset="/sysadmin/sites/default/files/styles/card/public/2019-09/traffic_jam.jpg?itok=p2pZRpjq 1x" type="image/jpeg"/>
            <!--[if IE 9]></video><![endif]-->
            
<img srcset="/sysadmin/sites/default/files/styles/card/public/2019-09/traffic_jam.jpg?itok=p2pZRpjq 1x" src="/sysadmin/sites/default/files/styles/card/public/2019-09/traffic_jam.jpg?itok=p2pZRpjq" typeof="foaf:Image" loading="lazy" class="img-thumbnail" src="/sysadmin/sites/default/files/styles/card/public/2019-09/traffic_jam.jpg?itok=p2pZRpjq" alt="traffic jam on city street. " />

  </picture>

</div>
              </div>

  </article>
</div>
      </div>
      <div class="card-body">
    <div class="h4 card-title"><a href="/sysadmin/troubleshooting-slow-servers"><span property="schema:name">Troubleshooting slow servers: How to check CPU, RAM, and Disk I/O</span>
</a></div>
    <div class="card-text">
            <div property="schema:text" class="article__body">When all you have to go on is a user report, how do you get started debugging server speed?</div>
      </div>
  </div>
  <div class="card-footer">
    <div class="article-date">
      <span class="label">Posted:</span>
      October 4, 2019
    </div>
    <div class="article-authors">
              <span class="label">Author:</span>
                    <a href="/sysadmin/users/jakewalters5" class="article-author article-author--primary">Jake Walters</a>          </div>
  </div>
</article>


                              </div>
            
    

  
  

  
  
</div>
</div>

  
  </div>

    </div>
  </div>
</div>
<div  class="section my-5 pb-5 narrow">
  <div class="container">
    <div >
      
    </div>
  </div>
</div>
<div  class="section my-5 pb-5 ">
  <div class="container">
    <div >
      

  <div data-layout-content-preview-placeholder-label="&quot;CTA Subscribe (Red on Black)&quot; block" class="block block--cta cta cta--red-on-black cta-- my-5 p-3 text-center">

  
    

    <div class="d-md-flex justify-content-around align-items-center flex-wrap">
    <div class="cta__content my-2">
      
            <div class="cta__field-content p-2"><p class="h4 mb-4 mt-3 font-weight-bold">OUR BEST CONTENT, DELIVERED TO YOUR INBOX</p>

<p><iframe title="Subscribe to our newsletter" aria-label="Embedded form to subscribe to our email newsletter" frameborder="0" height="50" scrolling="no" src="/sysadmin/eloqua-embedded-subscribe.html?offer_id=701f20000012gE7AAI" style="max-width:670px;margin:0 auto;" width="100%"></iframe></p>
</div>
      
    </div>
      </div>
  
  </div>

    </div>
  </div>
</div>

  </article>

  
  </div>


              </div>
        </main>

            <footer>
              <div class="page__colophon bg-dark-gray py-4 bg-dark-gray">
          <div class="container">
              
  <div class="block block--basic block--sysadmin-colophon-disclaimer">

  
    

      
            <div class="basic__body"><p>The opinions expressed on this website are those of each author, not of the author's employer or of Red Hat.</p>

<p>Red Hat and the Red Hat logo are trademarks of Red Hat, Inc., registered in the United States and other countries.</p>
</div>
      
  
  </div>


          </div>
        </div>
                    <div class="page__footer bg-dark py-3">
        <div class="container">
          <div class="d-sm-flex justify-content-between align-items-center">
              

  
    

    
  <a href="https://www.redhat.com/" class="navbar-brand mr-0 mr-lg-auto mb-3 mb-sm-0">
            <img src="/sysadmin/themes/custom/sysadmin/logo.svg" width="135" height="31" class="d-inline-block align-top" alt="Red Hat logo" />

        
  </a>



  <div class="block block--basic block--copyright my-0 mx-sm-3 mb-1 mb-sm-0">

  
    

      
            <div class="basic__body"><p>Copyright ©2019 Red Hat, Inc.</p>
</div>
      
  
  </div>

  <div class="block block--sysadmin-footer my-0 mb-1 mb-sm-0">

  
    

      
  


  <ul class="nav d-flex d-sm-block d-md-flex justify-content-center align-items-center">
                                  <li class="nav-item  ">
                      <a href="https://www.redhat.com/en/about/privacy-policy" class="nav-link">Privacy Policy</a>
                  </li>
                              <li class="nav-item  ">
                      <a href="https://www.redhat.com/en/about/terms-use" class="nav-link">Terms of Use</a>
                  </li>
                              <li class="nav-item  ">
                      <a href="https://www.redhat.com/en/about/all-policies-guidelines" class="nav-link">All policies and guidelines</a>
                  </li>
            </ul>


  
  </div>

  <div class="block block--sharelinks">

  
    

      <div class="a2a_kit a2a_kit_size_32 a2a_floating_style a2a_vertical_style" data-a2a-url="https://www.redhat.com/sysadmin/getting-started-regular-expressions-example">
  <a class="a2a_button_twitter a2a_counter"></a>
  <a class="a2a_button_facebook a2a_counter"></a>
  <a class="a2a_button_linkedin a2a_counter"></a>
  <a class="a2a_button_reddit a2a_counter"></a>
  <a class="a2a_button_email a2a_counter"></a>
</div>
<div class="a2a_kit a2a_kit_size_32 a2a_floating_style a2a_default_style">
  <a class="a2a_button_twitter a2a_counter"></a>
  <a class="a2a_button_facebook a2a_counter"></a>
  <a class="a2a_button_linkedin a2a_counter"></a>
  <a class="a2a_button_reddit a2a_counter"></a>
  <a class="a2a_button_email a2a_counter"></a>
</div>

<script>
  var a2a_config = a2a_config || {};
  a2a_config.templates = a2a_config.templates || {};
  a2a_config.templates.twitter = {
    text: "Getting started with regular expressions: An example https://red.ht/2VNgYEj via #EnableSysadmin by @LinuxGeek46",
  };
  a2a_config.templates.facebook = {
    hashtag: "#EnableSysadmin",
  };
</script>
  
  </div>


  <div class="block block--cta block--ctasubscribesidebar cta cta--blue-on-white cta-- my-5 p-3 text-center">

  
    

    <div class="d-md-flex justify-content-around align-items-center flex-wrap">
    <div class="cta__content my-2">
      
            <div class="cta__field-content p-2"><div class="subscribe-sidebar">
<div class="target-band-never-show-button">x</div>

<h4>Subscribe now</h4>

<p class="eloqua-email-capture-text">Get the highlights in your inbox every week.</p>

<p><iframe aria-label="Embedded form to subscribe to our email newsletter" frameborder="0" height="50" scrolling="no" src="/sysadmin/eloqua-embedded-email-capture-block.html?offer_id=701f20000012gE7AAI" style="max-width:670px;margin:0 auto;" title="Subscribe to our newsletter" width="100%"></iframe></p>
</div>
</div>
      
    </div>
      </div>
  
  </div>


          </div>
        </div>
            </footer>
      </div>

  </div>


<script type="application/json" data-drupal-selector="drupal-settings-json">{"path":{"baseUrl":"\/sysadmin\/","scriptPath":null,"pathPrefix":"","currentPath":"node\/886","currentPathIsAdmin":false,"isFront":false,"currentLanguage":"en"},"pluralDelimiter":"\u0003","ckeditorheight":{"offset":1,"line_height":1.5,"unit":"em"},"user":{"uid":0,"permissionsHash":"653231f2fd62822d854a459f8c9bd92cdd388cedec8e99ad361c1430eee2d8b2"}}</script>
<script src="/sysadmin/sites/default/files/js/js_vVyKBAo8XLIi1nWMp7gveLngxddw-nDON-umfVH-RJg.js"></script>

  <script type="text/javascript">
    if (("undefined" !== typeof _satellite) && ("function" === typeof _satellite.pageBottom)) {
      _satellite.pageBottom();
    }
  </script>
</body>
</html>
