<!DOCTYPE html>
<html lang="en" dir="ltr" prefix="content: http://purl.org/rss/1.0/modules/content/  dc: http://purl.org/dc/terms/  foaf: http://xmlns.com/foaf/0.1/  og: http://ogp.me/ns#  rdfs: http://www.w3.org/2000/01/rdf-schema#  schema: http://schema.org/  sioc: http://rdfs.org/sioc/ns#  sioct: http://rdfs.org/sioc/types#  skos: http://www.w3.org/2004/02/skos/core#  xsd: http://www.w3.org/2001/XMLSchema# ">
<head>
<script id="dpal" src="https://www.redhat.com/ma/dpal.js"></script>
<meta charset="utf-8" /><script type="text/javascript">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</script>
<link rel="canonical" href="https://www.redhat.com/sysadmin/packaging-applications-python" />
<meta name="description" content="Use a virtual environment, pip, and setuptools to package applications with their dependencies for smooth installation on other computers." />
<meta name="dcterms.title" content="Packaging applications to install on other machines with Python" />
<meta name="dcterms.creator" content="Jose Vicente Nunez" />
<meta name="dcterms.publisher" content="Red Hat, Inc." />
<meta name="dcterms.language" content="en" />
<meta property="og:site_name" content="Enable Sysadmin" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.redhat.com/sysadmin/packaging-applications-python" />
<meta property="og:title" content="Packaging applications to install on other machines with Python" />
<meta property="og:image" content="https://www.redhat.com/sysadmin/sites/default/files/styles/google_discover/public/2021-11/package-applications.jpg?itok=nfIiNBZW" />
<meta property="og:image:secure_url" content="https://www.redhat.com/sysadmin/sites/default/files/styles/google_discover/public/2021-11/package-applications.jpg?itok=nfIiNBZW" />
<meta property="og:image:type" content="image/jpeg" />
<meta property="og:image:width" content="1000" />
<meta property="og:video:width" content="600" />
<meta property="og:image:height" content="675" />
<meta property="og:updated_time" content="2021-12-02T10:00:00+0000" />
<meta property="og:image:alt" content="https://www.redhat.com/sysadmin/sites/default/files/styles/google_discover/public/2021-11/package-applications.jpg?itok=nfIiNBZW" />
<meta property="og:street_address" content="100 East Davie Street" />
<meta property="og:locality" content="Raleigh" />
<meta property="og:region" content="NC" />
<meta property="og:postal_code" content="27601" />
<meta property="og:country_name" content="United States" />
<meta property="og:phone_number" content="+1 919 754 4950" />
<meta property="og:fax_number" content="+1 919 800 3804" />
<meta property="og:locale" content="en_US" />
<meta property="article:author" content="https://www.redhat.com/sysadmin/users/jose-vicente-nunez" />
<meta property="article:publisher" content="https://www.facebook.com/redhatinc" />
<meta property="article:section" content="Enable Sysadmin" />
<meta property="article:tag" content="Python" />
<meta property="article:tag" content="Package management" />
<meta property="article:tag" content="Software" />
<meta property="article:modified_time" content="2021-12-02T10:00:00+0000" />
<meta name="twitter:card" content="photo" />
<meta name="twitter:title" content="Packaging applications to install on other machines with Python" />
<meta name="twitter:site:id" content="14627400" />
<meta name="twitter:creator" content="@josevnz" />
<meta name="twitter:url" content="https://www.redhat.com/sysadmin/packaging-applications-python" />
<meta name="twitter:image:alt" content="Red Hat, Inc." />
<meta name="twitter:image:height" content="1000" />
<meta name="twitter:image:width" content="600" />
<meta name="twitter:image" content="https://www.redhat.com/sysadmin/sites/default/files/styles/full/public/2021-11/package-applications.jpg?itok=NdMZaBV9" />
<meta name="Generator" content="Drupal 9 (https://www.drupal.org)" />
<meta name="MobileOptimized" content="width" />
<meta name="HandheldFriendly" content="true" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<script type="application/ld+json">{
    "@context": "https://schema.org",
    "@graph": [
        {
            "@type": "TechArticle",
            "headline": "Packaging applications to install on other machines with Python",
            "name": "Packaging applications to install on other machines with Python",
            "about": [
                "\u003Ca href=\u0022/sysadmin/topics/python\u0022 hreflang=\u0022en\u0022\u003EPython\u003C/a\u003E",
                "\u003Ca href=\u0022/sysadmin/topics/package-management\u0022 hreflang=\u0022en\u0022\u003EPackage management\u003C/a\u003E",
                "\u003Ca href=\u0022/sysadmin/topics/software\u0022 hreflang=\u0022en\u0022\u003ESoftware\u003C/a\u003E"
            ],
            "description": "Use a virtual environment, pip, and setuptools to package applications with their dependencies for smooth installation on other computers.",
            "image": {
                "@type": "ImageObject",
                "url": "https://www.redhat.com/sysadmin/sites/default/files/styles/full/public/2021-11/package-applications.jpg?itok=NdMZaBV9",
                "width": "1000",
                "height": "600"
            },
            "dateModified": "2021-12-02T10:00:00+0000",
            "author": {
                "@type": "Person",
                "@id": "https://www.redhat.com/sysadmin/users/jose-vicente-nunez",
                "name": "Jose Vicente Nunez",
                "url": "https://www.redhat.com/sysadmin/users/jose-vicente-nunez",
                "sameAs": "https://twitter.com/josevnz"
            },
            "publisher": {
                "@type": "Organization",
                "@id": "https://www.redhat.com/"
            },
            "mainEntityOfPage": "https://www.redhat.com/sysadmin/packaging-applications-python"
        },
        {
            "@type": "Corporation",
            "@id": "https://www.redhat.com/",
            "name": "Red Hat, Inc.",
            "sameAs": [
                "https://en.wikipedia.org/wiki/Red_Hat",
                "http://www.linkedin.com/company/red-hat",
                "http://www.youtube.com/user/RedHatVideos",
                "https://www.facebook.com/redhatinc",
                "https://twitter.com/RedHat"
            ],
            "url": "https://www.redhat.com/",
            "telephone": "+1 919 754 4950",
            "contactPoint": {
                "@type": "ContactPoint",
                "telephone": "+1-888-RED-HAT1",
                "availableLanguage": "English",
                "contactType": "sales",
                "faxnumber": "+1 919 800 3804"
            },
            "logo": {
                "@type": "ImageObject",
                "url": "https://www.redhat.com/sysadmin/themes/custom/sysadmin/assets/images/red-hat-logo.png",
                "width": "254",
                "height": "60"
            },
            "address": {
                "@type": "PostalAddress",
                "streetAddress": "100 East Davie Street",
                "addressLocality": "Raleigh",
                "addressRegion": "NC",
                "postalCode": "27601",
                "addressCountry": "United States"
            }
        },
        {
            "@type": "Person",
            "name": "Jose Vicente Nunez",
            "sameAs": "https://twitter.com/josevnz",
            "image": {
                "@type": "ImageObject",
                "url": "https://www.redhat.com/sysadmin/sites/default/files/styles/user_picture_square/public/pictures/2021-06/JVNunez.jpeg?itok=WPMixr1I",
                "width": "240",
                "height": "240"
            }
        },
        {
            "@type": "WebPage",
            "@id": "https://www.redhat.com/sysadmin/packaging-applications-python",
            "publisher": {
                "@type": "Organization",
                "@id": "https://www.redhat.com/"
            }
        },
        {
            "@type": "WebSite",
            "@id": "https://www.redhat.com/sysadmin/",
            "name": "Enable Sysadmin",
            "url": "https://www.redhat.com/sysadmin/",
            "publisher": {
                "@type": "Organization",
                "@id": "https://www.redhat.com/"
            }
        }
    ]
}</script>
<meta name="robots" content="max-image-preview:large" />
<link rel="shortcut icon" href="/sysadmin/themes/custom/sysadmin/favicon.ico" type="image/vnd.microsoft.icon" />
<link rel="revision" href="https://www.redhat.com/sysadmin/packaging-applications-python" />
<link rel="apple-touch-icon" sizes="180x180" href="/sysadmin/themes/custom/sysadmin/assets/favicon/apple-touch-icon.png">
<link rel="icon" type="image/png" sizes="32x32" href="/sysadmin/themes/custom/sysadmin/assets/favicon/favicon-32x32.png">
<link rel="icon" type="image/png" sizes="16x16" href="/sysadmin/themes/custom/sysadmin/assets/favicon/favicon-16x16.png">
<link rel="manifest" href="/sysadmin/themes/custom/sysadmin/assets/favicon/site.webmanifest">
<link rel="mask-icon" href="/sysadmin/themes/custom/sysadmin/assets/favicon/safari-pinned-tab.svg" color="#ee0000">
<meta name="msapplication-TileColor" content="#1a1a1a">
<meta name="theme-color" content="#ffffff">
<title>Packaging applications to install on other machines with Python | Enable Sysadmin</title>
<link rel="stylesheet" media="all" href="/sysadmin/sites/default/files/css/css_K-etweG1PGH6xQ8c1GPXlg7Kf-iQ9nD5hOKFOqg1DI0.css" />
<link rel="stylesheet" media="all" href="/sysadmin/sites/default/files/css/css_wL5vQsqSGZeeFvsRIov4xFil8zWkEzY2DL19yeqGeqw.css" />

<script src="/sysadmin/sites/default/files/js/js_QHqjxhGPGgZFwOfW92tmrVpssmC1sbO0zDG4TgLmaEI.js"></script>


</head>
<body>
<a href="#main-content" class="visually-hidden focusable">
Skip to main content
</a>

  <div class="dialog-off-canvas-main-canvas" data-off-canvas-main-canvas>
    

<div class="redhat-cookie-banner">
<section id="redhat-cookie-privacy-banner" class="redhat-cookie-banner-wrapper" style="display: block;">
  <div class="container my-3 pr-5">
    <p>We use cookies on our websites to deliver our online services. Details about how we use cookies and how you may disable them are set out in our <a href="http://www.redhat.com/en/about/privacy-policy#cookies">Privacy Statement</a>. By using this website you agree to our use of cookies.
    <span class="cookie-more">
    <a id="redhat-cookie-privacy-banner-close" href="javascript:void(0);" class="cookie-close">&times;</a>
    </span>
    </p>
  </div>
</section>
</div>

<div class="page d-flex flex-column">
  <div class="navbar navbar-expand-lg justify-content-between navbar-dark bg-dark">
    <div class="container">
                
  <div class="block block--sysadmin-navbar-branding">

  
    

    
  <a href="https://www.redhat.com/" class="navbar-brand ">
            <img src="/sysadmin/themes/custom/sysadmin/logo.svg" width="135" height="31" class="d-inline-block align-top" alt="Red Hat logo" />

        
  </a>


  </div>


      
      <div class="navbar-toggler-wrapper">
        <button class="navbar-toggler" type="button" data-toggle="collapse"  data-parent="#collapse-parent" data-target="#search-collapse" aria-controls="search-collapse" aria-expanded="false" aria-label="Toggle search">
          <svg class="icon-collapsed" width="30" height="30" viewBox="0 0 30 30" xmlns="http://www.w3.org/2000/svg"><line x1="18.95" y1="19.15" x2="25.25" y2="25.75"/><circle cx="13.25" cy="12.75" r="8.5"/></svg>
          <svg class="icon-expanded" width="30" height="30" viewBox="0 0 30 30" xmlns="http://www.w3.org/2000/svg"><line x1="7.25" y1="7.25" x2="22.75" y2="22.75"/><line x1="7.25" y1="22.75" x2="22.75" y2="7.25"/></svg>
          <span style="vertical-align: middle;">Search</span>
        </button>
        <button class="navbar-toggler" type="button" data-toggle="collapse" data-parent="#collapse-parent" data-target="#mobilenav-collapse" aria-controls="mobilenav-collapse" aria-expanded="false" aria-label="Toggle navigation">
          <svg class="icon-collapsed" width="30" height="30" viewBox="0 0 30 30" xmlns="http://www.w3.org/2000/svg"><path d="M4 7h22M4 15h22M4 23h22"/></svg>
          <svg class="icon-expanded" width="30" height="30" viewBox="0 0 30 30" xmlns="http://www.w3.org/2000/svg"><line x1="7.25" y1="7.25" x2="22.75" y2="22.75"/><line x1="7.25" y1="22.75" x2="22.75" y2="7.25"/></svg>
        </button>
      </div>
    </div>
  </div>

  <div id="collapse-parent">
    <div id="search-collapse" class="search-collapse collapse" data-parent="#collapse-parent">
      <div class="py-4 px-3">
        <form class="form-inline m-2" action="/sysadmin/search/node" accept-charset="UTF-8" method="get">
          <div class="input-group flex-fill">
            <input class="form-control" type="search" name="keys" id="search" value="" placeholder="Search this site…" aria-label="Search this site…">
            <div class="input-group-append">
              <button class="btn btn-secondary font-weight-bold" type="submit">Search</button>
            </div>
          </div>
        </form>
      </div>
    </div>

    <div id="mobilenav-collapse" class="mobilenav-collapse d-lg-none collapse" data-parent="#collapse-parent">
                
  <div class="block block--sysadmin-navbar-sitename sitename">

  
    

    
  <a href="/sysadmin/" class="navbar-brand sitename">
        Enable Sysadmin
  </a>

  <span class="d-none d-lg-inline ml-1 mr-3 h5 navbar-sitename-divider">&nbsp;</span>

  </div>

  <div class="block block--sysadmin-main-menu">

  
    

      
  


  <ul class="nav navbar-nav">
                                          <li class="nav-item  dropdown">
                      <a href="/sysadmin/" class="nav-link dropdown-toggle" data-toggle="dropdown" data-drupal-link-system-path="&lt;front&gt;">Articles</a>
                          <div class="dropdown-menu">
              <a href="/sysadmin/topics/automation" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/146">Automation</a>
              <a href="/sysadmin/topics/career" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/51">Career</a>
              <a href="/sysadmin/topics/containers" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/36"> Containers</a>
              <a href="/sysadmin/topics/sysadmin-culture" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/41">Culture</a>
              <a href="/sysadmin/topics/kubernetes" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/66">Kubernetes</a>
              <a href="/sysadmin/topics/linux" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/21">Linux</a>
              <a href="/sysadmin/topics/programming" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/71"> Programming</a>
              <a href="/sysadmin/topics/security" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/96">Security</a>
  </div>
                              </li>
                                      <li class="nav-item  dropdown">
                      <a href="/sysadmin/about" class="nav-link dropdown-toggle" data-toggle="dropdown" data-drupal-link-system-path="node/71">About</a>
                          <div class="dropdown-menu">
              <a href="/sysadmin/about" class="dropdown-item" data-drupal-link-system-path="node/71">Topics</a>
              <a href="/sysadmin/email" class="dropdown-item" data-drupal-link-system-path="node/376">Email newsletter</a>
              <a href="/sysadmin/join-community" class="dropdown-item" data-drupal-link-system-path="node/641">Join the community</a>
              <a href="/sysadmin/community-guidelines" class="dropdown-item" data-drupal-link-system-path="node/156">Community guidelines</a>
              <a href="/sysadmin/sudoers-program" class="dropdown-item" data-drupal-link-system-path="node/2106">Sudoers program</a>
              <a href="/sysadmin/meet-team" class="dropdown-item" data-drupal-link-system-path="node/2316">Meet the team</a>
              <a href="/sysadmin/faq" class="dropdown-item" data-drupal-link-system-path="node/1526">FAQs</a>
  </div>
                              </li>
                                      <li class="nav-item  ">
                      <a href="/sysadmin/welcome-enable-sysadmin" title="A Red Hat community publication for sysadmins, by sysadmins" class="nav-link">Welcome</a>
                  </li>
            </ul>


  
  </div>


      
              
          </div>
  </div>

  


<nav class="navbar navbar-expand-lg justify-content-between navbar-light  d-none d-lg-block text-dark bg-light border-bottom-light-gray">
      <div class="container">
  
      
  
  <button class="navbar-toggler" type="button" data-toggle="collapse" data-target=".navbar-collapse" aria-controls="navbar-collapse" aria-expanded="false" aria-label="Toggle navigation">
    <span class="navbar-toggler-icon"></span>
  </button>

  <div class="collapse navbar-collapse">
                  <div class="mr-auto d-flex navbar-desktop">
            
  <div class="block block--sysadmin-navbar-sitename sitename">

  
    

    
  <a href="/sysadmin/" class="navbar-brand sitename">
        Enable Sysadmin
  </a>

  <span class="d-none d-lg-inline ml-1 mr-3 h5 navbar-sitename-divider">&nbsp;</span>

  </div>

  <div class="block block--sysadmin-main-menu">

  
    

      
  


  <ul class="nav navbar-nav">
                                          <li class="nav-item  dropdown">
                      <a href="/sysadmin/" class="nav-link dropdown-toggle" data-toggle="dropdown" data-drupal-link-system-path="&lt;front&gt;">Articles</a>
                          <div class="dropdown-menu">
              <a href="/sysadmin/topics/automation" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/146">Automation</a>
              <a href="/sysadmin/topics/career" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/51">Career</a>
              <a href="/sysadmin/topics/containers" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/36"> Containers</a>
              <a href="/sysadmin/topics/sysadmin-culture" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/41">Culture</a>
              <a href="/sysadmin/topics/kubernetes" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/66">Kubernetes</a>
              <a href="/sysadmin/topics/linux" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/21">Linux</a>
              <a href="/sysadmin/topics/programming" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/71"> Programming</a>
              <a href="/sysadmin/topics/security" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/96">Security</a>
  </div>
                              </li>
                                      <li class="nav-item  dropdown">
                      <a href="/sysadmin/about" class="nav-link dropdown-toggle" data-toggle="dropdown" data-drupal-link-system-path="node/71">About</a>
                          <div class="dropdown-menu">
              <a href="/sysadmin/about" class="dropdown-item" data-drupal-link-system-path="node/71">Topics</a>
              <a href="/sysadmin/email" class="dropdown-item" data-drupal-link-system-path="node/376">Email newsletter</a>
              <a href="/sysadmin/join-community" class="dropdown-item" data-drupal-link-system-path="node/641">Join the community</a>
              <a href="/sysadmin/community-guidelines" class="dropdown-item" data-drupal-link-system-path="node/156">Community guidelines</a>
              <a href="/sysadmin/sudoers-program" class="dropdown-item" data-drupal-link-system-path="node/2106">Sudoers program</a>
              <a href="/sysadmin/meet-team" class="dropdown-item" data-drupal-link-system-path="node/2316">Meet the team</a>
              <a href="/sysadmin/faq" class="dropdown-item" data-drupal-link-system-path="node/1526">FAQs</a>
  </div>
                              </li>
                                      <li class="nav-item  ">
                      <a href="/sysadmin/welcome-enable-sysadmin" title="A Red Hat community publication for sysadmins, by sysadmins" class="nav-link">Welcome</a>
                  </li>
            </ul>


  
  </div>


        </div>
          
                  
      
      

<div class="dropdown show text-align-right">
    <a href="/sysadmin/subscribe" class="navbar-util navbar-util--rss" aria-label="Subscribe to our feed or newsletter blast">
    <svg width="22" height="23" viewBox="0 0 22 23" xmlns="http://www.w3.org/2000/svg"><title>Subscribe to our RSS feed or Email newsletter</title><path d="M0 4.23c9.79 0 17.75 8 17.75 17.84h4.23A22.05 22.05 0 0 0 0 0v4.23z M0 7.67v4.23c2.74 0 5.33 1.07 7.27 3.03a10.26 10.26 0 0 1 3 7.3h4.24c0-8.02-6.5-14.56-14.51-14.56M2.93 16.87a2.94 2.94 0 0 0 0 5.85 2.93 2.93 0 1 0 0-5.85" fill-rule="evenodd"/></svg>

    <span class="sr-only">Subscribe to our RSS feed or Email newsletter.</span>
  </a>

    <a id="dropdownSearchLink" href="/sysadmin/search/node" class="navbar-util navbar-util--search" role="button" aria-label="Search this site…" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false">
    <svg width="30" height="30" viewBox="0 0 30 30" xmlns="http://www.w3.org/2000/svg" style="fill:none;stroke-width:3;stroke:#000;stroke-linecap:round;"><line x1="18.95" y1="19.15" x2="25.25" y2="25.75"/><circle cx="13.25" cy="12.75" r="8.5"/></svg>

  </a>
  <div class="dropdown-menu dropdown-menu-right p-1 pt-2" aria-labelledby="dropdownSearchLink">
    <form class="form-inline m-2" action="/sysadmin/search/node" accept-charset="UTF-8" method="get">
      <div class="input-group flex-fill">
        <input class="form-control" type="search" name="keys" id="search" value="" placeholder="Search this site…" aria-label="Search this site…">
        <div class="input-group-append">
          <button class="btn btn-secondary font-weight-bold" type="submit">GO</button>
        </div>
      </div>
    </form>
  </div>
  </div>
      </div>

      </div>
  </nav>

  <main class="pb-5">
                  <header class="page__header">
          <div class="container">
              <div data-drupal-messages-fallback class="hidden"></div>


          </div>
        </header>
          
    <a name="main-content" tabindex="-1"></a>

                  <div class="page__content">
                  
  <div class="block block--sysadmin-content">

  
    

      <article data-history-node-id="5386" role="article" about="/sysadmin/packaging-applications-python" typeof="schema:Article" id="node--article--5386" class="full full--article node node--promoted">
  
    <span property="schema:name" content="Packaging applications to install on other machines with Python" class="hidden"></span>
  <span property="schema:interactionCount" content="UserComments:0" class="hidden"></span>


      <div  class="section my-5 narrow">
  <div class="container">
    <div >
      
  <div class="block">

  
    

      <span property="schema:name"><h1 class="font-weight-bold">Packaging applications to install on other machines with Python</h1>
</span>

  
  </div>

  <div class="block">

  
    

      
            <div class="article__field-subhead">Use a virtual environment, pip, and setuptools to package applications with their dependencies for smooth installation on other computers.</div>
      
  
  </div>

    </div>
  </div>
</div>
<div  class="section pb-5 narrow">
  <div class="container">
    <div >
      
  <div class="block">

  
    

      <p class="article-byline">
  <span class="article-date">
    <span class="label">Posted:</span>
    December 2, 2021
  </span>
    <span aria-hidden="true">|</span>
  <span class="article-authors">
    <strong class="sr-only">by</strong>
          <a href="/sysadmin/users/jose-vicente-nunez" class="article-author article-author--primary">Jose Vicente Nunez<span class="author-affiliate"> (Sudoer)</span></a>      </span>
  </p>

  
  </div>

  <div class="block">

  
    

      
            <div class="article__field-media"><figure>
  
  
  <div data-blazy="" class="blazy blazy--field blazy--field-media-image image__field-media-image">
    <div class="field__label font-weight-bold visually-hidden">
      Image    </div>
                  <div class="field__item">



                  <div class="media media--blazy media--bundle--image media--loading is-b-loading media--image">
<img alt="Package with a QR code" class="media__image media__element b-lazy img-fluid" data-src="/sysadmin/sites/default/files/styles/full/public/2021-11/package-applications.jpg?itok=NdMZaBV9" src="data:image/svg+xml;charset=utf-8,%3Csvg%20xmlns%3D&#039;http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg&#039;%20viewBox%3D&#039;0%200%201000%20600&#039;%2F%3E" width="1000" height="600" loading="lazy" typeof="foaf:Image" />
        </div>
        
  
</div>
              </div>

  <figcaption>
    
            <div class="image__field-media-description"><p><sup>Photo by <a href="https://www.pexels.com/@kampus?utm_content=attributionCopyText&amp;utm_medium=referral&amp;utm_source=pexels">Kampus Production</a> from <a href="https://www.pexels.com/photo/person-holding-brown-cardboard-box-7289721/?utm_content=attributionCopyText&amp;utm_medium=referral&amp;utm_source=pexels">Pexels</a></sup></p>
</div>
      
  </figcaption>
</figure>
</div>
      
  
  </div>

  <div class="block">

  
    

      
            <div property="schema:text" class="clearfix article__body"><p>In my <a href="https://www.redhat.com/sysadmin/query-rpm-database-python" target="_blank">last article in this series</a>, I showed how to write a script in Python that returned a list of <a href="https://rpm.org/" target="_blank">RPM</a>-installed software installed on a machine. The output looks like this:</p>

<pre>
<code class="language-shell">$ rpmqa_simple.py --limit 20
linux-firmware-20210818: 395,099,476
code-1.61.2: 303,882,220
brave-browser-1.31.87: 293,857,731
libreoffice-core-7.0.6.2: 287,370,064
thunderbird-91.1.0: 271,239,962
firefox-92.0: 266,349,777
glibc-all-langpacks-2.32: 227,552,812
mysql-workbench-community-8.0.23: 190,641,403
java-11-openjdk-headless-11.0.13.0.8: 179,469,639
iwl7260-firmware-25.30.13.0: 148,167,043
docker-ce-cli-20.10.10: 145,890,250
google-noto-sans-cjk-ttc-fonts-20190416: 136,611,853
containerd.io-1.4.11: 113,368,911
ansible-2.9.25: 101,106,247
docker-ce-20.10.10: 100,134,880
ibus-1.5.23: 90,840,441
llvm-libs-11.0.0: 87,593,600
gcc-10.3.1: 84,899,923
cldr-emoji-annotation-38: 80,832,870
kernel-core-5.14.12: 79,447,964</code></pre>

<p>Now I want to package an application so that I can install it easily, including all the dependencies, on other machines. In this article, I'll show how to use the <strong>setuptools</strong> package to do that.</p>

<p>That's a lot to cover, so basic knowledge of Python is required. Even if you don't know much, the code is simple to follow, and the boilerplate code is small.</p>

<h2>Set up your environment</h2>

<p>My previous article explained how to install the code and use <a href="https://opensource.com/article/20/10/venv-python" target="_blank">virtual environments</a>, but here is a shortcut:</p>

<pre>
<code class="language-shell">$ sudo dnf install -y python3-rpm
$ git clone git@github.com:josevnz/tutorials.git
$ cd rpm_query
$ python3 -m venv --system-site-packages ~/virtualenv/rpm_query
. ~/virtualenv/rpm_query/bin/activate
(rpm_query)$ </code></pre>

<h2>Package and install the distribution</h2>

<div data-embed-button="resource_list" data-entity-embed-display="view_mode:resource_list.link" data-entity-type="resource_list" data-entity-uuid="78d8f7ba-4831-497f-b66d-ec0bb740244e" data-langcode="en" class="align-right embedded-entity embedded-entity--resources embedded-entity--resources--link"><aside id="resource-list-linux-containers" class="eck-entity mt-2 py-3 pr-3 border-top border-danger"><h2 class="h4">
      Linux containers
  </h2>

<ul class="pl-3 mb-0"><li class="my-2"><a href="https://www.redhat.com/en/services/training/do080-deploying-containerized-applications-technical-overview?intcmp=701f20000012ngPAAQ">Free course: Deploying containerized applications</a></li>
      <li class="my-2"><a href="https://www.redhat.com/en/technologies/cloud-computing/openshift/try-it?intcmp=701f20000012ngPAAQ">Download now: Red Hat OpenShift trial</a></li>
      <li class="my-2"><a href="https://www.kubernetesbyexample.com/?intcmp=701f20000012ngPAAQ">Learn Kubernetes by example</a></li>
  </ul></aside></div>
<p>The next step is to package the application. However, I won't use RPM for that.</p>

<p><em>Why not use an RPM to package the Python application?</em></p>

<p>Well, there is no short answer to that.</p>

<p>RPM is <em>great</em> <a href="https://www.redhat.com/sysadmin/package-linux-applications-rpm" target="_blank">if you want to share your application</a> with <em>all</em> the users of your system, especially because RPM can automatically install related dependencies.</p>

<p>For example, the RPM Python bindings (<code>rpm-python3</code>) are distributed this way, which makes sense as it is thinly tied to RPM.</p>

<p>In some cases, it is also a disadvantage:</p>

<ul><li>Users need root elevated access to install an RPM. If the code is malicious, it will take control of the server very easily. (That's why <a href="https://www.redhat.com/sysadmin/rpm-gpg-verify-packages" target="_blank">you always check the RPM signatures</a> and download code from well-known sources, right?)</li>
	<li>Attempting to upgrade to an RPM that is incompatible with older dependent applications fails.</li>
	<li>RPM is not well suited to share "test" code created during continuous integration, at least in bare-metal deployments. With a container, that is probably a different story.</li>
	<li>If the Python code has dependencies, they will likely have to be packaged as RPMs.</li>
</ul><h3>Use virtual environments and pip + setuptools</h3>

<p>Using virtual environments, pip, and setup tools solves these RPM limitations because:</p>

<ul><li><a href="https://docs.python.org/3/library/venv.html" target="_blank">Virtual environments</a> allow installing applications without elevated permissions.</li>
	<li>The application is self-contained in the virtual environment. Administrators can install different versions of the libraries without affecting the whole system.</li>
	<li>It is very easy to integrate a virtual environment with continuous integration and unit testing. After the tests pass, the environment can be recycled.</li>
	<li><a href="https://packaging.python.org/tutorials/installing-packages/" target="_blank">setuptools</a> solves the problem of packaging your application in a nice directory structure for making scripts and libraries available to users.</li>
	<li>setuptools also deals with keeping track of dependencies by using proper version checks to make the build process repeatable.</li>
	<li>setuptools works with <a href="https://pip.pypa.io/en/stable/" target="_blank">pip</a>, the Python package manager.</li>
	<li>Both virtual environments and setuptools have excellent support in IDEs like PyCharm and <a href="https://opensource.com/article/21/7/vs-code-remote-containers-podman" target="_blank">VS Code</a>.</li>
</ul><p><strong><em>[ Decrease the complexity of getting into the cloud by downloading the <a href="https://www.redhat.com/en/resources/hybrid-cloud-strategy-for-dummies-ebook?intcmp=701f20000012ngPAAQ" target="_blank">Hybrid cloud strategy for dummies</a> eBook. ]</em></strong></p>

<h2>Work with setuptools</h2>

<p>Once you're ready to deploy the application, you can package it, copy its wheel file, and then install it in a new virtual environment. First, define a very important file, <code>setup.py</code>, which is used by <a href="https://opensource.com/article/21/11/packaging-python-setuptools" target="_blank">setuptools</a>.</p>

<p>The most important sections in the file below are:</p>

<ul><li><strong>*_requires sections:</strong> Build and installation dependencies</li>
	<li><strong>packages:</strong> The location of Python classes</li>
	<li><strong>scripts:</strong> The scripts that the end user calls to interact with the libraries (if any)</li>
</ul><pre>
<code class="language-python">"""
Project packaging and deployment
More details: https://setuptools.pypa.io/en/latest/userguide/quickstart.html
"""
import os
from setuptools import setup
from reporter import __version__

def __read__(file_name):
    return open(os.path.join(os.path.dirname(__file__), file_name)).read()

setup(
    name="rpm_query",
    version=__version__,
    author="Jose Vicente Nunez Zuleta",
    author_email="kodegeek.com@protonmail.com",
    description=__doc__,
    license="Apache",
    keywords="rpm query",
    url="https://github.com/josevnz/rpm_query",
    packages=[
        'reporter'
    ],
    long_description=__read__('README.md'),
    # https://pypi.org/pypi?%3Aaction=list_classifiers
    classifiers=[
        "Development Status :: 3 - Alpha",
        "Topic :: Utilities",
        "Environment :: X11 Applications",
        "Intended Audience :: System Administrators"
        "License :: OSI Approved :: Apache Software License"
    ],
    setup_requires=[
        "setuptools==49.1.3",
        "wheel==0.37.0",
        "rich==9.5.1",
        "dearpygui==1.0.2"
    ],
    install_requires=[
        "rich==9.5.1",
    ],
    scripts=[
        "bin/rpmq_simple.py",
    ]
)</code></pre>

<p>Things to note:</p>

<ul><li>I stored the version in the <code>reporter/__init__.py</code> package module to share with other parts of the application, not just setuptools. I also used a <a href="https://packaging.python.org/guides/distributing-packages-using-setuptools/#semantic-versioning-preferred" target="_blank">semantic version schema</a> naming convention.</li>
	<li>The module's README is also stored as an external file. This makes editing the file much easier without worrying about size or breaking the Python syntax.</li>
	<li><a href="https://pypi.org/pypi?%3Aaction=list_classifiers" target="_blank">Classifiers</a> make it easier to see the application's intent.</li>
	<li>I can define packaging dependencies (<code>setup_requires</code>) and runtime dependencies (<code>install_requires</code>).</li>
	<li>I need the <code>wheel</code> package to create a <a href="https://packaging.python.org/glossary/#term-Wheel" target="_blank">precompiled</a> distribution that is faster to install than other modes.</li>
</ul><p>The <code>rpm_query.toml</code> file is also very important. Here is the file:</p>

<pre>
<code class="language-plaintext">[build-system]
requires = ["setuptools", "wheel"]</code></pre>

<p>The <code>rpm_query.toml</code> file specifies what is used for packaging the scripts and installing from source.</p>

<h3>Quick check before uploading</h3>

<p>Before you upload the wheel, you should ask Twine to check your settings for errors, like this:</p>

<pre>
<code class="language-shell">(rpm_query) [josevnz@dmaf5 rpm_query]$ twine check dist/rpm_query-0.0.1-py3-none-any.whl 
Checking dist/rpm_query-0.0.1-py3-none-any.whl: FAILED
  `long_description` has syntax errors in markup and would not be rendered on PyPI.
    line 20: Warning: Bullet list ends without a blank line; unexpected unindent.
  warning: `long_description_content_type` missing. defaulting to `text/x-rst`.</code></pre>

<p>The Markdown is incorrect in the file. One way to fix this issue is to install:</p>

<pre>
<code class="language-shell">$ pip install readme_renderer[md]</code></pre>

<p>Also, the <code>long_description_content_type</code> section is there:</p>

<pre>
<code class="language-python">    long_description_content_type="text/markdown",
    long_description=__read__('README.md'),</code></pre>

<p>If you rerun it after making the changes above, you <a href="https://github.com/pypa/warehouse/issues/4079" target="_blank">still see the warning</a>:</p>

<pre>
<code class="language-shell">rpm_query) [josevnz@dmaf5 rpm_query]$ twine check dist/rpm_query-0.0.1-py3-none-any.whl 
Checking dist/rpm_query-0.0.1-py3-none-any.whl: PASSED, with warnings
  warning: `long_description_content_type` missing. defaulting to `text/x-rst`.</code></pre>

<p>No serious errors and one false alarm. You are ready to upload your wheel.</p>

<h3>How to deploy while testing</h3>

<p>You don't need to package and deploy the application in full mode. This is because setuptools has a very convenient <strong>develop </strong>mode that installs dependencies and allows editing the code while testing it:</p>

<pre>
<code class="language-shell">(rpm_query)$ python setup.py develop</code></pre>

<p>This mode creates special symbolic links that put the scripts (remember that <code>scripts:</code> section inside <code>setup.py</code>?) into your path.</p>

<p>By the way, once you are finished testing, you can remove development mode:</p>

<pre>
<code class="language-shell">(rpm_query)$ python setup.py develop --uninstall</code></pre>

<p>The official documentation recommends migrating from a <code>setup.py</code> configuration to <code>setup.cfg.</code> I decided to use <code>setup.py</code> because it is still the most popular format.</p>

<h3>Create a precompiled distribution</h3>

<p>Compiling is as simple as typing this:</p>

<pre>
<code class="language-shell">(rpm_query)$ python setup.py bdist_wheel
running bdist_wheel
...  # Omitted output
(rpm_query)$ ls dist/
rpm_query-0.0.1-py3-none-any.whl</code></pre>

<p>Then you can install it on the same machine or a new virtual machine:</p>

<pre>
<code class="language-shell">(rpm_query)$ python setup.py install \
dist/rpm_query-1.0.0-py3-none-any.whl</code></pre>

<p>What if you want to share the .pip file with other users? I could copy the wheel file to the different machines and have the users install it, but there is a better way.</p>

<h2>Set up a private PyPI server</h2>

<p><strong>Note</strong>: This setup <em>is not production quality</em> because:</p>

<ul><li>It is not secure because it uses passwords instead of tokens for authentication.</li>
	<li>There's no SSL encryption. HTTP sends clear-text passwords over the wire.</li>
	<li>There's no storage redundancy. Ideally, the pip storage should have some sort of redundancy and backups.</li>
</ul><p>You can do a lot more than just installing from a wheel file. For example, you can set up a private server compatible with <a href="https://pypi.org/" target="_blank">PyPI</a> using a container running <a href="https://pypi.org/project/pypiserver/#using-the-docker-image" target="_blank">pypiserver</a>.</p>

<p><strong><em>[ Download the datasheet for information about <a href="https://www.redhat.com/en/resources/openshift-container-platform-datasheet?intcmp=701f20000012ngPAAQ" target="_blank">Red Hat OpenShift Container Platform</a>. ]</em></strong></p>

<p>First, create a directory to store the packages:</p>

<pre>
<code class="language-shell">$ mkdir -p -v $HOME/pypiserver
$ mkdir: created directory '/home/josevnz/pypiserver'</code></pre>

<p>Then use <a href="https://httpd.apache.org/docs/current/programs/htpasswd.html" target="_blank">htpasswd</a> to set up a user and password to upload the packages:</p>

<pre>
<code class="language-shell">htpasswd -c $HOME/.htpasswd josevnz
New password: 
Re-type new password: 
Adding password for user josevnz</code></pre>

<p>After that, run the container in a detached mode:</p>

<pre>
<code class="language-shell">$ docker run --detach --name privatepypiserver --publish 8080:8080 --volume ~/.htpasswd:/data/.htpasswd --volume $HOME/pypiserver:/data/packages pypiserver/pypiserver:latest -P .htpasswd --overwrite packages
f95f59a882b639db4509081de19a670fa8fdd93c63c3d4562c89e49e70bf6ee5
$ docker ps
CONTAINER ID   IMAGE                          COMMAND                  CREATED         STATUS         PORTS                                       NAMES
f95f59a882b6   pypiserver/pypiserver:latest   "/entrypoint.sh -P .…"   7 seconds ago   Up 6 seconds   0.0.0.0:8080-&gt;8080/tcp, :::8080-&gt;8080/tcp   privatepypiserver</code></pre>

<p>Confirm it is running by pointing curl or lynx to the new <code>privatepypiserver</code>:</p>

<pre>
<code class="language-shell">[josevnz@dmaf5 ~]$ lynx http://localhost:8080                                                                                                                                            Welcome to pypiserver!
                                                                         Welcome to pypiserver!

   This is a PyPI compatible package index serving 0 packages.

   To use this server with pip, run the following command:
        pip install --index-url http://localhost:8080/simple/ PACKAGE [PACKAGE2...]

   To use this server with easy_install, run the following command:
        easy_install --index-url http://localhost:8080/simple/ PACKAGE [PACKAGE2...]

   The complete list of all packages can be found here or via the simple index.

   This instance is running version 1.4.2 of the pypiserver software.</code></pre>

<p>Next, upload the wheel to your private PyPI server.</p>

<h2>Upload the application to a repository with Twine</h2>

<p>The most common way to share Python code is to upload it to an artifact manager like Sonatype Nexus or pypiserver using a tool like <a href="https://twine.readthedocs.io/en/latest/" target="_blank">Twine</a>.</p>

<pre>
<code class="language-shell">(rpm_query)$ pip install twine</code></pre>

<p>The next step is to set up <a href="https://packaging.python.org/specifications/pypirc/#pypirc" target="_blank">~/.pypirc</a> to allow passwordless uploads to the local PyPI server:</p>

<pre>
<code class="language-plaintext">[distutils]
index-servers =
    pypi
    privatepypi

[pypi]
repository = https://upload.pypi.org/legacy/

[privatepypi]
repository = http://localhost:8080/
username = josevnz</code></pre>

<p>It's best to not put the <code>password = XXXX</code> inside the file. Let Twine ask for it instead. Also, make the configuration accessible only to the owner:</p>

<pre>
<code class="language-shell">$ chmod 600 ~/.pypirc</code></pre>

<p>Finally, upload the wheel using the <code>twine</code> command:</p>

<pre>
<code class="language-shell">(rpm_query) twine upload -r privatepypi dist/rpm_query-0.0.1-py3-none-any.whl 
Uploading distributions to http://localhost:8080/
Uploading rpm_query-0.0.1-py3-none-any.whl
100%|██████████████████████████████████</code></pre>

<p>Confirm it was installed with <code>lynx http://localhost:8080/packages/</code>:</p>

<pre>
<code class="language-shell">                                                                           Index of packages

   rpm_query-0.0.1-py3-none-any.whl

Commands: Use arrow keys to move, '?' for help, 'q' to quit, '&lt;-' to go back.
  Arrow keys: Up and Down to move.  Right to follow a link; Left to go back.
 H)elp O)ptions P)rint G)o M)ain screen Q)uit /=search [delete]=history list</code></pre>

<h2>Install from the local privatepypi server</h2>

<p>Wait, don't leave yet. It is time to install the package from your private PyPI server:</p>

<p>First, <a href="https://pypi.org/project/pypiserver/#configuring-pip" target="_blank">tell pip</a> to look for packages on the private PyPI server:</p>

<pre>
<code class="language-shell">$ mkdir --verbose --parents ~/.pip
$ cat&lt;&lt;PIPCONF&gt;~/.pip/.pip.conf
[global]
extra-index-url = http://localhost:8080/simple/
trusted-host = http://localhost:8080/simple/
PIPCONF</code></pre>

<p>To prove this works well, install it to a different virtual environment (or you can override any previous installation with <code>pip install --force</code>):</p>

<pre>
<code class="language-shell">$ python3 -m venv ~/virtualenv/test2
$ . ~/virtualenv/test2/bin/activate
(test2)$ pip install --index-url http://localhost:8080/simple/ rpm_query
Looking in indexes: http://localhost:8080/simple/
Collecting rpm_query
  Downloading http://localhost:8080/packages/rpm_query-0.0.1-py3-none-any.whl (12 kB)
Collecting rich==9.5.1
  Using cached rich-9.5.1-py3-none-any.whl (180 kB)
Collecting pygments&lt;3.0.0,&gt;=2.6.0
  Downloading Pygments-2.10.0-py3-none-any.whl (1.0 MB)
     |████████████████████████████████| 1.0 MB 5.4 MB/s            
Collecting colorama&lt;0.5.0,&gt;=0.4.0
  Downloading colorama-0.4.4-py2.py3-none-any.whl (16 kB)
Collecting typing-extensions&lt;4.0.0,&gt;=3.7.4
  Downloading typing_extensions-3.10.0.2-py3-none-any.whl (26 kB)
Collecting commonmark&lt;0.10.0,&gt;=0.9.0
  Downloading commonmark-0.9.1-py2.py3-none-any.whl (51 kB)
     |████████████████████████████████| 51 kB 5.8 MB/s             
Installing collected packages: typing-extensions, pygments, commonmark, colorama, rich, rpm-query
Successfully installed colorama-0.4.4 commonmark-0.9.1 pygments-2.10.0 rich-9.5.1 rpm-query-0.0.1 typing-extensions-3.10.0.2</code></pre>

<h2>What you've learned</h2>

<p>I provided a lot of information here. Here's what I covered:</p>

<ul><li>Package the application with <a href="https://setuptools.pypa.io/en/latest/index.html" target="_blank">setuptools</a>.</li>
	<li>Run a private <a href="https://pypi.org/project/pypiserver" target="_blank">PyPI server using a container</a>.</li>
	<li>Upload the generated wheel package to the private repository using Twine.</li>
	<li>Install the wheel from the private repository instead of a file using <a href="https://pip.pypa.io/en/stable/cli/pip_install/" target="_blank">pip</a>.</li>
</ul><p>In my next article in this series, I'll explore writing user interface applications in Python.</p>
</div>
      
  
  </div>

  <div class="views-element-container block">

  
    

      <div><div class="listicle-view js-view-dom-id-264bf68d2a9d82fce1b446b251d1486bcaf6d3932e1751c4ca3417396b9f9fd0">
  
  
  

  
  
  

    <h3>Check out these related articles on Enable Sysadmin</h3>
    <div class="listicle-row"><div class="views-field views-field-field-listicle"><div class="field-content"><article data-history-node-id="5376" role="article" about="/sysadmin/query-rpm-database-python" typeof="schema:Article" id="node--article--5376" class="listicle listicle--article node node--promoted">
  <div class="row align-items-center">
    <div class="col-md-6 listicle-image">
            <div class="article__field-media"><div>
  
  
  <div data-blazy="" class="blazy blazy--field blazy--field-media-image blazy--field-media-image--block-1 blazy--view blazy--view--listicle blazy--view--listicle--block-1 image__field-media-image">
    <div class="field__label font-weight-bold visually-hidden">
      Image    </div>
                  <div class="field__item">



                  <div class="media media--blazy media--bundle--image media--loading is-b-loading media--image">
<img alt="Person programming with Python book nearby" class="media__image media__element b-lazy img-fluid" data-src="/sysadmin/sites/default/files/styles/card/public/2021-11/Python-programmer_1.jpg?itok=ycrzLu3t" src="data:image/svg+xml;charset=utf-8,%3Csvg%20xmlns%3D&#039;http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg&#039;%20viewBox%3D&#039;0%200%20700%20420&#039;%2F%3E" width="700" height="420" loading="lazy" typeof="foaf:Image" />
        </div>
        
  
</div>
              </div>

</div>
</div>
      </div>
    <div class="col-md-6 listicle-body">
      <div class="h4 listicle-title pt-4 pt-md-0"><a href="/sysadmin/query-rpm-database-python"><span property="schema:name">Writing and unit testing a Python application to query the RPM database</span>
</a></div>
      <div class="listicle-text font-weight-light py-2">
        
            <div property="schema:text" class="clearfix article__body">Write a Python program that prints a list of software installed on your system, then test whether the application behaves correctly.</div>
      
      </div>

      <div class="listicle-footer">
        <div class="article-date">
          <span class="label">Posted:</span>
          December 1, 2021
        </div>
        <div class="article-authors">
                      <span class="label">Author:</span>
                                <a href="/sysadmin/users/jose-vicente-nunez" class="article-author article-author--primary">Jose Vicente Nunez<span class="author-affiliate"> (Sudoer)</span></a>                  </div>
      </div>
    </div>
  </div>
</article>
<article data-history-node-id="3491" role="article" about="/sysadmin/create-rpm-package" typeof="schema:Article" id="node--article--3491" class="listicle listicle--article node node--promoted">
  <div class="row align-items-center">
    <div class="col-md-6 listicle-image">
            <div class="article__field-media"><div>
  
  
  <div data-blazy="" class="blazy blazy--field blazy--field-media-image blazy--field-media-image--block-1 blazy--view blazy--view--listicle blazy--view--listicle--block-1 image__field-media-image">
    <div class="field__label font-weight-bold visually-hidden">
      Image    </div>
                  <div class="field__item">



                  <div class="media media--blazy media--bundle--image media--loading is-b-loading media--image">
<img alt="How to create a Linux RPM package" class="media__image media__element b-lazy img-fluid" data-src="/sysadmin/sites/default/files/styles/card/public/2020-11/Create_a_Linux_package.jpg?itok=6SYwBma-" src="data:image/svg+xml;charset=utf-8,%3Csvg%20xmlns%3D&#039;http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg&#039;%20viewBox%3D&#039;0%200%20700%20420&#039;%2F%3E" width="700" height="420" loading="lazy" typeof="foaf:Image" />
        </div>
        
  
</div>
              </div>

</div>
</div>
      </div>
    <div class="col-md-6 listicle-body">
      <div class="h4 listicle-title pt-4 pt-md-0"><a href="/sysadmin/create-rpm-package"><span property="schema:name">How to create a Linux RPM package</span>
</a></div>
      <div class="listicle-text font-weight-light py-2">
        
            <div property="schema:text" class="clearfix article__body">You've written a great script that you want to distribute, so why not package it as an RPM? </div>
      
      </div>

      <div class="listicle-footer">
        <div class="article-date">
          <span class="label">Posted:</span>
          November 27, 2020
        </div>
        <div class="article-authors">
                      <span class="label">Author:</span>
                                <a href="/sysadmin/users/valentin-bajrami" class="article-author article-author--primary">Valentin Bajrami<span class="author-affiliate"> (Red Hat Accelerator)</span></a>                  </div>
      </div>
    </div>
  </div>
</article>
<article data-history-node-id="5256" role="article" about="/sysadmin/package-linux-applications-rpm" typeof="schema:Article" id="node--article--5256" class="listicle listicle--article node node--promoted">
  <div class="row align-items-center">
    <div class="col-md-6 listicle-image">
            <div class="article__field-media"><div>
  
  
  <div data-blazy="" class="blazy blazy--field blazy--field-media-image blazy--field-media-image--block-1 blazy--view blazy--view--listicle blazy--view--listicle--block-1 image__field-media-image">
    <div class="field__label font-weight-bold visually-hidden">
      Image    </div>
                  <div class="field__item">



                  <div class="media media--blazy media--bundle--image media--loading is-b-loading media--image">
<img alt="Two packages with red ribbon on red background" class="media__image media__element b-lazy img-fluid" data-src="/sysadmin/sites/default/files/styles/card/public/2021-10/Linux-package-RPM.jpg?itok=7eaR-k0Z" src="data:image/svg+xml;charset=utf-8,%3Csvg%20xmlns%3D&#039;http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg&#039;%20viewBox%3D&#039;0%200%20700%20420&#039;%2F%3E" width="700" height="420" loading="lazy" typeof="foaf:Image" />
        </div>
        
  
</div>
              </div>

</div>
</div>
      </div>
    <div class="col-md-6 listicle-body">
      <div class="h4 listicle-title pt-4 pt-md-0"><a href="/sysadmin/package-linux-applications-rpm"><span property="schema:name">More tips for packaging your Linux software with RPM</span>
</a></div>
      <div class="listicle-text font-weight-light py-2">
        
            <div property="schema:text" class="clearfix article__body">Learn how to compile and package your Linux application for distribution with Red Hat Package Manager.</div>
      
      </div>

      <div class="listicle-footer">
        <div class="article-date">
          <span class="label">Posted:</span>
          November 4, 2021
        </div>
        <div class="article-authors">
                      <span class="label">Author:</span>
                                <a href="/sysadmin/users/jose-vicente-nunez" class="article-author article-author--primary">Jose Vicente Nunez<span class="author-affiliate"> (Sudoer)</span></a>                  </div>
      </div>
    </div>
  </div>
</article>
<article data-history-node-id="5266" role="article" about="/sysadmin/package-open-source-rpm" typeof="schema:Article" id="node--article--5266" class="listicle listicle--article node node--promoted">
  <div class="row align-items-center">
    <div class="col-md-6 listicle-image">
            <div class="article__field-media"><div>
  
  
  <div data-blazy="" class="blazy blazy--field blazy--field-media-image blazy--field-media-image--block-1 blazy--view blazy--view--listicle blazy--view--listicle--block-1 image__field-media-image">
    <div class="field__label font-weight-bold visually-hidden">
      Image    </div>
                  <div class="field__item">



                  <div class="media media--blazy media--bundle--image media--loading is-b-loading media--image">
<img alt="Hands holding a small package" class="media__image media__element b-lazy img-fluid" data-src="/sysadmin/sites/default/files/styles/card/public/2021-10/package-in-hands.jpg?itok=bMygQWEC" src="data:image/svg+xml;charset=utf-8,%3Csvg%20xmlns%3D&#039;http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg&#039;%20viewBox%3D&#039;0%200%20700%20420&#039;%2F%3E" width="700" height="420" loading="lazy" typeof="foaf:Image" />
        </div>
        
  
</div>
              </div>

</div>
</div>
      </div>
    <div class="col-md-6 listicle-body">
      <div class="h4 listicle-title pt-4 pt-md-0"><a href="/sysadmin/package-open-source-rpm"><span property="schema:name">How to package open source applications as RPMs</span>
</a></div>
      <div class="listicle-text font-weight-light py-2">
        
            <div property="schema:text" class="clearfix article__body">Want to use a piece of third-party software but there's no RPM to install it? No problem: You can customize third-party software packages with RPM.</div>
      
      </div>

      <div class="listicle-footer">
        <div class="article-date">
          <span class="label">Posted:</span>
          November 11, 2021
        </div>
        <div class="article-authors">
                      <span class="label">Author:</span>
                                <a href="/sysadmin/users/jose-vicente-nunez" class="article-author article-author--primary">Jose Vicente Nunez<span class="author-affiliate"> (Sudoer)</span></a>                  </div>
      </div>
    </div>
  </div>
</article>
</div></div></div>

    

  
  

  
  
</div>
</div>

  
  </div>

  <div class="block">

  
    

      <div class="topics">
  <strong>Topics:</strong>&nbsp;&nbsp;
      <a href="/sysadmin/topics/python" class="btn btn-primary btn-sm font-weight-bold">Python</a>&nbsp;&nbsp;
      <a href="/sysadmin/topics/package-management" class="btn btn-primary btn-sm font-weight-bold">Package management</a>&nbsp;&nbsp;
      <a href="/sysadmin/topics/software" class="btn btn-primary btn-sm font-weight-bold">Software</a>&nbsp;&nbsp;
  </div>
  
  </div>

    </div>
  </div>
</div>
<div >
  <div >
    
  <div class="block">

  
    

      
<section data-history-node-id="5386" role="article" about="/sysadmin/packaging-applications-python" typeof="schema:Article" id="node--article--5386" class="section my-5 py-5 bg-light-gray authors-bio authors-bio--article">
  <div class="container">
          <div class="row">
        <div class="col-md-2 text-center">
                      
<img alt="Author’s photo" data-affiliation="Sudoer" src="/sysadmin/sites/default/files/styles/user_picture_square/public/pictures/2021-06/JVNunez.jpeg?itok=WPMixr1I" width="240" height="240" loading="lazy" typeof="foaf:Image" class="rounded-circle img-fluid" />


          
        </div>
        <div class="col-md-10 col-lg-8">
          <h2 class="font-weight-light text-center text-md-left">
                          Jose Vicente Nunez
                      </h2>
          <div>
                          <p>
                Proud dad and husband, software developer and sysadmin. Recreational runner and geek.
                                  <a href="/sysadmin/users/jose-vicente-nunez" class="author-more-link">More about me</a>
                              </p>
                      </div>
        </div>
      </div>
      </div>
</section>



  
  </div>

  <div class="block">

  
    

      

  
  </div>

  </div>
</div>
<div >
  <div >
    

  <div class="block block--cta cta cta--red-on-black cta-- my-5 p-3 text-center">

  
    

    <div class="d-md-flex justify-content-around align-items-center flex-wrap">
    <div class="cta__content my-2">
      
            <div class="cta__field-content p-2"><h4>On Demand: Red Hat Summit 2021 Virtual Experience</h4>

<p>Relive our April event with demos, keynotes, and technical sessions from<br />
experts, all available on demand.</p>
</div>
      
    </div>
        <div class="cta__link my-2">
      <a
        href="https://www.redhat.com/en/summit?intcmp=7013a0000026RhqAAE"
        target="_blank"
        class="btn btn-lg btn-danger font-weight-bold">
        Watch Now
      </a>
    </div>
      </div>
  
  </div>

  </div>
</div>
<div  class="section">
  <div class="container">
    <div >
      
  <div class="views-element-container block">

  
    

      <div><div class="js-view-dom-id-cdd5fd3d64deae40fedc620f6fc03aeffa9e7a74b025ddaad933a3a597b712a3">
  
  
  

  
  
  

    <h2>Related Content</h2>
                        <div class="card-deck my-4">
                        <article data-history-node-id="5376" role="article" about="/sysadmin/query-rpm-database-python" typeof="schema:Article" id="node--article--5376" class="card card--article node node--promoted">
      <div class="card-img-top">
            <div class="article__field-media"><div>
  
  
  <div data-blazy="" class="blazy blazy--field blazy--field-media-image blazy--field-media-image--card image__field-media-image">
    <div class="field__label font-weight-bold visually-hidden">
      Image    </div>
                  <div class="field__item">



                  <div class="media media--blazy media--bundle--image media--loading is-b-loading media--responsive media--image">  
<img class="media__image media__element b-lazy b-responsive img-fluid" data-src="/sysadmin/sites/default/files/styles/card/public/2021-11/Python-programmer_1.jpg?itok=ycrzLu3t" srcset="" data-srcset="/sysadmin/sites/default/files/styles/card/public/2021-11/Python-programmer_1.jpg?itok=ycrzLu3t 1x" src="data:image/svg+xml;charset=utf-8,%3Csvg%20xmlns%3D&#039;http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg&#039;%20viewBox%3D&#039;0%200%201000%20600&#039;%2F%3E" alt="Person programming with Python book nearby" typeof="foaf:Image" loading="lazy" />

        </div>
        
  
</div>
              </div>

</div>
</div>
      </div>
    <div class="card-body">
    <div class="h4 card-title"><a href="/sysadmin/query-rpm-database-python"><span property="schema:name">Writing and unit testing a Python application to query the RPM database</span>
</a></div>
    <div class="card-text">
            <div property="schema:text" class="clearfix article__body">Write a Python program that prints a list of software installed on your system, then test whether the application behaves correctly.</div>
      </div>
  </div>
  <div class="card-footer">
    <div class="article-date">
      <span class="label">Posted:</span>
      December 1, 2021
    </div>
    <div class="article-authors">
              <span class="label">Author:</span>
                    <a href="/sysadmin/users/jose-vicente-nunez" class="article-author article-author--primary">Jose Vicente Nunez<span class="author-affiliate"> (Sudoer)</span></a>          </div>
  </div>
</article>


                            <article data-history-node-id="5356" role="article" about="/sysadmin/self-compressed-scripts" typeof="schema:Article" id="node--article--5356" class="card card--article node node--promoted">
      <div class="card-img-top">
            <div class="article__field-media"><div>
  
  
  <div data-blazy="" class="blazy blazy--field blazy--field-media-image blazy--field-media-image--card image__field-media-image">
    <div class="field__label font-weight-bold visually-hidden">
      Image    </div>
                  <div class="field__item">



                  <div class="media media--blazy media--bundle--image media--loading is-b-loading media--responsive media--image">  
<img class="media__image media__element b-lazy b-responsive img-fluid" data-src="/sysadmin/sites/default/files/styles/card/public/2021-11/sealing-a-package.jpg?itok=R8ewVfHn" srcset="" data-srcset="/sysadmin/sites/default/files/styles/card/public/2021-11/sealing-a-package.jpg?itok=R8ewVfHn 1x" src="data:image/svg+xml;charset=utf-8,%3Csvg%20xmlns%3D&#039;http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg&#039;%20viewBox%3D&#039;0%200%201000%20600&#039;%2F%3E" alt="Sealing a package with tape" typeof="foaf:Image" loading="lazy" />

        </div>
        
  
</div>
              </div>

</div>
</div>
      </div>
    <div class="card-body">
    <div class="h4 card-title"><a href="/sysadmin/self-compressed-scripts"><span property="schema:name">Package software and data with self-compressed scripts</span>
</a></div>
    <div class="card-text">
            <div property="schema:text" class="clearfix article__body">Self-compressed scrips are a quick, reliable way to distribute software or data to users without a package manager, elevated privileges, or other limitations.</div>
      </div>
  </div>
  <div class="card-footer">
    <div class="article-date">
      <span class="label">Posted:</span>
      November 23, 2021
    </div>
    <div class="article-authors">
              <span class="label">Author:</span>
                    <a href="/sysadmin/users/jose-vicente-nunez" class="article-author article-author--primary">Jose Vicente Nunez<span class="author-affiliate"> (Sudoer)</span></a>          </div>
  </div>
</article>


                            <article data-history-node-id="5266" role="article" about="/sysadmin/package-open-source-rpm" typeof="schema:Article" id="node--article--5266" class="card card--article node node--promoted">
      <div class="card-img-top">
            <div class="article__field-media"><div>
  
  
  <div data-blazy="" class="blazy blazy--field blazy--field-media-image blazy--field-media-image--card image__field-media-image">
    <div class="field__label font-weight-bold visually-hidden">
      Image    </div>
                  <div class="field__item">



                  <div class="media media--blazy media--bundle--image media--loading is-b-loading media--responsive media--image">  
<img class="media__image media__element b-lazy b-responsive img-fluid" data-src="/sysadmin/sites/default/files/styles/card/public/2021-10/package-in-hands.jpg?itok=bMygQWEC" srcset="" data-srcset="/sysadmin/sites/default/files/styles/card/public/2021-10/package-in-hands.jpg?itok=bMygQWEC 1x" src="data:image/svg+xml;charset=utf-8,%3Csvg%20xmlns%3D&#039;http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg&#039;%20viewBox%3D&#039;0%200%201920%201149&#039;%2F%3E" alt="Hands holding a small package" typeof="foaf:Image" loading="lazy" />

        </div>
        
  
</div>
              </div>

</div>
</div>
      </div>
    <div class="card-body">
    <div class="h4 card-title"><a href="/sysadmin/package-open-source-rpm"><span property="schema:name">How to package open source applications as RPMs</span>
</a></div>
    <div class="card-text">
            <div property="schema:text" class="clearfix article__body">Want to use a piece of third-party software but there's no RPM to install it? No problem: You can customize third-party software packages with RPM.</div>
      </div>
  </div>
  <div class="card-footer">
    <div class="article-date">
      <span class="label">Posted:</span>
      November 11, 2021
    </div>
    <div class="article-authors">
              <span class="label">Author:</span>
                    <a href="/sysadmin/users/jose-vicente-nunez" class="article-author article-author--primary">Jose Vicente Nunez<span class="author-affiliate"> (Sudoer)</span></a>          </div>
  </div>
</article>


                              </div>
            
    

  
  

  
  
</div>
</div>

  
  </div>

    </div>
  </div>
</div>
<div  class="section my-5 pb-5 narrow">
  <div class="container">
    <div >
      
    </div>
  </div>
</div>
<div  class="section my-5 pb-5 ">
  <div class="container">
    <div >
      

  <div class="block block--cta cta cta--red-on-black cta-- my-5 p-3 text-center">

  
    

    <div class="d-md-flex justify-content-around align-items-center flex-wrap">
    <div class="cta__content my-2">
      
            <div class="cta__field-content p-2"><p class="h4 mb-4 mt-3 font-weight-bold">OUR BEST CONTENT, DELIVERED TO YOUR INBOX</p>

<p><iframe title="Subscribe to our newsletter" aria-label="Embedded form to subscribe to our email newsletter" frameborder="0" height="50" scrolling="no" src="/sysadmin/eloqua-embedded-subscribe.html?offer_id=701f20000012gE7AAI" style="max-width:670px;margin:0 auto;" width="100%"></iframe></p>
</div>
      
    </div>
      </div>
  
  </div>

    </div>
  </div>
</div>

  </article>

  
  </div>


              </div>
        </main>

            <footer>
              <div class="page__colophon bg-dark-gray py-4 bg-dark-gray">
          <div class="container">
              
  <div class="block block--basic block--sysadmin-colophon-disclaimer">

  
    

      
            <div class="basic__body"><p>The opinions expressed on this website are those of each author, not of the author's employer or of Red Hat. The content published on this site are community contributions and are for informational purpose only AND ARE NOT, AND ARE NOT INTENDED TO BE, RED HAT DOCUMENTATION, SUPPORT, OR ADVICE.</p>

<p>Red Hat and the Red Hat logo are trademarks of Red Hat, Inc., registered in the United States and other countries.</p>
</div>
      
  
  </div>


          </div>
        </div>
                    <div class="page__footer bg-dark py-3">
        <div class="container">
          <div class="d-sm-flex justify-content-between align-items-center">
              

  
    

    
  <a href="https://www.redhat.com/" class="navbar-brand mr-0 mr-lg-auto mb-3 mb-sm-0">
            <img src="/sysadmin/themes/custom/sysadmin/logo.svg" width="135" height="31" class="d-inline-block align-top" alt="Red Hat logo" />

        
  </a>



  <div class="block block--basic block--copyright my-0 mx-sm-3 mb-1 mb-sm-0">

  
    

      
            <div class="basic__body"><p>Copyright ©2021 Red Hat, Inc.</p>
</div>
      
  
  </div>

  <div class="block block--sysadmin-footer my-0 mb-1 mb-sm-0">

  
    

      
  


  <ul class="nav d-flex d-sm-block d-md-flex justify-content-center align-items-center">
                                          <li class="nav-item  ">
                      <a href="https://www.redhat.com/en/about/privacy-policy" class="nav-link">Privacy Policy</a>
                  </li>
                                      <li class="nav-item  ">
                      <a href="https://www.redhat.com/en/about/terms-use" class="nav-link">Terms of Use</a>
                  </li>
                                      <li class="nav-item  ">
                      <a href="https://www.redhat.com/en/about/all-policies-guidelines" class="nav-link">All policies and guidelines</a>
                  </li>
            </ul>


  
  </div>

  <div class="block block--basic block--footerredhatsummit">

  
    

      
            <div class="basic__body"><div style="margin-left: 1rem"><a href="https://www.redhat.com/en/summit?intcmp=7013a0000026RhqAAE" target="_blank"><img alt="Red Hat Summit" src="https://www.redhat.com/cms/managed-files/Logo-Red_Hat-Summit-A-Standard-RGB-02_0.svg" width="72px" /></a></div>
</div>
      
  
  </div>

  <div class="block block--sharelinks">

  
    

      <div class="a2a_kit a2a_kit_size_32 a2a_floating_style a2a_vertical_style" data-a2a-url="https://www.redhat.com/sysadmin/packaging-applications-python">
  <a class="a2a_button_twitter"></a>
  <a class="a2a_button_facebook"></a>
  <a class="a2a_button_linkedin"></a>
  <a class="a2a_button_reddit"></a>
  <a class="a2a_button_email"></a>
</div>
<div class="a2a_kit a2a_kit_size_32 a2a_floating_style a2a_default_style">
  <a class="a2a_button_twitter"></a>
  <a class="a2a_button_facebook"></a>
  <a class="a2a_button_linkedin"></a>
  <a class="a2a_button_reddit"></a>
  <a class="a2a_button_email"></a>
</div>

<script>
  var a2a_config = a2a_config || {};
  a2a_config.templates = a2a_config.templates || {};
  a2a_config.templates.twitter = {
    text: "Packaging applications to install on other machines with Python https://red.ht/3Dkp8Iq via #EnableSysadmin by @josevnz",
  };
    a2a_config.templates.facebook = {
    hashtag: "#EnableSysadmin",
  };
  </script>

  
  </div>


  <div class="block block--cta block--ctasubscribesidebar cta cta--blue-on-white cta-- my-5 p-3 text-center">

  
    

    <div class="d-md-flex justify-content-around align-items-center flex-wrap">
    <div class="cta__content my-2">
      
            <div class="cta__field-content p-2"><div class="subscribe-sidebar">
<div class="target-band-never-show-button">x</div>

<h4>Subscribe now</h4>

<p class="eloqua-email-capture-text">Get the highlights in your inbox every week.</p>

<p><iframe aria-label="Embedded form to subscribe to our email newsletter" frameborder="0" height="50" scrolling="no" src="/sysadmin/eloqua-embedded-email-capture-block.html?offer_id=701f20000012gE7AAI" style="max-width:670px;margin:0 auto;" title="Subscribe to our newsletter" width="100%"></iframe></p>
</div>
</div>
      
    </div>
      </div>
  
  </div>


          </div>
        </div>
            </footer>
      </div>

  </div>


<script type="application/json" data-drupal-selector="drupal-settings-json">{"path":{"baseUrl":"\/sysadmin\/","scriptPath":null,"pathPrefix":"","currentPath":"node\/5386","currentPathIsAdmin":false,"isFront":false,"currentLanguage":"en"},"pluralDelimiter":"\u0003","suppressDeprecationErrors":true,"ckeditorheight":{"offset":1,"line_height":1.5,"unit":"em","disable_autogrow":null},"colorbox":{"opacity":"0.85","current":"{current} of {total}","previous":"\u00ab Prev","next":"Next \u00bb","close":"Close","maxWidth":"98%","maxHeight":"98%","fixed":true,"mobiledetect":true,"mobiledevicewidth":"480px"},"blazy":{"loadInvisible":false,"offset":100,"saveViewportOffsetDelay":50,"validateDelay":25},"blazyIo":{"enabled":false,"disconnect":false,"rootMargin":"0px","threshold":[0]},"user":{"uid":0,"permissionsHash":"51f347f394db8c9bda75fb2a6f2d406a82353e6cfb9faf5ace3100b98d716870"}}</script>
<script src="/sysadmin/sites/default/files/js/js_qIDgH_1Ntr3oybBWS5Dii3UJ8C3X9Nh-0RbMnncIcGE.js"></script>

  <script type="text/javascript">
    if (("undefined" !== typeof _satellite) && ("function" === typeof _satellite.pageBottom)) {
      _satellite.pageBottom();
    }
  </script>
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam-cell.nr-data.net","licenseKey":"a03a21ae8a","applicationID":"467345710","transactionName":"ZlNTbUBQDxZUWxJRVl8ZcFpGWA4LGnwUTUlQWm1XXVUEOXZXCExLXlpdXEBtLwpRXTBRXEZ1XldGQw4JWV0UFQdHX1RO","queueTime":0,"applicationTime":539,"atts":"ShRQGwhKHBg=","errorBeacon":"bam-cell.nr-data.net","agent":""}</script><script type="text/javascript"  src="/rCAP5/w-/ZJ/1EnB/lDHtt5n/ViaV8JSbJ1iw/dzojDwE/UGE4/MkhLCDwB"></script></body>
</html>
