<!DOCTYPE html>
<html lang="en" dir="ltr" prefix="content: http://purl.org/rss/1.0/modules/content/  dc: http://purl.org/dc/terms/  foaf: http://xmlns.com/foaf/0.1/  og: http://ogp.me/ns#  rdfs: http://www.w3.org/2000/01/rdf-schema#  schema: http://schema.org/  sioc: http://rdfs.org/sioc/ns#  sioct: http://rdfs.org/sioc/types#  skos: http://www.w3.org/2004/02/skos/core#  xsd: http://www.w3.org/2001/XMLSchema# ">
<head>
<script id="dpal" src="https://www.redhat.com/ma/dpal.js"></script>
<meta charset="utf-8" /><script type="text/javascript">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</script>
<link rel="canonical" href="https://www.redhat.com/sysadmin/text-editor-roundup-2022" />
<meta name="description" content="Are you getting everything you need out of your text editor? Read Enable Sysadmin&#039;s recent articles about Linux text editors to find out what you&#039;re missing." />
<meta name="dcterms.title" content="Linux skills: 9 tutorials to get more from your text editor" />
<meta name="dcterms.creator" content="vwalker" />
<meta name="dcterms.publisher" content="Red Hat, Inc." />
<meta name="dcterms.language" content="en" />
<meta property="og:site_name" content="Enable Sysadmin" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.redhat.com/sysadmin/text-editor-roundup-2022" />
<meta property="og:title" content="Linux skills: 9 tutorials to get more from your text editor" />
<meta property="og:image" content="https://www.redhat.com/sysadmin/sites/default/files/styles/google_discover/public/2020-12/five-highlighters-text-editors.jpg?itok=vhlt088w" />
<meta property="og:image:secure_url" content="https://www.redhat.com/sysadmin/sites/default/files/styles/google_discover/public/2020-12/five-highlighters-text-editors.jpg?itok=vhlt088w" />
<meta property="og:image:type" content="image/jpeg" />
<meta property="og:image:width" content="1000" />
<meta property="og:video:width" content="600" />
<meta property="og:image:height" content="675" />
<meta property="og:updated_time" content="2022-07-22T09:00:00+0000" />
<meta property="og:image:alt" content="https://www.redhat.com/sysadmin/sites/default/files/styles/google_discover/public/2020-12/five-highlighters-text-editors.jpg?itok=vhlt088w" />
<meta property="og:street_address" content="100 East Davie Street" />
<meta property="og:locality" content="Raleigh" />
<meta property="og:region" content="NC" />
<meta property="og:postal_code" content="27601" />
<meta property="og:country_name" content="United States" />
<meta property="og:phone_number" content="+1 919 754 4950" />
<meta property="og:fax_number" content="+1 919 800 3804" />
<meta property="og:locale" content="en_US" />
<meta property="article:author" content="https://www.redhat.com/sysadmin/users/vwalker" />
<meta property="article:publisher" content="https://www.facebook.com/redhatinc" />
<meta property="article:section" content="Enable Sysadmin" />
<meta property="article:tag" content="Text editors" />
<meta property="article:tag" content="Software" />
<meta property="article:modified_time" content="2022-07-22T09:00:00+0000" />
<meta name="twitter:card" content="photo" />
<meta name="twitter:title" content="Linux skills: 9 tutorials to get more from your text editor" />
<meta name="twitter:site:id" content="14627400" />
<meta name="twitter:creator" content="@" />
<meta name="twitter:url" content="https://www.redhat.com/sysadmin/text-editor-roundup-2022" />
<meta name="twitter:image:alt" content="Red Hat, Inc." />
<meta name="twitter:image:height" content="1000" />
<meta name="twitter:image:width" content="600" />
<meta name="twitter:image" content="https://www.redhat.com/sysadmin/sites/default/files/styles/full/public/2020-12/five-highlighters-text-editors.jpg?itok=97N75qI9" />
<meta name="Generator" content="Drupal 9 (https://www.drupal.org)" />
<meta name="MobileOptimized" content="width" />
<meta name="HandheldFriendly" content="true" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<script type="application/ld+json">{
    "@context": "https://schema.org",
    "@graph": [
        {
            "@type": "TechArticle",
            "headline": "Linux skills: 9 tutorials to get more from your text editor",
            "name": "Linux skills: 9 tutorials to get more from your text editor",
            "about": [
                "\u003Ca href=\u0022/sysadmin/topics/text-editors\u0022 hreflang=\u0022en\u0022\u003EText editors\u003C/a\u003E",
                "\u003Ca href=\u0022/sysadmin/topics/software\u0022 hreflang=\u0022en\u0022\u003ESoftware\u003C/a\u003E"
            ],
            "description": "Are you getting everything you need out of your text editor? Read Enable Sysadmin\u0027s recent articles about Linux text editors to find out what you\u0027re missing.",
            "image": {
                "@type": "ImageObject",
                "url": "https://www.redhat.com/sysadmin/sites/default/files/styles/full/public/2020-12/five-highlighters-text-editors.jpg?itok=97N75qI9",
                "width": "1000",
                "height": "600"
            },
            "dateModified": "2022-07-22T09:00:00+0000",
            "author": {
                "@type": "Person",
                "@id": "https://www.redhat.com/sysadmin/users/vwalker",
                "name": "vwalker",
                "url": "https://www.redhat.com/sysadmin/users/vwalker",
                "sameAs": "https://twitter.com/"
            },
            "publisher": {
                "@type": "Organization",
                "@id": "https://www.redhat.com/"
            },
            "mainEntityOfPage": "https://www.redhat.com/sysadmin/text-editor-roundup-2022"
        },
        {
            "@type": "Corporation",
            "@id": "https://www.redhat.com/",
            "name": "Red Hat, Inc.",
            "sameAs": [
                "https://en.wikipedia.org/wiki/Red_Hat",
                "http://www.linkedin.com/company/red-hat",
                "http://www.youtube.com/user/RedHatVideos",
                "https://www.facebook.com/redhatinc",
                "https://twitter.com/RedHat"
            ],
            "url": "https://www.redhat.com/",
            "telephone": "+1 919 754 4950",
            "contactPoint": {
                "@type": "ContactPoint",
                "telephone": "+1-888-RED-HAT1",
                "availableLanguage": "English",
                "contactType": "sales",
                "faxnumber": "+1 919 800 3804"
            },
            "logo": {
                "@type": "ImageObject",
                "url": "https://www.redhat.com/sysadmin/themes/custom/sysadmin/assets/images/red-hat-logo.png",
                "width": "254",
                "height": "60"
            },
            "address": {
                "@type": "PostalAddress",
                "streetAddress": "100 East Davie Street",
                "addressLocality": "Raleigh",
                "addressRegion": "NC",
                "postalCode": "27601",
                "addressCountry": "United States"
            }
        },
        {
            "@type": "Person",
            "name": "Vicki Walker",
            "sameAs": "https://twitter.com/",
            "image": {
                "@type": "ImageObject",
                "url": "https://www.redhat.com/sysadmin/sites/default/files/styles/user_picture_square/public/pictures/2021-07/VW_headshot.jpg?itok=NFWm4kZr",
                "width": "240",
                "height": "240"
            }
        },
        {
            "@type": "WebPage",
            "@id": "https://www.redhat.com/sysadmin/text-editor-roundup-2022",
            "publisher": {
                "@type": "Organization",
                "@id": "https://www.redhat.com/"
            }
        },
        {
            "@type": "WebSite",
            "@id": "https://www.redhat.com/sysadmin/",
            "name": "Enable Sysadmin",
            "url": "https://www.redhat.com/sysadmin/",
            "publisher": {
                "@type": "Organization",
                "@id": "https://www.redhat.com/"
            }
        }
    ]
}</script>
<meta name="robots" content="max-image-preview:large" />
<link rel="shortcut icon" href="/sysadmin/themes/custom/sysadmin/favicon.ico" type="image/vnd.microsoft.icon" />
<link rel="revision" href="https://www.redhat.com/sysadmin/text-editor-roundup-2022" />
<link rel="apple-touch-icon" sizes="180x180" href="/sysadmin/themes/custom/sysadmin/assets/favicon/apple-touch-icon.png">
<link rel="icon" type="image/png" sizes="32x32" href="/sysadmin/themes/custom/sysadmin/assets/favicon/favicon-32x32.png">
<link rel="icon" type="image/png" sizes="16x16" href="/sysadmin/themes/custom/sysadmin/assets/favicon/favicon-16x16.png">
<link rel="manifest" href="/sysadmin/themes/custom/sysadmin/assets/favicon/site.webmanifest">
<link rel="mask-icon" href="/sysadmin/themes/custom/sysadmin/assets/favicon/safari-pinned-tab.svg" color="#ee0000">
<meta name="msapplication-TileColor" content="#1a1a1a">
<meta name="theme-color" content="#ffffff">
<title>Linux skills: 9 tutorials to get more from your text editor | Enable Sysadmin</title>
<link rel="stylesheet" media="all" href="/sysadmin/sites/default/files/css/css_OQj4E-N4_wLOrDqdlnY-zAp-8guMrz7U3seBP7DrzWQ.css" />
<link rel="stylesheet" media="all" href="/sysadmin/sites/default/files/css/css_Dzx-6Xpc6oyg3ei1B0RkzAh9Rm1O8dGLLPO9Ucsd39M.css" />



</head>
<body>
<a href="#main-content" class="visually-hidden focusable">
Skip to main content
</a>

  <div class="dialog-off-canvas-main-canvas" data-off-canvas-main-canvas>
    

<div class="redhat-cookie-banner">
<section id="redhat-cookie-privacy-banner" class="redhat-cookie-banner-wrapper" style="display: block;">
  <div class="container my-3 pr-5">
    <p>We use cookies on our websites to deliver our online services. Details about how we use cookies and how you may disable them are set out in our <a href="http://www.redhat.com/en/about/privacy-policy#cookies">Privacy Statement</a>. By using this website you agree to our use of cookies.
    <span class="cookie-more">
    <a id="redhat-cookie-privacy-banner-close" href="javascript:void(0);" class="cookie-close">&times;</a>
    </span>
    </p>
  </div>
</section>
</div>

<div class="page d-flex flex-column">
  <div class="navbar navbar-expand-lg justify-content-between navbar-dark bg-dark">
    <div class="container">
                
  <div class="block block--sysadmin-navbar-branding">

  
    

    
  <a href="https://www.redhat.com/" class="navbar-brand ">
            <img src="/sysadmin/themes/custom/sysadmin/logo.svg" width="135" height="31" class="d-inline-block align-top" alt="Red Hat logo" />

        
  </a>


  </div>


      
      <div class="navbar-toggler-wrapper">
        <button class="navbar-toggler" type="button" data-toggle="collapse"  data-parent="#collapse-parent" data-target="#search-collapse" aria-controls="search-collapse" aria-expanded="false" aria-label="Toggle search">
          <svg class="icon-collapsed" width="30" height="30" viewBox="0 0 30 30" xmlns="http://www.w3.org/2000/svg"><line x1="18.95" y1="19.15" x2="25.25" y2="25.75"/><circle cx="13.25" cy="12.75" r="8.5"/></svg>
          <svg class="icon-expanded" width="30" height="30" viewBox="0 0 30 30" xmlns="http://www.w3.org/2000/svg"><line x1="7.25" y1="7.25" x2="22.75" y2="22.75"/><line x1="7.25" y1="22.75" x2="22.75" y2="7.25"/></svg>
          <span style="vertical-align: middle;">Search</span>
        </button>
        <button class="navbar-toggler" type="button" data-toggle="collapse" data-parent="#collapse-parent" data-target="#mobilenav-collapse" aria-controls="mobilenav-collapse" aria-expanded="false" aria-label="Toggle navigation">
          <svg class="icon-collapsed" width="30" height="30" viewBox="0 0 30 30" xmlns="http://www.w3.org/2000/svg"><path d="M4 7h22M4 15h22M4 23h22"/></svg>
          <svg class="icon-expanded" width="30" height="30" viewBox="0 0 30 30" xmlns="http://www.w3.org/2000/svg"><line x1="7.25" y1="7.25" x2="22.75" y2="22.75"/><line x1="7.25" y1="22.75" x2="22.75" y2="7.25"/></svg>
        </button>
      </div>
    </div>
  </div>

  <div id="collapse-parent">
    <div id="search-collapse" class="search-collapse collapse" data-parent="#collapse-parent">
      <div class="py-4 px-3">
        <form class="form-inline m-2" action="/sysadmin/search/node" accept-charset="UTF-8" method="get">
          <div class="input-group flex-fill">
            <input class="form-control" type="search" name="keys" id="search" value="" placeholder="Search this site…" aria-label="Search this site…">
            <div class="input-group-append">
              <button class="btn btn-secondary font-weight-bold" type="submit">Search</button>
            </div>
          </div>
        </form>
      </div>
    </div>

    <div id="mobilenav-collapse" class="mobilenav-collapse d-lg-none collapse" data-parent="#collapse-parent">
                
  <div class="block block--sysadmin-navbar-sitename sitename">

  
    

    
  <a href="/sysadmin/" class="navbar-brand sitename">
        Enable Sysadmin
  </a>

  <span class="d-none d-lg-inline ml-1 mr-3 h5 navbar-sitename-divider">&nbsp;</span>

  </div>

  <div class="block block--sysadmin-main-menu">

  
    

      
  


  <ul class="nav navbar-nav">
                                          <li class="nav-item  dropdown">
                      <a href="/sysadmin/" class="nav-link dropdown-toggle" data-toggle="dropdown" data-drupal-link-system-path="&lt;front&gt;">Articles</a>
                          <div class="dropdown-menu">
              <a href="/sysadmin/topics/automation" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/146">Automation</a>
              <a href="/sysadmin/topics/career" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/51">Career</a>
              <a href="/sysadmin/topics/cloud" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/311">Cloud</a>
              <a href="/sysadmin/topics/containers" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/36"> Containers</a>
              <a href="/sysadmin/topics/kubernetes" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/66">Kubernetes</a>
              <a href="/sysadmin/topics/linux" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/21">Linux</a>
              <a href="/sysadmin/topics/programming" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/71"> Programming</a>
              <a href="/sysadmin/topics/security" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/96">Security</a>
  </div>
                              </li>
                                      <li class="nav-item  dropdown">
                      <a href="/sysadmin/about" class="nav-link dropdown-toggle" data-toggle="dropdown" data-drupal-link-system-path="node/71">About</a>
                          <div class="dropdown-menu">
              <a href="/sysadmin/about" class="dropdown-item" data-drupal-link-system-path="node/71">About Enable Sysadmin</a>
              <a href="/sysadmin/email" class="dropdown-item" data-drupal-link-system-path="node/376">Email newsletter</a>
              <a href="/sysadmin/join-community" class="dropdown-item" data-drupal-link-system-path="node/641">Join the community</a>
              <a href="/sysadmin/sudoers-program" class="dropdown-item" data-drupal-link-system-path="node/2106">Sudoers program</a>
              <a href="/sysadmin/meet-team" class="dropdown-item" data-drupal-link-system-path="node/2316">Meet the team</a>
              <a href="/sysadmin/faq" class="dropdown-item" data-drupal-link-system-path="node/1526">FAQs</a>
  </div>
                              </li>
                                      <li class="nav-item  ">
                      <a href="/sysadmin/welcome-enable-sysadmin" title="A Red Hat community publication for sysadmins, by sysadmins" class="nav-link">Welcome</a>
                  </li>
            </ul>


  
  </div>


      
              
          </div>
  </div>

  


<nav class="navbar navbar-expand-lg justify-content-between navbar-light  d-none d-lg-block text-dark bg-light border-bottom-light-gray">
      <div class="container">
  
      
  
  <button class="navbar-toggler" type="button" data-toggle="collapse" data-target=".navbar-collapse" aria-controls="navbar-collapse" aria-expanded="false" aria-label="Toggle navigation">
    <span class="navbar-toggler-icon"></span>
  </button>

  <div class="collapse navbar-collapse">
                  <div class="mr-auto d-flex navbar-desktop">
            
  <div class="block block--sysadmin-navbar-sitename sitename">

  
    

    
  <a href="/sysadmin/" class="navbar-brand sitename">
        Enable Sysadmin
  </a>

  <span class="d-none d-lg-inline ml-1 mr-3 h5 navbar-sitename-divider">&nbsp;</span>

  </div>

  <div class="block block--sysadmin-main-menu">

  
    

      
  


  <ul class="nav navbar-nav">
                                          <li class="nav-item  dropdown">
                      <a href="/sysadmin/" class="nav-link dropdown-toggle" data-toggle="dropdown" data-drupal-link-system-path="&lt;front&gt;">Articles</a>
                          <div class="dropdown-menu">
              <a href="/sysadmin/topics/automation" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/146">Automation</a>
              <a href="/sysadmin/topics/career" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/51">Career</a>
              <a href="/sysadmin/topics/cloud" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/311">Cloud</a>
              <a href="/sysadmin/topics/containers" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/36"> Containers</a>
              <a href="/sysadmin/topics/kubernetes" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/66">Kubernetes</a>
              <a href="/sysadmin/topics/linux" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/21">Linux</a>
              <a href="/sysadmin/topics/programming" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/71"> Programming</a>
              <a href="/sysadmin/topics/security" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/96">Security</a>
  </div>
                              </li>
                                      <li class="nav-item  dropdown">
                      <a href="/sysadmin/about" class="nav-link dropdown-toggle" data-toggle="dropdown" data-drupal-link-system-path="node/71">About</a>
                          <div class="dropdown-menu">
              <a href="/sysadmin/about" class="dropdown-item" data-drupal-link-system-path="node/71">About Enable Sysadmin</a>
              <a href="/sysadmin/email" class="dropdown-item" data-drupal-link-system-path="node/376">Email newsletter</a>
              <a href="/sysadmin/join-community" class="dropdown-item" data-drupal-link-system-path="node/641">Join the community</a>
              <a href="/sysadmin/sudoers-program" class="dropdown-item" data-drupal-link-system-path="node/2106">Sudoers program</a>
              <a href="/sysadmin/meet-team" class="dropdown-item" data-drupal-link-system-path="node/2316">Meet the team</a>
              <a href="/sysadmin/faq" class="dropdown-item" data-drupal-link-system-path="node/1526">FAQs</a>
  </div>
                              </li>
                                      <li class="nav-item  ">
                      <a href="/sysadmin/welcome-enable-sysadmin" title="A Red Hat community publication for sysadmins, by sysadmins" class="nav-link">Welcome</a>
                  </li>
            </ul>


  
  </div>


        </div>
          
                  
      
      

<div class="dropdown show text-align-right">
    <a href="/sysadmin/subscribe" class="navbar-util navbar-util--rss" aria-label="Subscribe to our feed or newsletter blast">
    <svg width="22" height="23" viewBox="0 0 22 23" xmlns="http://www.w3.org/2000/svg"><title>Subscribe to our RSS feed or Email newsletter</title><path d="M0 4.23c9.79 0 17.75 8 17.75 17.84h4.23A22.05 22.05 0 0 0 0 0v4.23z M0 7.67v4.23c2.74 0 5.33 1.07 7.27 3.03a10.26 10.26 0 0 1 3 7.3h4.24c0-8.02-6.5-14.56-14.51-14.56M2.93 16.87a2.94 2.94 0 0 0 0 5.85 2.93 2.93 0 1 0 0-5.85" fill-rule="evenodd"/></svg>

    <span class="sr-only">Subscribe to our RSS feed or Email newsletter.</span>
  </a>

    <a id="dropdownSearchLink" href="/sysadmin/search/node" class="navbar-util navbar-util--search" role="button" aria-label="Search this site…" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false">
    <svg width="30" height="30" viewBox="0 0 30 30" xmlns="http://www.w3.org/2000/svg" style="fill:none;stroke-width:3;stroke:#000;stroke-linecap:round;"><line x1="18.95" y1="19.15" x2="25.25" y2="25.75"/><circle cx="13.25" cy="12.75" r="8.5"/></svg>

  </a>
  <div class="dropdown-menu dropdown-menu-right p-1 pt-2" aria-labelledby="dropdownSearchLink">
    <form class="form-inline m-2" action="/sysadmin/search/node" accept-charset="UTF-8" method="get">
      <div class="input-group flex-fill">
        <input class="form-control" type="search" name="keys" id="search" value="" placeholder="Search this site…" aria-label="Search this site…">
        <div class="input-group-append">
          <button class="btn btn-secondary font-weight-bold" type="submit">GO</button>
        </div>
      </div>
    </form>
  </div>
  </div>
      </div>

      </div>
  </nav>

  <main class="pb-5">
                  <header class="page__header">
          <div class="container">
              <div data-drupal-messages-fallback class="hidden"></div>


          </div>
        </header>
          
    <a name="main-content" tabindex="-1"></a>

                  <div class="page__content">
                  
  <div class="block block--sysadmin-content">

  
    

      <article data-history-node-id="6028" role="article" about="/sysadmin/text-editor-roundup-2022" typeof="schema:Article" id="node--article--6028" class="full full--article node node--promoted">
  
    <span property="schema:name" content="Linux skills: 9 tutorials to get more from your text editor" class="hidden"></span>
  <span property="schema:interactionCount" content="UserComments:0" class="hidden"></span>


      <div  class="section my-5 narrow">
  <div class="container">
    <div >
      
  <div class="block">

  
    

      <span property="schema:name"><h1 class="font-weight-bold">Linux skills: 9 tutorials to get more from your text editor</h1>
</span>

  
  </div>

  <div class="block">

  
    

      
            <div class="article__field-subhead">Are you getting everything you need out of your text editor? Read Enable Sysadmin&#039;s recent articles about Linux text editors to find out what you&#039;re missing.</div>
      
  
  </div>

    </div>
  </div>
</div>
<div  class="section pb-5 narrow">
  <div class="container">
    <div >
      
  <div class="block">

  
    

      <p class="article-byline">
  <span class="article-date">
    <span class="label">Posted:</span>
    July 22, 2022
  </span>
    <span aria-hidden="true">|</span>
    <pfe-readtime for=".article__body" hidden>%t min read</pfe-readtime>
  <span aria-hidden="true">|</span>
  <span class="article-authors">
    <strong class="sr-only">by</strong>
          <a href="/sysadmin/users/vwalker" class="article-author article-author--primary">Vicki Walker<span class="author-affiliate"> (Red Hat)</span></a>      </span>
  </p>

  
  </div>

  <div class="block">

  
    

      
            <div class="article__field-media"><figure>
  
  
  <div class="blazy blazy--field blazy--field-media-image blazy--field-media-image--full-with-description image__field-media-image" data-blazy="">
    <div class="field__label font-weight-bold visually-hidden">
      Image    </div>
                  <div class="field__item">




                  <div class="media media--blazy media--image is-b-loading">
<img alt="5 Linux commands I&#039;m going to start using" class="media__image media__element b-lazy img-fluid" decoding="async" loading="lazy" data-src="/sysadmin/sites/default/files/styles/full/public/2020-12/five-highlighters-text-editors.jpg?itok=97N75qI9" src="data:image/svg+xml;charset=utf-8,%3Csvg%20xmlns%3D&#039;http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg&#039;%20viewBox%3D&#039;0%200%201%201&#039;%2F%3E" width="1000" height="600" typeof="foaf:Image" />
        </div>
        
  
</div>
              </div>

  <figcaption>
    
            <div class="image__field-media-description"><p><sup>Image by <a href="https://pixabay.com/users/422737-422737" target="_blank">422737</a> from <a href="https://pixabay.com/photos/highlighter-light-pens-coloured-603995/" target="_blank">Pixabay</a></sup></p>
</div>
      
  </figcaption>
</figure>
</div>
      
  
  </div>

  <div class="block">

  
    

      
            <div property="schema:text" class="clearfix article__body"><p>When it comes to a sysadmin's daily drivers, text editors are always near the top of the list. Whether you're partial to Vi/Vim, Emacs, Nano, ed, or any of the many other options out there, you probably couldn't do your job without one of these handy tools close at hand.</p>

<div data-embed-button="resource_list" data-entity-embed-display="view_mode:resource_list.link" data-entity-type="resource_list" data-entity-uuid="60b26066-acd0-4332-afa7-d98c9a079f02" data-langcode="en" class="align-right embedded-entity embedded-entity--resources embedded-entity--resources--link"><aside id="resource-list-more-linux-resources" class="eck-entity mt-2 py-3 pr-3 border-top border-danger">
  

<h2 class="h4">
      More Linux resources
  </h2>

<ul class="pl-3 mb-0">
      <li class="my-2"><a href="https://developers.redhat.com/cheat-sheets/advanced-linux-commands/?intcmp=701f20000012ngPAAQ">Advanced Linux commands cheat sheet</a></li>
      <li class="my-2"><a href="https://developers.redhat.com/products/rhel/download?intcmp=701f20000012ngPAAQ">Download RHEL 9 for free through the Red Hat Developer program</a></li>
      <li class="my-2"><a href="https://opensource.com/downloads/installing-linux-applications-ebook?intcmp=701f20000012ngPAAQ">A guide to installing applications on Linux</a></li>
      <li class="my-2"><a href="https://rhtapps.redhat.com/assessment/?intcmp=701f20000012ngPAAQ">Linux system administration skills assessment</a></li>
      <li class="my-2"><a href="https://www.redhat.com/en/services/training/rh024-red-hat-linux-technical-overview?intcmp=701f20000012ngPAAQ">Free course: RHEL technical overview</a></li>
  </ul>

</aside>
</div>


<p>If you're considering a new text editor, or aren't sure you're getting everything out of your current favorite, read some of Enable Sysadmin's recent articles about Linux text editors to find out what you're missing.</p>

<h2 id="learn-vivim-features-for-new-and-old-users">Learn Vi/Vim features for new and experienced users</h2>

<p>Vi was written way back in 1976, but it remains the default text editor on most Linux distributions (as well as macOS, BSD, and Solaris). Vim (which stands for “Vim improved”) is a port of Vi first released in 1991 with, as the name suggests, features that you won't find in Vi.</p>

<p>So if you're just getting started with Linux, you're probably using Vi or Vim. In that case, Seth Kenlon's <a href="https://www.redhat.com/sysadmin/get-started-vi-editor" target="_blank">How to get started with the Vi editor</a> will give you a leg up on your learning journey. Seth shares how to launch Vi, the differences between command mode and insert mode, and some shortcuts that will make your work on the command line easier.</p>

<p>If you're a seasoned Vim user, check out Jack Knight's <a href="https://www.redhat.com/sysadmin/vim-power-commands" target="_blank">Vim features for power users</a> to add some advanced features to your toolkit. Jack explains how to work with multiple files, comment several lines at once, write a macro to generate a number list, and more.</p>

<p><strong><em>[ Download now: <a href="https://opensource.com/downloads/bash-scripting-ebook?intcmp=701f20000012ngPAAQ" target="_blank">A sysadmin's guide to Bash scripting</a>. ]</em></strong></p>

<p>Automating tasks is one of the most important things a sysadmin can do to avoid rework and become more efficient. In <a href="https://www.redhat.com/sysadmin/recursive-vim-macros" target="_blank">Recursive Vim macros: One step further into automating repetitive tasks</a>, Elyezer Rezende takes the recommendations Ricardo Gerardi offers in <a href="https://www.redhat.com/sysadmin/use-vim-macros" target="_blank">Use Vim macros to automate frequent tasks</a> a step (or two further). Check out these two articles for tips on automating tasks with Vim.</p>

<p>If you love Vi/Vim but want some of the features available in newer text editors, Kakoune might help you bridge the gap. In <a href="https://www.redhat.com/sysadmin/kakoune-vi-text-editor" target="_blank">Try Kakoune for a modern Vi</a>, Seth Kenlon tells you how to get started with Kakoune and take advantage of its updated navigation options, keyboard shortcuts, and more.</p>

<h2 id="fall-for-emacs-features">Fall for Emacs features</h2>

<p>Emacs is a well-loved cousin of Vim with a dedicated fan base. If you're a new user, Tara Gu's article <a href="https://www.redhat.com/sysadmin/beginners-guide-emacs" target="_blank">A beginner's guide to text editing with Emacs</a> remains a must-read getting-started resource.</p>

<div data-embed-button="resource_list" data-entity-embed-display="view_mode:resource_list.link" data-entity-type="resource_list" data-entity-uuid="fa7b02cd-605a-450a-a022-fc9948302fa2" data-langcode="en" class="align-right embedded-entity embedded-entity--resources embedded-entity--resources--link"><aside id="resource-list-career-advice" class="eck-entity mt-2 py-3 pr-3 border-top border-danger">
  

<h2 class="h4">
      Career advice
  </h2>

<ul class="pl-3 mb-0">
      <li class="my-2"><a href="https://www.redhat.com/rhtapps/assessment/?intcmp=701f20000012ngPAAQ">Take a sysadmin skills assessment</a></li>
      <li class="my-2"><a href="https://www.redhat.com/en/services/training/all-courses-exams?intcmp=701f20000012ngPAAQ">Explore training and certification options</a></li>
      <li class="my-2"><a href="https://www.redhat.com/en/resources/certification-remote-exams-FAQ?intcmp=701f20000012ngPAAQ">Red Hat Certification remote exams FAQ</a></li>
      <li class="my-2"><a href="https://enterprisersproject.com/IT-career-advice-ebook?intcmp=701f20000012ngPAAQ">Get essential IT career advice from IT leaders</a></li>
  </ul>

</aside>
</div>


<p>But if you want to go in a little deeper, Seth Kenlon's <a href="https://www.redhat.com/sysadmin/5-emacs-features-to-love" target="_blank">5 features that will make you fall in love with Emacs</a> gives you insight into using plugins, remote editing, keyboard shortcuts, and more. And because these features are so useful, Seth shows how to implement them in other text editors, including Vim, Atom, and VS Code.</p>

<h2 id="go-really-old-school-with-ed">Go really old school with ed</h2>

<p>Ed was the first text editor written for Unix, making it one of the oldest text editors available. It's also one of the smallest and most powerful text editors. It may not have modern features, but as Seth Kenlon says in <a href="https://www.redhat.com/sysadmin/introduction-ed-editor" target="_blank">How to get started with the ed text editor</a>, it can get you out of a bind in an emergency, like when your system is in recovery mode and you don't have your usual tools available. For this reason alone, it's worth your time to learn.</p>

<p><strong><em>[ Free eBook: <a href="https://www.redhat.com/en/engage/linux-management-ebook-s-201912231121?intcmp=701f20000012ngPAAQ" target="_blank">Manage your Linux environment for success</a>. ]</em></strong></p>

<h2 id="compare-text-editors">Compare text editors</h2>

<p>There are <a href="https://opensource.com/article/21/2/open-source-text-editors" target="_blank">dozens of text editors</a> to choose from, and who has time to compare them all? If you're trying to decide which editor is right for you, get expert advice from real-world users in <a href="https://www.redhat.com/sysadmin/3-text-editors-compared" target="_blank">Vim vs. Nano vs. Emacs: Three sysadmins weigh in</a>. In this article, Seth Kenlon, Ricardo Gerardi, and Amy Marrich tell you what they like about their favorite text editor. See what they have to say when making your decision.</p>

<p>Do you have some text editor tips that make your life easier? Consider sharing them with other sysadmins by writing about them for Enable Sysadmin. For information about contributing, visit our <a href="https://www.redhat.com/sysadmin/faq" target="_blank">FAQ page</a> and sign up to <a href="https://www.redhat.com/sysadmin/join-community" target="_blank">join the community</a>.</p>
</div>
      
  
  </div>

  <div class="views-element-container block">

  
    

      <div><div class="listicle-view js-view-dom-id-29fbccfddf8b0e0f1ccf71cc99f9a11b4e748f2d917d84e1de5b5552cf3b51d0">
  
  
  

  
  
  

    <h3>Check out these related articles on Enable Sysadmin</h3>
    <div class="listicle-row"><div class="views-field views-field-field-listicle"><div class="field-content"><article data-history-node-id="3236" role="article" about="/sysadmin/five-vim-plugins" typeof="schema:Article" id="node--article--3236" class="listicle listicle--article node node--promoted">
  <div class="row align-items-center">
    <div class="col-md-6 listicle-image">
            <div class="article__field-media"><div>
  
  
  <div class="blazy blazy--field blazy--field-media-image blazy--field-media-image--listicle blazy--view--listicle-block-block-1 blazy--view blazy--view--listicle blazy--view--listicle--block-1 image__field-media-image" data-blazy="">
    <div class="field__label font-weight-bold visually-hidden">
      Image    </div>
                  <div class="field__item">




                  <div class="media media--blazy media--image is-b-loading">
<img alt="Top 5 Vim plugins for sysadmins" class="media__image media__element b-lazy img-fluid" decoding="async" loading="lazy" data-src="/sysadmin/sites/default/files/styles/card/public/2020-10/plugins.jpg?itok=5cYF7uSc" src="data:image/svg+xml;charset=utf-8,%3Csvg%20xmlns%3D&#039;http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg&#039;%20viewBox%3D&#039;0%200%201%201&#039;%2F%3E" width="700" height="420" typeof="foaf:Image" />
        </div>
        
  
</div>
              </div>

</div>
</div>
      </div>
    <div class="col-md-6 listicle-body">
      <div class="h4 listicle-title pt-4 pt-md-0"><a href="/sysadmin/five-vim-plugins"><span property="schema:name">Top five Vim plugins for sysadmins</span>
</a></div>
      <div class="listicle-text font-weight-light py-2">
        
            <div property="schema:text" class="clearfix article__body">My list of the top five Vim plugins—plus a bonus.</div>
      
      </div>

      <div class="listicle-footer">
        <div class="article-date">
          <span class="label">Posted:</span>
          October 16, 2020
        </div>
        <div class="article-authors">
                      <span class="label">Author:</span>
                                <a href="/sysadmin/users/ricardo-gerardi" class="article-author article-author--primary">Ricardo Gerardi<span class="author-affiliate"> (Red Hat, Sudoer)</span></a>                  </div>
      </div>
    </div>
  </div>
</article>
<article data-history-node-id="2811" role="article" about="/sysadmin/vim-commands" typeof="schema:Article" id="node--article--2811" class="listicle listicle--article node node--promoted">
  <div class="row align-items-center">
    <div class="col-md-6 listicle-image">
            <div class="article__field-media"><div>
  
  
  <div class="blazy blazy--field blazy--field-media-image blazy--field-media-image--listicle blazy--view--listicle-block-block-1 blazy--view blazy--view--listicle blazy--view--listicle--block-1 image__field-media-image" data-blazy="">
    <div class="field__label font-weight-bold visually-hidden">
      Image    </div>
                  <div class="field__item">




                  <div class="media media--blazy media--image is-b-loading">
<img alt="vim 2.0" class="media__image media__element b-lazy img-fluid" decoding="async" loading="lazy" data-src="/sysadmin/sites/default/files/styles/card/public/2020-07/writing-5283739_1920%20Cropped.jpg?itok=exDX4Fde" src="data:image/svg+xml;charset=utf-8,%3Csvg%20xmlns%3D&#039;http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg&#039;%20viewBox%3D&#039;0%200%201%201&#039;%2F%3E" width="700" height="420" typeof="foaf:Image" />
        </div>
        
  
</div>
              </div>

</div>
</div>
      </div>
    <div class="col-md-6 listicle-body">
      <div class="h4 listicle-title pt-4 pt-md-0"><a href="/sysadmin/vim-commands"><span property="schema:name">Vim: Basic and intermediate commands</span>
</a></div>
      <div class="listicle-text font-weight-light py-2">
        
            <div property="schema:text" class="clearfix article__body">Here are some of my most frequently used commands in the Vim text editor.</div>
      
      </div>

      <div class="listicle-footer">
        <div class="article-date">
          <span class="label">Posted:</span>
          August 13, 2020
        </div>
        <div class="article-authors">
                      <span class="label">Author:</span>
                                <a href="/sysadmin/users/shashank-hegde" class="article-author article-author--primary">Shashank Nandishwar Hegde<span class="author-affiliate"> (Red Hat)</span></a>                  </div>
      </div>
    </div>
  </div>
</article>
<article data-history-node-id="1151" role="article" about="/sysadmin/beginners-guide-emacs" typeof="schema:Article" id="node--article--1151" class="listicle listicle--article node node--promoted">
  <div class="row align-items-center">
    <div class="col-md-6 listicle-image">
            <div class="article__field-media"><div>
  
  
  <div class="blazy blazy--field blazy--field-media-image blazy--field-media-image--listicle blazy--view--listicle-block-block-1 blazy--view blazy--view--listicle blazy--view--listicle--block-1 image__field-media-image" data-blazy="">
    <div class="field__label font-weight-bold visually-hidden">
      Image    </div>
                  <div class="field__item">




                  <div class="media media--blazy media--image is-b-loading">
<img alt="typewriter vintage" class="media__image media__element b-lazy img-fluid" decoding="async" loading="lazy" data-src="/sysadmin/sites/default/files/styles/card/public/2019-11/typewriter.jpg?itok=NWXCs8l6" src="data:image/svg+xml;charset=utf-8,%3Csvg%20xmlns%3D&#039;http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg&#039;%20viewBox%3D&#039;0%200%201%201&#039;%2F%3E" width="700" height="420" typeof="foaf:Image" />
        </div>
        
  
</div>
              </div>

</div>
</div>
      </div>
    <div class="col-md-6 listicle-body">
      <div class="h4 listicle-title pt-4 pt-md-0"><a href="/sysadmin/beginners-guide-emacs"><span property="schema:name">A beginner’s guide to text editing with Emacs</span>
</a></div>
      <div class="listicle-text font-weight-light py-2">
        
            <div property="schema:text" class="clearfix article__body">Learning this lightweight text editing tool can help you navigate faster, inside and outside of the text editor.</div>
      
      </div>

      <div class="listicle-footer">
        <div class="article-date">
          <span class="label">Posted:</span>
          November 27, 2019
        </div>
        <div class="article-authors">
                      <span class="label">Author:</span>
                                <a href="/sysadmin/users/taragu" class="article-author article-author--primary">Tara Gu</a>                  </div>
      </div>
    </div>
  </div>
</article>
</div></div></div>

    

  
  

  
  
</div>
</div>

  
  </div>

  <div class="block">

  
    

      <div class="topics">
  <strong>Topics:</strong>&nbsp;&nbsp;
      <a href="/sysadmin/topics/text-editors" class="btn btn-primary btn-sm font-weight-bold">Text editors</a>&nbsp;&nbsp;
      <a href="/sysadmin/topics/software" class="btn btn-primary btn-sm font-weight-bold">Software</a>&nbsp;&nbsp;
  </div>
  
  </div>

    </div>
  </div>
</div>
<div >
  <div >
    
  <div class="block">

  
    

      
<section data-history-node-id="6028" role="article" about="/sysadmin/text-editor-roundup-2022" typeof="schema:Article" id="node--article--6028" class="section my-5 py-5 bg-light-gray authors-bio authors-bio--article">
  <div class="container">
          <div class="row">
        <div class="col-md-2 text-center">
                      
<img alt="Author’s photo" data-affiliation="Red Hat" src="/sysadmin/sites/default/files/styles/user_picture_square/public/pictures/2021-07/VW_headshot.jpg?itok=NFWm4kZr" width="240" height="240" loading="lazy" typeof="foaf:Image" class="rounded-circle img-fluid" />


          
        </div>
        <div class="col-md-10 col-lg-8">
          <h2 class="font-weight-light text-center text-md-left">
                          Vicki Walker
                      </h2>
          <div>
                          <p>
                Vicki Walker is Managing Editor, Digital Communities, for Red Hat. She has more than 15 years of experience in technology publishing for companies including Red Hat, InformationWeek.com, Dark Reading, SAP, BlackBerry, and Network Computing, for more than 15 years.
                                  <a href="/sysadmin/users/vwalker" class="author-more-link">More about me</a>
                              </p>
                      </div>
        </div>
      </div>
      </div>
</section>



  
  </div>

  <div class="block">

  
    

      

  
  </div>

  </div>
</div>
<div >
  <div >
    

  <div class="block block--cta cta cta--red-on-black cta-- my-5 p-3 text-center">

  
    

    <div class="d-md-flex justify-content-around align-items-center flex-wrap">
    <div class="cta__content my-2">
      
            <div class="cta__field-content p-2"><h2>Red Hat Summit 2022: On Demand</h2>

<p>Get the latest on Ansible, Red Hat Enterprise Linux, OpenShift, and more from our virtual event on demand.</p>
</div>
      
    </div>
        <div class="cta__link my-2">
      <a
        href="https://www.redhat.com/en/summit?intcmp=701f20000012ngPAAQ"
        target="_blank"
        class="btn btn-lg btn-danger font-weight-bold">
        Register for free
      </a>
    </div>
      </div>
  
  </div>

  </div>
</div>
<div  class="section">
  <div class="container">
    <div >
      
  <div class="views-element-container block">

  
    

      <div><div class="js-view-dom-id-8102e5d309367adc8079207be1499b3660ff0f72bb2dc71b454c90563b193f9a">
  
  
  

  
  
  

    <h2>Related Content</h2>
                        <div class="card-deck my-4">
                        <article data-history-node-id="5999" role="article" about="/sysadmin/install-software-packages-rhel" typeof="schema:Article" id="node--article--5999" class="card card--article node node--promoted">
      <div class="card-img-top">
            <div class="article__field-media"><div>
  
  
  <div class="blazy blazy--field blazy--field-media-image blazy--field-media-image--card image__field-media-image" data-blazy="">
    <div class="field__label font-weight-bold visually-hidden">
      Image    </div>
                  <div class="field__item">




                  <div class="media media--blazy media--image media--responsive is-b-loading">  
<img class="media__image media__element b-lazy b-responsive img-fluid" decoding="async" loading="lazy" data-src="/sysadmin/sites/default/files/2021-01/TerminalSession.jpg" srcset="" data-srcset="/sysadmin/sites/default/files/styles/card/public/2021-01/TerminalSession.jpg?itok=qAx4R8pg 1x" src="data:image/svg+xml;charset=utf-8,%3Csvg%20xmlns%3D&#039;http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg&#039;%20viewBox%3D&#039;0%200%201%201&#039;%2F%3E" alt="How to capture terminal sessions using the script commandPhoto by Sora Shimazaki from Pexels" typeof="foaf:Image" />

        </div>
        
  
</div>
              </div>

</div>
</div>
      </div>
    <div class="card-body">
    <div class="h4 card-title"><a href="/sysadmin/install-software-packages-rhel"><span property="schema:name">How to install software packages on Red Hat Enterprise Linux (RHEL)</span>
</a></div>
    <div class="card-text">
            <div property="schema:text" class="clearfix article__body">Learn how to install software with RHEL's package manager using the dnf command or the GNOME Software app.</div>
      </div>
  </div>
  <div class="card-footer">
    <div class="article-date">
      <span class="label">Posted:</span>
      June 27, 2022
    </div>
    <div class="article-authors">
              <span class="label">Author:</span>
                    <a href="/sysadmin/users/skenlon" class="article-author article-author--primary">Seth Kenlon<span class="author-affiliate"> (Red Hat)</span></a>          </div>
  </div>
</article>


                            <article data-history-node-id="5990" role="article" about="/sysadmin/vim-power-commands" typeof="schema:Article" id="node--article--5990" class="card card--article node node--promoted">
      <div class="card-img-top">
            <div class="article__field-media"><div>
  
  
  <div class="blazy blazy--field blazy--field-media-image blazy--field-media-image--card image__field-media-image" data-blazy="">
    <div class="field__label font-weight-bold visually-hidden">
      Image    </div>
                  <div class="field__item">




                  <div class="media media--blazy media--image media--responsive is-b-loading">  
<img class="media__image media__element b-lazy b-responsive img-fluid" decoding="async" loading="lazy" data-src="/sysadmin/sites/default/files/2022-01/text-editor.jpg" srcset="" data-srcset="/sysadmin/sites/default/files/styles/card/public/2022-01/text-editor.jpg?itok=ZhhOLtky 1x" src="data:image/svg+xml;charset=utf-8,%3Csvg%20xmlns%3D&#039;http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg&#039;%20viewBox%3D&#039;0%200%201%201&#039;%2F%3E" alt="Person typing in a text editor on a laptop" typeof="foaf:Image" />

        </div>
        
  
</div>
              </div>

</div>
</div>
      </div>
    <div class="card-body">
    <div class="h4 card-title"><a href="/sysadmin/vim-power-commands"><span property="schema:name">5 Vim features for power users</span>
</a></div>
    <div class="card-text">
            <div property="schema:text" class="clearfix article__body">Learn how to work with multiple files, comment several lines at once, write a macro to generate a number list, and more.</div>
      </div>
  </div>
  <div class="card-footer">
    <div class="article-date">
      <span class="label">Posted:</span>
      June 8, 2022
    </div>
    <div class="article-authors">
              <span class="label">Author:</span>
                    <a href="/sysadmin/jackknight" class="article-author article-author--primary">Jack Knight</a>          </div>
  </div>
</article>


                            <article data-history-node-id="5962" role="article" about="/sysadmin/mutt-email-oauth2" typeof="schema:Article" id="node--article--5962" class="card card--article node node--promoted">
      <div class="card-img-top">
            <div class="article__field-media"><div>
  
  
  <div class="blazy blazy--field blazy--field-media-image blazy--field-media-image--card image__field-media-image" data-blazy="">
    <div class="field__label font-weight-bold visually-hidden">
      Image    </div>
                  <div class="field__item">




                  <div class="media media--blazy media--image media--responsive is-b-loading">  
<img class="media__image media__element b-lazy b-responsive img-fluid" decoding="async" loading="lazy" data-src="/sysadmin/sites/default/files/2020-02/email-824310_1920%20Cropped.jpg" srcset="" data-srcset="/sysadmin/sites/default/files/styles/card/public/2020-02/email-824310_1920%20Cropped.jpg?itok=FBM1cVcx 1x" src="data:image/svg+xml;charset=utf-8,%3Csvg%20xmlns%3D&#039;http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg&#039;%20viewBox%3D&#039;0%200%201%201&#039;%2F%3E" alt="@ (at sign) on keyboard" typeof="foaf:Image" />

        </div>
        
  
</div>
              </div>

</div>
</div>
      </div>
    <div class="card-body">
    <div class="h4 card-title"><a href="/sysadmin/mutt-email-oauth2"><span property="schema:name">How to set up OAuth2 in the Mutt email client</span>
</a></div>
    <div class="card-text">
            <div property="schema:text" class="clearfix article__body">Configure Mutt to use your OAuth2 credentials to send and receive Gmail from the command line.</div>
      </div>
  </div>
  <div class="card-footer">
    <div class="article-date">
      <span class="label">Posted:</span>
      May 4, 2022
    </div>
    <div class="article-authors">
              <span class="label">Author:</span>
                    <a href="/sysadmin/users/filip-janus" class="article-author article-author--primary">Filip Januš<span class="author-affiliate"> (Red Hat)</span></a>          </div>
  </div>
</article>


                              </div>
            
    

  
  

  
  
</div>
</div>

  
  </div>

    </div>
  </div>
</div>
<div  class="section my-5 pb-5 narrow">
  <div class="container">
    <div >
      
    </div>
  </div>
</div>
<div  class="section my-5 pb-5 ">
  <div class="container">
    <div >
      

  <div class="block block--cta cta cta--red-on-black cta-- my-5 p-3 text-center">

  
    

    <div class="d-md-flex justify-content-around align-items-center flex-wrap">
    <div class="cta__content my-2">
      
            <div class="cta__field-content p-2"><p class="h4 mb-4 mt-3 font-weight-bold">OUR BEST CONTENT, DELIVERED TO YOUR INBOX</p>

<p><iframe aria-label="Embedded form to subscribe to our email newsletter" frameborder="0" height="50" scrolling="no" src="/sysadmin/eloqua-embedded-subscribe.html?offer_id=701f20000012gE7AAI" style="max-width:670px;margin:0 auto;" title="Subscribe to our newsletter" width="100%"></iframe></p>
</div>
      
    </div>
      </div>
  
  </div>

    </div>
  </div>
</div>

  </article>

  
  </div>


              </div>
        </main>

            <footer>
              <div class="page__colophon bg-dark-gray py-4 bg-dark-gray">
          <div class="container">
              
  <div class="block block--basic block--sysadmin-colophon-disclaimer">

  
    

      
            <div class="basic__body"><p>The opinions expressed on this website are those of each author, not of the author's employer or of Red Hat. The content published on this site are community contributions and are for informational purpose only AND ARE NOT, AND ARE NOT INTENDED TO BE, RED HAT DOCUMENTATION, SUPPORT, OR ADVICE.</p>

<p>Red Hat and the Red Hat logo are trademarks of Red Hat, Inc., registered in the United States and other countries.</p>
</div>
      
  
  </div>


          </div>
        </div>
                    <div class="page__footer bg-dark py-3">
        <div class="container">
          <div class="d-sm-flex justify-content-between align-items-center">
              

  
    

    
  <a href="https://www.redhat.com/" class="navbar-brand mr-0 mr-lg-auto mb-3 mb-sm-0">
            <img src="/sysadmin/themes/custom/sysadmin/logo.svg" width="135" height="31" class="d-inline-block align-top" alt="Red Hat logo" />

        
  </a>



  <div class="block block--basic block--copyright my-0 mx-sm-3 mb-1 mb-sm-0">

  
    

      
            <div class="basic__body"><p>Copyright ©2022 Red Hat, Inc.</p>
</div>
      
  
  </div>

  <div class="block block--sysadmin-footer my-0 mb-1 mb-sm-0">

  
    

      
  


  <ul class="nav d-flex d-sm-block d-md-flex justify-content-center align-items-center">
                                          <li class="nav-item  ">
                      <a href="https://www.redhat.com/en/about/privacy-policy" class="nav-link">Privacy Policy</a>
                  </li>
                                      <li class="nav-item  ">
                      <a href="https://www.redhat.com/en/about/terms-use" class="nav-link">Terms of Use</a>
                  </li>
                                      <li class="nav-item  ">
                      <a href="https://www.redhat.com/en/about/all-policies-guidelines" class="nav-link">All policies and guidelines</a>
                  </li>
            </ul>


  
  </div>

  <div class="block block--basic block--footerredhatsummit">

  
    

      
            <div class="basic__body"><div style="margin-left: 1rem"><a href="https://www.redhat.com/en/summit?intcmp=7013a0000026RhqAAE" target="_blank"><img alt="Red Hat Summit" src="https://www.redhat.com/cms/managed-files/Logo-Red_Hat-Summit-A-Standard-RGB-02_0.svg" width="72px" /></a></div>
</div>
      
  
  </div>

  <div class="block block--sharelinks">

  
    

      <div class="a2a_kit a2a_kit_size_32 a2a_floating_style a2a_vertical_style" data-a2a-url="https://www.redhat.com/sysadmin/text-editor-roundup-2022">
  <a class="a2a_button_twitter"></a>
  <a class="a2a_button_facebook"></a>
  <a class="a2a_button_linkedin"></a>
  <a class="a2a_button_reddit"></a>
  <a class="a2a_button_email"></a>
</div>
<div class="a2a_kit a2a_kit_size_32 a2a_floating_style a2a_default_style">
  <a class="a2a_button_twitter"></a>
  <a class="a2a_button_facebook"></a>
  <a class="a2a_button_linkedin"></a>
  <a class="a2a_button_reddit"></a>
  <a class="a2a_button_email"></a>
</div>

<script>
  var a2a_config = a2a_config || {};
  a2a_config.templates = a2a_config.templates || {};
  a2a_config.templates.twitter = {
    text: "Linux skills: 9 tutorials to get more from your text editor https://red.ht/3Otq5DT via #EnableSysadmin",
  };
    a2a_config.templates.facebook = {
    hashtag: "#EnableSysadmin",
  };
  </script>

  
  </div>


  <div class="block block--cta block--ctasubscribesidebar cta cta--blue-on-white cta-- my-5 p-3 text-center">

  
    

    <div class="d-md-flex justify-content-around align-items-center flex-wrap">
    <div class="cta__content my-2">
      
            <div class="cta__field-content p-2"><div class="subscribe-sidebar">
<div class="target-band-never-show-button">x</div>

<h4>Subscribe now</h4>

<p class="eloqua-email-capture-text">Get the highlights in your inbox every week.</p>

<p><iframe aria-label="Embedded form to subscribe to our email newsletter" frameborder="0" height="50" scrolling="no" src="/sysadmin/eloqua-embedded-email-capture-block.html?offer_id=701f20000012gE7AAI" style="max-width:670px;margin:0 auto;" title="Subscribe to our newsletter" width="100%"></iframe></p>
</div>
</div>
      
    </div>
      </div>
  
  </div>


          </div>
        </div>
            </footer>
      </div>

  </div>


<script type="application/json" data-drupal-selector="drupal-settings-json">{"path":{"baseUrl":"\/sysadmin\/","scriptPath":null,"pathPrefix":"","currentPath":"node\/6028","currentPathIsAdmin":false,"isFront":false,"currentLanguage":"en"},"pluralDelimiter":"\u0003","suppressDeprecationErrors":true,"ckeditorheight":{"offset":1,"line_height":1.5,"unit":"em","disable_autogrow":null},"colorbox":{"opacity":"0.85","current":"{current} of {total}","previous":"\u00ab Prev","next":"Next \u00bb","close":"Close","maxWidth":"98%","maxHeight":"98%","fixed":true,"mobiledetect":true,"mobiledevicewidth":"480px"},"blazy":{"loadInvisible":false,"offset":100,"saveViewportOffsetDelay":50,"validateDelay":25,"loader":true,"unblazy":false},"blazyIo":{"disconnect":false,"rootMargin":"0px","threshold":[0,0.25,0.5,0.75,1]},"user":{"uid":0,"permissionsHash":"dc7d17feb5a701a6cd2af389e508cec93041634fd7d8a05a7eea3ad5fed5c8df"}}</script>
<script src="/sysadmin/sites/default/files/js/js_VTYyD96hijIBmNcLQgQNj8IO5n29VJslnCGi-dMVT60.js"></script>
<script src="/sysadmin/themes/custom/sysadmin/node_modules/%40patternfly/pfe-readtime/dist/pfe-readtime.min.js?v=9.2.21" type="module"></script>
<script src="/sysadmin/sites/default/files/js/js_rMs8Arj1CXNJToNmczGpHk64iKyWbrTVpznewhF9t8Q.js"></script>

  <script type="text/javascript">
    if (("undefined" !== typeof _satellite) && ("function" === typeof _satellite.pageBottom)) {
      _satellite.pageBottom();
    }
  </script>
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"NRJS-969d30985413823a2a8","applicationID":"1080948181","transactionName":"M1ZTYUEHXEZVAkwKDgoccFZHD11bGyVKFhEFX21bXAJXaXcOVhcTC19dUEE6fFpQBG4KBBNwXltHFF1ZWARKTl8SWlRC","queueTime":0,"applicationTime":501,"atts":"HxFQFwkdT0g=","errorBeacon":"bam.nr-data.net","agent":""}</script><script type="text/javascript"  src="/6EhgT8iaS2F4/Pp/XJzS3XPZN-/X3YJQGmz/NVNVOTdpKgY/fANc/L2ApNzM"></script></body>
</html>
