<!DOCTYPE html>
<html lang="en" dir="ltr" prefix="content: http://purl.org/rss/1.0/modules/content/  dc: http://purl.org/dc/terms/  foaf: http://xmlns.com/foaf/0.1/  og: http://ogp.me/ns#  rdfs: http://www.w3.org/2000/01/rdf-schema#  schema: http://schema.org/  sioc: http://rdfs.org/sioc/ns#  sioct: http://rdfs.org/sioc/types#  skos: http://www.w3.org/2004/02/skos/core#  xsd: http://www.w3.org/2001/XMLSchema# ">
<head>
<script id="dpal" src="https://www.redhat.com/ma/dpal.js"></script>
<meta charset="utf-8" /><script type="text/javascript">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</script>
<link rel="canonical" href="https://www.redhat.com/sysadmin/vim-power-commands" />
<meta name="description" content="Learn how to work with multiple files, comment several lines at once, write a macro to generate a number list, and more." />
<meta name="dcterms.title" content="5 Vim features for power users" />
<meta name="dcterms.creator" content="jknight" />
<meta name="dcterms.publisher" content="Red Hat, Inc." />
<meta name="dcterms.language" content="en" />
<meta property="og:site_name" content="Enable Sysadmin" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.redhat.com/sysadmin/vim-power-commands" />
<meta property="og:title" content="5 Vim features for power users" />
<meta property="og:image" content="https://www.redhat.com/sysadmin/sites/default/files/styles/google_discover/public/2022-01/text-editor.jpg?itok=wmAkT211" />
<meta property="og:image:secure_url" content="https://www.redhat.com/sysadmin/sites/default/files/styles/google_discover/public/2022-01/text-editor.jpg?itok=wmAkT211" />
<meta property="og:image:type" content="image/jpeg" />
<meta property="og:image:width" content="1000" />
<meta property="og:video:width" content="600" />
<meta property="og:image:height" content="675" />
<meta property="og:updated_time" content="2022-06-08T09:00:00+0000" />
<meta property="og:image:alt" content="https://www.redhat.com/sysadmin/sites/default/files/styles/google_discover/public/2022-01/text-editor.jpg?itok=wmAkT211" />
<meta property="og:street_address" content="100 East Davie Street" />
<meta property="og:locality" content="Raleigh" />
<meta property="og:region" content="NC" />
<meta property="og:postal_code" content="27601" />
<meta property="og:country_name" content="United States" />
<meta property="og:phone_number" content="+1 919 754 4950" />
<meta property="og:fax_number" content="+1 919 800 3804" />
<meta property="og:locale" content="en_US" />
<meta property="article:author" content="https://www.redhat.com/sysadmin/jackknight" />
<meta property="article:publisher" content="https://www.facebook.com/redhatinc" />
<meta property="article:section" content="Enable Sysadmin" />
<meta property="article:tag" content="Text editors" />
<meta property="article:tag" content="Command line utilities" />
<meta property="article:modified_time" content="2022-06-08T09:00:00+0000" />
<meta name="twitter:card" content="photo" />
<meta name="twitter:title" content="5 Vim features for power users" />
<meta name="twitter:site:id" content="14627400" />
<meta name="twitter:creator" content="@" />
<meta name="twitter:url" content="https://www.redhat.com/sysadmin/vim-power-commands" />
<meta name="twitter:image:alt" content="Red Hat, Inc." />
<meta name="twitter:image:height" content="1000" />
<meta name="twitter:image:width" content="600" />
<meta name="twitter:image" content="https://www.redhat.com/sysadmin/sites/default/files/styles/full/public/2022-01/text-editor.jpg?itok=AKXgbXD1" />
<meta name="Generator" content="Drupal 9 (https://www.drupal.org)" />
<meta name="MobileOptimized" content="width" />
<meta name="HandheldFriendly" content="true" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<script type="application/ld+json">{
    "@context": "https://schema.org",
    "@graph": [
        {
            "@type": "TechArticle",
            "headline": "5 Vim features for power users",
            "name": "5 Vim features for power users",
            "about": [
                "\u003Ca href=\u0022/sysadmin/topics/text-editors\u0022 hreflang=\u0022en\u0022\u003EText editors\u003C/a\u003E",
                "\u003Ca href=\u0022/sysadmin/topics/command-line-utilities\u0022 hreflang=\u0022en\u0022\u003ECommand line utilities\u003C/a\u003E"
            ],
            "description": "Learn how to work with multiple files, comment several lines at once, write a macro to generate a number list, and more.",
            "image": {
                "@type": "ImageObject",
                "url": "https://www.redhat.com/sysadmin/sites/default/files/styles/full/public/2022-01/text-editor.jpg?itok=AKXgbXD1",
                "width": "1000",
                "height": "600"
            },
            "dateModified": "2022-06-08T09:00:00+0000",
            "author": {
                "@type": "Person",
                "@id": "https://www.redhat.com/sysadmin/jackknight",
                "name": "jknight",
                "url": "https://www.redhat.com/sysadmin/jackknight",
                "sameAs": "https://twitter.com/"
            },
            "publisher": {
                "@type": "Organization",
                "@id": "https://www.redhat.com/"
            },
            "mainEntityOfPage": "https://www.redhat.com/sysadmin/vim-power-commands"
        },
        {
            "@type": "Corporation",
            "@id": "https://www.redhat.com/",
            "name": "Red Hat, Inc.",
            "sameAs": [
                "https://en.wikipedia.org/wiki/Red_Hat",
                "http://www.linkedin.com/company/red-hat",
                "http://www.youtube.com/user/RedHatVideos",
                "https://www.facebook.com/redhatinc",
                "https://twitter.com/RedHat"
            ],
            "url": "https://www.redhat.com/",
            "telephone": "+1 919 754 4950",
            "contactPoint": {
                "@type": "ContactPoint",
                "telephone": "+1-888-RED-HAT1",
                "availableLanguage": "English",
                "contactType": "sales",
                "faxnumber": "+1 919 800 3804"
            },
            "logo": {
                "@type": "ImageObject",
                "url": "https://www.redhat.com/sysadmin/themes/custom/sysadmin/assets/images/red-hat-logo.png",
                "width": "254",
                "height": "60"
            },
            "address": {
                "@type": "PostalAddress",
                "streetAddress": "100 East Davie Street",
                "addressLocality": "Raleigh",
                "addressRegion": "NC",
                "postalCode": "27601",
                "addressCountry": "United States"
            }
        },
        {
            "@type": "Person",
            "name": "Jack Knight",
            "sameAs": "https://twitter.com/",
            "image": {
                "@type": "ImageObject",
                "url": "https://www.redhat.com/sysadmin/sites/default/files/styles/user_picture_square/public/pictures/2022-06/JackKnight.jpg?itok=28Do6Czo",
                "width": "240",
                "height": "240"
            }
        },
        {
            "@type": "WebPage",
            "@id": "https://www.redhat.com/sysadmin/vim-power-commands",
            "publisher": {
                "@type": "Organization",
                "@id": "https://www.redhat.com/"
            }
        },
        {
            "@type": "WebSite",
            "@id": "https://www.redhat.com/sysadmin/",
            "name": "Enable Sysadmin",
            "url": "https://www.redhat.com/sysadmin/",
            "publisher": {
                "@type": "Organization",
                "@id": "https://www.redhat.com/"
            }
        }
    ]
}</script>
<meta name="robots" content="max-image-preview:large" />
<link rel="shortcut icon" href="/sysadmin/themes/custom/sysadmin/favicon.ico" type="image/vnd.microsoft.icon" />
<link rel="revision" href="https://www.redhat.com/sysadmin/vim-power-commands" />
<link rel="apple-touch-icon" sizes="180x180" href="/sysadmin/themes/custom/sysadmin/assets/favicon/apple-touch-icon.png">
<link rel="icon" type="image/png" sizes="32x32" href="/sysadmin/themes/custom/sysadmin/assets/favicon/favicon-32x32.png">
<link rel="icon" type="image/png" sizes="16x16" href="/sysadmin/themes/custom/sysadmin/assets/favicon/favicon-16x16.png">
<link rel="manifest" href="/sysadmin/themes/custom/sysadmin/assets/favicon/site.webmanifest">
<link rel="mask-icon" href="/sysadmin/themes/custom/sysadmin/assets/favicon/safari-pinned-tab.svg" color="#ee0000">
<meta name="msapplication-TileColor" content="#1a1a1a">
<meta name="theme-color" content="#ffffff">
<title>5 Vim features for power users | Enable Sysadmin</title>
<link rel="stylesheet" media="all" href="/sysadmin/sites/default/files/css/css_K-etweG1PGH6xQ8c1GPXlg7Kf-iQ9nD5hOKFOqg1DI0.css" />
<link rel="stylesheet" media="all" href="/sysadmin/sites/default/files/css/css_wL5vQsqSGZeeFvsRIov4xFil8zWkEzY2DL19yeqGeqw.css" />

<script src="/sysadmin/sites/default/files/js/js_QHqjxhGPGgZFwOfW92tmrVpssmC1sbO0zDG4TgLmaEI.js"></script>


</head>
<body>
<a href="#main-content" class="visually-hidden focusable">
Skip to main content
</a>

  <div class="dialog-off-canvas-main-canvas" data-off-canvas-main-canvas>
    

<div class="redhat-cookie-banner">
<section id="redhat-cookie-privacy-banner" class="redhat-cookie-banner-wrapper" style="display: block;">
  <div class="container my-3 pr-5">
    <p>We use cookies on our websites to deliver our online services. Details about how we use cookies and how you may disable them are set out in our <a href="http://www.redhat.com/en/about/privacy-policy#cookies">Privacy Statement</a>. By using this website you agree to our use of cookies.
    <span class="cookie-more">
    <a id="redhat-cookie-privacy-banner-close" href="javascript:void(0);" class="cookie-close">&times;</a>
    </span>
    </p>
  </div>
</section>
</div>

<div class="page d-flex flex-column">
  <div class="navbar navbar-expand-lg justify-content-between navbar-dark bg-dark">
    <div class="container">
                
  <div class="block block--sysadmin-navbar-branding">

  
    

    
  <a href="https://www.redhat.com/" class="navbar-brand ">
            <img src="/sysadmin/themes/custom/sysadmin/logo.svg" width="135" height="31" class="d-inline-block align-top" alt="Red Hat logo" />

        
  </a>


  </div>


      
      <div class="navbar-toggler-wrapper">
        <button class="navbar-toggler" type="button" data-toggle="collapse"  data-parent="#collapse-parent" data-target="#search-collapse" aria-controls="search-collapse" aria-expanded="false" aria-label="Toggle search">
          <svg class="icon-collapsed" width="30" height="30" viewBox="0 0 30 30" xmlns="http://www.w3.org/2000/svg"><line x1="18.95" y1="19.15" x2="25.25" y2="25.75"/><circle cx="13.25" cy="12.75" r="8.5"/></svg>
          <svg class="icon-expanded" width="30" height="30" viewBox="0 0 30 30" xmlns="http://www.w3.org/2000/svg"><line x1="7.25" y1="7.25" x2="22.75" y2="22.75"/><line x1="7.25" y1="22.75" x2="22.75" y2="7.25"/></svg>
          <span style="vertical-align: middle;">Search</span>
        </button>
        <button class="navbar-toggler" type="button" data-toggle="collapse" data-parent="#collapse-parent" data-target="#mobilenav-collapse" aria-controls="mobilenav-collapse" aria-expanded="false" aria-label="Toggle navigation">
          <svg class="icon-collapsed" width="30" height="30" viewBox="0 0 30 30" xmlns="http://www.w3.org/2000/svg"><path d="M4 7h22M4 15h22M4 23h22"/></svg>
          <svg class="icon-expanded" width="30" height="30" viewBox="0 0 30 30" xmlns="http://www.w3.org/2000/svg"><line x1="7.25" y1="7.25" x2="22.75" y2="22.75"/><line x1="7.25" y1="22.75" x2="22.75" y2="7.25"/></svg>
        </button>
      </div>
    </div>
  </div>

  <div id="collapse-parent">
    <div id="search-collapse" class="search-collapse collapse" data-parent="#collapse-parent">
      <div class="py-4 px-3">
        <form class="form-inline m-2" action="/sysadmin/search/node" accept-charset="UTF-8" method="get">
          <div class="input-group flex-fill">
            <input class="form-control" type="search" name="keys" id="search" value="" placeholder="Search this site…" aria-label="Search this site…">
            <div class="input-group-append">
              <button class="btn btn-secondary font-weight-bold" type="submit">Search</button>
            </div>
          </div>
        </form>
      </div>
    </div>

    <div id="mobilenav-collapse" class="mobilenav-collapse d-lg-none collapse" data-parent="#collapse-parent">
                
  <div class="block block--sysadmin-navbar-sitename sitename">

  
    

    
  <a href="/sysadmin/" class="navbar-brand sitename">
        Enable Sysadmin
  </a>

  <span class="d-none d-lg-inline ml-1 mr-3 h5 navbar-sitename-divider">&nbsp;</span>

  </div>

  <div class="block block--sysadmin-main-menu">

  
    

      
  


  <ul class="nav navbar-nav">
                                          <li class="nav-item  dropdown">
                      <a href="/sysadmin/" class="nav-link dropdown-toggle" data-toggle="dropdown" data-drupal-link-system-path="&lt;front&gt;">Articles</a>
                          <div class="dropdown-menu">
              <a href="/sysadmin/topics/automation" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/146">Automation</a>
              <a href="/sysadmin/topics/career" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/51">Career</a>
              <a href="http://www.redhat.com/sysadmin/topics/cloud" class="dropdown-item">Cloud</a>
              <a href="/sysadmin/topics/containers" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/36"> Containers</a>
              <a href="/sysadmin/topics/kubernetes" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/66">Kubernetes</a>
              <a href="/sysadmin/topics/linux" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/21">Linux</a>
              <a href="/sysadmin/topics/programming" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/71"> Programming</a>
              <a href="/sysadmin/topics/security" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/96">Security</a>
  </div>
                              </li>
                                      <li class="nav-item  dropdown">
                      <a href="/sysadmin/about" class="nav-link dropdown-toggle" data-toggle="dropdown" data-drupal-link-system-path="node/71">About</a>
                          <div class="dropdown-menu">
              <a href="/sysadmin/about" class="dropdown-item" data-drupal-link-system-path="node/71">About Enable Sysadmin</a>
              <a href="/sysadmin/email" class="dropdown-item" data-drupal-link-system-path="node/376">Email newsletter</a>
              <a href="/sysadmin/join-community" class="dropdown-item" data-drupal-link-system-path="node/641">Join the community</a>
              <a href="/sysadmin/sudoers-program" class="dropdown-item" data-drupal-link-system-path="node/2106">Sudoers program</a>
              <a href="/sysadmin/meet-team" class="dropdown-item" data-drupal-link-system-path="node/2316">Meet the team</a>
              <a href="/sysadmin/faq" class="dropdown-item" data-drupal-link-system-path="node/1526">FAQs</a>
  </div>
                              </li>
                                      <li class="nav-item  ">
                      <a href="/sysadmin/welcome-enable-sysadmin" title="A Red Hat community publication for sysadmins, by sysadmins" class="nav-link">Welcome</a>
                  </li>
            </ul>


  
  </div>


      
              
          </div>
  </div>

  


<nav class="navbar navbar-expand-lg justify-content-between navbar-light  d-none d-lg-block text-dark bg-light border-bottom-light-gray">
      <div class="container">
  
      
  
  <button class="navbar-toggler" type="button" data-toggle="collapse" data-target=".navbar-collapse" aria-controls="navbar-collapse" aria-expanded="false" aria-label="Toggle navigation">
    <span class="navbar-toggler-icon"></span>
  </button>

  <div class="collapse navbar-collapse">
                  <div class="mr-auto d-flex navbar-desktop">
            
  <div class="block block--sysadmin-navbar-sitename sitename">

  
    

    
  <a href="/sysadmin/" class="navbar-brand sitename">
        Enable Sysadmin
  </a>

  <span class="d-none d-lg-inline ml-1 mr-3 h5 navbar-sitename-divider">&nbsp;</span>

  </div>

  <div class="block block--sysadmin-main-menu">

  
    

      
  


  <ul class="nav navbar-nav">
                                          <li class="nav-item  dropdown">
                      <a href="/sysadmin/" class="nav-link dropdown-toggle" data-toggle="dropdown" data-drupal-link-system-path="&lt;front&gt;">Articles</a>
                          <div class="dropdown-menu">
              <a href="/sysadmin/topics/automation" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/146">Automation</a>
              <a href="/sysadmin/topics/career" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/51">Career</a>
              <a href="http://www.redhat.com/sysadmin/topics/cloud" class="dropdown-item">Cloud</a>
              <a href="/sysadmin/topics/containers" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/36"> Containers</a>
              <a href="/sysadmin/topics/kubernetes" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/66">Kubernetes</a>
              <a href="/sysadmin/topics/linux" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/21">Linux</a>
              <a href="/sysadmin/topics/programming" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/71"> Programming</a>
              <a href="/sysadmin/topics/security" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/96">Security</a>
  </div>
                              </li>
                                      <li class="nav-item  dropdown">
                      <a href="/sysadmin/about" class="nav-link dropdown-toggle" data-toggle="dropdown" data-drupal-link-system-path="node/71">About</a>
                          <div class="dropdown-menu">
              <a href="/sysadmin/about" class="dropdown-item" data-drupal-link-system-path="node/71">About Enable Sysadmin</a>
              <a href="/sysadmin/email" class="dropdown-item" data-drupal-link-system-path="node/376">Email newsletter</a>
              <a href="/sysadmin/join-community" class="dropdown-item" data-drupal-link-system-path="node/641">Join the community</a>
              <a href="/sysadmin/sudoers-program" class="dropdown-item" data-drupal-link-system-path="node/2106">Sudoers program</a>
              <a href="/sysadmin/meet-team" class="dropdown-item" data-drupal-link-system-path="node/2316">Meet the team</a>
              <a href="/sysadmin/faq" class="dropdown-item" data-drupal-link-system-path="node/1526">FAQs</a>
  </div>
                              </li>
                                      <li class="nav-item  ">
                      <a href="/sysadmin/welcome-enable-sysadmin" title="A Red Hat community publication for sysadmins, by sysadmins" class="nav-link">Welcome</a>
                  </li>
            </ul>


  
  </div>


        </div>
          
                  
      
      

<div class="dropdown show text-align-right">
    <a href="/sysadmin/subscribe" class="navbar-util navbar-util--rss" aria-label="Subscribe to our feed or newsletter blast">
    <svg width="22" height="23" viewBox="0 0 22 23" xmlns="http://www.w3.org/2000/svg"><title>Subscribe to our RSS feed or Email newsletter</title><path d="M0 4.23c9.79 0 17.75 8 17.75 17.84h4.23A22.05 22.05 0 0 0 0 0v4.23z M0 7.67v4.23c2.74 0 5.33 1.07 7.27 3.03a10.26 10.26 0 0 1 3 7.3h4.24c0-8.02-6.5-14.56-14.51-14.56M2.93 16.87a2.94 2.94 0 0 0 0 5.85 2.93 2.93 0 1 0 0-5.85" fill-rule="evenodd"/></svg>

    <span class="sr-only">Subscribe to our RSS feed or Email newsletter.</span>
  </a>

    <a id="dropdownSearchLink" href="/sysadmin/search/node" class="navbar-util navbar-util--search" role="button" aria-label="Search this site…" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false">
    <svg width="30" height="30" viewBox="0 0 30 30" xmlns="http://www.w3.org/2000/svg" style="fill:none;stroke-width:3;stroke:#000;stroke-linecap:round;"><line x1="18.95" y1="19.15" x2="25.25" y2="25.75"/><circle cx="13.25" cy="12.75" r="8.5"/></svg>

  </a>
  <div class="dropdown-menu dropdown-menu-right p-1 pt-2" aria-labelledby="dropdownSearchLink">
    <form class="form-inline m-2" action="/sysadmin/search/node" accept-charset="UTF-8" method="get">
      <div class="input-group flex-fill">
        <input class="form-control" type="search" name="keys" id="search" value="" placeholder="Search this site…" aria-label="Search this site…">
        <div class="input-group-append">
          <button class="btn btn-secondary font-weight-bold" type="submit">GO</button>
        </div>
      </div>
    </form>
  </div>
  </div>
      </div>

      </div>
  </nav>

  <main class="pb-5">
                  <header class="page__header">
          <div class="container">
              <div data-drupal-messages-fallback class="hidden"></div>


          </div>
        </header>
          
    <a name="main-content" tabindex="-1"></a>

                  <div class="page__content">
                  
  <div class="block block--sysadmin-content">

  
    

      <article data-history-node-id="5990" role="article" about="/sysadmin/vim-power-commands" typeof="schema:Article" id="node--article--5990" class="full full--article node node--promoted">
  
    <span property="schema:name" content="5 Vim features for power users" class="hidden"></span>
  <span property="schema:interactionCount" content="UserComments:0" class="hidden"></span>


      <div  class="section my-5 narrow">
  <div class="container">
    <div >
      
  <div class="block">

  
    

      <span property="schema:name"><h1 class="font-weight-bold">5 Vim features for power users</h1>
</span>

  
  </div>

  <div class="block">

  
    

      
            <div class="article__field-subhead">Learn how to work with multiple files, comment several lines at once, write a macro to generate a number list, and more.</div>
      
  
  </div>

    </div>
  </div>
</div>
<div  class="section pb-5 narrow">
  <div class="container">
    <div >
      
  <div class="block">

  
    

      <p class="article-byline">
  <span class="article-date">
    <span class="label">Posted:</span>
    June 8, 2022
  </span>
    <span aria-hidden="true">|</span>
  <span class="article-authors">
    <strong class="sr-only">by</strong>
          <a href="/sysadmin/jackknight" class="article-author article-author--primary">Jack Knight</a>      </span>
  </p>

  
  </div>

  <div class="block">

  
    

      
            <div class="article__field-media"><figure>
  
  
  <div data-blazy="" class="blazy blazy--field blazy--field-media-image image__field-media-image">
    <div class="field__label font-weight-bold visually-hidden">
      Image    </div>
                  <div class="field__item">



                  <div class="media media--blazy media--bundle--image media--loading is-b-loading media--image">
<img alt="Person typing in a text editor on a laptop" class="media__image media__element b-lazy img-fluid" data-src="/sysadmin/sites/default/files/styles/full/public/2022-01/text-editor.jpg?itok=AKXgbXD1" src="data:image/svg+xml;charset=utf-8,%3Csvg%20xmlns%3D&#039;http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg&#039;%20viewBox%3D&#039;0%200%201000%20600&#039;%2F%3E" width="1000" height="600" loading="lazy" typeof="foaf:Image" />
        </div>
        
  
</div>
              </div>

  <figcaption>
    
            <div class="image__field-media-description"><p><sup>Photo by <a href="https://www.pexels.com/@karolina-grabowska?utm_content=attributionCopyText&amp;utm_medium=referral&amp;utm_source=pexels">Karolina Grabowska</a> from <a href="https://www.pexels.com/photo/person-typing-on-laptop-5387244/?utm_content=attributionCopyText&amp;utm_medium=referral&amp;utm_source=pexels">Pexels</a></sup></p>
</div>
      
  </figcaption>
</figure>
</div>
      
  
  </div>

  <div class="block">

  
    

      
            <div property="schema:text" class="clearfix article__body"><p>I first discovered the <a href="https://www.redhat.com/sysadmin/get-started-vi-editor" target="_blank">Vi editor</a> back in 1986, when the company I worked for took delivery of a <a href="https://www.old-computers.com/history/detail.asp?n=52&amp;t=3" target="_blank">Zilog System 8000</a> running ZEUS—Zilog's version of Unix (a port of Unix Version 7). Its clone Vim was originally an acronym for <em>vi imitation</em> but was subsequently changed to <em>Vi iMproved</em> in 1993. Originally only available on Unix systems, Vim has since been ported to many modern operating systems and also ships with Apple macOS.</p>

<div data-embed-button="resource_list" data-entity-embed-display="view_mode:resource_list.link" data-entity-type="resource_list" data-entity-uuid="60b26066-acd0-4332-afa7-d98c9a079f02" data-langcode="en" class="align-right embedded-entity embedded-entity--resources embedded-entity--resources--link"><aside id="resource-list-more-linux-resources" class="eck-entity mt-2 py-3 pr-3 border-top border-danger">
  

<h2 class="h4">
      More Linux resources
  </h2>

<ul class="pl-3 mb-0">
      <li class="my-2"><a href="https://developers.redhat.com/cheat-sheets/advanced-linux-commands/?intcmp=701f20000012ngPAAQ">Advanced Linux commands cheat sheet</a></li>
      <li class="my-2"><a href="https://developers.redhat.com/products/rhel/download?intcmp=701f20000012ngPAAQ">Download RHEL 9 for free through the Red Hat Developer program</a></li>
      <li class="my-2"><a href="https://opensource.com/downloads/installing-linux-applications-ebook?intcmp=701f20000012ngPAAQ">A guide to installing applications on Linux</a></li>
      <li class="my-2"><a href="https://rhtapps.redhat.com/assessment/?intcmp=701f20000012ngPAAQ">Linux system administration skills assessment</a></li>
      <li class="my-2"><a href="https://www.redhat.com/en/services/training/rh024-red-hat-linux-technical-overview?intcmp=701f20000012ngPAAQ">Free course: RHEL technical overview</a></li>
  </ul>

</aside>
</div>


<p>Vim now has a large user base, and there are many publicly available tweaks and enhancements available for free download. A major advantage of it as an editor is that you can use it anywhere once you have learned the basic building block commands. Despite using Vim for more years than I care to remember, I still find things that surprise me!</p>

<p>This article focuses on a very small subset of some useful advanced features.</p>

<h2>1. Work with multiple files</h2>

<p>When working on a project, I often find myself using multiple files. Fortunately, Vim allows you to have several files open in different tabs. To initiate this behavior, issue the following command (from command mode):</p>

<pre>
<code class="language-vim">:tabe &lt;filename&gt;</code></pre>

<p>This command enables tab expansion mode to make it easy to find files. Also, history is enabled and can be accessed by hitting the Up arrow.</p>

<p>To switch between tabs, use:</p>

<ul>
	<li><strong>gt</strong> — Switch to the tab on the right</li>
	<li><strong>gT</strong> — Switch to the tab on the left</li>
</ul>

<h2>2. Switch case</h2>

<p>Most power users know the <strong>~</strong> command to switch a single character's case, but this can also be expanded using Vim movement commands. For example, if you want to switch the word to the right of the cursor to upper case, enter:</p>

<pre>
<code class="language-vim">gUw</code></pre>

<p>So, if the cursor is at the start of a line, this results in the following change:</p>

<pre>
<code class="language-plaintext">This is a line of text =&gt; THIS is a line of text</code></pre>

<p>To change multiple words, put a number in front of the command, like so:</p>

<pre>
<code class="language-vim">gU2w</code></pre>

<p>So now the change becomes this:</p>

<pre>
<code class="language-plaintext">This is a line of text =&gt; THIS IS a line of text</code></pre>

<p><strong><em>[ Free eBook: <a href="https://www.redhat.com/en/engage/linux-management-ebook-s-201912231121?intcmp=701f20000012ngPAAQ" target="_blank">Manage your Linux environment for success</a>. ]</em></strong></p>

<p>To change the whole line, try:</p>

<pre>
<code class="language-vim">gU$</code></pre>

<p>The result is:</p>

<pre>
<code class="language-plaintext">This is a line of text =&gt; THIS IS A LINE OF TEXT</code></pre>

<p>You can use any of the Vim movement commands for these tasks. For example, use <strong>b</strong> for the previous word and <strong>{, }, (, )</strong> for sentences and paragraphs, and so forth.</p>

<p>To reference Vim movement commands, use</p>

<pre>
<code class="language-vim">:help motions.txt</code></pre>

<h2>3. Use block mode</h2>

<p>Have you ever heard the sound a keyboard makes as someone bashes out comments one line at a time? Here's a quick and easy way to comment a whole block. Given the sample file below:</p>

<pre>
<code class="language-plaintext">&gt;1 this is a test
2 this is a test
3 this is a test
4 this is a test
5 this is a test
6 this is a test
7 this is a test</code></pre>

<ol>
	<li>
	<div data-embed-button="resource_list" data-entity-embed-display="view_mode:resource_list.link" data-entity-type="resource_list" data-entity-uuid="78d8f7ba-4831-497f-b66d-ec0bb740244e" data-langcode="en" class="align-right embedded-entity embedded-entity--resources embedded-entity--resources--link"><aside id="resource-list-linux-containers" class="eck-entity mt-2 py-3 pr-3 border-top border-danger">
  

<h2 class="h4">
      Linux containers
  </h2>

<ul class="pl-3 mb-0">
      <li class="my-2"><a href="https://www.redhat.com/en/topics/containers?intcmp=701f20000012ngPAAQ">Understanding Linux containers</a></li>
      <li class="my-2"><a href="https://developers.redhat.com/blog/2018/02/22/container-terminology-practical-introduction?intcmp=701f20000012ngPAAQ">A practical introduction to container terminology</a></li>
      <li class="my-2"><a href="https://www.redhat.com/en/services/training/do080-deploying-containerized-applications-technical-overview?intcmp=701f20000012ngPAAQ">Free course: Deploying containerized applications</a></li>
      <li class="my-2"><a href="https://www.redhat.com/en/technologies/cloud-computing/openshift/try-it?intcmp=701f20000012ngPAAQ">Download now: Red Hat OpenShift trial</a></li>
      <li class="my-2"><a href="https://www.redhat.com/en/resources/container-storage-dummies?intcmp=701f20000012ngPAAQ">eBook: Container storage for dummies</a></li>
  </ul>

</aside>
</div>

	Position the cursor at the start of line 1 and press <strong>CTRL+V</strong>. At the bottom of the window, you will see the words <strong>VISUAL BLOCK</strong> appear.</li>
	<li>Now use either the Down arrow or the<strong> j</strong> key to move to the beginning of the last line. The first character of each line is highlighted.</li>
	<li>Now press <strong>I#</strong>.</li>
	<li>Finally, select <strong>ESC</strong>.</li>
</ol>

<p>Voila! The entire block is now commented out. You can also perform other common operations on text blocks similarly, such as removing leading whitespace or trailing garbage.</p>

<p>The reverse operation to uncomment the block works similarly.</p>

<ol>
	<li>Position the cursor at the start of line 1 (you can start it wherever you like and use the movement keys as needed, but for this example, I'll keep it consistent).</li>
	<li>Hit <strong>CTRL+V</strong>. Again, the words <strong>VISUAL BLOCK</strong> appear at the bottom of the window.</li>
	<li>Repeat the operation from before, using the Down arrow or <strong>j</strong> to move the cursor to the beginning of the last line.</li>
	<li>Now use the Right arrow or <strong>l</strong> movement keys to highlight the hash signs and the one space preceding the start of the text.</li>
	<li>Hit <strong>D</strong>.</li>
</ol>

<p>Comments are now removed from the block!</p>

<h2>4. Increment or decrement numbers</h2>

<div data-embed-button="image_cta" data-entity-embed-display="view_mode:cta.embed" data-entity-type="cta" data-entity-uuid="3bce38af-666b-4c0b-9a8e-7fdf0fa88f91" data-langcode="en" class="align-right embedded-entity embedded-entity--cta_image embedded-entity--cta_image--embed">
<div class="eck-entity">
    
            <div class="cta-image__field-body-text"><a href="https://www.redhat.com/en/engage/system-administrator-guide-s-202107300146?intcmp=701f20000012ngPAAQ" target="_blank">
<div data-embed-button="media_entity_embed" data-entity-embed-display="view_mode:media.image_cta" data-entity-type="media" data-entity-uuid="f5f0382f-f5f1-4540-a004-9db7a3124319" data-langcode="en" class="embedded-entity embedded-entity--image embedded-entity--image--image-cta"><div>
  
  
  <div class="image__field-media-image">
    <div class="field__label font-weight-bold visually-hidden">
      Image    </div>
                  <div class="field__item">  
<img src="/sysadmin/sites/default/files/styles/image_cta/public/2021-07/automation-expert-e-book-medium.jpg?itok=X_OfbjdH" width="300" height="250" alt="IT Automation ebook" loading="lazy" typeof="foaf:Image" class="img-fluid" />


</div>
              </div>

</div>
</div>

</a>
</div>
      
            <div class="cta-image__field-cta-button"><a href="https://www.redhat.com/en/engage/system-administrator-guide-s-202107300146?intcmp=701f20000012ngPAAQ" class="btn btn-primary">Download now</a></div>
      
</div>
</div>


<p>Another frequent task is adjusting a code block or list in a text file to increment numbers. Instead of manually editing each line with something like <strong>cW</strong>, just position the cursor over the number and use one of the following:</p>

<ul>
	<li><strong>CTRL+A</strong> to increment the number</li>
	<li><strong>CTRL+X</strong> to decrement the number</li>
</ul>

<h2>5. Generate a list of numbers with a simple macro</h2>

<p>Here is another common task. For this example, create a list from 1 to 20. Yes, I know there are myriad ways of doing this outside Vim, but this is about Vim and its shortcuts.</p>

<p>First, create a file with a single line containing <strong>line 1</strong>.</p>

<p>The cursor should be on the <strong>1</strong> as it should have nowhere else to go.</p>

<p>Select <strong>qayyp</strong> (which will record a macro into register <em>a</em> and copy line 1), then <strong>CTRL+A</strong>, which will increment line 2.</p>

<p>You should now have two lines, as follows:</p>

<pre>
<code class="language-plaintext">&gt;line 1
line 2</code></pre>

<p>Now, leaving the cursor where it is, type <strong>q</strong>, <strong>ESC</strong>, and then <strong>18a</strong>.</p>

<p>You should now see the following:</p>

<pre>
<code class="language-plaintext">&gt;line 1
line 2
line 3
line 4
line 5
line 6
line 7
line 8
line 9
line 10
line 11
line 12
line 13
line 14
line 15
line 16
line 17
line 18
line 19
line 20 </code></pre>

<div data-embed-button="resource_list" data-entity-embed-display="view_mode:resource_list.link" data-entity-type="resource_list" data-entity-uuid="fa7b02cd-605a-450a-a022-fc9948302fa2" data-langcode="en" class="align-right embedded-entity embedded-entity--resources embedded-entity--resources--link"><aside id="resource-list-career-advice" class="eck-entity mt-2 py-3 pr-3 border-top border-danger">
  

<h2 class="h4">
      Career advice
  </h2>

<ul class="pl-3 mb-0">
      <li class="my-2"><a href="https://www.redhat.com/rhtapps/assessment/?intcmp=701f20000012ngPAAQ">Take a sysadmin skills assessment</a></li>
      <li class="my-2"><a href="https://www.redhat.com/en/services/training/all-courses-exams?intcmp=701f20000012ngPAAQ">Explore training and certification options</a></li>
      <li class="my-2"><a href="https://www.redhat.com/en/resources/certification-remote-exams-FAQ?intcmp=701f20000012ngPAAQ">Red Hat Certification remote exams FAQ</a></li>
      <li class="my-2"><a href="https://www.redhat.com/en/engage/system-administrator-guide-s-202107300146?intcmp=701f20000012ngPAAQ">Tales from the field: A system administrator's guide to IT automation</a></li>
  </ul>

</aside>
</div>


<h2>6. Bonus</h2>

<p>Finally, here are some additional useful timesaving commands:</p>

<ul>
	<li><strong>ga</strong> — Print the ASCII value of the character under the cursor (also shows in octal and hex).</li>
	<li><strong>gi</strong> — Move to the last insert you did and enter Insert mode.</li>
	<li><strong>gv</strong> — Start visual mode and use the previous selection made.</li>
	<li><strong>gI</strong> — Start inserting at the beginning of the line no matter what the first characters are.</li>
</ul>

<h2>Wrap up</h2>

<p>Vim is powerful and available for all major platforms. While many Linux users get complacent after learning the basics, there are many time-saving opportunities baked right into the application. These five tasks (and the bonus commands) may inspire you to learn more Vim tricks.</p>
</div>
      
  
  </div>

  <div class="views-element-container block">

  
    

      <div><div class="listicle-view js-view-dom-id-0fea993048f38b8b41c0bf00fbf75e2adef806558b694c3cff14f41d8f2de1c9">
  
  
  

  
  
  

    <h3>Check out these related articles on Enable Sysadmin</h3>
    <div class="listicle-row"><div class="views-field views-field-field-listicle"><div class="field-content"><article data-history-node-id="5586" role="article" about="/sysadmin/get-started-vi-editor" typeof="schema:Article" id="node--article--5586" class="listicle listicle--article node node--promoted">
  <div class="row align-items-center">
    <div class="col-md-6 listicle-image">
            <div class="article__field-media"><div>
  
  
  <div data-blazy="" class="blazy blazy--field blazy--field-media-image blazy--field-media-image--block-1 blazy--view blazy--view--listicle blazy--view--listicle--block-1 image__field-media-image">
    <div class="field__label font-weight-bold visually-hidden">
      Image    </div>
                  <div class="field__item">



                  <div class="media media--blazy media--bundle--image media--loading is-b-loading media--image">
<img alt="Typing on a laptop with headphones next to the computer" class="media__image media__element b-lazy img-fluid" data-src="/sysadmin/sites/default/files/styles/card/public/2022-01/text-editor-typing.jpg?itok=BuobUOzh" src="data:image/svg+xml;charset=utf-8,%3Csvg%20xmlns%3D&#039;http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg&#039;%20viewBox%3D&#039;0%200%20700%20420&#039;%2F%3E" width="700" height="420" loading="lazy" typeof="foaf:Image" />
        </div>
        
  
</div>
              </div>

</div>
</div>
      </div>
    <div class="col-md-6 listicle-body">
      <div class="h4 listicle-title pt-4 pt-md-0"><a href="/sysadmin/get-started-vi-editor"><span property="schema:name">How to get started with the Vi editor</span>
</a></div>
      <div class="listicle-text font-weight-light py-2">
        
            <div property="schema:text" class="clearfix article__body">Once you've committed Vi's keyboard shortcuts to muscle memory, watch how fast you work.</div>
      
      </div>

      <div class="listicle-footer">
        <div class="article-date">
          <span class="label">Posted:</span>
          January 25, 2022
        </div>
        <div class="article-authors">
                      <span class="label">Author:</span>
                                <a href="/sysadmin/users/skenlon" class="article-author article-author--primary">Seth Kenlon<span class="author-affiliate"> (Red Hat)</span></a>                  </div>
      </div>
    </div>
  </div>
</article>
<article data-history-node-id="4661" role="article" about="/sysadmin/3-text-editors-compared" typeof="schema:Article" id="node--article--4661" class="listicle listicle--article node node--promoted">
  <div class="row align-items-center">
    <div class="col-md-6 listicle-image">
            <div class="article__field-media"><div>
  
  
  <div data-blazy="" class="blazy blazy--field blazy--field-media-image blazy--field-media-image--block-1 blazy--view blazy--view--listicle blazy--view--listicle--block-1 image__field-media-image">
    <div class="field__label font-weight-bold visually-hidden">
      Image    </div>
                  <div class="field__item">



                  <div class="media media--blazy media--bundle--image media--loading is-b-loading media--image">
<img alt="Vim, Emacs, Nano, and a panel of experts" class="media__image media__element b-lazy img-fluid" data-src="/sysadmin/sites/default/files/styles/card/public/2021-06/typewriter.jpg?itok=wAE1mM9j" src="data:image/svg+xml;charset=utf-8,%3Csvg%20xmlns%3D&#039;http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg&#039;%20viewBox%3D&#039;0%200%20700%20420&#039;%2F%3E" width="700" height="420" loading="lazy" typeof="foaf:Image" />
        </div>
        
  
</div>
              </div>

</div>
</div>
      </div>
    <div class="col-md-6 listicle-body">
      <div class="h4 listicle-title pt-4 pt-md-0"><a href="/sysadmin/3-text-editors-compared"><span property="schema:name">Vim vs. Nano vs. Emacs: Three sysadmins weigh in</span>
</a></div>
      <div class="listicle-text font-weight-light py-2">
        
            <div property="schema:text" class="clearfix article__body">Three editors. Three experts. Which Linux text editor is right for you?</div>
      
      </div>

      <div class="listicle-footer">
        <div class="article-date">
          <span class="label">Posted:</span>
          June 22, 2021
        </div>
        <div class="article-authors">
                      <span class="label">Authors:</span>
                                <a href="/sysadmin/users/tcarriga" class="article-author article-author--primary">Tyler Carrigan<span class="author-affiliate"> (Red Hat)</span></a><span>, </span>                      <a href="/sysadmin/users/amy-marrich" class="article-author article-author--co">Amy Marrich<span class="author-affiliate"> (Red Hat, Sudoer)</span></a><span>, </span>                      <a href="/sysadmin/users/skenlon" class="article-author article-author--co">Seth Kenlon<span class="author-affiliate"> (Red Hat)</span></a><span>, </span>                      <a href="/sysadmin/users/ricardo-gerardi" class="article-author article-author--co">Ricardo Gerardi<span class="author-affiliate"> (Red Hat, Sudoer)</span></a>                  </div>
      </div>
    </div>
  </div>
</article>
<article data-history-node-id="5621" role="article" about="/sysadmin/kakoune-vi-text-editor" typeof="schema:Article" id="node--article--5621" class="listicle listicle--article node node--promoted">
  <div class="row align-items-center">
    <div class="col-md-6 listicle-image">
            <div class="article__field-media"><div>
  
  
  <div data-blazy="" class="blazy blazy--field blazy--field-media-image blazy--field-media-image--block-1 blazy--view blazy--view--listicle blazy--view--listicle--block-1 image__field-media-image">
    <div class="field__label font-weight-bold visually-hidden">
      Image    </div>
                  <div class="field__item">



                  <div class="media media--blazy media--bundle--image media--loading is-b-loading media--image">
<img alt="Person typing code on laptop" class="media__image media__element b-lazy img-fluid" data-src="/sysadmin/sites/default/files/styles/card/public/2021-11/git-diff-patch.jpg?itok=F8ealOgm" src="data:image/svg+xml;charset=utf-8,%3Csvg%20xmlns%3D&#039;http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg&#039;%20viewBox%3D&#039;0%200%20700%20420&#039;%2F%3E" width="700" height="420" loading="lazy" typeof="foaf:Image" />
        </div>
        
  
</div>
              </div>

</div>
</div>
      </div>
    <div class="col-md-6 listicle-body">
      <div class="h4 listicle-title pt-4 pt-md-0"><a href="/sysadmin/kakoune-vi-text-editor"><span property="schema:name">Try Kakoune for a modern Vi</span>
</a></div>
      <div class="listicle-text font-weight-light py-2">
        
            <div property="schema:text" class="clearfix article__body">Kakoune is a modern text editor that incorporates ideas from recent editors as well as Vi and Vim.</div>
      
      </div>

      <div class="listicle-footer">
        <div class="article-date">
          <span class="label">Posted:</span>
          February 7, 2022
        </div>
        <div class="article-authors">
                      <span class="label">Author:</span>
                                <a href="/sysadmin/users/skenlon" class="article-author article-author--primary">Seth Kenlon<span class="author-affiliate"> (Red Hat)</span></a>                  </div>
      </div>
    </div>
  </div>
</article>
</div></div></div>

    

  
  

  
  
</div>
</div>

  
  </div>

  <div class="block">

  
    

      <div class="topics">
  <strong>Topics:</strong>&nbsp;&nbsp;
      <a href="/sysadmin/topics/text-editors" class="btn btn-primary btn-sm font-weight-bold">Text editors</a>&nbsp;&nbsp;
      <a href="/sysadmin/topics/command-line-utilities" class="btn btn-primary btn-sm font-weight-bold">Command line utilities</a>&nbsp;&nbsp;
  </div>
  
  </div>

    </div>
  </div>
</div>
<div >
  <div >
    
  <div class="block">

  
    

      
<section data-history-node-id="5990" role="article" about="/sysadmin/vim-power-commands" typeof="schema:Article" id="node--article--5990" class="section my-5 py-5 bg-light-gray authors-bio authors-bio--article">
  <div class="container">
          <div class="row">
        <div class="col-md-2 text-center">
                      
<img alt="Author’s photo" data-affiliation="" src="/sysadmin/sites/default/files/styles/user_picture_square/public/pictures/2022-06/JackKnight.jpg?itok=28Do6Czo" width="240" height="240" loading="lazy" typeof="foaf:Image" class="rounded-circle img-fluid" />


          
        </div>
        <div class="col-md-10 col-lg-8">
          <h2 class="font-weight-light text-center text-md-left">
                          Jack Knight
                      </h2>
          <div>
                          <p>
                Jack is a veteran Unix/Linux guy who has worked in many different sectors and industries including electronics, telcos, gaming, finance, and government. He&#039;s experienced in multiple cloud platforms, automation tooling, and platform engineering.
                                  <a href="/sysadmin/jackknight" class="author-more-link">More about me</a>
                              </p>
                      </div>
        </div>
      </div>
      </div>
</section>



  
  </div>

  <div class="block">

  
    

      

  
  </div>

  </div>
</div>
<div >
  <div >
    

  <div class="block block--cta cta cta--red-on-black cta-- my-5 p-3 text-center">

  
    

    <div class="d-md-flex justify-content-around align-items-center flex-wrap">
    <div class="cta__content my-2">
      
            <div class="cta__field-content p-2"><h2>Red Hat Summit 2022: On Demand</h2>

<p>Get the latest on Ansible, Red Hat Enterprise Linux, OpenShift, and more from our virtual event on demand.</p>
</div>
      
    </div>
        <div class="cta__link my-2">
      <a
        href="https://www.redhat.com/en/summit?intcmp=701f20000012ngPAAQ"
        target="_blank"
        class="btn btn-lg btn-danger font-weight-bold">
        Register for free
      </a>
    </div>
      </div>
  
  </div>

  </div>
</div>
<div  class="section">
  <div class="container">
    <div >
      
  <div class="views-element-container block">

  
    

      <div><div class="js-view-dom-id-d0886771195f369a1d955086e847567fba9df96535e5d1d5b827230b560fa12d">
  
  
  

  
  
  

    <h2>Related Content</h2>
                        <div class="card-deck my-4">
                        <article data-history-node-id="5984" role="article" about="/sysadmin/deprecated-linux-command-replacements" typeof="schema:Article" id="node--article--5984" class="card card--article node node--promoted">
      <div class="card-img-top">
            <div class="article__field-media"><div>
  
  
  <div data-blazy="" class="blazy blazy--field blazy--field-media-image blazy--field-media-image--card image__field-media-image">
    <div class="field__label font-weight-bold visually-hidden">
      Image    </div>
                  <div class="field__item">



                  <div class="media media--blazy media--bundle--image media--loading is-b-loading media--responsive media--image">  
<img class="media__image media__element b-lazy b-responsive img-fluid" data-src="/sysadmin/sites/default/files/styles/card/public/2021-06/drill-tip-tool-sharp.jpg?itok=EY7bLaQE" srcset="" data-srcset="/sysadmin/sites/default/files/styles/card/public/2021-06/drill-tip-tool-sharp.jpg?itok=EY7bLaQE 1x" src="data:image/svg+xml;charset=utf-8,%3Csvg%20xmlns%3D&#039;http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg&#039;%20viewBox%3D&#039;0%200%201001%20600&#039;%2F%3E" alt="Sharp drill tip" typeof="foaf:Image" loading="lazy" />

        </div>
        
  
</div>
              </div>

</div>
</div>
      </div>
    <div class="card-body">
    <div class="h4 card-title"><a href="/sysadmin/deprecated-linux-command-replacements"><span property="schema:name">6 deprecated Linux commands and the tools you should be using instead</span>
</a></div>
    <div class="card-text">
            <div property="schema:text" class="clearfix article__body">Swap your old Linux commands for new and improved alternatives that provide the same functionality, if not more.</div>
      </div>
  </div>
  <div class="card-footer">
    <div class="article-date">
      <span class="label">Posted:</span>
      June 3, 2022
    </div>
    <div class="article-authors">
              <span class="label">Author:</span>
                    <a href="/sysadmin/users/jose-vicente-nunez" class="article-author article-author--primary">Jose Vicente Nunez<span class="author-affiliate"> (Sudoer)</span></a>          </div>
  </div>
</article>


                            <article data-history-node-id="5962" role="article" about="/sysadmin/mutt-email-oauth2" typeof="schema:Article" id="node--article--5962" class="card card--article node node--promoted">
      <div class="card-img-top">
            <div class="article__field-media"><div>
  
  
  <div data-blazy="" class="blazy blazy--field blazy--field-media-image blazy--field-media-image--card image__field-media-image">
    <div class="field__label font-weight-bold visually-hidden">
      Image    </div>
                  <div class="field__item">



                  <div class="media media--blazy media--bundle--image media--loading is-b-loading media--responsive media--image">  
<img class="media__image media__element b-lazy b-responsive img-fluid" data-src="/sysadmin/sites/default/files/styles/card/public/2020-02/email-824310_1920%20Cropped.jpg?itok=FBM1cVcx" srcset="" data-srcset="/sysadmin/sites/default/files/styles/card/public/2020-02/email-824310_1920%20Cropped.jpg?itok=FBM1cVcx 1x" src="data:image/svg+xml;charset=utf-8,%3Csvg%20xmlns%3D&#039;http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg&#039;%20viewBox%3D&#039;0%200%201920%201152&#039;%2F%3E" alt="@ (at sign) on keyboard" typeof="foaf:Image" loading="lazy" />

        </div>
        
  
</div>
              </div>

</div>
</div>
      </div>
    <div class="card-body">
    <div class="h4 card-title"><a href="/sysadmin/mutt-email-oauth2"><span property="schema:name">How to set up OAuth2 in the Mutt email client</span>
</a></div>
    <div class="card-text">
            <div property="schema:text" class="clearfix article__body">Configure Mutt to use your OAuth2 credentials to send and receive Gmail from the command line.</div>
      </div>
  </div>
  <div class="card-footer">
    <div class="article-date">
      <span class="label">Posted:</span>
      May 4, 2022
    </div>
    <div class="article-authors">
              <span class="label">Author:</span>
                    <a href="/sysadmin/users/filip-janus" class="article-author article-author--primary">Filip Januš<span class="author-affiliate"> (Red Hat)</span></a>          </div>
  </div>
</article>


                            <article data-history-node-id="5911" role="article" about="/sysadmin/ansible-logs-customize" typeof="schema:Article" id="node--article--5911" class="card card--article node node--promoted">
      <div class="card-img-top">
            <div class="article__field-media"><div>
  
  
  <div data-blazy="" class="blazy blazy--field blazy--field-media-image blazy--field-media-image--card image__field-media-image">
    <div class="field__label font-weight-bold visually-hidden">
      Image    </div>
                  <div class="field__item">



                  <div class="media media--blazy media--bundle--image media--loading is-b-loading media--responsive media--image">  
<img class="media__image media__element b-lazy b-responsive img-fluid" data-src="/sysadmin/sites/default/files/styles/card/public/2021-01/TerminalLogging.jpg?itok=LUfgcPhL" srcset="" data-srcset="/sysadmin/sites/default/files/styles/card/public/2021-01/TerminalLogging.jpg?itok=LUfgcPhL 1x" src="data:image/svg+xml;charset=utf-8,%3Csvg%20xmlns%3D&#039;http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg&#039;%20viewBox%3D&#039;0%200%203840%202304&#039;%2F%3E" alt="How to set up terminal logging on Linux" typeof="foaf:Image" loading="lazy" />

        </div>
        
  
</div>
              </div>

</div>
</div>
      </div>
    <div class="card-body">
    <div class="h4 card-title"><a href="/sysadmin/ansible-logs-customize"><span property="schema:name">How to customize your Ansible logs</span>
</a></div>
    <div class="card-text">
            <div property="schema:text" class="clearfix article__body">Learn how to use callback plugins to customize Ansible's output and then save that output to a file.</div>
      </div>
  </div>
  <div class="card-footer">
    <div class="article-date">
      <span class="label">Posted:</span>
      April 13, 2022
    </div>
    <div class="article-authors">
              <span class="label">Author:</span>
                    <a href="/sysadmin/users/anthony-critelli" class="article-author article-author--primary">Anthony Critelli<span class="author-affiliate"> (Sudoer)</span></a>          </div>
  </div>
</article>


                              </div>
            
    

  
  

  
  
</div>
</div>

  
  </div>

    </div>
  </div>
</div>
<div  class="section my-5 pb-5 narrow">
  <div class="container">
    <div >
      
    </div>
  </div>
</div>
<div  class="section my-5 pb-5 ">
  <div class="container">
    <div >
      

  <div class="block block--cta cta cta--red-on-black cta-- my-5 p-3 text-center">

  
    

    <div class="d-md-flex justify-content-around align-items-center flex-wrap">
    <div class="cta__content my-2">
      
            <div class="cta__field-content p-2"><p class="h4 mb-4 mt-3 font-weight-bold">OUR BEST CONTENT, DELIVERED TO YOUR INBOX</p>

<p><iframe title="Subscribe to our newsletter" aria-label="Embedded form to subscribe to our email newsletter" frameborder="0" height="50" scrolling="no" src="/sysadmin/eloqua-embedded-subscribe.html?offer_id=701f20000012gE7AAI" style="max-width:670px;margin:0 auto;" width="100%"></iframe></p>
</div>
      
    </div>
      </div>
  
  </div>

    </div>
  </div>
</div>

  </article>

  
  </div>


              </div>
        </main>

            <footer>
              <div class="page__colophon bg-dark-gray py-4 bg-dark-gray">
          <div class="container">
              
  <div class="block block--basic block--sysadmin-colophon-disclaimer">

  
    

      
            <div class="basic__body"><p>The opinions expressed on this website are those of each author, not of the author's employer or of Red Hat. The content published on this site are community contributions and are for informational purpose only AND ARE NOT, AND ARE NOT INTENDED TO BE, RED HAT DOCUMENTATION, SUPPORT, OR ADVICE.</p>

<p>Red Hat and the Red Hat logo are trademarks of Red Hat, Inc., registered in the United States and other countries.</p>
</div>
      
  
  </div>


          </div>
        </div>
                    <div class="page__footer bg-dark py-3">
        <div class="container">
          <div class="d-sm-flex justify-content-between align-items-center">
              

  
    

    
  <a href="https://www.redhat.com/" class="navbar-brand mr-0 mr-lg-auto mb-3 mb-sm-0">
            <img src="/sysadmin/themes/custom/sysadmin/logo.svg" width="135" height="31" class="d-inline-block align-top" alt="Red Hat logo" />

        
  </a>



  <div class="block block--basic block--copyright my-0 mx-sm-3 mb-1 mb-sm-0">

  
    

      
            <div class="basic__body"><p>Copyright ©2022 Red Hat, Inc.</p>
</div>
      
  
  </div>

  <div class="block block--sysadmin-footer my-0 mb-1 mb-sm-0">

  
    

      
  


  <ul class="nav d-flex d-sm-block d-md-flex justify-content-center align-items-center">
                                          <li class="nav-item  ">
                      <a href="https://www.redhat.com/en/about/privacy-policy" class="nav-link">Privacy Policy</a>
                  </li>
                                      <li class="nav-item  ">
                      <a href="https://www.redhat.com/en/about/terms-use" class="nav-link">Terms of Use</a>
                  </li>
                                      <li class="nav-item  ">
                      <a href="https://www.redhat.com/en/about/all-policies-guidelines" class="nav-link">All policies and guidelines</a>
                  </li>
            </ul>


  
  </div>

  <div class="block block--basic block--footerredhatsummit">

  
    

      
            <div class="basic__body"><div style="margin-left: 1rem"><a href="https://www.redhat.com/en/summit?intcmp=7013a0000026RhqAAE" target="_blank"><img alt="Red Hat Summit" src="https://www.redhat.com/cms/managed-files/Logo-Red_Hat-Summit-A-Standard-RGB-02_0.svg" width="72px" /></a></div>
</div>
      
  
  </div>

  <div class="block block--sharelinks">

  
    

      <div class="a2a_kit a2a_kit_size_32 a2a_floating_style a2a_vertical_style" data-a2a-url="https://www.redhat.com/sysadmin/vim-power-commands">
  <a class="a2a_button_twitter"></a>
  <a class="a2a_button_facebook"></a>
  <a class="a2a_button_linkedin"></a>
  <a class="a2a_button_reddit"></a>
  <a class="a2a_button_email"></a>
</div>
<div class="a2a_kit a2a_kit_size_32 a2a_floating_style a2a_default_style">
  <a class="a2a_button_twitter"></a>
  <a class="a2a_button_facebook"></a>
  <a class="a2a_button_linkedin"></a>
  <a class="a2a_button_reddit"></a>
  <a class="a2a_button_email"></a>
</div>

<script>
  var a2a_config = a2a_config || {};
  a2a_config.templates = a2a_config.templates || {};
  a2a_config.templates.twitter = {
    text: "5 Vim features for power users https://red.ht/3augkXI via #EnableSysadmin",
  };
    a2a_config.templates.facebook = {
    hashtag: "#EnableSysadmin",
  };
  </script>

  
  </div>


  <div class="block block--cta block--ctasubscribesidebar cta cta--blue-on-white cta-- my-5 p-3 text-center">

  
    

    <div class="d-md-flex justify-content-around align-items-center flex-wrap">
    <div class="cta__content my-2">
      
            <div class="cta__field-content p-2"><div class="subscribe-sidebar">
<div class="target-band-never-show-button">x</div>

<h4>Subscribe now</h4>

<p class="eloqua-email-capture-text">Get the highlights in your inbox every week.</p>

<p><iframe aria-label="Embedded form to subscribe to our email newsletter" frameborder="0" height="50" scrolling="no" src="/sysadmin/eloqua-embedded-email-capture-block.html?offer_id=701f20000012gE7AAI" style="max-width:670px;margin:0 auto;" title="Subscribe to our newsletter" width="100%"></iframe></p>
</div>
</div>
      
    </div>
      </div>
  
  </div>


          </div>
        </div>
            </footer>
      </div>

  </div>


<script type="application/json" data-drupal-selector="drupal-settings-json">{"path":{"baseUrl":"\/sysadmin\/","scriptPath":null,"pathPrefix":"","currentPath":"node\/5990","currentPathIsAdmin":false,"isFront":false,"currentLanguage":"en"},"pluralDelimiter":"\u0003","suppressDeprecationErrors":true,"ckeditorheight":{"offset":1,"line_height":1.5,"unit":"em","disable_autogrow":null},"colorbox":{"opacity":"0.85","current":"{current} of {total}","previous":"\u00ab Prev","next":"Next \u00bb","close":"Close","maxWidth":"98%","maxHeight":"98%","fixed":true,"mobiledetect":true,"mobiledevicewidth":"480px"},"blazy":{"loadInvisible":false,"offset":100,"saveViewportOffsetDelay":50,"validateDelay":25},"blazyIo":{"enabled":false,"disconnect":false,"rootMargin":"0px","threshold":[0]},"user":{"uid":0,"permissionsHash":"dc7d17feb5a701a6cd2af389e508cec93041634fd7d8a05a7eea3ad5fed5c8df"}}</script>
<script src="/sysadmin/sites/default/files/js/js_qIDgH_1Ntr3oybBWS5Dii3UJ8C3X9Nh-0RbMnncIcGE.js"></script>

  <script type="text/javascript">
    if (("undefined" !== typeof _satellite) && ("function" === typeof _satellite.pageBottom)) {
      _satellite.pageBottom();
    }
  </script>
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"NRJS-969d30985413823a2a8","applicationID":"1080948181","transactionName":"M1ZTYUEHXEZVAkwKDgoccFZHD11bGyVKFhEFX21bXAJXaXcOVhcTC19dUEE6fFpQBG4KBBNwXltHFF1ZWARKTl8SWlRC","queueTime":0,"applicationTime":989,"atts":"HxFQFwkdT0g=","errorBeacon":"bam.nr-data.net","agent":""}</script><script type="text/javascript"  src="/1wW_IETfMIgzG5J1bPVcxIhY/5QS9fppfYi/VRFBOFZ1QQM/eX0LL/R4oGSw"></script></body>
</html>
