<!DOCTYPE html>
<html lang="en" dir="ltr" prefix="content: http://purl.org/rss/1.0/modules/content/  dc: http://purl.org/dc/terms/  foaf: http://xmlns.com/foaf/0.1/  og: http://ogp.me/ns#  rdfs: http://www.w3.org/2000/01/rdf-schema#  schema: http://schema.org/  sioc: http://rdfs.org/sioc/ns#  sioct: http://rdfs.org/sioc/types#  skos: http://www.w3.org/2004/02/skos/core#  xsd: http://www.w3.org/2001/XMLSchema# ">
<head>
<script id="dpal" src="https://www.redhat.com/ma/dpal.js"></script>
<meta charset="utf-8" />
<meta name="title" content="Linux capacity planning: 5 things you need to do | Enable Sysadmin" />
<link rel="canonical" href="https://www.redhat.com/sysadmin/linux-capacity-planning" />
<meta property="og:site_name" content="Enable Sysadmin" />
<meta name="twitter:card" content="photo" />
<meta name="dcterms.title" content="Linux capacity planning: 5 things you need to do" />
<meta name="twitter:title" content="Linux capacity planning: 5 things you need to do" />
<meta name="dcterms.creator" content="khess" />
<meta name="description" content="Capacity planning is the &quot;black box&quot; of Linux system administration. Here are five things you need to do to get started." />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.redhat.com/sysadmin/linux-capacity-planning" />
<meta name="twitter:site:id" content="14627400" />
<meta property="og:title" content="Linux capacity planning: 5 things you need to do" />
<meta name="twitter:creator" content="@kenhess" />
<meta name="dcterms.publisher" content="Red Hat, Inc." />
<meta name="twitter:url" content="https://www.redhat.com/sysadmin/linux-capacity-planning" />
<meta name="twitter:image" content="https://www.redhat.com/sysadmin/sites/default/files/styles/full/public/2019-09/bees_0.jpg?itok=GzElhcQQ" />
<meta name="twitter:image:width" content="600" />
<meta name="twitter:image:height" content="1000" />
<meta name="twitter:image:alt" content="Red Hat, Inc." />
<meta property="og:image" content="https://www.redhat.com/sysadmin/sites/default/files/styles/full/public/2019-09/bees_0.jpg?itok=GzElhcQQ" />
<meta property="og:image:secure_url" content="https://www.redhat.com/sysadmin/sites/default/files/styles/full/public/2019-09/bees_0.jpg?itok=GzElhcQQ" />
<meta name="dcterms.language" content="en" />
<meta property="og:image:type" content="image/jpeg" />
<meta property="og:video:width" content="600" />
<meta property="og:image:width" content="1000" />
<meta property="og:image:height" content="675" />
<meta property="og:image:alt" content="https://www.redhat.com/sysadmin/sites/default/files/styles/full/public/2019-09/bees_0.jpg?itok=GzElhcQQ" />
<meta property="og:updated_time" content="2019-09-23T06:00:00+0000" />
<meta property="og:street_address" content="100 East Davie Street" />
<meta property="og:locality" content="Raleigh" />
<meta property="og:region" content="NC" />
<meta property="og:postal_code" content="27601" />
<meta property="og:country_name" content="United States" />
<meta property="og:phone_number" content="+1 919 754 4950" />
<meta property="og:fax_number" content="+1 919 800 3804" />
<meta property="og:locale" content="en_US" />
<meta property="article:author" content="https://www.redhat.com/sysadmin/users/khess" />
<meta property="article:publisher" content="https://www.facebook.com/redhatinc" />
<meta property="article:section" content="Enable Sysadmin" />
<meta property="article:tag" content="linux administration" />
<meta property="article:tag" content="Linux" />
<meta property="article:modified_time" content="2019-09-23T06:00:00+0000" />
<meta name="Generator" content="Drupal 8 (https://www.drupal.org)" />
<meta name="MobileOptimized" content="width" />
<meta name="HandheldFriendly" content="true" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<script type="application/ld+json">{
    "@context": "https://schema.org",
    "@graph": [
        {
            "@type": "TechArticle",
            "headline": "Linux capacity planning: 5 things you need to do",
            "name": "Linux capacity planning: 5 things you need to do",
            "about": [
                "linux administration",
                "Linux"
            ],
            "description": "Capacity planning is the \u0022black box\u0022 of Linux system administration. Here are five things you need to do to get started.",
            "image": {
                "@type": "ImageObject",
                "url": "https://www.redhat.com/sysadmin/sites/default/files/styles/full/public/2019-09/bees_0.jpg?itok=GzElhcQQ",
                "width": "1000",
                "height": "600"
            },
            "dateModified": "2019-09-23T06:00:00+0000",
            "author": {
                "@type": "Person",
                "@id": "https://www.redhat.com/sysadmin/users/khess",
                "name": "khess",
                "url": "https://www.redhat.com/sysadmin/users/khess",
                "sameAs": "https://twitter.com/kenhess"
            },
            "publisher": {
                "@type": "Organization",
                "@id": "https://www.redhat.com/"
            },
            "mainEntityOfPage": "https://www.redhat.com/sysadmin/linux-capacity-planning"
        },
        {
            "@type": "WebPage",
            "@id": "https://www.redhat.com/sysadmin/linux-capacity-planning",
            "publisher": {
                "@type": "Organization",
                "@id": "https://www.redhat.com/"
            }
        },
        {
            "@type": "Person",
            "name": "Ken Hess",
            "sameAs": "https://twitter.com/kenhess",
            "image": {
                "@type": "ImageObject",
                "url": "https://www.redhat.com/sysadmin/sites/default/files/styles/user_picture_square/public/pictures/2019-07/Ken_Hess.jpg?itok=0muInbxY",
                "width": "240",
                "height": "240"
            }
        },
        {
            "@type": "Corporation",
            "@id": "https://www.redhat.com/",
            "name": "Red Hat, Inc.",
            "url": "https://www.redhat.com/",
            "sameAs": [
                "https://en.wikipedia.org/wiki/Red_Hat",
                "http://www.linkedin.com/company/red-hat",
                "http://www.youtube.com/user/RedHatVideos",
                "https://www.facebook.com/redhatinc",
                "https://twitter.com/RedHat"
            ],
            "telephone": "+1 919 754 4950",
            "contactPoint": {
                "@type": "ContactPoint",
                "telephone": "+1-888-RED-HAT1",
                "availableLanguage": "English",
                "contactType": "sales",
                "faxnumber": "+1 919 800 3804"
            },
            "logo": {
                "@type": "ImageObject",
                "url": "https://www.redhat.com/sysadmin/themes/custom/sysadmin/assets/images/red-hat-logo.png",
                "width": "254",
                "height": "60"
            },
            "address": {
                "@type": "PostalAddress",
                "streetAddress": "100 East Davie Street",
                "addressLocality": "Raleigh",
                "addressRegion": "NC",
                "postalCode": "27601",
                "addressCountry": "United States"
            }
        },
        {
            "@type": "WebSite",
            "@id": "https://www.redhat.com/sysadmin/",
            "name": "Enable Sysadmin",
            "url": "https://www.redhat.com/sysadmin/",
            "publisher": {
                "@type": "Organization",
                "@id": "https://www.redhat.com/"
            }
        }
    ]
}</script>
<link rel="shortcut icon" href="/sysadmin/themes/custom/sysadmin/favicon.ico" type="image/vnd.microsoft.icon" />
<link rel="revision" href="https://www.redhat.com/sysadmin/linux-capacity-planning" />
<link rel="apple-touch-icon" sizes="180x180" href="/sysadmin/themes/custom/sysadmin/assets/favicon/apple-touch-icon.png">
<link rel="icon" type="image/png" sizes="32x32" href="/sysadmin/themes/custom/sysadmin/assets/favicon/favicon-32x32.png">
<link rel="icon" type="image/png" sizes="16x16" href="/sysadmin/themes/custom/sysadmin/assets/favicon/favicon-16x16.png">
<link rel="manifest" href="/sysadmin/themes/custom/sysadmin/assets/favicon/site.webmanifest">
<link rel="mask-icon" href="/sysadmin/themes/custom/sysadmin/assets/favicon/safari-pinned-tab.svg" color="#ee0000">
<meta name="msapplication-TileColor" content="#1a1a1a">
<meta name="theme-color" content="#ffffff">
<title>Linux capacity planning: 5 things you need to do | Enable Sysadmin</title>
<link rel="stylesheet" media="all" href="/sysadmin/sites/default/files/css/css_y3Xr5G8fIRYFF5ceJ8PSWt5P0C14zqhCAJrGX41FquU.css?pxaysw" />
<link rel="stylesheet" media="all" href="/sysadmin/sites/default/files/css/css_C5oENjkXowZdISXVWDGyU6xprqnvpe0Oz7MxqIHz0mg.css?pxaysw" />


<!--[if lte IE 8]>
<script src="/sysadmin/sites/default/files/js/js_VtafjXmRvoUgAzqzYTA3Wrjkx9wcWhjP0G4ZnnqRamA.js"></script>
<![endif]-->


</head>
<body>
<a href="#main-content" class="visually-hidden focusable">
Skip to main content
</a>

  <div class="dialog-off-canvas-main-canvas" data-off-canvas-main-canvas>
    

<div class="redhat-cookie-banner">
<section id="redhat-cookie-privacy-banner" class="redhat-cookie-banner-wrapper" style="display: block;">
  <div class="container my-3 pr-5">
    <p>We use cookies on our websites to deliver our online services. Details about how we use cookies and how you may disable them are set out in our <a href="http://www.redhat.com/en/about/privacy-policy#cookies">Privacy Statement</a>. By using this website you agree to our use of cookies.
    <span class="cookie-more">
    <a id="redhat-cookie-privacy-banner-close" href="javascript:void(0);" class="cookie-close">&times;</a>
    </span>
    </p>
  </div>
</section>
</div>

<div class="page">

  <div class="navbar navbar-expand-lg justify-content-between navbar-dark bg-dark">
    <div class="container">
                
  <div class="block block--sysadmin-navbar-branding">

  
    

    
  <a href="https://www.redhat.com/" class="navbar-brand ">
            <img src="/sysadmin/themes/custom/sysadmin/logo.svg" width="135" height="31" class="d-inline-block align-top" alt="Red Hat logo" />

        
  </a>


  </div>


      
      <div>
        <button class="navbar-toggler" type="button" data-toggle="collapse"  data-parent="#collapse-parent" data-target="#search-collapse" aria-controls="search-collapse" aria-expanded="false" aria-label="Toggle search">
          <svg class="icon-collapsed" width="30" height="30" viewBox="0 0 30 30" xmlns="http://www.w3.org/2000/svg"><line x1="18.95" y1="19.15" x2="25.25" y2="25.75"/><circle cx="13.25" cy="12.75" r="8.5"/></svg>
          <svg class="icon-expanded" width="30" height="30" viewBox="0 0 30 30" xmlns="http://www.w3.org/2000/svg"><line x1="7.25" y1="7.25" x2="22.75" y2="22.75"/><line x1="7.25" y1="22.75" x2="22.75" y2="7.25"/></svg>
          <span style="vertical-align: middle;">Search</span>
        </button>
        <button class="navbar-toggler" type="button" data-toggle="collapse" data-parent="#collapse-parent" data-target="#mobilenav-collapse" aria-controls="mobilenav-collapse" aria-expanded="false" aria-label="Toggle navigation">
          <svg class="icon-collapsed" width="30" height="30" viewBox="0 0 30 30" xmlns="http://www.w3.org/2000/svg"><path d="M4 7h22M4 15h22M4 23h22"/></svg>
          <svg class="icon-expanded" width="30" height="30" viewBox="0 0 30 30" xmlns="http://www.w3.org/2000/svg"><line x1="7.25" y1="7.25" x2="22.75" y2="22.75"/><line x1="7.25" y1="22.75" x2="22.75" y2="7.25"/></svg>
        </button>
      </div>
    </div>
  </div>

  <div id="collapse-parent">
    <div id="search-collapse" class="search-collapse collapse" data-parent="#collapse-parent">
      <div class="py-4 px-3">
        <form class="form-inline m-2" action="/sysadmin/search/node" accept-charset="UTF-8" method="get">
          <div class="input-group flex-fill">
            <input class="form-control" type="search" name="keys" id="search" value="" placeholder="Search this site…" aria-label="Search this site…">
            <div class="input-group-append">
              <button class="btn btn-secondary font-weight-bold" type="submit">Search</button>
            </div>
          </div>
        </form>
      </div>
    </div>

    <div id="mobilenav-collapse" class="mobilenav-collapse d-lg-none collapse" data-parent="#collapse-parent">
                
  <div class="block block--sysadmin-navbar-sitename sitename">

  
    

    
  <a href="/sysadmin/" class="navbar-brand sitename">
        Enable Sysadmin
  </a>

  <span class="d-none d-lg-inline ml-1 mr-3 h5 navbar-sitename-divider">&nbsp;</span>

  </div>

  <div class="block block--sysadmin-main-menu">

  
    

      
  


  <ul class="nav navbar-nav">
                                  <li class="nav-item  dropdown">
                      <a href="/sysadmin/" class="nav-link dropdown-toggle" data-toggle="dropdown" data-drupal-link-system-path="&lt;front&gt;">Articles</a>
                          <div class="dropdown-menu">
          <a href="/sysadmin/topics/automation" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/146">Automation</a>
          <a href="/sysadmin/topics/career" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/51">Career</a>
          <a href="/sysadmin/topics/sysadmin-culture" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/41">Culture</a>
          <a href="/sysadmin/topics/linux" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/21">Linux</a>
          <a href="/sysadmin/topics/programming" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/71"> Programming</a>
          <a href="/sysadmin/topics/security" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/96">Security</a>
  </div>
                              </li>
                              <li class="nav-item  dropdown">
                      <a href="/sysadmin/about" class="nav-link dropdown-toggle" data-toggle="dropdown" data-drupal-link-system-path="node/71">About</a>
                          <div class="dropdown-menu">
          <a href="/sysadmin/about" class="dropdown-item" data-drupal-link-system-path="node/71">Topics</a>
          <a href="/sysadmin/email" class="dropdown-item" data-drupal-link-system-path="node/376">Email newsletter</a>
          <a href="/sysadmin/join-community" class="dropdown-item" data-drupal-link-system-path="node/641">Join the community</a>
          <a href="/sysadmin/community-guidelines" class="dropdown-item" data-drupal-link-system-path="node/156">Community guidelines</a>
  </div>
                              </li>
                              <li class="nav-item  ">
                      <a href="/sysadmin/welcome" class="nav-link">Welcome</a>
                  </li>
            </ul>


  
  </div>


      
              
          </div>
  </div>

  


<nav class="navbar navbar-expand-lg justify-content-between navbar-light  d-none d-lg-block text-dark bg-light border-bottom-light-gray">
      <div class="container">
  
      
  
  <button class="navbar-toggler" type="button" data-toggle="collapse" data-target=".navbar-collapse" aria-controls="navbar-collapse" aria-expanded="false" aria-label="Toggle navigation">
    <span class="navbar-toggler-icon"></span>
  </button>

  <div class="collapse navbar-collapse">
                  <div class="mr-auto d-flex navbar-desktop">
            
  <div class="block block--sysadmin-navbar-sitename sitename">

  
    

    
  <a href="/sysadmin/" class="navbar-brand sitename">
        Enable Sysadmin
  </a>

  <span class="d-none d-lg-inline ml-1 mr-3 h5 navbar-sitename-divider">&nbsp;</span>

  </div>

  <div class="block block--sysadmin-main-menu">

  
    

      
  


  <ul class="nav navbar-nav">
                                  <li class="nav-item  dropdown">
                      <a href="/sysadmin/" class="nav-link dropdown-toggle" data-toggle="dropdown" data-drupal-link-system-path="&lt;front&gt;">Articles</a>
                          <div class="dropdown-menu">
          <a href="/sysadmin/topics/automation" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/146">Automation</a>
          <a href="/sysadmin/topics/career" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/51">Career</a>
          <a href="/sysadmin/topics/sysadmin-culture" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/41">Culture</a>
          <a href="/sysadmin/topics/linux" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/21">Linux</a>
          <a href="/sysadmin/topics/programming" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/71"> Programming</a>
          <a href="/sysadmin/topics/security" class="dropdown-item" data-drupal-link-system-path="taxonomy/term/96">Security</a>
  </div>
                              </li>
                              <li class="nav-item  dropdown">
                      <a href="/sysadmin/about" class="nav-link dropdown-toggle" data-toggle="dropdown" data-drupal-link-system-path="node/71">About</a>
                          <div class="dropdown-menu">
          <a href="/sysadmin/about" class="dropdown-item" data-drupal-link-system-path="node/71">Topics</a>
          <a href="/sysadmin/email" class="dropdown-item" data-drupal-link-system-path="node/376">Email newsletter</a>
          <a href="/sysadmin/join-community" class="dropdown-item" data-drupal-link-system-path="node/641">Join the community</a>
          <a href="/sysadmin/community-guidelines" class="dropdown-item" data-drupal-link-system-path="node/156">Community guidelines</a>
  </div>
                              </li>
                              <li class="nav-item  ">
                      <a href="/sysadmin/welcome" class="nav-link">Welcome</a>
                  </li>
            </ul>


  
  </div>


        </div>
          
                  
      
      <div class="dropdown show text-align-right">
  <a href="/sysadmin/subscribe" class="navbar-util navbar-util--rss" aria-label="Subscribe to our feed or newsletter blast">
    <svg width="22" height="23" viewBox="0 0 22 23" xmlns="http://www.w3.org/2000/svg"><title>Subscribe to our RSS feed or Email blast</title><path d="M0 4.23c9.79 0 17.75 8 17.75 17.84h4.23A22.05 22.05 0 0 0 0 0v4.23z M0 7.67v4.23c2.74 0 5.33 1.07 7.27 3.03a10.26 10.26 0 0 1 3 7.3h4.24c0-8.02-6.5-14.56-14.51-14.56M2.93 16.87a2.94 2.94 0 0 0 0 5.85 2.93 2.93 0 1 0 0-5.85" fill-rule="evenodd"/></svg>

    <span class="sr-only">Subscribe to our RSS feed or Email blast.</span>
  </a>

    <a id="dropdownSearchLink" href="/sysadmin/search/node" class="navbar-util navbar-util--search" role="button" aria-label="Search this site…" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false">
    <svg width="30" height="30" viewBox="0 0 30 30" xmlns="http://www.w3.org/2000/svg" style="fill:none;stroke-width:3;stroke:#000;stroke-linecap:round;"><line x1="18.95" y1="19.15" x2="25.25" y2="25.75"/><circle cx="13.25" cy="12.75" r="8.5"/></svg>

  </a>
  <div class="dropdown-menu dropdown-menu-right p-1 pt-2" aria-labelledby="dropdownSearchLink">
    <form class="form-inline m-2" action="/sysadmin/search/node" accept-charset="UTF-8" method="get">
      <div class="input-group flex-fill">
        <input class="form-control" type="search" name="keys" id="search" value="" placeholder="Search this site…" aria-label="Search this site…">
        <div class="input-group-append">
          <button class="btn btn-secondary font-weight-bold" type="submit">GO</button>
        </div>
      </div>
    </form>
  </div>
  </div>
      </div>

      </div>
  </nav>

  <main class="pb-5">
                  <header class="page__header">
          <div class="container">
              <div data-drupal-messages-fallback class="hidden"></div>


          </div>
        </header>
          
    <a name="main-content" tabindex="-1"></a>

                  <div class="page__content">
                  
  <div class="block block--sysadmin-content">

  
    

      <article data-history-node-id="736" role="article" about="/sysadmin/linux-capacity-planning" typeof="schema:Article" class="full full--article node node--promoted">
  
    <span property="schema:name" content="Linux capacity planning: 5 things you need to do" class="hidden"></span>
  <span property="schema:interactionCount" content="UserComments:0" class="hidden"></span>


      <div  class="section my-5 narrow">
  <div class="container">
    <div >
      
  <div data-layout-content-preview-placeholder-label="&quot;Title&quot; field" class="block">

  
    

      <span property="schema:name"><h1 class="font-weight-bold">Linux capacity planning: 5 things you need to do</h1>
</span>

  
  </div>

  <div data-layout-content-preview-placeholder-label="&quot;Subhead&quot; field" class="block">

  
    

      
            <div class="article__field-subhead">Capacity planning is the &quot;black box&quot; of Linux system administration. Here are five things you need to do to get started.</div>
      
  
  </div>

    </div>
  </div>
</div>
<div  class="section pb-5 narrow">
  <div class="container">
    <div >
      
  <div data-layout-content-preview-placeholder-label="&quot;Article Byline&quot; block" class="block">

  
    

      <p class="article-byline">
  <span class="article-date">
          Posted September 23, 2019
      </span>
    <span aria-hidden="true">|</span>
  <span class="article-authors">
    <strong class="sr-only">by</strong>
          <a href="/sysadmin/users/khess" class="article-author article-author--primary">Ken Hess<span class="author-affiliate"> (Red Hat)</span></a>      </span>
  </p>

  
  </div>

  <div data-layout-content-preview-placeholder-label="&quot;Media&quot; field" class="block">

  
    

      
            <div class="article__field-media"><figure>
  
  
  <div class="image__field-media-image">
    <div class="field__label font-weight-bold visually-hidden">
      Image    </div>
                  <div class="field__item">  
<img src="/sysadmin/sites/default/files/styles/full/public/2019-09/bees_0.jpg?itok=GzElhcQQ" width="1000" height="600" typeof="foaf:Image" class="img-thumbnail" src="/sysadmin/sites/default/files/styles/full/public/2019-09/bees_0.jpg?itok=GzElhcQQ" alt="5 things you need to know when getting started with Linux capacity planning" />


</div>
              </div>

  <figcaption>
    
            <div class="image__field-media-description"><a href="https://www.flickr.com/photos/13434526@N00/3724515196">"Bees"</a> by <a href="https://www.flickr.com/photos/13434526@N00">plenty.r.</a> is licensed under <a href="https://creativecommons.org/licenses/by-sa/2.0/?ref=ccsearch&amp;atype=rich">CC BY-SA 2.0 </a></div>
      
  </figcaption>
</figure>
</div>
      
  
  </div>

  <div data-layout-content-preview-placeholder-label="&quot;Body&quot; field" class="block">

  
    

      
            <div property="schema:text" class="article__body"><p>I think a lot of system administrators either fear capacity planning or just think it's unnecessary. First, there's no reason to fear capacity planning (it isn't rocket science); and second, capacity planning is 100% necessary. In the past, system administrators had to deal with management making sweeping decisions to add capacity and enhance performance, either by throwing new systems into the mix or adding CPU, RAM, or faster storage. Usually, but not always, the problem persisted beyond the upgrades and added capacity. But the "usually" qualifier is the part of the equation that stumps system administrators and managers alike—to the point that no one wants to deal with actual capacity and performance planning and administration.</p>

<p>This issue doesn't have to be a struggle. In this article, I present five things you need to know to get started in Linux capacity planning. You can also apply these guidelines to any environment: Linux, Windows, Unix, or a hybrid version of these.</p>

<h2>Capacity planning basics</h2>

<div data-embed-button="resource_list" data-entity-embed-display="view_mode:resource_list.link" data-entity-type="resource_list" data-entity-uuid="60b26066-acd0-4332-afa7-d98c9a079f02" data-langcode="en" class="align-right embedded-entity embedded-entity--resources embedded-entity--resources--link"><aside class="eck-entity mt-2 py-3 pr-3 border-top border-danger"><h2 class="h4">
      More Linux resources
  </h2>

<ul class="pl-3 mb-0"><li class="my-2"><a href="https://developers.redhat.com/promotions/linux-cheatsheet/?intcmp=701f20000012ngPAAQ">Download Now: Linux Commands Cheat Sheet</a></li>
      <li class="my-2"><a href="https://developers.redhat.com/cheat-sheets/advanced-linux-commands/?intcmp=701f20000012ngPAAQ">Advanced Linux Commands Cheat Sheet for Developers</a></li>
      <li class="my-2"><a href="https://www.redhat.com/en/technologies/linux-platforms/enterprise-linux/try-it?intcmp=701f20000012ngPAAQ">Download Red Hat Enterprise Linux Server 8 Trial</a></li>
      <li class="my-2"><a href="https://www.redhat.com/rhtapps/assessment/session/?intcmp=701f20000012ngPAAQ">Linux System Administration Skills Assessment</a></li>
  </ul></aside></div>
<p>When you discuss capacity, you're really discussing performance. Capacity and performance are always mentioned together. You have to measure and monitor performance to do any sort of capacity planning. Capacity means the ability to process and store data without bottlenecks or impact to the end user. Most of the time, system administrators think of performance in terms of data processing for websites, databases, or applications. But, that's not where performance ends. Think about backup and restore performance. Backups require compression, deduplication, disk-to-disk transfer, or over-the-network transfer. And don't forget, moving virtual machines from one host to another requires compute, storage, AND network capacity.</p>

<p>Your takeaway here is is this: Capacity and performance are too closely related to separate them into different conversations. Let's take a look at the steps in this process.</p>

<h2>First: Get a baseline</h2>

<p>It doesn't matter whether your systems are brand new or three years old, you must establish a baseline before you can begin capacity planning and projection. Establishing a baseline is somewhat time-consuming because a baseline is not a snapshot, it is rather a longer-term view of performance. Use at least a one-month baseline for each system. A month of data should give you the range of performance from which you can plan and forecast capacity needs.</p>

<p>There are three numbers you need to examine after you've gathered the preliminary date: peak, low, and average load or usage. After analyzing this data, you'll realize why you cannot depend on a load snapshot to guide you through the capacity planning process. A baseline tells you where you are in this process.</p>

<p>The next set of data you need to consider is current capacity. You need to assess RAM, CPU, disk, and network capacity information. Then, you need to find out what your maximum capacity is for each system. The difference between current and maximum capacity gives you your growth capacity. For example, consider a system that has the following configuration: two Quad-core CPUs, 128GB RAM, two 1TB disks in RAID 1 (mirrored), and one dual Gb Ethernet network interface. Your maximum capacity for this system, then, is four quad-core CPUs, 512GB RAM, six disks, and two open PCIe slots for expansion cards such as Gb Ethernet network interface cards (NICs). </p>

<table align="center" border="1" cellpadding="1" cellspacing="1" style="width: 500px;" summary="ooo"><caption> </caption>
	<thead><tr><th scope="col"> </th>
			<th scope="col">
			<center>Current Capacity</center>
			</th>
			<th scope="col">
			<center>Maximum Capacity</center>
			</th>
		</tr></thead><tbody><tr><td><strong>CPU</strong></td>
			<td>2 - Quad core</td>
			<td>4 - Quad core</td>
		</tr><tr><td><strong>RAM</strong></td>
			<td>128 GB</td>
			<td>512 GB</td>
		</tr><tr><td><strong>Disk</strong></td>
			<td>2 Disks - 1 TB - RAID 1</td>
			<td>6 Disks</td>
		</tr><tr><td><strong>NIC</strong></td>
			<td>2 GbE (Dual)</td>
			<td>6 GbE (Dual) - 10 GbE (Quad)</td>
		</tr></tbody></table><p>Now, compare the two. This system has much more available capacity for increased compute power, network, and storage. These hardware capacity parameters plus your month's worth of performance data are your starting points in predicting the need for extra capacity, whether in the form of system upgrades or a complete technology refresh.</p>

<h2>Second: Set up performance monitoring</h2>

<p>If you don't already have a performance monitoring package such as <code>sysstat</code> installed, you can easily do so from the default repositories. Check to see if you have <code>sysstat</code>:</p>

<pre>
<code class="language-shell">$ rpm -qa |grep sysstat</code></pre>

<p>If you don't have it, then install it with:</p>

<pre>
<code class="language-shell">$ sudo yum -y install sysstat</code></pre>

<p>Execute the following two commands to run <code>sysstat</code>'s data collectors on startup and then to start <code>sysstat</code>'s data collectors on your system:</p>

<pre>
<code class="language-shell">$ sudo systemctl enable sysstat sysstat-collect.timer sysstat-summary.timer

$ sudo systemctl start sysstat sysstat-collect.timer sysstat-summary.timer</code></pre>

<p>The <code>sysstat</code> package consists of a handful of commands that report performance statistics on a variety of subsystems and services from CIFS/Samba to disk to Linux tasks. The most useful command is <code>sar</code>, the System Activity Reporter. The <code>sar</code> command provides you with a running list of system activity statistics. Any user can issue the <code>sar</code> command to view statistics:</p>

<pre>
<code class="language-shell">$ sar 
Linux 4.18.0-80.7.1.el8_0.x86_64 (rhel) 	08/14/2019 	_x86_64_	(1 CPU)

12:00:24 AM     CPU     %user     %nice   %system   %iowait    %steal     %idle
12:10:01 AM     all      0.22      0.00      0.43      0.01      0.00     99.33
12:20:32 AM     all      1.18      0.05      1.24      0.12      0.00     97.41
12:30:01 AM     all      0.27      0.00      0.49      0.01      0.00     99.23
12:40:32 AM     all      0.20      0.00      0.38      0.00      0.00     99.41
12:50:32 AM     all      0.18      0.00      0.36      0.01      0.00     99.46
</code></pre>

<p>By default, system statistics are gathered every 10 minutes. The <code>sar</code> command displays general system statistics, but the far more useful and extensive statistics option provides everything <code>sar</code> has to offer, using the <code>-A</code> option:</p>

<pre>
<code class="language-shell">$ sar -A</code></pre>

<p>The output is far too long to post here, but note that you'll see all statistics for every subsystem and service that <code>sar</code> collects. Please refer to the <code>sar</code> man page for further information and details about specific statistics and their options.</p>

<h2>Third: Analyze and plot data</h2>

<p>The <code>sysstat</code> collector gathers system information and keeps it under <font color="#e83e8c" face="Overpass Mono, Consolas, Monaco, Andale Mono, monospace"><span style="font-size: 14px;">/var/log/sa</span></font>. The file numbers are the day of the month from which they were collected. You'll need some method of gathering and analyzing this data. I suggest Blair Zajac's <a href="http://orcaware.com/orca" target="_blank">Orca</a>. I also suggest that you transfer your collected data to a central repository to process and display. In other words, do not process your statistics on your production systems because it will negatively impact your performance statistics and skew your results.</p>

<p>Orca is non-trivial but not terribly difficult to set up. A few years ago, I wrote an <a href="https://nnc3.com/mags/LM10/Magazine/Archive/2006/65/054-057_orca/article.html" target="_blank">article</a> that helps you start displaying your performance statistics on a web server with Orca. Orca hasn't been updated in a while, but still works as shown in the documentation and in my article.</p>

<h2>Fourth: Set performance thresholds</h2>

<p>For each of your production or monitored systems, you have to answer the question: "How busy is busy?" There is no perfect answer, and you will likely tweak the numbers at some point to reduce how many notifications you receive from breaching those thresholds. For example, let's say that you have five web servers that are load-balanced to supply web services to your external customers, and you need to monitor their performance to predict when to add more systems to the farm, or when you can take one or more offline.</p>

<p>As a preliminary test, you set the CPU threshold at 80% busy for all five servers. Twice per day, you receive email alerts that your systems have gone above 80%. The problem? You receive alerts every five minutes from all five servers, for two hours, twice per day. This is an indication that the thresholds are set too low unless you love getting all those notifications.</p>

<p>You have to look at performance during those peak times to decide where to set the threshold, and whether or not you need to add more systems to the farm to lower the overall utilization. After examining the numbers, you notice that utilization never exceeds 87% for any peak time on any server. You then decide to set the CPU threshold at 90% and continue to have your monitor check every five minutes, but you lower the alert threshold to sustained 90% for more than two hours. This means that if a system's CPU utilization exceeds 90% for more than two hours, you will receive a notification. That threshold for this environment is reasonable and manageable. Your level of tolerance for adding a new system to the farm, after a few months of observation, is CPU above 95% for more than two hours.</p>

<p>This is the process of determining how busy is busy and your tolerance levels for each service. It seems arbitrary, but it isn't, because you are observing the data on a continuous basis and making adjustments and decisions based on your observations. 90% utilization for two hours isn't excessive, but you don't want to exceed that level because then users start suffering long wait times when pulling data from your system.</p>

<h2>Fifth: Performance alerting</h2>

<p>I've discussed alerting but have yet to give you a solution for creating and handling events (alerts). You could create something as simple as a Bash script to check <code>sar</code> data for utilization numbers, but you can also deploy a commercial solution or even something in between. I won't recommend an alerting solution to you, but there are a handful of open source monitoring and alerting applications available. Most are agent-based, so add installing and maintaining another service to your list of administration duties.</p>

<p>As stated in the previous section, you'll have to adjust your thresholds and tolerances to avoid driving yourself crazy with alerts, especially if those alerts come across as texts to your phone(s). You only want to be notified if something is down or in trouble and requires your attention for a resolution.</p>

<h2>The capacity planning dilemma</h2>

<p>The dilemma of capacity planning and performance monitoring these days is that rather than purchasing several racks of servers, you're probably either leasing your server hardware, or you're using some sort of cloud solution where capacity and performance are dynamically handled by business rules. Three-year hardware leases dictate that you go through a hardware refresh every three years, whether you need to or not. The type of hardware policy you have at your company certainly alters the course of how you plan for capacity changes.</p>

<p>If you lease, you'll still need to perform performance monitoring and think about capacity, because if you've undersized or under-bought hardware, you'll certainly need to know. If you purchase, then you should look at performance and capacity planning on a five-year rolling basis. I say five years because managers and business owners don't want to replace hardware every three years if they're purchasing it. It's likely that they're using the hardware purchases as an amortized asset. </p>

<p>The trick with purchased assets is that you don't want to waste capacity by buying too much too soon. There are many stories circulating about people who buy top-of-the-line systems only to refresh them in five years without ever tapping the capacity of those systems, and after five years they're too old to bother updating and upgrading. The bottom line for acquiring new leased or purchased hardware is to buy with growth in mind and then take advantage of that growth by budgeting for upgrades based on utilization. In other words, buy what you need, upgrade as needed, and take full advantage of your hardware assets before the next refresh cycle.</p>

<h2>Summary</h2>

<p>Capacity planning and performance monitoring work together to give you a complete picture of your hardware and software life cycle. It's important to take the time and make the effort to set up monitoring and alerting, and to analyze the data. Too often, busy system administrators set up elaborate solutions for monitoring and then ignore them. Find a way to strike a balance between being driven crazy by performance alerts and never seeing the one that results in extended downtime. Capacity planning also helps you save money by redeploying services from overutilized to underutilized systems.</p>
</div>
      
  
  </div>

  <div data-layout-content-preview-placeholder-label="&quot;Listicle&quot; views block" class="block">

  
    

      <div class="views-element-container"><div class="listicle-view js-view-dom-id-b4f5099b463d2d0726a1341df95374a3d4f862ec7bdd665bc060a25612af07ac">
  
  
  

  
  
  

      <div class="listicle-row"><div class="views-field views-field-field-listicle"><div class="field-content"></div></div></div>

    

  
  

  
  
</div>
</div>

  
  </div>

  <div data-layout-content-preview-placeholder-label="&quot;Topics&quot; field" class="block">

  
    

      <div class="topics">
  <strong>Topics:</strong>&nbsp;&nbsp;
      <a href="/sysadmin/topics/linux-administration" class="btn btn-primary btn-sm font-weight-bold">linux administration</a>&nbsp;&nbsp;
      <a href="/sysadmin/topics/linux" class="btn btn-primary btn-sm font-weight-bold">Linux</a>&nbsp;&nbsp;
  </div>
  
  </div>

    </div>
  </div>
</div>
<div >
  <div >
    
  <div data-layout-content-preview-placeholder-label="&quot;Entity view (Content)&quot; block" class="block">

  
    

      
<section data-history-node-id="736" role="article" about="/sysadmin/linux-capacity-planning" typeof="schema:Article" class="section my-5 py-5 bg-light-gray authors-bio authors-bio--article">
  <div class="container">
          <div class="row">
        <div class="col-md-2 text-center">
                      
<img data-affiliation="Red Hat" src="/sysadmin/sites/default/files/styles/user_picture_square/public/pictures/2019-07/Ken_Hess.jpg?itok=0muInbxY" width="240" height="240" typeof="foaf:Image" class="rounded-circle img-thumbnail" src="/sysadmin/sites/default/files/styles/user_picture_square/public/pictures/2019-07/Ken_Hess.jpg?itok=0muInbxY" alt="Author’s photo" />


          
        </div>
        <div class="col-md-10 col-lg-8">
          <h2 class="font-weight-light text-center text-md-left">
                          Ken Hess
                      </h2>
          <div>
                          <p>
                Ken Hess is an Enable SysAdmin Community Manager and an Enable SysAdmin contributor. Ken has used Red Hat Linux since 1996 and has written ebooks, whitepapers, actual books, thousands of exam review questions, and hundreds of articles on open source and other topics.
                                  <a href="/sysadmin/users/khess" class="author-more-link">More about me</a>
                              </p>
                      </div>
        </div>
      </div>
      </div>
</section>



  
  </div>

  <div data-layout-content-preview-placeholder-label="&quot;Contributors&quot; block" class="block">

  
    

      

  
  </div>

  </div>
</div>
<div  class="section">
  <div class="container">
    <div >
      
  <div data-layout-content-preview-placeholder-label="&quot;Related Content&quot; views block" class="block">

  
    

      <div class="views-element-container"><div class="js-view-dom-id-43c30a507b7652f1e89072346e790f26df7c5bfc4bd08e7b99cfbf93a5c9c64a">
  
  
  

  
  
  

    <h2>Related Content</h2>
                        <div class="card-deck my-4">
                        <article data-history-node-id="751" role="article" about="/sysadmin/bash-bang-commands" typeof="schema:Article" class="card card--article node node--promoted">
      <div class="card-img-top">
            <div class="article__field-media"><article>
  
      
  <div class="image__field-media-image">
    <div class="field__label font-weight-bold visually-hidden">
      Image    </div>
                  <div class="field__item">  
<img src="/sysadmin/sites/default/files/styles/full/public/2019-09/beating-construction-crushing_0.jpg?itok=-EqtjjAY" width="1000" height="600" typeof="foaf:Image" class="img-thumbnail" src="/sysadmin/sites/default/files/styles/full/public/2019-09/beating-construction-crushing_0.jpg?itok=-EqtjjAY" alt="Hammer" />


</div>
              </div>

  </article>
</div>
      </div>
      <div class="card-body">
    <div class="h4 card-title"><a href="/sysadmin/bash-bang-commands"><span property="schema:name">Bash bang commands: A must-know trick for the Linux command line</span>
</a></div>
    <div class="card-text">
            <div property="schema:text" class="article__body">Your bash history maintains a record of the commands you've entered. Here's how to make good use of that record.</div>
      </div>
  </div>
  <div class="card-footer">
    <div class="article-date">
      <span class="label">Posted:</span>
      September 20, 2019
    </div>
    <div class="article-authors">
              <span class="label">Author:</span>
                    <a href="/sysadmin/users/keerthi-chinthaguntla" class="article-author article-author--primary">Keerthi Chinthaguntla</a>          </div>
  </div>
</article>


                            <article data-history-node-id="731" role="article" about="/sysadmin/customize-top-command" typeof="schema:Article" class="card card--article node node--promoted">
      <div class="card-img-top">
            <div class="article__field-media"><article>
  
      
  <div class="image__field-media-image">
    <div class="field__label font-weight-bold visually-hidden">
      Image    </div>
                  <div class="field__item">  
<img src="/sysadmin/sites/default/files/styles/full/public/2019-09/A_tough_gang_of_Spinning_Tops_1.jpg?itok=Y7HW7gB5" width="1000" height="600" typeof="foaf:Image" class="img-thumbnail" src="/sysadmin/sites/default/files/styles/full/public/2019-09/A_tough_gang_of_Spinning_Tops_1.jpg?itok=Y7HW7gB5" alt="How to customize the Linux top command" />


</div>
              </div>

  </article>
</div>
      </div>
      <div class="card-body">
    <div class="h4 card-title"><a href="/sysadmin/customize-top-command"><span property="schema:name">How to customize the Linux top command</span>
</a></div>
    <div class="card-text">
            <div property="schema:text" class="article__body">The top command offers many customization options. Here's one way to take advantage of them in order to check out memory use.</div>
      </div>
  </div>
  <div class="card-footer">
    <div class="article-date">
      <span class="label">Posted:</span>
      September 18, 2019
    </div>
    <div class="article-authors">
              <span class="label">Author:</span>
                    <a href="/sysadmin/users/hydnjames" class="article-author article-author--primary">Hayden James</a>          </div>
  </div>
</article>


                            <article data-history-node-id="716" role="article" about="/sysadmin/rootless-podman" typeof="schema:Article" class="card card--article node node--promoted">
      <div class="card-img-top">
            <div class="article__field-media"><article>
  
      
  <div class="image__field-media-image">
    <div class="field__label font-weight-bold visually-hidden">
      Image    </div>
                  <div class="field__item">  
<img src="/sysadmin/sites/default/files/styles/full/public/2019-09/RestrictedArea.jpg?itok=k_RewAdE" width="1000" height="600" typeof="foaf:Image" class="img-thumbnail" src="/sysadmin/sites/default/files/styles/full/public/2019-09/RestrictedArea.jpg?itok=k_RewAdE" alt="Why can&amp;#039;t rootless Podman pull my image?" />


</div>
              </div>

  </article>
</div>
      </div>
      <div class="card-body">
    <div class="h4 card-title"><a href="/sysadmin/rootless-podman"><span property="schema:name">Why can’t rootless Podman pull my image?</span>
</a></div>
    <div class="card-text">
            <div property="schema:text" class="article__body">Restrictions placed on rootless containers can be inconvenient, but there's always some sacrifice of convenience and usability for security improvements.</div>
      </div>
  </div>
  <div class="card-footer">
    <div class="article-date">
      <span class="label">Posted:</span>
      September 11, 2019
    </div>
    <div class="article-authors">
              <span class="label">Author:</span>
                    <a href="/sysadmin/users/mheon" class="article-author article-author--primary">Matthew Heon<span class="author-affiliate"> (Red Hat)</span></a>          </div>
  </div>
</article>


                              </div>
            
    

  
  

  
  
</div>
</div>

  
  </div>

    </div>
  </div>
</div>
<div  class="section my-5 pb-5 narrow">
  <div class="container">
    <div >
      
    </div>
  </div>
</div>
<div  class="section my-5 pb-5 ">
  <div class="container">
    <div >
      

  <div data-layout-content-preview-placeholder-label="&quot;CTA Subscribe (Red on Black)&quot; block" class="block block--cta cta cta--red-on-black cta-- my-5 p-3 text-center">

  
    

    <div class="d-md-flex justify-content-around align-items-center flex-wrap">
    <div class="cta__content my-2">
      
            <div class="cta__field-content p-2"><p class="h4 mb-4 mt-3 font-weight-bold">OUR BEST CONTENT, DELIVERED TO YOUR INBOX</p>

<p><iframe title="Subscribe to our newsletter" aria-label="Embedded form to subscribe to our email newsletter" frameborder="0" height="50" scrolling="no" src="/sysadmin/eloqua-embedded-subscribe.html?offer_id=701f20000012gE7AAI" style="max-width:670px;margin:0 auto;" width="100%"></iframe></p>
</div>
      
    </div>
      </div>
  
  </div>

    </div>
  </div>
</div>

  </article>

  
  </div>


              </div>
        </main>

            <footer>
              <div class="page__colophon bg-dark-gray py-4 bg-dark-gray">
          <div class="container">
              
  <div class="block block--basic block--sysadmin-colophon-disclaimer">

  
    

      
            <div class="basic__body"><p>The opinions expressed on this website are those of each author, not of the author's employer or of Red Hat.</p>

<p>Red Hat and the Red Hat logo are trademarks of Red Hat, Inc., registered in the United States and other countries.</p>
</div>
      
  
  </div>


          </div>
        </div>
                    <div class="page__footer bg-dark py-3">
        <div class="container">
          <div class="d-sm-flex justify-content-between align-items-center">
              

  
    

    
  <a href="https://www.redhat.com/" class="navbar-brand mr-0 mr-lg-auto mb-3 mb-sm-0">
            <img src="/sysadmin/themes/custom/sysadmin/logo.svg" width="135" height="31" class="d-inline-block align-top" alt="Red Hat logo" />

        
  </a>



  <div class="block block--basic block--copyright my-0 mx-sm-3 mb-1 mb-sm-0">

  
    

      
            <div class="basic__body"><p>Copyright ©2019 Red Hat, Inc.</p>
</div>
      
  
  </div>

  <div class="block block--sysadmin-footer my-0 mb-1 mb-sm-0">

  
    

      
  


  <ul class="nav d-flex d-sm-block d-md-flex justify-content-center align-items-center">
                                  <li class="nav-item  ">
                      <a href="https://www.redhat.com/en/about/privacy-policy" class="nav-link">Privacy Policy</a>
                  </li>
                              <li class="nav-item  ">
                      <a href="https://www.redhat.com/en/about/terms-use" class="nav-link">Terms of Use</a>
                  </li>
                              <li class="nav-item  ">
                      <a href="https://www.redhat.com/en/about/all-policies-guidelines" class="nav-link">All policies and guidelines</a>
                  </li>
            </ul>


  
  </div>

  <div class="block block--sharelinks">

  
    

      <div class="a2a_kit a2a_kit_size_32 a2a_floating_style a2a_vertical_style" data-a2a-url="https://www.redhat.com/sysadmin/linux-capacity-planning">
  <a class="a2a_button_twitter a2a_counter"></a>
  <a class="a2a_button_facebook a2a_counter"></a>
  <a class="a2a_button_linkedin a2a_counter"></a>
  <a class="a2a_button_reddit a2a_counter"></a>
  <a class="a2a_button_email a2a_counter"></a>
</div>
<div class="a2a_kit a2a_kit_size_32 a2a_floating_style a2a_default_style">
  <a class="a2a_button_twitter a2a_counter"></a>
  <a class="a2a_button_facebook a2a_counter"></a>
  <a class="a2a_button_linkedin a2a_counter"></a>
  <a class="a2a_button_reddit a2a_counter"></a>
  <a class="a2a_button_email a2a_counter"></a>
</div>

<script>
  var a2a_config = a2a_config || {};
  a2a_config.templates = a2a_config.templates || {};
  a2a_config.templates.twitter = {
    text: "Linux capacity planning: 5 things you need to do https://red.ht/30Hs52n via #EnableSysadmin by @kenhess",
  };
  a2a_config.templates.facebook = {
    hashtag: "#EnableSysadmin",
  };
</script>
  
  </div>


  <div class="block block--cta block--ctasubscribesidebar cta cta--blue-on-white cta-- my-5 p-3 text-center">

  
    

    <div class="d-md-flex justify-content-around align-items-center flex-wrap">
    <div class="cta__content my-2">
      
            <div class="cta__field-content p-2"><div class="subscribe-sidebar">
<div class="target-band-never-show-button">x</div>

<h4>Subscribe now</h4>

<p class="eloqua-email-capture-text">Get the highlights in your inbox every week.</p>

<p><iframe aria-label="Embedded form to subscribe to our email newsletter" frameborder="0" height="50" scrolling="no" src="/sysadmin/eloqua-embedded-email-capture-block.html?offer_id=701f20000012gE7AAI" style="max-width:670px;margin:0 auto;" title="Subscribe to our newsletter" width="100%"></iframe></p>
</div>
</div>
      
    </div>
      </div>
  
  </div>


          </div>
        </div>
            </footer>
      </div>

  </div>


<script type="application/json" data-drupal-selector="drupal-settings-json">{"path":{"baseUrl":"\/sysadmin\/","scriptPath":null,"pathPrefix":"","currentPath":"node\/736","currentPathIsAdmin":false,"isFront":false,"currentLanguage":"en"},"pluralDelimiter":"\u0003","ckeditorheight":{"offset":1,"line_height":1.5,"unit":"em"},"user":{"uid":0,"permissionsHash":"653231f2fd62822d854a459f8c9bd92cdd388cedec8e99ad361c1430eee2d8b2"}}</script>
<script src="/sysadmin/sites/default/files/js/js_UsiFp8Hn8V8k3ewecdSEt3m5USGLxXdUOVKl913EEZ0.js"></script>

  <script type="text/javascript">
    if (("undefined" !== typeof _satellite) && ("function" === typeof _satellite.pageBottom)) {
      _satellite.pageBottom();
    }
  </script>
</body>
</html>
